source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 847

Revision 847, 11.7 KB checked in by munepi, 14 years ago (diff)

updated gnome-mplayer-vl.spec

Line 
1#TODO: Nautilus extention
2%define with_nautilus 0
3%define with_my_japo 0
4%define svnrevision 1685
5
6%define GNOME_MPLAYER_BIN %{_libexecdir}/%{name}
7
8Name:           gnome-mplayer
9Version:        0.9.9.2
10Release:        3%{?svnrevision:.svn%svnrevision}%{?_dist_release}
11Summary:        An MPlayer GUI, a full-featured binary
12Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
13Group:          Applications/Multimedia
14License:        GPLv2+
15URL:            http://kdekorte.googlepages.com/gnomemplayer
16Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?svnrevision:.svn%svnrevision}.tar.%{?svnrevision:bz2}%{!?svnrevision:gz}
17Source10:       gnome-mplayer-snapshot.sh
18Source50:       gnome-mplayer.sh.in
19
20## vine
21%if %{with_my_japo}
22#Patch100:       gnome-mplayer-0.9.4-ja.patch
23Source100:      gnome-mplayer-0.9.9.svn1629-ja.po
24%endif
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
27
28BuildRequires:  alsa-lib-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  desktop-file-utils
31BuildRequires:  GConf2-devel
32BuildRequires:  gettext
33BuildRequires:  gtk2-devel
34#BuildRequires:  libcurl-devel
35BuildRequires:  curl-devel
36BuildRequires:  libgpod-devel
37#BuildRequires:  libmusicbrainz3-devel
38BuildRequires:  libmusicbrainz-devel
39BuildRequires:  libnotify-devel
40BuildRequires:  libXScrnSaver-devel
41
42Requires:       gvfs-fuse
43#Requires:       mencoder
44#Requires:       self-build-mplayer
45
46Requires(pre):  GConf2
47Requires(post): GConf2
48Requires(preun): GConf2
49
50Distribution:   Vine
51Vendor:         Project Vine
52Packager:       munepi
53
54
55%description
56GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
57player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
58a rich API that is exposed via DBus. Using DBus you can control a single or
59multiple instances of GNOME MPlayer from a single command.
60
61%description -l ja
62GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
63インターフェースです。とても引き締まったていて,
64MPlayer への簡単でかつ明確なインターフェースを提供します.
65GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
66DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
67GNOME MPlayer のインスタンスを制御できます.
68
69gnome-mplayer を使うためには,mplayer が必要です.
70
71
72%if %{with_nautilus}
73%package nautilus
74Summary:        A Nautilus extention of %{name}
75Summary(ja):    %{name} の Nautilus 拡張
76Group:          Applications/Multimedia
77Requires:       %{name} = %{version}-%{release}
78Requires:       nautilus-extensions
79
80%description nautilus
81GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
82player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
83a rich API that is exposed via DBus. Using DBus you can control a single or
84multiple instances of GNOME MPlayer from a single command.
85
86This package provides a nautilus extension, which shows properties of audio and
87video files in the properties dialogue.
88
89%description nautilus -l ja
90GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
91インターフェースです。とても引き締まったていて,
92MPlayer への簡単でかつ明確なインターフェースを提供します.
93GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
94DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
95GNOME MPlayer のインスタンスを制御できます.
96
97このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
98プロパティを示すに Nautilus 拡張を提供します.
99%endif
100
101%prep
102%setup -q
103
104%if %{with_my_japo}
105## vine
106#% patch100 -p1 -b .ja
107%__install -m644 %{SOURCE100} po/ja.po
108#autoreconf -f
109%endif
110
111
112%build
113%configure --disable-static
114%__make %{?_smp_mflags}
115
116
117%install
118%__rm -rf $RPM_BUILD_ROOT
119
120export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
121%__make install DESTDIR=$RPM_BUILD_ROOT
122
123desktop-file-install --vendor=vine \
124       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
125       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
126
127## wrapper
128%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
129%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{GNOME_MPLAYER_BIN}
130%__sed s,@@GNOME_MPLAYER_BIN@@,%{GNOME_MPLAYER_BIN}, %{SOURCE50} > $RPM_BUILD_ROOT%{_bindir}/%{name}
131%__chmod 0755 $RPM_BUILD_ROOT%{_bindir}/%{name}
132
133%find_lang %{name}
134
135# remove intrusive docs
136%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
137
138# remove unpackaged files
139find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
140
141
142%pre
143if [ "$1" -gt 1 ]; then
144    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
145    gconftool-2 --makefile-uninstall-rule \
146      %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
147    # If the schema file has ever been renamed::
148    #gconftool-2 --makefile-uninstall-rule \
149    #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
150fi
151
152
153%post
154touch --no-create %{_datadir}/icons/hicolor
155if [ -x %{_bindir}/gtk-update-icon-cache ]; then
156  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
157fi
158update-desktop-database &> /dev/null || :
159
160export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
161gconftool-2 --makefile-install-rule \
162  %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
163
164%preun
165if [ "$1" -eq 0 ]; then
166    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
167    gconftool-2 --makefile-uninstall-rule \
168      %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
169fi
170
171%postun
172touch --no-create %{_datadir}/icons/hicolor
173if [ -x %{_bindir}/gtk-update-icon-cache ]; then
174  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
175fi
176update-desktop-database &> /dev/null || :
177
178
179%clean
180%__rm -rf $RPM_BUILD_ROOT
181
182
183%files -f %{name}.lang
184%defattr(-,root,root,-)
185%{_bindir}/gnome-mplayer
186%{GNOME_MPLAYER_BIN}
187%{_datadir}/applications/*-gnome-mplayer.desktop
188%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
189%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
190%{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
191%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
192%{_mandir}/man1/gnome-mplayer.1.gz
193
194%if %{with_nautilus}
195%files nautilus
196%{_libdir}/nautilus/extensions-2.0/*.so.*
197%{_libdir}/nautilus/extensions-2.0/*.so
198%endif
199
200
201%changelog
202* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
203- source snapshot r1685
204- added gnome-mplayer.sh.in
205  - this script is a wrapper to check MPlayer binary existance
206
207* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
208- source snapshot r1673
209  - Rework vdpau codec selection and deinterlace (r1673)
210
211* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
212- new upstream release
213
214* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
215- new upstream release
216- added gnome-mplayer-snapshot.sh
217
218* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
219- source snapshot r1619
220- added gnome-mplayer-0.9.9.svn1619-ja.po
221
222* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
223- source snapshot r1599
224- added BuildRequires: libXScrnSaver-devel
225
226* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
227- source snapshot r1583
228- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
229
230* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
231- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
232  - fix hidden cursor over menus (r1576)
233
234* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
235- new upstream release
236
237* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
238- source snapshot r1540
239
240* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
241- source snapshot r1538
242  - updated the latest up-to-date ja.po
243
244* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
245- new upstream release
246
247* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
248- source snapshot r1493
249
250* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
251- source snapshot r1486
252  - updated the latest up-to-date ja.po
253- added gtk-update-icon-cache actions in %%post, %%postun
254
255* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
256- rebuild with libgpod-0.7.2
257- gconf uninstall rule in %%preun, not %%postun
258
259* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
260- new upstream release
261
262* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
263- source snapshot r1298
264  - updated the latest up-to-date ja.po
265
266* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
267- dropped Requires: self-build-mplayer
268
269* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
270- source snapshot r1236
271- updated the latest up-to-date ja.po
272
273* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
274- new upstream release
275
276* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
277- dropped a Nautilus plugin once
278
279* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
280- source snapshot r1184
281- dropped gnome-mplayer-0.9.4-ja.patch
282  - committed Japanese translation
283- applied gnome-mplayer-0.9.4.r1184-ja.po
284  - update the latest up-to-date ja.po
285
286* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
287- added Summary(ja), %%description -l ja
288- updated gnome-mplayer-0.9.4-ja.patch
289
290* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
291- new upstream release
292- updated gnome-mplayer-0.9.4-ja.patch
293- updated gnome-mplayer-0.9.4-ja.po
294- updated the URL tag
295
296* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
297- initial build
298- added ja.po
299
300* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
301- Added patch fixing rpmfusion bug #238 from SVN
302- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
303
304* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
305- Updated to 0.9.3
306
307* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
308- Refactored the spec to allow building both minimal and full-featured versions
309- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
310
311* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
312- Updated to 0.9.2
313- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
314- Provide gnome-mplayer-core-functionality
315
316* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
317- Updated to 0.9.1
318
319* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
320- Updated to 0.9.0
321- Added libnotify-devel to BuildRequires
322- Added gvfs-fuse to Requires
323
324* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
325- Updated to 0.8.0
326
327* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
328- Added alsa-lib-devel to BuildRequires (livna bug #2084)
329
330* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
331- Updated to 0.7.0
332
333* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
334- rebuild for buildsys cflags issue
335
336* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
337- Updated to 0.6.3
338
339* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
340- Added mencoder to Requires (bug #1991)
341
342* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
343- Updated to 0.6.2
344
345* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
346- Updated to 0.6.1
347- Updated URL and Source0
348
349* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
350- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.