source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 7044

Revision 7044, 15.6 KB checked in by munepi, 12 years ago (diff)

update gmtk, gnome-mplayer, gecko-mediaplayer

Line 
1#TODO: Nautilus extention
2%define with_nautilus 0
3%define with_my_japo 0
4#% define svnrevision 2346
5#% define rcversion 1
6#% define betaversion a1
7
8Name:           gnome-mplayer
9Version:        1.0.7
10Release:        1%{?betaversion:.%betaversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
11Summary:        An MPlayer GUI, a full-featured binary
12Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
13Group:          Applications/Multimedia
14License:        GPLv2+
15URL:            http://kdekorte.googlepages.com/gnomemplayer
16Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?betaversion:%betaversion}%{?svnrevision:.svn%svnrevision}%{?rcversion:.rc%rcversion}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
17Source10:       gnome-mplayer-snapshot.sh
18
19## vine
20%if %{with_my_japo}
21Source100:      gnome-mplayer-1.0.6b1.svn2227-ja.po
22%endif
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  gmtk-devel >= 1.0.7
27BuildRequires:  alsa-lib-devel
28BuildRequires:  pulseaudio-libs-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  desktop-file-utils
31BuildRequires:  GConf2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34%if %{?_dist_release} == "vl7"
35BuildRequires:  gtk3-devel
36%else
37%if %{?_dist_release} == "vl6"
38BuildRequires:  gtk2-devel
39%endif
40%endif
41#BuildRequires:  libcurl-devel
42BuildRequires:  curl-devel
43BuildRequires:  libgpod-devel
44%if %{?_dist_release} != "vl5"
45BuildRequires:  libmusicbrainz3-devel
46%endif
47#BuildRequires:  libmusicbrainz-devel
48BuildRequires:  libnotify-devel
49BuildRequires:  libXScrnSaver-devel
50BuildRequires:  gnome-power-manager
51
52Requires:       gvfs-fuse
53Requires:       gnome-power-manager
54#Requires:       mencoder
55#Requires:       self-build-mplayer
56
57Requires(pre):  GConf2
58Requires(post): GConf2
59Requires(preun): GConf2
60
61Distribution:   Vine Linux
62Vendor:         Project Vine
63Packager:       munepi
64
65
66%description
67GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
68player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
69a rich API that is exposed via DBus. Using DBus you can control a single or
70multiple instances of GNOME MPlayer from a single command.
71
72%description -l ja
73GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
74インターフェースです。とても引き締まったていて,
75MPlayer への簡単でかつ明確なインターフェースを提供します.
76GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
77DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
78GNOME MPlayer のインスタンスを制御できます.
79
80gnome-mplayer を使うためには,mplayer が必要です.
81
82
83%if %{with_nautilus}
84%package nautilus
85Summary:        A Nautilus extention of %{name}
86Summary(ja):    %{name} の Nautilus 拡張
87Group:          Applications/Multimedia
88Requires:       %{name} = %{version}-%{release}
89Requires:       nautilus-extensions
90
91%description nautilus
92GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
93player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
94a rich API that is exposed via DBus. Using DBus you can control a single or
95multiple instances of GNOME MPlayer from a single command.
96
97This package provides a nautilus extension, which shows properties of audio and
98video files in the properties dialogue.
99
100%description nautilus -l ja
101GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
102インターフェースです。とても引き締まったていて,
103MPlayer への簡単でかつ明確なインターフェースを提供します.
104GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
105DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
106GNOME MPlayer のインスタンスを制御できます.
107
108このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
109プロパティを示すに Nautilus 拡張を提供します.
110%endif
111
112%prep
113#% setup -q %{?rcversion:-n %{name}-%{version}.rc%{rcversion}}
114%setup -q %{?betaversion:-n %{name}-%{version}%betaversion}
115
116## vine
117%if %{with_my_japo}
118%__install -m644 %{SOURCE100} po/ja.po
119%endif
120
121
122%build
123%configure \
124    %if %{?_dist_release} == "vl7"
125    --enable-gtk3 \
126    %endif
127    %if !%{with_nautilus}
128    --disable-nautilus \
129    %endif
130    --disable-schemas-compile \
131    \
132    --with-dbus \
133    --with-alsa \
134    --with-pulseaudio \
135    --with-libnotify \
136    --with-libgpod \
137    %if %{?_dist_release} != "vl5"
138    --with-libmusicbrainz3 \
139    %endif
140    ;
141%__make %{?_smp_mflags}
142
143
144%install
145%__rm -rf $RPM_BUILD_ROOT
146
147export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
148%__make install DESTDIR=$RPM_BUILD_ROOT
149
150desktop-file-install --vendor=vine \
151       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
152       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
153
154%find_lang %{name}
155
156# remove intrusive docs
157%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
158
159# remove unpackaged files
160find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
161
162
163# %pre
164# if [ "$1" -gt 1 ]; then
165#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
166#     gconftool-2 --makefile-uninstall-rule \
167#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
168#     # If the schema file has ever been renamed::
169#     #gconftool-2 --makefile-uninstall-rule \
170#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
171# fi
172
173
174%post
175touch --no-create %{_datadir}/icons/hicolor
176if [ -x %{_bindir}/gtk-update-icon-cache ]; then
177  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
178fi
179update-desktop-database &> /dev/null || :
180
181# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
182# gconftool-2 --makefile-install-rule \
183#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
184
185%posttrans
186glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
187# update-desktop-database %{_datadir}/applications/
188
189# %preun
190# if [ "$1" -eq 0 ]; then
191#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
192#     gconftool-2 --makefile-uninstall-rule \
193#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
194# fi
195
196%postun
197if [ $1 -eq 0 ]; then
198  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
199  update-desktop-database %{_datadir}/applications/
200fi
201
202touch --no-create %{_datadir}/icons/hicolor
203if [ -x %{_bindir}/gtk-update-icon-cache ]; then
204  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
205fi
206update-desktop-database &> /dev/null || :
207
208
209%clean
210%__rm -rf $RPM_BUILD_ROOT
211
212
213%files -f %{name}.lang
214%defattr(-,root,root,-)
215%{_bindir}/gnome-mplayer
216%{_datadir}/applications/*-gnome-mplayer.desktop
217%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
218%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
219# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
220%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
221%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
222%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
223%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
224%{_mandir}/man1/gnome-mplayer.1.gz
225
226%if %{with_nautilus}
227%files nautilus
228%{_libdir}/nautilus/extensions-2.0/*.so.*
229%{_libdir}/nautilus/extensions-2.0/*.so
230%endif
231
232
233%changelog
234* Thu Nov  1 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-1
235- new upstream release
236
237* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-4
238- dropped a wrapper of /usr/bin/gnome-mplayer
239
240* Mon Apr 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-3
241- new upstream release
242
243* Thu Apr  5 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-2.b1.svn2227
244- source 1.0.6b1 svn2227
245- updated ja.po
246
247* Sat Mar 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-1.b1
248- new upstream release
249
250* Tue Feb 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
251- updated ja.po
252
253* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
254- updated ja.po
255
256* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
257- new upstream release
258
259* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1.b1.svn2180
260- source 1.0.5b1
261- updated ja.po
262- added BuildRequires: gmtk-devel >= 1.0.5
263  - dropped --disable-static from %%configure
264- enable gtk3 for vl7
265  - added BuildRequires: gtk3-devel
266  - added --enable-gtk3 in %%configure
267
268* Sun Sep 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-4
269- rebuilt with libnotify-0.7.4
270
271* Mon Jul 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-3
272- new upstream release
273
274* Fri Jun 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2.b2
275- source 1.0.4b2
276
277* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
278- source snapshot 1.0.4b1 r2124
279- use gsettings
280
281* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
282- new upstream release
283
284* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
285- source snapshot 1.0.3beta r1992
286
287* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
288- source snapshot 1.0.3beta r1989
289  - added --disable-schemas-compile in configure options
290  - use GSettings (%%posttrans, %%postun)
291- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
292
293* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
294- new upstream release
295
296* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
297- source snapshot 1.0.1b1 r1912
298
299* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
300- source snapshot 1.0.1b1 r1892
301- added BuildRequires: pulseaudio-libs-devel
302
303* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
304- new upstream release
305- added BuildRequires:
306  - libmusicbrainz3-devel (only vl6)
307  - gnome-power-manager
308- added Requires: gnome-power-manager
309
310* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
311- source 0.9.99.rc3
312
313* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
314- source 0.9.99.rc1
315  - applied gnome-mplayer-0.9.99.rc1-ja.po
316  - entry ja in gnome-mplayer.desktop
317
318* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
319- source snapshot r1729
320
321* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
322- fixed gnome-mplayer.sh.in
323
324* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
325- source snapshot r1685
326- added gnome-mplayer.sh.in
327  - this script is a wrapper to check MPlayer binary existance
328
329* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
330- source snapshot r1673
331  - Rework vdpau codec selection and deinterlace (r1673)
332
333* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
334- new upstream release
335
336* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
337- new upstream release
338- added gnome-mplayer-snapshot.sh
339
340* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
341- source snapshot r1619
342- added gnome-mplayer-0.9.9.svn1619-ja.po
343
344* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
345- source snapshot r1599
346- added BuildRequires: libXScrnSaver-devel
347
348* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
349- source snapshot r1583
350- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
351
352* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
353- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
354  - fix hidden cursor over menus (r1576)
355
356* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
357- new upstream release
358
359* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
360- source snapshot r1540
361
362* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
363- source snapshot r1538
364  - updated the latest up-to-date ja.po
365
366* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
367- new upstream release
368
369* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
370- source snapshot r1493
371
372* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
373- source snapshot r1486
374  - updated the latest up-to-date ja.po
375- added gtk-update-icon-cache actions in %%post, %%postun
376
377* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
378- rebuild with libgpod-0.7.2
379- gconf uninstall rule in %%preun, not %%postun
380
381* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
382- new upstream release
383
384* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
385- source snapshot r1298
386  - updated the latest up-to-date ja.po
387
388* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
389- dropped Requires: self-build-mplayer
390
391* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
392- source snapshot r1236
393- updated the latest up-to-date ja.po
394
395* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
396- new upstream release
397
398* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
399- dropped a Nautilus plugin once
400
401* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
402- source snapshot r1184
403- dropped gnome-mplayer-0.9.4-ja.patch
404  - committed Japanese translation
405- applied gnome-mplayer-0.9.4.r1184-ja.po
406  - update the latest up-to-date ja.po
407
408* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
409- added Summary(ja), %%description -l ja
410- updated gnome-mplayer-0.9.4-ja.patch
411
412* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
413- new upstream release
414- updated gnome-mplayer-0.9.4-ja.patch
415- updated gnome-mplayer-0.9.4-ja.po
416- updated the URL tag
417
418* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
419- initial build
420- added ja.po
421
422* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
423- Added patch fixing rpmfusion bug #238 from SVN
424- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
425
426* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
427- Updated to 0.9.3
428
429* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
430- Refactored the spec to allow building both minimal and full-featured versions
431- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
432
433* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
434- Updated to 0.9.2
435- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
436- Provide gnome-mplayer-core-functionality
437
438* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
439- Updated to 0.9.1
440
441* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
442- Updated to 0.9.0
443- Added libnotify-devel to BuildRequires
444- Added gvfs-fuse to Requires
445
446* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
447- Updated to 0.8.0
448
449* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
450- Added alsa-lib-devel to BuildRequires (livna bug #2084)
451
452* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
453- Updated to 0.7.0
454
455* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
456- rebuild for buildsys cflags issue
457
458* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
459- Updated to 0.6.3
460
461* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
462- Added mencoder to Requires (bug #1991)
463
464* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
465- Updated to 0.6.2
466
467* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
468- Updated to 0.6.1
469- Updated URL and Source0
470
471* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
472- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.