source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 6286

Revision 6286, 15.5 KB checked in by munepi, 12 years ago (diff)

dropped a wrapper of /usr/bin/gnome-mplayer

Line 
1#TODO: Nautilus extention
2%define with_nautilus 0
3%define with_my_japo 0
4#% define svnrevision 2227
5#% define rcversion 1
6#% define betaversion b1
7
8Name:           gnome-mplayer
9Version:        1.0.6
10Release:        4%{?betaversion:.%betaversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
11Summary:        An MPlayer GUI, a full-featured binary
12Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
13Group:          Applications/Multimedia
14License:        GPLv2+
15URL:            http://kdekorte.googlepages.com/gnomemplayer
16Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?betaversion:%betaversion}%{?svnrevision:.svn%svnrevision}%{?rcversion:.rc%rcversion}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
17Source10:       gnome-mplayer-snapshot.sh
18
19## vine
20%if %{with_my_japo}
21Source100:      gnome-mplayer-1.0.6b1.svn2227-ja.po
22%endif
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  gmtk-devel >= 1.0.5
27BuildRequires:  alsa-lib-devel
28BuildRequires:  pulseaudio-libs-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  desktop-file-utils
31BuildRequires:  GConf2-devel
32BuildRequires:  gettext
33BuildRequires:  glib2-devel
34%if %{?_dist_release} == "vl7"
35BuildRequires:  gtk3-devel
36%elseif %{?_dist_release} == "vl6"
37BuildRequires:  gtk2-devel
38%endif
39#BuildRequires:  libcurl-devel
40BuildRequires:  curl-devel
41BuildRequires:  libgpod-devel
42%if %{?_dist_release} != "vl5"
43BuildRequires:  libmusicbrainz3-devel
44%endif
45#BuildRequires:  libmusicbrainz-devel
46BuildRequires:  libnotify-devel
47BuildRequires:  libXScrnSaver-devel
48BuildRequires:  gnome-power-manager
49
50Requires:       gvfs-fuse
51Requires:       gnome-power-manager
52#Requires:       mencoder
53#Requires:       self-build-mplayer
54
55Requires(pre):  GConf2
56Requires(post): GConf2
57Requires(preun): GConf2
58
59Distribution:   Vine Linux
60Vendor:         Project Vine
61Packager:       munepi
62
63
64%description
65GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
66player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
67a rich API that is exposed via DBus. Using DBus you can control a single or
68multiple instances of GNOME MPlayer from a single command.
69
70%description -l ja
71GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
72インターフェースです。とても引き締まったていて,
73MPlayer への簡単でかつ明確なインターフェースを提供します.
74GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
75DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
76GNOME MPlayer のインスタンスを制御できます.
77
78gnome-mplayer を使うためには,mplayer が必要です.
79
80
81%if %{with_nautilus}
82%package nautilus
83Summary:        A Nautilus extention of %{name}
84Summary(ja):    %{name} の Nautilus 拡張
85Group:          Applications/Multimedia
86Requires:       %{name} = %{version}-%{release}
87Requires:       nautilus-extensions
88
89%description nautilus
90GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
91player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
92a rich API that is exposed via DBus. Using DBus you can control a single or
93multiple instances of GNOME MPlayer from a single command.
94
95This package provides a nautilus extension, which shows properties of audio and
96video files in the properties dialogue.
97
98%description nautilus -l ja
99GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
100インターフェースです。とても引き締まったていて,
101MPlayer への簡単でかつ明確なインターフェースを提供します.
102GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
103DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
104GNOME MPlayer のインスタンスを制御できます.
105
106このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
107プロパティを示すに Nautilus 拡張を提供します.
108%endif
109
110%prep
111#% setup -q %{?rcversion:-n %{name}-%{version}.rc%{rcversion}}
112%setup -q %{?betaversion:-n %{name}-%{version}%betaversion}
113
114## vine
115%if %{with_my_japo}
116%__install -m644 %{SOURCE100} po/ja.po
117%endif
118
119
120%build
121%configure \
122    %if %{?_dist_release} == "vl7"
123    --enable-gtk3 \
124    %endif
125    %if !%{with_nautilus}
126    --disable-nautilus \
127    %endif
128    --disable-schemas-compile \
129    \
130    --with-dbus \
131    --with-alsa \
132    --with-pulseaudio \
133    --with-libnotify \
134    --with-libgpod \
135    %if %{?_dist_release} != "vl5"
136    --with-libmusicbrainz3 \
137    %endif
138    ;
139%__make %{?_smp_mflags}
140
141
142%install
143%__rm -rf $RPM_BUILD_ROOT
144
145export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
146%__make install DESTDIR=$RPM_BUILD_ROOT
147
148desktop-file-install --vendor=vine \
149       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
150       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
151
152%find_lang %{name}
153
154# remove intrusive docs
155%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
156
157# remove unpackaged files
158find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
159
160
161# %pre
162# if [ "$1" -gt 1 ]; then
163#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
164#     gconftool-2 --makefile-uninstall-rule \
165#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
166#     # If the schema file has ever been renamed::
167#     #gconftool-2 --makefile-uninstall-rule \
168#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
169# fi
170
171
172%post
173touch --no-create %{_datadir}/icons/hicolor
174if [ -x %{_bindir}/gtk-update-icon-cache ]; then
175  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
176fi
177update-desktop-database &> /dev/null || :
178
179# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
180# gconftool-2 --makefile-install-rule \
181#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
182
183%posttrans
184glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
185# update-desktop-database %{_datadir}/applications/
186
187# %preun
188# if [ "$1" -eq 0 ]; then
189#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
190#     gconftool-2 --makefile-uninstall-rule \
191#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
192# fi
193
194%postun
195if [ $1 -eq 0 ]; then
196  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
197  update-desktop-database %{_datadir}/applications/
198fi
199
200touch --no-create %{_datadir}/icons/hicolor
201if [ -x %{_bindir}/gtk-update-icon-cache ]; then
202  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
203fi
204update-desktop-database &> /dev/null || :
205
206
207%clean
208%__rm -rf $RPM_BUILD_ROOT
209
210
211%files -f %{name}.lang
212%defattr(-,root,root,-)
213%{_bindir}/gnome-mplayer
214%{_datadir}/applications/*-gnome-mplayer.desktop
215%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
216%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
217# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
218%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
219%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
220%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
221%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
222%{_mandir}/man1/gnome-mplayer.1.gz
223
224%if %{with_nautilus}
225%files nautilus
226%{_libdir}/nautilus/extensions-2.0/*.so.*
227%{_libdir}/nautilus/extensions-2.0/*.so
228%endif
229
230
231%changelog
232* Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-4
233- dropped a wrapper of /usr/bin/gnome-mplayer
234
235* Mon Apr 16 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-3
236- new upstream release
237
238* Thu Apr  5 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-2.b1.svn2227
239- source 1.0.6b1 svn2227
240- updated ja.po
241
242* Sat Mar 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.6-1.b1
243- new upstream release
244
245* Tue Feb 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
246- updated ja.po
247
248* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
249- updated ja.po
250
251* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
252- new upstream release
253
254* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1.b1.svn2180
255- source 1.0.5b1
256- updated ja.po
257- added BuildRequires: gmtk-devel >= 1.0.5
258  - dropped --disable-static from %%configure
259- enable gtk3 for vl7
260  - added BuildRequires: gtk3-devel
261  - added --enable-gtk3 in %%configure
262
263* Sun Sep 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-4
264- rebuilt with libnotify-0.7.4
265
266* Mon Jul 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-3
267- new upstream release
268
269* Fri Jun 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2.b2
270- source 1.0.4b2
271
272* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
273- source snapshot 1.0.4b1 r2124
274- use gsettings
275
276* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
277- new upstream release
278
279* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
280- source snapshot 1.0.3beta r1992
281
282* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
283- source snapshot 1.0.3beta r1989
284  - added --disable-schemas-compile in configure options
285  - use GSettings (%%posttrans, %%postun)
286- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
287
288* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
289- new upstream release
290
291* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
292- source snapshot 1.0.1b1 r1912
293
294* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
295- source snapshot 1.0.1b1 r1892
296- added BuildRequires: pulseaudio-libs-devel
297
298* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
299- new upstream release
300- added BuildRequires:
301  - libmusicbrainz3-devel (only vl6)
302  - gnome-power-manager
303- added Requires: gnome-power-manager
304
305* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
306- source 0.9.99.rc3
307
308* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
309- source 0.9.99.rc1
310  - applied gnome-mplayer-0.9.99.rc1-ja.po
311  - entry ja in gnome-mplayer.desktop
312
313* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
314- source snapshot r1729
315
316* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
317- fixed gnome-mplayer.sh.in
318
319* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
320- source snapshot r1685
321- added gnome-mplayer.sh.in
322  - this script is a wrapper to check MPlayer binary existance
323
324* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
325- source snapshot r1673
326  - Rework vdpau codec selection and deinterlace (r1673)
327
328* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
329- new upstream release
330
331* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
332- new upstream release
333- added gnome-mplayer-snapshot.sh
334
335* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
336- source snapshot r1619
337- added gnome-mplayer-0.9.9.svn1619-ja.po
338
339* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
340- source snapshot r1599
341- added BuildRequires: libXScrnSaver-devel
342
343* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
344- source snapshot r1583
345- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
346
347* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
348- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
349  - fix hidden cursor over menus (r1576)
350
351* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
352- new upstream release
353
354* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
355- source snapshot r1540
356
357* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
358- source snapshot r1538
359  - updated the latest up-to-date ja.po
360
361* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
362- new upstream release
363
364* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
365- source snapshot r1493
366
367* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
368- source snapshot r1486
369  - updated the latest up-to-date ja.po
370- added gtk-update-icon-cache actions in %%post, %%postun
371
372* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
373- rebuild with libgpod-0.7.2
374- gconf uninstall rule in %%preun, not %%postun
375
376* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
377- new upstream release
378
379* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
380- source snapshot r1298
381  - updated the latest up-to-date ja.po
382
383* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
384- dropped Requires: self-build-mplayer
385
386* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
387- source snapshot r1236
388- updated the latest up-to-date ja.po
389
390* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
391- new upstream release
392
393* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
394- dropped a Nautilus plugin once
395
396* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
397- source snapshot r1184
398- dropped gnome-mplayer-0.9.4-ja.patch
399  - committed Japanese translation
400- applied gnome-mplayer-0.9.4.r1184-ja.po
401  - update the latest up-to-date ja.po
402
403* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
404- added Summary(ja), %%description -l ja
405- updated gnome-mplayer-0.9.4-ja.patch
406
407* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
408- new upstream release
409- updated gnome-mplayer-0.9.4-ja.patch
410- updated gnome-mplayer-0.9.4-ja.po
411- updated the URL tag
412
413* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
414- initial build
415- added ja.po
416
417* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
418- Added patch fixing rpmfusion bug #238 from SVN
419- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
420
421* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
422- Updated to 0.9.3
423
424* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
425- Refactored the spec to allow building both minimal and full-featured versions
426- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
427
428* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
429- Updated to 0.9.2
430- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
431- Provide gnome-mplayer-core-functionality
432
433* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
434- Updated to 0.9.1
435
436* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
437- Updated to 0.9.0
438- Added libnotify-devel to BuildRequires
439- Added gvfs-fuse to Requires
440
441* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
442- Updated to 0.8.0
443
444* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
445- Added alsa-lib-devel to BuildRequires (livna bug #2084)
446
447* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
448- Updated to 0.7.0
449
450* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
451- rebuild for buildsys cflags issue
452
453* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
454- Updated to 0.6.3
455
456* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
457- Added mencoder to Requires (bug #1991)
458
459* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
460- Updated to 0.6.2
461
462* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
463- Updated to 0.6.1
464- Updated URL and Source0
465
466* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
467- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.