source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 5783

Revision 5783, 15.4 KB checked in by munepi, 12 years ago (diff)

updated gnome-mplayer

Line 
1#TODO: Nautilus extention
2%define with_nautilus 0
3%define with_my_japo 1
4#% define svnrevision 2180
5#% define rcversion 1
6#% define betaversion b1
7
8%define GNOME_MPLAYER_BIN %{_libexecdir}/%{name}
9
10Name:           gnome-mplayer
11Version:        1.0.5
12Release:        3%{?betaversion:.%betaversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
13Summary:        An MPlayer GUI, a full-featured binary
14Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
15Group:          Applications/Multimedia
16License:        GPLv2+
17URL:            http://kdekorte.googlepages.com/gnomemplayer
18Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?betaversion:%betaversion}%{?svnrevision:.svn%svnrevision}%{?rcversion:.rc%rcversion}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
19Source10:       gnome-mplayer-snapshot.sh
20Source50:       gnome-mplayer.sh.in
21
22## vine
23%if %{with_my_japo}
24Source100:      gnome-mplayer-1.0.6b1.svn2220-ja.po
25%endif
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
28
29BuildRequires:  gmtk-devel >= 1.0.5
30BuildRequires:  alsa-lib-devel
31BuildRequires:  pulseaudio-libs-devel
32BuildRequires:  dbus-glib-devel
33BuildRequires:  desktop-file-utils
34BuildRequires:  GConf2-devel
35BuildRequires:  gettext
36BuildRequires:  glib2-devel
37%if %{?_dist_release} == "vl7"
38BuildRequires:  gtk3-devel
39%elseif %{?_dist_release} == "vl6"
40BuildRequires:  gtk2-devel
41%endif
42#BuildRequires:  libcurl-devel
43BuildRequires:  curl-devel
44BuildRequires:  libgpod-devel
45%if %{?_dist_release} != "vl5"
46BuildRequires:  libmusicbrainz3-devel
47%endif
48#BuildRequires:  libmusicbrainz-devel
49BuildRequires:  libnotify-devel
50BuildRequires:  libXScrnSaver-devel
51BuildRequires:  gnome-power-manager
52
53Requires:       gvfs-fuse
54Requires:       gnome-power-manager
55#Requires:       mencoder
56#Requires:       self-build-mplayer
57
58Requires(pre):  GConf2
59Requires(post): GConf2
60Requires(preun): GConf2
61
62Distribution:   Vine Linux
63Vendor:         Project Vine
64Packager:       munepi
65
66
67%description
68GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
69player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
70a rich API that is exposed via DBus. Using DBus you can control a single or
71multiple instances of GNOME MPlayer from a single command.
72
73%description -l ja
74GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
75インターフェースです。とても引き締まったていて,
76MPlayer への簡単でかつ明確なインターフェースを提供します.
77GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
78DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
79GNOME MPlayer のインスタンスを制御できます.
80
81gnome-mplayer を使うためには,mplayer が必要です.
82
83
84%if %{with_nautilus}
85%package nautilus
86Summary:        A Nautilus extention of %{name}
87Summary(ja):    %{name} の Nautilus 拡張
88Group:          Applications/Multimedia
89Requires:       %{name} = %{version}-%{release}
90Requires:       nautilus-extensions
91
92%description nautilus
93GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
94player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
95a rich API that is exposed via DBus. Using DBus you can control a single or
96multiple instances of GNOME MPlayer from a single command.
97
98This package provides a nautilus extension, which shows properties of audio and
99video files in the properties dialogue.
100
101%description nautilus -l ja
102GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
103インターフェースです。とても引き締まったていて,
104MPlayer への簡単でかつ明確なインターフェースを提供します.
105GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
106DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
107GNOME MPlayer のインスタンスを制御できます.
108
109このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
110プロパティを示すに Nautilus 拡張を提供します.
111%endif
112
113%prep
114#% setup -q %{?rcversion:-n %{name}-%{version}.rc%{rcversion}}
115%setup -q %{?betaversion:-n %{name}-%{version}%betaversion}
116
117## vine
118%if %{with_my_japo}
119%__install -m644 %{SOURCE100} po/ja.po
120%endif
121
122
123%build
124%configure \
125    %if %{?_dist_release} == "vl7"
126    --enable-gtk3 \
127    %endif
128    %if !%{with_nautilus}
129    --disable-nautilus \
130    %endif
131    --disable-schemas-compile \
132    \
133    --with-dbus \
134    --with-alsa \
135    --with-pulseaudio \
136    --with-libnotify \
137    --with-libgpod \
138    %if %{?_dist_release} != "vl5"
139    --with-libmusicbrainz3 \
140    %endif
141    ;
142%__make %{?_smp_mflags}
143
144
145%install
146%__rm -rf $RPM_BUILD_ROOT
147
148export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
149%__make install DESTDIR=$RPM_BUILD_ROOT
150
151desktop-file-install --vendor=vine \
152       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
153       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
154
155## wrapper
156%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
157%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{GNOME_MPLAYER_BIN}
158%__sed s,@@GNOME_MPLAYER_BIN@@,%{GNOME_MPLAYER_BIN}, %{SOURCE50} > $RPM_BUILD_ROOT%{_bindir}/%{name}
159%__chmod 0755 $RPM_BUILD_ROOT%{_bindir}/%{name}
160
161%find_lang %{name}
162
163# remove intrusive docs
164%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
165
166# remove unpackaged files
167find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
168
169
170# %pre
171# if [ "$1" -gt 1 ]; then
172#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
173#     gconftool-2 --makefile-uninstall-rule \
174#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
175#     # If the schema file has ever been renamed::
176#     #gconftool-2 --makefile-uninstall-rule \
177#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
178# fi
179
180
181%post
182touch --no-create %{_datadir}/icons/hicolor
183if [ -x %{_bindir}/gtk-update-icon-cache ]; then
184  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
185fi
186update-desktop-database &> /dev/null || :
187
188# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
189# gconftool-2 --makefile-install-rule \
190#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
191
192%posttrans
193glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
194# update-desktop-database %{_datadir}/applications/
195
196# %preun
197# if [ "$1" -eq 0 ]; then
198#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
199#     gconftool-2 --makefile-uninstall-rule \
200#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
201# fi
202
203%postun
204if [ $1 -eq 0 ]; then
205  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
206  update-desktop-database %{_datadir}/applications/
207fi
208
209touch --no-create %{_datadir}/icons/hicolor
210if [ -x %{_bindir}/gtk-update-icon-cache ]; then
211  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
212fi
213update-desktop-database &> /dev/null || :
214
215
216%clean
217%__rm -rf $RPM_BUILD_ROOT
218
219
220%files -f %{name}.lang
221%defattr(-,root,root,-)
222%{_bindir}/gnome-mplayer
223%{GNOME_MPLAYER_BIN}
224%{_datadir}/applications/*-gnome-mplayer.desktop
225%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
226%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
227# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
228%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
229%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
230%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
231%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
232%{_mandir}/man1/gnome-mplayer.1.gz
233
234%if %{with_nautilus}
235%files nautilus
236%{_libdir}/nautilus/extensions-2.0/*.so.*
237%{_libdir}/nautilus/extensions-2.0/*.so
238%endif
239
240
241%changelog
242* Tue Feb 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
243- updated ja.po
244
245* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
246- updated ja.po
247
248* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
249- new upstream release
250
251* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1.b1.svn2180
252- source 1.0.5b1
253- updated ja.po
254- added BuildRequires: gmtk-devel >= 1.0.5
255  - dropped --disable-static from %%configure
256- enable gtk3 for vl7
257  - added BuildRequires: gtk3-devel
258  - added --enable-gtk3 in %%configure
259
260* Sun Sep 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-4
261- rebuilt with libnotify-0.7.4
262
263* Mon Jul 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-3
264- new upstream release
265
266* Fri Jun 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2.b2
267- source 1.0.4b2
268
269* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
270- source snapshot 1.0.4b1 r2124
271- use gsettings
272
273* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
274- new upstream release
275
276* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
277- source snapshot 1.0.3beta r1992
278
279* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
280- source snapshot 1.0.3beta r1989
281  - added --disable-schemas-compile in configure options
282  - use GSettings (%%posttrans, %%postun)
283- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
284
285* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
286- new upstream release
287
288* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
289- source snapshot 1.0.1b1 r1912
290
291* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
292- source snapshot 1.0.1b1 r1892
293- added BuildRequires: pulseaudio-libs-devel
294
295* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
296- new upstream release
297- added BuildRequires:
298  - libmusicbrainz3-devel (only vl6)
299  - gnome-power-manager
300- added Requires: gnome-power-manager
301
302* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
303- source 0.9.99.rc3
304
305* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
306- source 0.9.99.rc1
307  - applied gnome-mplayer-0.9.99.rc1-ja.po
308  - entry ja in gnome-mplayer.desktop
309
310* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
311- source snapshot r1729
312
313* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
314- fixed gnome-mplayer.sh.in
315
316* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
317- source snapshot r1685
318- added gnome-mplayer.sh.in
319  - this script is a wrapper to check MPlayer binary existance
320
321* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
322- source snapshot r1673
323  - Rework vdpau codec selection and deinterlace (r1673)
324
325* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
326- new upstream release
327
328* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
329- new upstream release
330- added gnome-mplayer-snapshot.sh
331
332* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
333- source snapshot r1619
334- added gnome-mplayer-0.9.9.svn1619-ja.po
335
336* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
337- source snapshot r1599
338- added BuildRequires: libXScrnSaver-devel
339
340* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
341- source snapshot r1583
342- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
343
344* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
345- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
346  - fix hidden cursor over menus (r1576)
347
348* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
349- new upstream release
350
351* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
352- source snapshot r1540
353
354* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
355- source snapshot r1538
356  - updated the latest up-to-date ja.po
357
358* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
359- new upstream release
360
361* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
362- source snapshot r1493
363
364* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
365- source snapshot r1486
366  - updated the latest up-to-date ja.po
367- added gtk-update-icon-cache actions in %%post, %%postun
368
369* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
370- rebuild with libgpod-0.7.2
371- gconf uninstall rule in %%preun, not %%postun
372
373* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
374- new upstream release
375
376* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
377- source snapshot r1298
378  - updated the latest up-to-date ja.po
379
380* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
381- dropped Requires: self-build-mplayer
382
383* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
384- source snapshot r1236
385- updated the latest up-to-date ja.po
386
387* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
388- new upstream release
389
390* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
391- dropped a Nautilus plugin once
392
393* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
394- source snapshot r1184
395- dropped gnome-mplayer-0.9.4-ja.patch
396  - committed Japanese translation
397- applied gnome-mplayer-0.9.4.r1184-ja.po
398  - update the latest up-to-date ja.po
399
400* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
401- added Summary(ja), %%description -l ja
402- updated gnome-mplayer-0.9.4-ja.patch
403
404* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
405- new upstream release
406- updated gnome-mplayer-0.9.4-ja.patch
407- updated gnome-mplayer-0.9.4-ja.po
408- updated the URL tag
409
410* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
411- initial build
412- added ja.po
413
414* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
415- Added patch fixing rpmfusion bug #238 from SVN
416- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
417
418* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
419- Updated to 0.9.3
420
421* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
422- Refactored the spec to allow building both minimal and full-featured versions
423- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
424
425* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
426- Updated to 0.9.2
427- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
428- Provide gnome-mplayer-core-functionality
429
430* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
431- Updated to 0.9.1
432
433* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
434- Updated to 0.9.0
435- Added libnotify-devel to BuildRequires
436- Added gvfs-fuse to Requires
437
438* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
439- Updated to 0.8.0
440
441* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
442- Added alsa-lib-devel to BuildRequires (livna bug #2084)
443
444* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
445- Updated to 0.7.0
446
447* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
448- rebuild for buildsys cflags issue
449
450* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
451- Updated to 0.6.3
452
453* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
454- Added mencoder to Requires (bug #1991)
455
456* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
457- Updated to 0.6.2
458
459* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
460- Updated to 0.6.1
461- Updated URL and Source0
462
463* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
464- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.