source: projects/specs/trunk/g/gnome-mplayer/gnome-mplayer-vl.spec @ 4060

Revision 4060, 14.3 KB checked in by munepi, 13 years ago (diff)

updated gnome-mplayer-vl.spec and gecko-mediaplayer-vl.spec

Line 
1#TODO: Nautilus extention
2%define with_nautilus 0
3%define with_my_japo 1
4%define svnrevision 2124
5%define betaversion b1
6
7%define GNOME_MPLAYER_BIN %{_libexecdir}/%{name}
8
9Name:           gnome-mplayer
10Version:        1.0.4
11Release:        1%{?betaversion:.%betaversion}%{?svnrevision:.svn%svnrevision}%{?_dist_release}
12Summary:        An MPlayer GUI, a full-featured binary
13Summary(ja):    高機能な MPlayer のグラフィカルユーザーインターフェース
14Group:          Applications/Multimedia
15License:        GPLv2+
16URL:            http://kdekorte.googlepages.com/gnomemplayer
17Source0:        http://gnome-mplayer.googlecode.com/files/%{name}-%{version}%{?betaversion:%betaversion}%{?svnrevision:.svn%svnrevision}.tar.%{?svnrevision:xz}%{!?svnrevision:gz}
18Source10:       gnome-mplayer-snapshot.sh
19Source50:       gnome-mplayer.sh.in
20
21## vine
22%if %{with_my_japo}
23Source100:      gnome-mplayer-1.0.4b1.svn2124-ja.po
24%endif
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
27
28BuildRequires:  alsa-lib-devel
29BuildRequires:  pulseaudio-libs-devel
30BuildRequires:  dbus-glib-devel
31BuildRequires:  desktop-file-utils
32BuildRequires:  GConf2-devel
33BuildRequires:  gettext
34BuildRequires:  glib2-devel
35BuildRequires:  gtk2-devel
36#BuildRequires:  libcurl-devel
37BuildRequires:  curl-devel
38BuildRequires:  libgpod-devel
39%if %{?_dist_release} != "vl5"
40BuildRequires:  libmusicbrainz3-devel
41%endif
42#BuildRequires:  libmusicbrainz-devel
43BuildRequires:  libnotify-devel
44BuildRequires:  libXScrnSaver-devel
45BuildRequires:  gnome-power-manager
46
47Requires:       gvfs-fuse
48Requires:       gnome-power-manager
49#Requires:       mencoder
50#Requires:       self-build-mplayer
51
52Requires(pre):  GConf2
53Requires(post): GConf2
54Requires(preun): GConf2
55
56Distribution:   Vine
57Vendor:         Project Vine
58Packager:       munepi
59
60
61%description
62GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
63player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
64a rich API that is exposed via DBus. Using DBus you can control a single or
65multiple instances of GNOME MPlayer from a single command.
66
67%description -l ja
68GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
69インターフェースです。とても引き締まったていて,
70MPlayer への簡単でかつ明確なインターフェースを提供します.
71GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
72DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
73GNOME MPlayer のインスタンスを制御できます.
74
75gnome-mplayer を使うためには,mplayer が必要です.
76
77
78%if %{with_nautilus}
79%package nautilus
80Summary:        A Nautilus extention of %{name}
81Summary(ja):    %{name} の Nautilus 拡張
82Group:          Applications/Multimedia
83Requires:       %{name} = %{version}-%{release}
84Requires:       nautilus-extensions
85
86%description nautilus
87GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
88player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
89a rich API that is exposed via DBus. Using DBus you can control a single or
90multiple instances of GNOME MPlayer from a single command.
91
92This package provides a nautilus extension, which shows properties of audio and
93video files in the properties dialogue.
94
95%description nautilus -l ja
96GNOME MPlayer は MPlayer のための簡単なグラフィカルユーザー
97インターフェースです。とても引き締まったていて,
98MPlayer への簡単でかつ明確なインターフェースを提供します.
99GNOME MPlayer は DBus 経由で公開されている豊富な API を持っています。
100DBus を使って,あなたは1つのコマンドから単一のあるいは複数の
101GNOME MPlayer のインスタンスを制御できます.
102
103このパッケージはプロパティダイアログ内でオーディオやビデオファイルの
104プロパティを示すに Nautilus 拡張を提供します.
105%endif
106
107%prep
108%setup -q %{?betaversion:-n %{name}-%{version}%betaversion}
109
110%if %{with_my_japo}
111## vine
112%__install -m644 %{SOURCE100} po/ja.po
113%endif
114
115
116%build
117%configure \
118    --disable-static \
119    %if !%{with_nautilus}
120    --disable-nautilus \
121    %endif
122    --disable-schemas-compile \
123    \
124    --with-dbus \
125    --with-alsa \
126    --with-pulseaudio \
127    --with-libnotify \
128    --with-libgpod \
129    %if %{?_dist_release} != "vl5"
130    --with-libmusicbrainz3 \
131    %endif
132    ;
133%__make %{?_smp_mflags}
134
135
136%install
137%__rm -rf $RPM_BUILD_ROOT
138
139export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
140%__make install DESTDIR=$RPM_BUILD_ROOT
141
142desktop-file-install --vendor=vine \
143       --delete-original --dir $RPM_BUILD_ROOT%{_datadir}/applications \
144       $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
145
146## wrapper
147%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
148%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{GNOME_MPLAYER_BIN}
149%__sed s,@@GNOME_MPLAYER_BIN@@,%{GNOME_MPLAYER_BIN}, %{SOURCE50} > $RPM_BUILD_ROOT%{_bindir}/%{name}
150%__chmod 0755 $RPM_BUILD_ROOT%{_bindir}/%{name}
151
152%find_lang %{name}
153
154# remove intrusive docs
155%__rm -rf $RPM_BUILD_ROOT%{_docdir}/gnome-mplayer
156
157# remove unpackaged files
158find $RPM_BUILD_ROOT -name *.la -exec %__rm -f {} \;
159
160
161# %pre
162# if [ "$1" -gt 1 ]; then
163#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
164#     gconftool-2 --makefile-uninstall-rule \
165#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas >/dev/null || :
166#     # If the schema file has ever been renamed::
167#     #gconftool-2 --makefile-uninstall-rule \
168#     #  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
169# fi
170
171
172%post
173touch --no-create %{_datadir}/icons/hicolor
174if [ -x %{_bindir}/gtk-update-icon-cache ]; then
175  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
176fi
177update-desktop-database &> /dev/null || :
178
179# export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
180# gconftool-2 --makefile-install-rule \
181#   %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
182
183%posttrans
184glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
185# update-desktop-database %{_datadir}/applications/
186
187# %preun
188# if [ "$1" -eq 0 ]; then
189#     export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
190#     gconftool-2 --makefile-uninstall-rule \
191#       %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas > /dev/null || :
192# fi
193
194%postun
195if [ $1 -eq 0 ]; then
196  glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
197  update-desktop-database %{_datadir}/applications/
198fi
199
200touch --no-create %{_datadir}/icons/hicolor
201if [ -x %{_bindir}/gtk-update-icon-cache ]; then
202  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
203fi
204update-desktop-database &> /dev/null || :
205
206
207%clean
208%__rm -rf $RPM_BUILD_ROOT
209
210
211%files -f %{name}.lang
212%defattr(-,root,root,-)
213%{_bindir}/gnome-mplayer
214%{GNOME_MPLAYER_BIN}
215%{_datadir}/applications/*-gnome-mplayer.desktop
216%{_datadir}/gnome-control-center/default-apps/gnome-mplayer.xml
217%doc AUTHORS COPYING ChangeLog INSTALL NEWS README DOCS/* DOCS/tech/*
218# %{_sysconfdir}/gconf/schemas/gnome-mplayer.schemas
219%{_datadir}/glib-2.0/schemas/apps.gecko-mediaplayer.preferences.gschema.xml
220%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.enums.xml
221%{_datadir}/glib-2.0/schemas/apps.gnome-mplayer.preferences.gschema.xml
222%{_datadir}/icons/hicolor/*/apps/gnome-mplayer.*
223%{_mandir}/man1/gnome-mplayer.1.gz
224
225%if %{with_nautilus}
226%files nautilus
227%{_libdir}/nautilus/extensions-2.0/*.so.*
228%{_libdir}/nautilus/extensions-2.0/*.so
229%endif
230
231
232%changelog
233* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1.b1.svn2124
234- source snapshot 1.0.4b1 r2124
235
236* Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-3
237- new upstream release
238
239* Tue Apr 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2.beta.svn1992
240- source snapshot 1.0.3beta r1992
241
242* Sun Apr 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1.beta.svn1989
243- source snapshot 1.0.3beta r1989
244  - added --disable-schemas-compile in configure options
245  - use GSettings (%%posttrans, %%postun)
246- updated Japanese translation (gnome-mplayer-1.0.3beta.svn1989-ja.po)
247
248* Tue Mar 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-2
249- new upstream release
250
251* Wed Mar 02 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1912
252- source snapshot 1.0.1b1 r1912
253
254* Thu Feb 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1.b1.svn1892
255- source snapshot 1.0.1b1 r1892
256- added BuildRequires: pulseaudio-libs-devel
257
258* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.0-1
259- new upstream release
260- added BuildRequires:
261  - libmusicbrainz3-devel (only vl6)
262  - gnome-power-manager
263- added Requires: gnome-power-manager
264
265* Tue Oct 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-2.rc3
266- source 0.9.99.rc3
267
268* Fri Aug 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.99-1.rc1
269- source 0.9.99.rc1
270  - applied gnome-mplayer-0.9.99.rc1-ja.po
271  - entry ja in gnome-mplayer.desktop
272
273* Mon Jun 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-5.svn1729
274- source snapshot r1729
275
276* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-4.svn1685
277- fixed gnome-mplayer.sh.in
278
279* Sat Apr 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-3.svn1685
280- source snapshot r1685
281- added gnome-mplayer.sh.in
282  - this script is a wrapper to check MPlayer binary existance
283
284* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-2.svn1673
285- source snapshot r1673
286  - Rework vdpau codec selection and deinterlace (r1673)
287
288* Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9.2-1
289- new upstream release
290
291* Sat Feb 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-4
292- new upstream release
293- added gnome-mplayer-snapshot.sh
294
295* Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-2.svn1619
296- source snapshot r1619
297- added gnome-mplayer-0.9.9.svn1619-ja.po
298
299* Mon Dec 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1599
300- source snapshot r1599
301- added BuildRequires: libXScrnSaver-devel
302
303* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.9-1.svn1583
304- source snapshot r1583
305- dropped gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
306
307* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-4
308- applied gnome-mplayer-0.9.8-fix-hidden-cursor-over-menus.patch
309  - fix hidden cursor over menus (r1576)
310
311* Sat Sep 19 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-3
312- new upstream release
313
314* Tue Sep 15 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-2.svn1540
315- source snapshot r1540
316
317* Mon Sep 14 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.8-1.svn1538
318- source snapshot r1538
319  - updated the latest up-to-date ja.po
320
321* Sat Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-3
322- new upstream release
323
324* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-2.svn1493
325- source snapshot r1493
326
327* Fri Aug 07 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.7-1.svn1486
328- source snapshot r1486
329  - updated the latest up-to-date ja.po
330- added gtk-update-icon-cache actions in %%post, %%postun
331
332* Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6-2
333- rebuild with libgpod-0.7.2
334- gconf uninstall rule in %%preun, not %%postun
335
336* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.6-1
337- new upstream release
338
339* Thu May 27 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-4.svn1298
340- source snapshot r1298
341  - updated the latest up-to-date ja.po
342
343* Sat Apr 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-3.svn1236
344- dropped Requires: self-build-mplayer
345
346* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-2.svn1236
347- source snapshot r1236
348- updated the latest up-to-date ja.po
349
350* Sun Mar 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.5-1
351- new upstream release
352
353* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-4.r1184
354- dropped a Nautilus plugin once
355
356* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-3.r1184
357- source snapshot r1184
358- dropped gnome-mplayer-0.9.4-ja.patch
359  - committed Japanese translation
360- applied gnome-mplayer-0.9.4.r1184-ja.po
361  - update the latest up-to-date ja.po
362
363* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-2
364- added Summary(ja), %%description -l ja
365- updated gnome-mplayer-0.9.4-ja.patch
366
367* Fri Feb 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.4-1
368- new upstream release
369- updated gnome-mplayer-0.9.4-ja.patch
370- updated gnome-mplayer-0.9.4-ja.po
371- updated the URL tag
372
373* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.3-1
374- initial build
375- added ja.po
376
377* Thu Jan  8 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-2
378- Added patch fixing rpmfusion bug #238 from SVN
379- Made the dependencies between packages stricter (%%{version} → %%{version}-%%{release})
380
381* Sat Jan  3 2009 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.3-1
382- Updated to 0.9.3
383
384* Mon Nov 24 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-2
385- Refactored the spec to allow building both minimal and full-featured versions
386- s/gnome-mplayer-core-functionality/gnome-mplayer-binary
387
388* Sat Nov 22 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.2-1
389- Updated to 0.9.2
390- Added libcurl-devel, libgpod-devel and libmusicbrainz3-devel to BuildRequires
391- Provide gnome-mplayer-core-functionality
392
393* Sun Nov  2 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.1-1
394- Updated to 0.9.1
395
396* Fri Oct 31 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.9.0-1
397- Updated to 0.9.0
398- Added libnotify-devel to BuildRequires
399- Added gvfs-fuse to Requires
400
401* Mon Sep 29 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.8.0-1.1
402- Updated to 0.8.0
403
404* Sat Sep  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-2.1
405- Added alsa-lib-devel to BuildRequires (livna bug #2084)
406
407* Sun Aug 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.7.0-1.1
408- Updated to 0.7.0
409
410* Wed Jul 30 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 0.6.3-2
411- rebuild for buildsys cflags issue
412
413* Sun Jul  6 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.3-1
414- Updated to 0.6.3
415
416* Tue Jun 10 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-2
417- Added mencoder to Requires (bug #1991)
418
419* Wed May 28 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.2-1
420- Updated to 0.6.2
421
422* Thu Apr 17 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.1-1
423- Updated to 0.6.1
424- Updated URL and Source0
425
426* Wed Feb 13 2008 Julian Sikorski <belegdol[at]gmail[dot]com> - 0.6.0-1
427- Initial rpmfusion release
Note: See TracBrowser for help on using the repository browser.