source: projects/specs/trunk/g/gnome-libs/gnome-libs-vl.spec @ 521

Revision 521, 12.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define name    gnome-libs
3%define ver     1.4.2
4%define rel     3%{?_dist_release}
5
6Summary:        The libraries needed to run the GNOME GUI desktop environment.
7Summary(ja):    GNOME GUI デスクトップ環境に必要なライブラリ集
8
9Name:           %name
10Version:        %ver
11Release:        %rel
12License:        LGPL
13Group:          System Environment/Libraries
14Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.4/%{name}-%{ver}.tar.bz2
15Source2:        gnome-libs-pofiles.tar.gz
16
17URL:            http://www.gnome.org/
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  libutempter-devel
20BuildRequires:  zlib-devel
21BuildRequires:  db4-devel
22BuildRequires:  imlib-devel
23BuildRequires:  esound-devel
24BuildRequires:  ORBit-devel
25BuildRequires:  glib-devel
26BuildRequires:  gtk+-devel >= 1.2.5
27BuildRequires:  libpng-devel >= 1.2.5
28BuildRequires:  libXt-devel
29BuildRequires:  libXpm-devel
30BuildRequires:  automake14
31BuildRequires:  autoconf213
32
33Requires:       gtk+ >= 1.2.5
34Requires:       libpng >= 1.2.5
35Requires:       gnome-audio
36#Requires:      utempter
37Requires:       ORBit
38Requires:       imlib
39
40Obsoletes:      gnome
41
42# Red Hat-specific patches are prefaced with RH, please.
43Patch5:         gnome-libs-gtkrc.patch
44
45Patch25:        http://www.kr.freebsd.org/~hwang/patch/gnome-icon-item.c-preedit-diff
46# Enable setting canvas into a "bghack" mode with gtk_object_set_data
47Patch34:        gnome-libs-1.2.13-bghack.patch
48Patch40:        gnome-libs-1.4.1.2.90-png10.patch
49Patch41:        gnome-libs-1.4.1.2.90-db1.patch
50Patch42:        gnome-libs-1.4.1.2.90-ac25.patch
51Patch44:        gnome-libs-1.4.1.2.90-alpha_size_t.patch
52Patch45:        gnome-libs-1.4.1.2.90-moz-remote-fix.patch
53Patch46:        gnome-libs-1.4.1.2.90-ghelp.patch
54Patch50:        gnome-libs-1.2.13-config-dir-variable.patch
55Patch52:        gnome-libs-1.4.1.2.90-htmlview.patch
56Patch53:        gnome-libs-1.4.1.2.90-remove-duplicate-definition.patch
57
58# Fedora patches
59Patch80:        gnome-libs-1.4.2-multilib.patch
60Patch81:        gnome-libs-1.4.2-dateedit-fix1.patch
61
62# source/patch for vine
63Source100:      gnome-libs-gtkrc.ja
64Patch100:       gnome-libs-1.0.61-fontset.patch
65Patch101:       gnome-libs-1.2.8-vine-font.patch
66Patch107:       gnome-libs-1.2.4-zvt-fontsize.patch
67Patch108:       gnome-libs-1.2.12-config.patch
68Patch109:       gnome-libs-1.4.2-db48.patch
69Patch110:       gnome-libs-1.4.2-noxalf.patch
70Patch111:       gnome-libs-1.4.2-dentry.patch
71Patch112:       gnome-libs-1.4.2-html_escape.patch
72Patch113:       gnome-libs-1.4.2-vine-font.patch
73Patch120:       gnome-libs-1.4.2-iconfont.patch
74
75# patch from kondara
76Patch200:       gnome-libs-1.0.55-i18nfix.patch
77
78Packager:       inagaki
79
80%description
81GNOME (GNU Network Object Model Environment) is a user-friendly set of
82GUI applications and desktop tools to be used in conjunction with a
83window manager for the X Window System.  The gnome-libs package
84includes libraries that are needed to run GNOME.
85
86%description -l ja
87GNOME (GNU Network Object Model Environment) は、
88Xウィンドウ・システム用ウィンドウマネージャと結合して利用される、
89ユーザ・フレンドリなGUIアプリケーションとデスクトップ・ツールの
90セットです。gnome-libsパッケージはGNOMEの実行に必要なライブラリ
91郡を含んでいます。
92
93%package devel
94Summary:        Libraries and include files for developing GNOME applications.
95Summary(ja):    GNOMEアプリケーション開発用のライブラリとインクルードファイル郡
96Group:          Development/Libraries
97Requires:       %{name} = %{version}-%{release}
98Requires:       imlib-devel
99Requires:       ORBit-devel
100Requires:       esound-devel
101Requires:       gtk+-devel
102Obsoletes:      gnome-devel
103
104%description devel
105GNOME (GNU Network Object Model Environment) is a user-friendly set of
106GUI applications and desktop tools to be used in conjunction with a
107window manager for the X Window System. The gnome-libs-devel package
108includes the libraries and include files that you will need to develop
109GNOME applications.
110
111You should install the gnome-libs-devel package if you would like to
112develop GNOME applications.  You don't need to install gnome-libs-devel
113if you just want to use the GNOME desktop environment.
114
115%description -l ja
116GNOME (GNU Network Object Model Environment) は、
117Xウィンドウ・システム用ウィンドウマネージャと結合して利用される、
118ユーザ・フレンドリなGUIアプリケーションとデスクトップ・ツールの
119セットです。gnome-libs-develパッケージはGNOMEアプリケーションの
120開発に必要なライブラリ郡を含んでいます。
121
122GNOMEアプリケーションを開発したい場合、gnome-libs-develパッケージ
123をインストールする必要があります。単にGNOMEデスクトップ環境を利用
124するだけなら、gnome-libs-develパッケージは必要ありません。
125
126%prep
127%setup -q
128
129cp %{SOURCE100} libgnomeui/gtkrc.ja
130
131%patch5 -p1 -b .gtkrc
132
133%patch25 -p0 -b .iconedit
134%patch34 -p1 -b .bghack
135
136## using a perl munge instead to avoid rerunning autoconf
137# %patch40 -p1 -b .png10
138# %patch41 -p1 -b .db1
139%patch42 -p1 -b .ac25
140%patch44 -p1 -b .alpha_size_t
141
142%patch45 -p1 -b .moz-remote-fix
143%patch46 -p1 -b .ghelp
144%patch50 -p1 -b .config-dir-variable
145%patch52 -p1 -b .htmlview
146%patch53 -p1 -b .remove-duplicate-definition
147
148%patch80 -p1 -b .multilib
149%patch81 -p1 -b .dateedit-fix1
150
151%patch100 -p1 -b .fontset
152#%patch101 -p1 -b .vine-font
153%patch107 -p1 -b .zvt-fontsize
154%patch108 -p1 -b .config
155%patch109 -p1 -b .db46
156
157%patch110 -p1 -b .noxalf
158%patch111 -p1 -b .dentry
159%patch112 -p1 -b .html_escape
160%patch113 -p1 -b .vine-font
161%patch120 -p0 -b .iconfont
162
163%patch200 -p1 -b .i18nfix
164
165# translations
166tar zxf %{SOURCE2}
167
168
169%build
170#libtoolize --copy --force
171## the gtkrc patch changes a Makefile.am
172automake-1.4
173autoconf-2.13
174%configure --disable-static \
175    --enable-prefer-db1 \
176    --with-kde-datadir=/usr/share \
177    --disable-gtk-doc
178make %{?_smp_mflags}
179
180%install
181[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
182
183%makeinstall
184mv $RPM_BUILD_ROOT%{_datadir}/doc/gnome-doc $RPM_BUILD_ROOT%{_bindir}
185chmod a+x $RPM_BUILD_ROOT%{_bindir}/gnome-doc
186mv $RPM_BUILD_ROOT%{_datadir}/doc/mkstub $RPM_BUILD_ROOT%{_bindir}
187chmod a+x $RPM_BUILD_ROOT%{_bindir}/mkstub
188%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
189mv $RPM_BUILD_ROOT%{_datadir}/doc/gnome-doc.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
190
191%find_lang %{name}
192
193## remove unused files
194rm -f $RPM_BUILD_ROOT%{_prefix}/doc/*
195rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
196rm -f $RPM_BUILD_ROOT%{_datadir}/doc/*
197rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/*
198
199
200%clean
201[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
202
203%post -p /sbin/ldconfig
204%postun -p /sbin/ldconfig
205
206%files -f %{name}.lang
207%defattr(-, root, root)
208%doc AUTHORS COPYING ChangeLog NEWS README
209%{_bindir}/dns-helper
210%{_bindir}/gconfigger
211%{_bindir}/gnome-bug
212%{_bindir}/gnome-dump-metadata
213%{_bindir}/gnome-gen-mimedb
214%{_bindir}/gnome-moz-remote
215%{_bindir}/gnome-name-service
216%{_bindir}/gnome_segv
217%{_bindir}/goad-browser
218%{_bindir}/loadshlib
219%{_bindir}/new-object
220%attr(2755, root, utmp) %{_sbindir}/gnome-pty-helper
221%{_libdir}/lib*.so.*
222%{_datadir}/idl/*
223%{_datadir}/pixmaps/*
224%{_datadir}/mime-info/gnome.mime
225%{_datadir}/type-convert/*
226%{_mandir}/man1/*
227%{_mandir}/man5/*
228%config %{_sysconfdir}/*
229
230%files devel
231%defattr(-, root, root)
232%doc devel-docs
233%{_bindir}/gnome-config
234%{_bindir}/libart-config
235%{_bindir}/gnome-doc
236%{_bindir}/mkstub
237%{_libdir}/lib*.so
238#{_libdir}/*.a
239#{_libdir}/*.la
240%{_libdir}/*.sh
241%{_libdir}/gnome-libs
242%{_includedir}/*
243%{_datadir}/aclocal/*
244%{_datadir}/gnome
245%{_datadir}/emacs/site-lisp/*
246
247%changelog
248* Fri Feb 12 2010 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.2-3
249- rebuilt with db4-4.8
250- updated Patch109: gnome-libs-1.4.2-db48.patch
251
252* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-2
253- updated Patch109 for using db-4.6.21
254- BuildRequires: libutempter-devel instead of utempter
255- removed lib*.a
256
257* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.2-1vl5
258- removed lib*.la
259- removed unused files
260- applied new versioning policy and spec in utf-8
261
262* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl8
263- rebuilt for fixing libgnorba.la
264
265* Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl7
266- rebuilt with new toolchains/environment
267- updated Patch109 for using db-4.3.29
268- added patches from Fedora
269  * Fri Mar  9 2007 Paul Howarth <paul@city-fan.org> 1:1.4.2-5
270  - Fix GnomeDateEdit time format regression (#230186)
271  * Tue Feb 13 2007 Paul Howarth <paul@city-fan.org> 1:1.4.2-4
272  - Fix multilib conflict in /etc/mime-magic.dat (#228361)
273
274* Tue Feb 28 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.2-0vl6
275- dropt libtoolize
276- rebuilt for x86_64 architecture
277
278* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-0vl5
279- rebuilt with db4-4.2.25
280- --disable-gtk-doc
281
282* Tue Dec 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl4
283- rebuilt with new toolchains
284- added Patch120 from Vine Linux 2.6r3 release
285- s/Copyright/License/
286
287* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-0vl3
288- rebuilt against libpng >= 1.2.5
289
290* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-0vl2
291- rebuilt against db4 (disabled Patch41, added Patch109)
292
293* Fri Oct 25 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-0vl1
294- new upstream release.
295- cleaned patch files (several was merged source)
296- noxalf.pactch was renewal   (Patch110)
297- vine-font.patch was renewal (Patch113)
298
299* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.4.1.2-0vl1
300- New upstream release.
301- Merged several RH patches.
302
303* Wed Mar 21 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.13-0vl1
304- New upstream release.
305- Use rpmmacros.
306
307* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
308- 1.2.8-0vl1
309
310* Mon Oct 16 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl3
311- zvt default font size changed
312
313* Mon Oct 16 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
314- XmHTML default font size changed
315
316* Wed Jul 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
317- updated to 1.2.4
318- added dialog_default patch to focus a specfied button for keybord.
319
320* Fri Jun 21 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
321- updated to 1.2.3
322
323* Mon Jun 19 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
324- added vine's gtkrc.ja.
325
326* Fri Jun  2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
327- updated to 1.2.1
328
329* Wed May 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
330- modified zvt_mb pach to fix threshold value of MB_CUR_MAX for glibc 2.1.3.
331
332* Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
333- updated 1.2.0
334
335* Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
336- updated 1.0.61
337
338* Mon May  8 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
339- updated 1.0.60
340- removed some RH patch (RH-snd*) merged.
341- add japo_fix patch to fix a bug that make popt to segfault.
342
343* Wed Mar 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
344- updated 1.0.57
345- remake SPEC from RH6.2 for vine
346
347* Mon Feb 21 2000 Preston Brown <pbrown@redhat.com>
348- keyboard mapping follows debian policy, xterm
349
350* Tue Feb 15 2000 Owen Taylor <otaylor@redhat.com>
351- Add checks to make sure gnome-terminal survives if the
352  bg pixmap vanishes.
353
354* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
355- Install gtkrc files in /etc/gnome
356
357* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
358- Remove broken alpha timeval fix, fix bug in configure.in
359  that was misdetecting ut_tv field of utmpx
360
361* Thu Feb 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
362- Fix up escape sequences in zvt (Bug #9143)
363
364* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
365- Accept true/yes/non-zero as TRUE for gnome-config boolean values.
366
367* Wed Feb 03 2000 Havoc Pennington <hp@redhat.com>
368- set ECHOK for terminal widget, bug 8823
369
370* Wed Feb 02 2000 Havoc Pennington <hp@redhat.com>
371- include man pages in the file list, also bug 8017
372
373* Wed Feb 02 2000 Havoc Pennington <hp@redhat.com>
374- Fix an alpha warning bugzilla #8017
375
376* Tue Feb 01 2000 Elliot Lee <sopwith@redhat.com>
377- Update to 1.0.55
378
379* Tue Aug 31 1999 Elliot Lee <sopwith@redhat.com>
380- Update to 1.0.15
381
382* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com>
383- Merge in various minor things from RHL
384
385* Mon Jun 14 1999 Gregory McLean <gregm@comstar.net>
386
387- Added the -q option to the setup stage, quiet please!
388
389* Tue Mar 2  1999 Gregory McLean <gregm@comstar.net>
390
391- Added some hackage in for the brain dead libtool on the alpha
392- Cleaned up the spec file abit to be more consistant.
393
394* Wed Feb 17 1999 Elliot Lee <sopwith@redhat.com>
395
396- Add debugging disabling flags to $CFLAGS
397
398* Fri Nov 20 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
399
400- use --localstatedir=/var/lib in config state (score files for games
401  for exemple will go there).
402- added several more files to %files section, in particular language
403  files and corba IDLs
404
405* Wed Sep 23 1998 Michael Fulbright <msf@redhat.com>
406
407- Updated to version 0.30
408
409* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
410- Added %{prefix}/lib/gnome-libs
411
412* Fri Mar 13 1998 Marc Ewing <marc@redhat.com>
413
414- Integrate into gnome-libs source tree
Note: See TracBrowser for help on using the repository browser.