source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 9602

Revision 9602, 9.3 KB checked in by Takemikaduchi, 9 years ago (diff)

task-mate: change keyring package
others: new upstream release

Line 
1%define gtk3_version 3.16.0
2
3Summary: A framework for managing user passwords and other secrets
4Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
5Name: gnome-keyring
6Version: 3.16.0
7Release: 1%{?_dist_release}
8License: GPL/LGPL
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.16/%{name}-%{version}.tar.xz
11URL: http://www.gnome.org
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Patch2: %{name}-2.31.91-configure-vine.patch
15
16Requires: gtk3 >= %{gtk3_version}
17BuildRequires: gtk3-devel >= %{gtk3_version}
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libgcrypt-devel
21BuildRequires: libtasn1-devel
22BuildRequires: openssl-devel
23BuildRequires: gcr-devel
24BuildRequires: pam-devel
25BuildRequires: p11-kit-devel
26BuildRequires: libxslt
27BuildRequires: docbook-style-xsl
28BuildRequires: autoconf, automake, libtool
29BuildRequires: intltool
30BuildRequires: perl(XML::Parser)
31
32# remove mate-keyring package
33Obsoletes: mate-keyring < 1.8.0
34Obsoletes: mate-keyring-devel < 1.8.0
35Obsoletes: mate-keyring-doc < 1.8.0
36
37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: Takemikaduchi
40
41%description
42gnome-keyring manages passwords and other types of secrets
43for the user, storing them encrypted with a main password.
44Applications can use the gnome-keyring library to integrate
45with the keyring.
46
47%package pam
48Summary: A pam module for unlocking keyrings at login time
49License: LGPLv2+
50Group: System Environment/Libraries
51Requires: %{name} = %{version}-%{release}
52# for /lib/security
53Requires: pam
54
55%description pam
56The gnome-keyring-pam package contains a pam module that can
57automatically unlock the "login" keyring when the user logs in
58and start the keyring daemon.
59
60
61%prep
62%setup -q -n gnome-keyring-%{version}
63%patch2 -p1 -b .vine
64
65%build
66%configure \
67        --with-gtk=3.0 \
68        --disable-gtk-doc \
69        --disable-update-mime \
70        --enable-pam \
71        --without-libcap-ng \
72        --with-pam-dir=/%{_lib}/security
73
74make %{?_smp_mflags}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install install-pam DESTDIR=$RPM_BUILD_ROOT
79
80rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
81
82%find_lang %{name}
83
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
86rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
87rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
88rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post
94/sbin/ldconfig
95if [ -x /usr/bin/gtk-update-icon-cache ]; then
96  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
97fi
98update-mime-database %{_datadir}/mime > /dev/null || :
99
100
101%postun
102/sbin/ldconfig
103if [ $1 -eq 0 ]; then
104        glib-compile-schemas %{_datadir}/glib-2.0/schemas
105        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
106        update-mime-database %{_datadir}/mime > /dev/null || :
107fi
108
109%posttrans
110glib-compile-schemas %{_datadir}/glib-2.0/schemas
111
112
113%files -f %{name}.lang
114%defattr(-, root, root)
115%doc AUTHORS NEWS README COPYING COPYING.LIB
116%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
117%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
118%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
119%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
120%{_datadir}/p11-kit/modules/gnome-keyring.module
121%{_bindir}/*
122%dir %{_libdir}/gnome-keyring
123%{_libdir}/gnome-keyring/devel/*.so
124%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
125%{_datadir}/dbus-1/services/*
126%{_datadir}/GConf/gsettings/*
127%{_datadir}/glib-2.0/schemas/*
128%{_mandir}/man1/gnome-keyring-3.1.gz
129%{_mandir}/man1/gnome-keyring-daemon.1.gz
130%{_mandir}/man1/gnome-keyring.1.gz
131
132%files pam
133%defattr(-, root, root)
134/%{_lib}/security/*.so
135
136
137%changelog
138* Sun Jun 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
139- new upstream release
140- add Obsoletes: mate-keyring
141
142* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.15.92-1
143- new upstream release
144
145* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
146- new upstream release
147- remove BuildRequires: libcap-ng-devel
148
149* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
150- new upstream release
151
152* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
153- new upstream release
154
155* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 3.10.1-3
156- rebuilt libtasn1-3.4 and libgcrypt-1.6
157
158* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
159- rebuild with VineSeed environment
160
161* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
162- new upstream release
163- add BuildRequires: p11-kit-devel, libxslt, docbook-style-xsl
164
165* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
166- new upstream release
167
168* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
169- new upstream release
170
171* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
172- new upstream release
173
174* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
175- new upstream release
176
177* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
178- new upstream release
179
180* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
181- new upstream release
182
183* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
184- new upstream release
185- remove BuildRequires: p11-kit-devel
186- add BuildRequires: gcr-devel
187- remove devel sub package
188- remove compat32 sub packages
189
190* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
191- new upstream release
192
193* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
194- new upstream release
195
196* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
197- new upstream release
198
199* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
200- new upstream release
201
202* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
203- new upstream release
204- remove Patch3
205
206* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
207- new upstream release
208- change BuildRequires: gtk3-devel instead of gtk2-devel
209- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
210- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
211
212* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
213- new upstream release
214
215* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
216- new upstream release
217- add configure option (--enable-pam)
218- remove configure option (--disable-schemas-install)
219- add Patch2 (%{name}-2.31.91-configure-vine.patch)
220
221* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
222- build with rpm-4.8.1-1 for pkg-config file
223
224* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
225- new upstream release
226
227* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
228- new upstream release
229
230* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
231- new upstream release
232- remove BuildRequires: hal-devel
233
234* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
235- new upstream release
236- add BuildRequires: GConf2-devel
237
238* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
239- new upstream release
240
241* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
242- added compat32 package for x86_64 arch support
243
244* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
245- new upstream release
246
247* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
248- new upstream release
249
250* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
251- new upstream release
252
253* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
254- new upstream release
255
256* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
257- new upstream release
258
259* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
260- new upstream release
261
262* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
263- new upstream release
264
265* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
266- new upstream release
267- added BuildRequires: libtasn1-devel
268
269* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
270- new upstream release
271- added a pam subpackage
272
273* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
274- new upstream release
275
276* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
277- new upstream release
278
279* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
280- new upstream release
281
282* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
283- new upstream release
284
285* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
286- new upstream release
287
288* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
289- new upstream version
290
291* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
292- new upstream release
293
294* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
295- initial build for Vine Linux based on fedora's spec file.
296
297* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
298- rebuilt
299
300* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
301- update to 0.2.0
302
303* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
304- update to 0.1.90
305
306* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
307- rebuilt
308
309* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
310- update to 0.1.4
311
312* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
313- rebuilt
314
315* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
316- update to 0.1.3
317
318* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
319- tweak summary
320
321* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
322- devel package only needs glib2-devel, not gtk2-devel
323
324* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
325- First version
Note: See TracBrowser for help on using the repository browser.