source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 9073

Revision 9073, 8.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.14.1

Line 
1%define gtk3_version 3.14.0
2
3Summary: A framework for managing user passwords and other secrets
4Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
5Name: gnome-keyring
6Version: 3.14.0
7Release: 1%{?_dist_release}
8License: GPL/LGPL
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.14/%{name}-%{version}.tar.xz
11URL: http://www.gnome.org
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: gtk3 >= %{gtk3_version}
14BuildRequires: gtk3-devel >= %{gtk3_version}
15BuildRequires: dbus-devel >= 1.0
16BuildRequires: gettext
17BuildRequires: libgcrypt-devel
18BuildRequires: libtasn1-devel
19BuildRequires: openssl-devel
20BuildRequires: gcr-devel
21BuildRequires: pam-devel
22BuildRequires: p11-kit-devel
23BuildRequires: libxslt
24BuildRequires: docbook-style-xsl
25BuildRequires: autoconf, automake, libtool
26BuildRequires: intltool
27BuildRequires: perl(XML::Parser)
28
29Patch2: %{name}-2.31.91-configure-vine.patch
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35gnome-keyring manages passwords and other types of secrets
36for the user, storing them encrypted with a main password.
37Applications can use the gnome-keyring library to integrate
38with the keyring.
39
40%package pam
41Summary: A pam module for unlocking keyrings at login time
42License: LGPLv2+
43Group: System Environment/Libraries
44Requires: %{name} = %{version}-%{release}
45# for /lib/security
46Requires: pam
47
48%description pam
49The gnome-keyring-pam package contains a pam module that can
50automatically unlock the "login" keyring when the user logs in
51and start the keyring daemon.
52
53
54%prep
55%setup -q -n gnome-keyring-%{version}
56%patch2 -p1 -b .vine
57
58%build
59%configure \
60        --with-gtk=3.0 \
61        --disable-gtk-doc \
62        --disable-update-mime \
63        --enable-pam \
64        --without-libcap-ng \
65        --with-pam-dir=/%{_lib}/security
66
67make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install install-pam DESTDIR=$RPM_BUILD_ROOT
72
73rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
74
75%find_lang %{name}
76
77rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
79rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
80rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
81rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87/sbin/ldconfig
88if [ -x /usr/bin/gtk-update-icon-cache ]; then
89  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
90fi
91update-mime-database %{_datadir}/mime > /dev/null || :
92
93
94%postun
95/sbin/ldconfig
96if [ $1 -eq 0 ]; then
97        glib-compile-schemas %{_datadir}/glib-2.0/schemas
98        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
99        update-mime-database %{_datadir}/mime > /dev/null || :
100fi
101
102%posttrans
103glib-compile-schemas %{_datadir}/glib-2.0/schemas
104
105
106%files -f %{name}.lang
107%defattr(-, root, root)
108%doc AUTHORS NEWS README COPYING COPYING.LIB
109%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
110%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
111%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
112%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
113%{_datadir}/p11-kit/modules/gnome-keyring.module
114%{_bindir}/*
115%dir %{_libdir}/gnome-keyring
116%{_libdir}/gnome-keyring/devel/*.so
117%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
118%{_datadir}/dbus-1/services/*
119%{_datadir}/GConf/gsettings/*
120%{_datadir}/glib-2.0/schemas/*
121%{_mandir}/man1/gnome-keyring-3.1.gz
122%{_mandir}/man1/gnome-keyring-daemon.1.gz
123%{_mandir}/man1/gnome-keyring.1.gz
124
125%files pam
126%defattr(-, root, root)
127/%{_lib}/security/*.so
128
129
130%changelog
131* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
132- new upstream release
133- remove BuildRequires: libcap-ng-devel
134
135* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
136- new upstream release
137
138* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
139- new upstream release
140
141* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 3.10.1-3
142- rebuilt libtasn1-3.4 and libgcrypt-1.6
143
144* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
145- rebuild with VineSeed environment
146
147* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
148- new upstream release
149- add BuildRequires: p11-kit-devel, libxslt, docbook-style-xsl
150
151* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
152- new upstream release
153
154* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
155- new upstream release
156
157* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
158- new upstream release
159
160* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
161- new upstream release
162
163* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
164- new upstream release
165
166* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
167- new upstream release
168
169* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
170- new upstream release
171- remove BuildRequires: p11-kit-devel
172- add BuildRequires: gcr-devel
173- remove devel sub package
174- remove compat32 sub packages
175
176* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
177- new upstream release
178
179* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
180- new upstream release
181
182* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
183- new upstream release
184
185* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
186- new upstream release
187
188* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
189- new upstream release
190- remove Patch3
191
192* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
193- new upstream release
194- change BuildRequires: gtk3-devel instead of gtk2-devel
195- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
196- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
197
198* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
199- new upstream release
200
201* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
202- new upstream release
203- add configure option (--enable-pam)
204- remove configure option (--disable-schemas-install)
205- add Patch2 (%{name}-2.31.91-configure-vine.patch)
206
207* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
208- build with rpm-4.8.1-1 for pkg-config file
209
210* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
211- new upstream release
212
213* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
214- new upstream release
215
216* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
217- new upstream release
218- remove BuildRequires: hal-devel
219
220* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
221- new upstream release
222- add BuildRequires: GConf2-devel
223
224* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
225- new upstream release
226
227* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
228- added compat32 package for x86_64 arch support
229
230* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
231- new upstream release
232
233* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
234- new upstream release
235
236* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
237- new upstream release
238
239* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
240- new upstream release
241
242* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
243- new upstream release
244
245* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
246- new upstream release
247
248* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
249- new upstream release
250
251* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
252- new upstream release
253- added BuildRequires: libtasn1-devel
254
255* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
256- new upstream release
257- added a pam subpackage
258
259* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
260- new upstream release
261
262* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
263- new upstream release
264
265* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
266- new upstream release
267
268* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
269- new upstream release
270
271* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
272- new upstream release
273
274* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
275- new upstream version
276
277* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
278- new upstream release
279
280* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
281- initial build for Vine Linux based on fedora's spec file.
282
283* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
284- rebuilt
285
286* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
287- update to 0.2.0
288
289* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
290- update to 0.1.90
291
292* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
293- rebuilt
294
295* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
296- update to 0.1.4
297
298* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
299- rebuilt
300
301* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
302- update to 0.1.3
303
304* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
305- tweak summary
306
307* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
308- devel package only needs glib2-devel, not gtk2-devel
309
310* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
311- First version
Note: See TracBrowser for help on using the repository browser.