source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 8447

Revision 8447, 8.8 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.2

Line 
1%define gtk3_version 3.12.0
2
3Summary: A framework for managing user passwords and other secrets
4Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
5Name: gnome-keyring
6Version: 3.12.2
7Release: 1%{?_dist_release}
8License: GPL/LGPL
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.12/%{name}-%{version}.tar.xz
11URL: http://www.gnome.org
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: gtk3 >= %{gtk3_version}
14BuildRequires: gtk3-devel >= %{gtk3_version}
15BuildRequires: dbus-devel >= 1.0
16BuildRequires: gettext
17BuildRequires: libcap-ng-devel
18BuildRequires: libgcrypt-devel
19BuildRequires: libtasn1-devel
20BuildRequires: openssl-devel
21BuildRequires: gcr-devel
22BuildRequires: pam-devel
23BuildRequires: p11-kit-devel
24BuildRequires: libxslt
25BuildRequires: docbook-style-xsl
26BuildRequires: autoconf, automake, libtool
27BuildRequires: intltool
28BuildRequires: perl(XML::Parser)
29
30Patch2: %{name}-2.31.91-configure-vine.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36gnome-keyring manages passwords and other types of secrets
37for the user, storing them encrypted with a main password.
38Applications can use the gnome-keyring library to integrate
39with the keyring.
40
41%package pam
42Summary: A pam module for unlocking keyrings at login time
43License: LGPLv2+
44Group: System Environment/Libraries
45Requires: %{name} = %{version}-%{release}
46# for /lib/security
47Requires: pam
48
49%description pam
50The gnome-keyring-pam package contains a pam module that can
51automatically unlock the "login" keyring when the user logs in
52and start the keyring daemon.
53
54
55%prep
56%setup -q -n gnome-keyring-%{version}
57%patch2 -p1 -b .vine
58
59%build
60%configure \
61        --with-gtk=3.0 \
62        --disable-gtk-doc \
63        --disable-update-mime \
64        --enable-pam \
65        --with-pam-dir=/%{_lib}/security
66
67make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install install-pam DESTDIR=$RPM_BUILD_ROOT
72
73rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
74
75%find_lang %{name}
76
77rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
79rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
80rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
81rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87/sbin/ldconfig
88if [ -x /usr/bin/gtk-update-icon-cache ]; then
89  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
90fi
91update-mime-database %{_datadir}/mime > /dev/null || :
92
93
94%postun
95/sbin/ldconfig
96if [ $1 -eq 0 ]; then
97        glib-compile-schemas %{_datadir}/glib-2.0/schemas
98        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
99        update-mime-database %{_datadir}/mime > /dev/null || :
100fi
101
102%posttrans
103glib-compile-schemas %{_datadir}/glib-2.0/schemas
104
105
106%files -f %{name}.lang
107%defattr(-, root, root)
108%doc AUTHORS NEWS README COPYING COPYING.LIB
109%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
110%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
111%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
112%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
113%{_datadir}/p11-kit/modules/gnome-keyring.module
114%{_bindir}/*
115%dir %{_libdir}/gnome-keyring
116%{_libdir}/gnome-keyring/devel/*.so
117%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
118%{_datadir}/dbus-1/services/*
119%{_datadir}/GConf/gsettings/*
120%{_datadir}/glib-2.0/schemas/*
121%{_mandir}/man1/gnome-keyring-3.1.gz
122%{_mandir}/man1/gnome-keyring-daemon.1.gz
123%{_mandir}/man1/gnome-keyring.1.gz
124
125%files pam
126%defattr(-, root, root)
127/%{_lib}/security/*.so
128
129
130%changelog
131* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
132- new upstream release
133
134* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
135- new upstream release
136
137* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 3.10.1-3
138- rebuilt libtasn1-3.4 and libgcrypt-1.6
139
140* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
141- rebuild with VineSeed environment
142
143* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
144- new upstream release
145- add BuildRequires: p11-kit-devel, libxslt, docbook-style-xsl
146
147* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
148- new upstream release
149
150* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
151- new upstream release
152
153* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
154- new upstream release
155
156* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
157- new upstream release
158
159* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
160- new upstream release
161
162* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
163- new upstream release
164
165* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
166- new upstream release
167- remove BuildRequires: p11-kit-devel
168- add BuildRequires: gcr-devel
169- remove devel sub package
170- remove compat32 sub packages
171
172* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
173- new upstream release
174
175* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
176- new upstream release
177
178* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
179- new upstream release
180
181* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
182- new upstream release
183
184* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
185- new upstream release
186- remove Patch3
187
188* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
189- new upstream release
190- change BuildRequires: gtk3-devel instead of gtk2-devel
191- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
192- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
193
194* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
195- new upstream release
196
197* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
198- new upstream release
199- add configure option (--enable-pam)
200- remove configure option (--disable-schemas-install)
201- add Patch2 (%{name}-2.31.91-configure-vine.patch)
202
203* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
204- build with rpm-4.8.1-1 for pkg-config file
205
206* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
207- new upstream release
208
209* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
210- new upstream release
211
212* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
213- new upstream release
214- remove BuildRequires: hal-devel
215
216* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
217- new upstream release
218- add BuildRequires: GConf2-devel
219
220* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
221- new upstream release
222
223* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
224- added compat32 package for x86_64 arch support
225
226* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
227- new upstream release
228
229* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
230- new upstream release
231
232* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
233- new upstream release
234
235* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
236- new upstream release
237
238* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
239- new upstream release
240
241* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
242- new upstream release
243
244* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
245- new upstream release
246
247* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
248- new upstream release
249- added BuildRequires: libtasn1-devel
250
251* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
252- new upstream release
253- added a pam subpackage
254
255* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
256- new upstream release
257
258* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
259- new upstream release
260
261* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
262- new upstream release
263
264* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
265- new upstream release
266
267* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
268- new upstream release
269
270* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
271- new upstream version
272
273* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
274- new upstream release
275
276* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
277- initial build for Vine Linux based on fedora's spec file.
278
279* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
280- rebuilt
281
282* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
283- update to 0.2.0
284
285* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
286- update to 0.1.90
287
288* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
289- rebuilt
290
291* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
292- update to 0.1.4
293
294* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
295- rebuilt
296
297* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
298- update to 0.1.3
299
300* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
301- tweak summary
302
303* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
304- devel package only needs glib2-devel, not gtk2-devel
305
306* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
307- First version
Note: See TracBrowser for help on using the repository browser.