source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 623

Revision 623, 8.5 KB checked in by Takemikaduchi, 14 years ago (diff)

takemikaduchi fix and add spec file

Line 
1%define gtk2_version 2.16.0
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: A framework for managing user passwords and other secrets
5Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
6Name: gnome-keyring
7Version: 2.28.2
8Release: 1%{?_dist_release}
9License: GPL/LGPL
10Group: System Environment/Libraries
11Source: gnome-keyring-%{version}.tar.bz2
12URL: http://www.gnome.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: gtk2 >= %{gtk2_version}
15Requires(post,pre,preun): GConf2
16BuildRequires: gtk2-devel >= %{gtk2_version}
17BuildRequires: GConf2-devel >= 1.0
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libgcrypt-devel
21BuildRequires: libtasn1-devel
22BuildRequires: pam-devel
23BuildRequires: hal-devel
24BuildRequires: autoconf, automake, libtool
25BuildRequires: intltool
26BuildRequires: perl(XML::Parser)
27
28# http://bugzilla.gnome.org/show_bug.cgi?id=484612
29Patch0:    gnome-keyring-2.20-selinux-pam.patch
30
31# autounlock does not currently work, see
32# https://bugzilla.redhat.com/show_bug.cgi?id=250147
33Patch1: no-autounlock.patch
34
35%description
36gnome-keyring manages passwords and other types of secrets
37for the user, storing them encrypted with a main password.
38Applications can use the gnome-keyring library to integrate
39with the keyring.
40
41%package devel
42Summary: The files needed for gnome-keyring application development.
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: glib2-devel
46
47%description devel
48The gnome-keyring-devel package contains the libraries and
49include files that you can use to develop applications that
50use gnome-keyring.
51
52%package pam
53Summary: A pam module for unlocking keyrings at login time
54License: LGPLv2+
55Group: System Environment/Libraries
56Requires: %{name} = %{version}-%{release}
57# for /lib/security
58Requires: pam
59
60%description pam
61The gnome-keyring-pam package contains a pam module that can
62automatically unlock the "login" keyring when the user logs in
63and start the keyring daemon.
64
65# compat32
66%package -n compat32-%{name}
67Summary: A framework for managing user passwords and other secrets
68Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
69Group: System Environment/Libraries
70Requires: %{name} = %{version}-%{release}
71
72%description -n compat32-%{name}
73gnome-keyring manages passwords and other types of secrets
74for the user, storing them encrypted with a main password.
75Applications can use the gnome-keyring library to integrate
76with the keyring.
77
78%package -n compat32-%{name}-devel
79Summary: The files needed for gnome-keyring application development.
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-%{name} = %{version}-%{release}
83Requires: compat32-glib2-devel
84
85%description -n compat32-%{name}-devel
86The gnome-keyring-devel package contains the libraries and
87include files that you can use to develop applications that
88use gnome-keyring.
89
90%package -n compat32-%{name}-pam
91Summary: A pam module for unlocking keyrings at login time
92License: LGPLv2+
93Group: System Environment/Libraries
94Requires: %{name}-pam = %{version}-%{release}
95Requires: compat32-%{name} = %{version}-%{release}
96# for /lib/security
97Requires: compat32-pam
98
99%description -n compat32-%{name}-pam
100The gnome-keyring-pam package contains a pam module that can
101automatically unlock the "login" keyring when the user logs in
102and start the keyring daemon.
103
104%prep
105%setup -q -n gnome-keyring-%{version}
106
107#patch0 -p1 -b .selinux_pam
108#patch1 -p1 -b .no-autounlock
109
110%build
111%configure --disable-gtk-doc --with-pam-dir=/%{_lib}/security --disable-schemas-install
112make %{?_smp_mflags}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116make install install-pam DESTDIR=$RPM_BUILD_ROOT
117
118rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
119
120%find_lang %{name}
121
122rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
123rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
125rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post
131export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
132gconftool-2 --makefile-install-rule \
133    %{_sysconfdir}/gconf/schemas/gnome-keyring.schemas \
134    > /dev/null || :
135/sbin/ldconfig
136
137%pre
138if [ "$1" -gt 1 ]; then
139  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
140  gconftool-2 --makefile-install-rule \
141      %{_sysconfdir}/gconf/schemas/gnome-keyring.schemas \
142      > /dev/null || :
143fi
144
145%preun
146if [ "$1" -eq 0 ]; then
147  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
148  gconftool-2 --makefile-uninstall-rule \
149      %{_sysconfdir}/gconf/schemas/gnome-keyring.schemas \
150      > /dev/null || :
151fi
152
153%postun -p /sbin/ldconfig
154
155%post -n compat32-%{name} -p /sbin/ldconfig
156
157%postun -n compat32-%{name} -p /sbin/ldconfig
158
159%files -f %{name}.lang
160%defattr(-, root, root)
161%doc AUTHORS NEWS README COPYING COPYING.LIB
162%{_sysconfdir}/gconf/schemas/*.schemas
163%{_sysconfdir}/xdg/autostart/gnome-keyring-daemon.desktop
164%{_bindir}/*
165%{_libdir}/lib*.so.*
166%dir %{_libdir}/gnome-keyring
167%{_libdir}/gnome-keyring/*.so
168%{_libdir}/gnome-keyring/devel/*.so
169%{_libdir}/gnome-keyring/standalone/*.so
170%{_libexecdir}/*
171%{_datadir}/dbus-1/services/*
172%dir %{_datadir}/gcr
173%{_datadir}/gcr/ui/*.ui
174
175%files devel
176%defattr(-, root, root)
177%{_libdir}/lib*.so
178%{_libdir}/pkgconfig/*
179%{_includedir}/*
180%{_datadir}/gtk-doc/html/gnome-keyring
181%{_datadir}/gtk-doc/html/gp11
182%{_datadir}/gtk-doc/html/gcr
183
184%files pam
185%defattr(-, root, root)
186/%{_lib}/security/*.so
187
188# compat32
189%if %{build_compat32}
190%files -n compat32-%{name}
191%defattr(-, root, root)
192%{_libdir}/lib*.so.*
193%dir %{_libdir}/gnome-keyring
194%{_libdir}/gnome-keyring/*.so
195%{_libdir}/gnome-keyring/devel/*.so
196%{_libdir}/gnome-keyring/standalone/*.so
197
198%files -n compat32-%{name}-devel
199%defattr(-, root, root)
200%{_libdir}/lib*.so
201%{_libdir}/pkgconfig/*
202
203%files -n compat32-%{name}-pam
204%defattr(-, root, root)
205/%{_lib}/security/*.so
206%endif
207
208%changelog
209* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
210- new upstream release
211- add BuildRequires: GConf2-devel
212
213* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
214- new upstream release
215
216* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
217- added compat32 package for x86_64 arch support
218
219* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
220- new upstream release
221
222* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
223- new upstream release
224
225* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
226- new upstream release
227
228* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
229- new upstream release
230
231* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
232- new upstream release
233
234* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
235- new upstream release
236
237* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
238- new upstream release
239
240* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
241- new upstream release
242- added BuildRequires: libtasn1-devel
243
244* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
245- new upstream release
246- added a pam subpackage
247
248* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
249- new upstream release
250
251* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
252- new upstream release
253
254* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
255- new upstream release
256
257* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
258- new upstream release
259
260* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
261- new upstream release
262
263* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
264- new upstream version
265
266* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
267- new upstream release
268
269* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
270- initial build for Vine Linux based on fedora's spec file.
271
272* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
273- rebuilt
274
275* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
276- update to 0.2.0
277
278* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
279- update to 0.1.90
280
281* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
282- rebuilt
283
284* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
285- update to 0.1.4
286
287* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
288- rebuilt
289
290* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
291- update to 0.1.3
292
293* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
294- tweak summary
295
296* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
297- devel package only needs glib2-devel, not gtk2-devel
298
299* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
300- First version
Note: See TracBrowser for help on using the repository browser.