source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 5168

Revision 5168, 10.2 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define gtk3_version 3.2.0
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: A framework for managing user passwords and other secrets
5Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
6Name: gnome-keyring
7Version: 3.2.2
8Release: 1%{?_dist_release}
9License: GPL/LGPL
10Group: System Environment/Libraries
11Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.2/%{name}-%{version}.tar.xz
12URL: http://www.gnome.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: gtk3 >= %{gtk3_version}
15Requires(post,pre,preun): GConf2
16BuildRequires: gtk3-devel >= %{gtk3_version}
17BuildRequires: GConf2-devel >= 1.0
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libcap-ng-devel
21BuildRequires: libgcrypt-devel
22BuildRequires: libtasn1-devel
23BuildRequires: openssl-devel
24BuildRequires: p11-kit-devel
25BuildRequires: pam-devel
26BuildRequires: autoconf, automake, libtool
27BuildRequires: intltool
28BuildRequires: perl(XML::Parser)
29
30Patch2: %{name}-2.31.91-configure-vine.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36gnome-keyring manages passwords and other types of secrets
37for the user, storing them encrypted with a main password.
38Applications can use the gnome-keyring library to integrate
39with the keyring.
40
41%package devel
42Summary: The files needed for gnome-keyring application development.
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: glib2-devel
46Requires: gtk3-devel
47Requires: libtasn1-devel
48Requires: p11-kit-devel
49
50%description devel
51The gnome-keyring-devel package contains the libraries and
52include files that you can use to develop applications that
53use gnome-keyring.
54
55%package pam
56Summary: A pam module for unlocking keyrings at login time
57License: LGPLv2+
58Group: System Environment/Libraries
59Requires: %{name} = %{version}-%{release}
60# for /lib/security
61Requires: pam
62
63%description pam
64The gnome-keyring-pam package contains a pam module that can
65automatically unlock the "login" keyring when the user logs in
66and start the keyring daemon.
67
68# compat32
69%package -n compat32-%{name}
70Summary: A framework for managing user passwords and other secrets
71Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
72Group: System Environment/Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description -n compat32-%{name}
76gnome-keyring manages passwords and other types of secrets
77for the user, storing them encrypted with a main password.
78Applications can use the gnome-keyring library to integrate
79with the keyring.
80
81%package -n compat32-%{name}-devel
82Summary: The files needed for gnome-keyring application development.
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85Requires: compat32-%{name} = %{version}-%{release}
86Requires: compat32-glib2-devel
87
88%description -n compat32-%{name}-devel
89The gnome-keyring-devel package contains the libraries and
90include files that you can use to develop applications that
91use gnome-keyring.
92
93%package -n compat32-%{name}-pam
94Summary: A pam module for unlocking keyrings at login time
95License: LGPLv2+
96Group: System Environment/Libraries
97Requires: %{name}-pam = %{version}-%{release}
98Requires: compat32-%{name} = %{version}-%{release}
99# for /lib/security
100Requires: compat32-pam
101
102%description -n compat32-%{name}-pam
103The gnome-keyring-pam package contains a pam module that can
104automatically unlock the "login" keyring when the user logs in
105and start the keyring daemon.
106
107%prep
108%setup -q -n gnome-keyring-%{version}
109%patch2 -p1 -b .vine
110
111%build
112%configure \
113        --with-gtk=3.0 \
114        --disable-gtk-doc \
115        --disable-update-mime \
116        --enable-pam \
117        --with-pam-dir=/%{_lib}/security \
118        --with-root-certs=%{_datadir}/ssl/certs
119
120make %{?_smp_mflags}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124make install install-pam DESTDIR=$RPM_BUILD_ROOT
125
126rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
127
128%find_lang %{name}
129
130rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
131rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
132rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
133rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
134rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post
140/sbin/ldconfig
141if [ -x /usr/bin/gtk-update-icon-cache ]; then
142  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
143fi
144update-mime-database %{_datadir}/mime > /dev/null || :
145
146
147%postun
148/sbin/ldconfig
149if [ $1 -eq 0 ]; then
150        glib-compile-schemas %{_datadir}/glib-2.0/schemas
151        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
152        update-mime-database %{_datadir}/mime > /dev/null || :
153fi
154
155%posttrans
156glib-compile-schemas %{_datadir}/glib-2.0/schemas
157
158%post -n compat32-%{name} -p /sbin/ldconfig
159
160%postun -n compat32-%{name} -p /sbin/ldconfig
161
162%files -f %{name}.lang
163%defattr(-, root, root)
164%doc AUTHORS NEWS README COPYING COPYING.LIB
165%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
166%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
167%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
168%{_sysconfdir}/xdg/autostart/gnome-keyring-gpg.desktop
169%{_sysconfdir}/pkcs11/modules/gnome-keyring-module
170%{_bindir}/*
171%{_libdir}/lib*.so.*
172%dir %{_libdir}/gnome-keyring
173%{_libdir}/gnome-keyring/devel/*.so
174%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
175%{_libexecdir}/*
176%{_datadir}/applications/gcr-viewer.desktop
177%{_datadir}/applications/gnome-keyring-prompt.desktop
178%{_datadir}/dbus-1/services/*
179%{_datadir}/gnome-keyring-3
180%dir %{_datadir}/gcr-3
181%{_datadir}/gcr-3/ui/*.ui
182%{_datadir}/GConf/gsettings/*
183%{_datadir}/glib-2.0/schemas/*
184%{_datadir}/icons/hicolor/*/apps/*.png
185%{_datadir}/mime/packages/gcr-crypto-types.xml
186
187%files devel
188%defattr(-, root, root)
189%{_libdir}/lib*.so
190%{_libdir}/pkgconfig/*
191%{_includedir}/*
192## %{_datadir}/gtk-doc/html/gnome-keyring
193%{_datadir}/gtk-doc/html/gcr-3
194%{_datadir}/gtk-doc/html/gck
195
196%files pam
197%defattr(-, root, root)
198/%{_lib}/security/*.so
199
200# compat32
201%if %{build_compat32}
202%files -n compat32-%{name}
203%defattr(-, root, root)
204%{_libdir}/lib*.so.*
205%dir %{_libdir}/gnome-keyring
206%{_libdir}/gnome-keyring/devel/*.so
207
208%files -n compat32-%{name}-devel
209%defattr(-, root, root)
210%{_libdir}/lib*.so
211%{_libdir}/pkgconfig/*
212
213%files -n compat32-%{name}-pam
214%defattr(-, root, root)
215/%{_lib}/security/*.so
216%endif
217
218%changelog
219* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
220- new upstream release
221
222* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
223- new upstream release
224
225* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
226- new upstream release
227
228* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
229- new upstream release
230
231* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
232- new upstream release
233- remove Patch3
234
235* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
236- new upstream release
237- change BuildRequires: gtk3-devel instead of gtk2-devel
238- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
239- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
240
241* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
242- new upstream release
243
244* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
245- new upstream release
246- add configure option (--enable-pam)
247- remove configure option (--disable-schemas-install)
248- add Patch2 (%{name}-2.31.91-configure-vine.patch)
249
250* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
251- build with rpm-4.8.1-1 for pkg-config file
252
253* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
254- new upstream release
255
256* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
257- new upstream release
258
259* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
260- new upstream release
261- remove BuildRequires: hal-devel
262
263* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
264- new upstream release
265- add BuildRequires: GConf2-devel
266
267* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
268- new upstream release
269
270* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
271- added compat32 package for x86_64 arch support
272
273* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
274- new upstream release
275
276* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
277- new upstream release
278
279* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
280- new upstream release
281
282* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
283- new upstream release
284
285* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
286- new upstream release
287
288* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
289- new upstream release
290
291* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
292- new upstream release
293
294* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
295- new upstream release
296- added BuildRequires: libtasn1-devel
297
298* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
299- new upstream release
300- added a pam subpackage
301
302* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
303- new upstream release
304
305* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
306- new upstream release
307
308* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
309- new upstream release
310
311* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
312- new upstream release
313
314* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
315- new upstream release
316
317* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
318- new upstream version
319
320* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
321- new upstream release
322
323* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
324- initial build for Vine Linux based on fedora's spec file.
325
326* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
327- rebuilt
328
329* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
330- update to 0.2.0
331
332* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
333- update to 0.1.90
334
335* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
336- rebuilt
337
338* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
339- update to 0.1.4
340
341* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
342- rebuilt
343
344* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
345- update to 0.1.3
346
347* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
348- tweak summary
349
350* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
351- devel package only needs glib2-devel, not gtk2-devel
352
353* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
354- First version
Note: See TracBrowser for help on using the repository browser.