source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 12005

Revision 12005, 9.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define gtk3_version 3.22.30
2
3Summary: A framework for managing user passwords and other secrets
4Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
5Name: gnome-keyring
6Version: 3.28.2
7Release: 1%{?_dist_release}
8License: GPL/LGPL
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
11URL: http://www.gnome.org
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14Patch2: %{name}-2.31.91-configure-vine.patch
15
16Requires: gtk3 >= %{gtk3_version}
17BuildRequires: gtk3-devel >= %{gtk3_version}
18BuildRequires: dbus-devel >= 1.0
19BuildRequires: gettext
20BuildRequires: libgcrypt-devel
21BuildRequires: libtasn1-devel
22BuildRequires: openssl-devel
23BuildRequires: gcr-devel
24BuildRequires: pam-devel
25BuildRequires: p11-kit-devel
26BuildRequires: libxslt
27BuildRequires: docbook-style-xsl
28BuildRequires: autoconf, automake, libtool
29BuildRequires: intltool
30BuildRequires: perl(XML::Parser)
31BuildRequires: openssh-clients
32
33# remove mate-keyring package
34Obsoletes: mate-keyring < 1.8.0
35Obsoletes: mate-keyring-devel < 1.8.0
36Obsoletes: mate-keyring-doc < 1.8.0
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42gnome-keyring manages passwords and other types of secrets
43for the user, storing them encrypted with a main password.
44Applications can use the gnome-keyring library to integrate
45with the keyring.
46
47%package pam
48Summary: A pam module for unlocking keyrings at login time
49License: LGPLv2+
50Group: System Environment/Libraries
51Requires: %{name} = %{version}-%{release}
52# for /lib/security
53Requires: pam
54
55%description pam
56The gnome-keyring-pam package contains a pam module that can
57automatically unlock the "login" keyring when the user logs in
58and start the keyring daemon.
59
60
61%prep
62%setup -q -n gnome-keyring-%{version}
63%patch2 -p1 -b .vine
64
65%build
66%configure \
67        --with-gtk=3.0 \
68        --disable-gtk-doc \
69        --disable-update-mime \
70        --enable-pam \
71        --without-libcap-ng \
72        --with-pam-dir=/%{_lib}/security
73
74make %{?_smp_mflags}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install install-pam DESTDIR=$RPM_BUILD_ROOT
79
80rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
81
82%find_lang %{name}
83
84rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
85rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
86rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
87rm -f $RPM_BUILD_ROOT%{_libdir}/pkcs11/*.la
88rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post
94/sbin/ldconfig
95if [ -x /usr/bin/gtk-update-icon-cache ]; then
96  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
97fi
98update-mime-database %{_datadir}/mime > /dev/null || :
99
100
101%postun
102/sbin/ldconfig
103if [ $1 -eq 0 ]; then
104        glib-compile-schemas %{_datadir}/glib-2.0/schemas
105        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
106        update-mime-database %{_datadir}/mime > /dev/null || :
107fi
108
109%posttrans
110glib-compile-schemas %{_datadir}/glib-2.0/schemas
111
112
113%files -f %{name}.lang
114%defattr(-, root, root)
115%license COPYING COPYING.LIB
116%doc AUTHORS NEWS README
117%{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
118%{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
119%{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
120%{_bindir}/*
121%dir %{_libdir}/gnome-keyring
122%{_libdir}/gnome-keyring/devel/*.so
123%{_libdir}/pkcs11/gnome-keyring-pkcs11.so
124%{_datadir}/dbus-1/services/*
125%{_datadir}/GConf/gsettings/*
126%{_datadir}/glib-2.0/schemas/*
127%{_mandir}/man1/gnome-keyring-3.1.gz
128%{_mandir}/man1/gnome-keyring-daemon.1.gz
129%{_mandir}/man1/gnome-keyring.1.gz
130
131%files pam
132%defattr(-, root, root)
133/%{_lib}/security/*.so
134
135
136%changelog
137* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.28.2-1
138- new upstream release.
139
140* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
141- new upstream release
142
143* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
144- new upstream release
145
146* Sun Jun 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
147- new upstream release
148- add Obsoletes: mate-keyring
149
150* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.15.92-1
151- new upstream release
152
153* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
154- new upstream release
155- remove BuildRequires: libcap-ng-devel
156
157* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
158- new upstream release
159
160* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
161- new upstream release
162
163* Wed Feb 19 2014 NAKAMURA Kenta <kenta@vinelinux.org> 3.10.1-3
164- rebuilt libtasn1-3.4 and libgcrypt-1.6
165
166* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
167- rebuild with VineSeed environment
168
169* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
170- new upstream release
171- add BuildRequires: p11-kit-devel, libxslt, docbook-style-xsl
172
173* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
174- new upstream release
175
176* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
177- new upstream release
178
179* Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
180- new upstream release
181
182* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
183- new upstream release
184
185* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
186- new upstream release
187
188* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
189- new upstream release
190
191* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
192- new upstream release
193- remove BuildRequires: p11-kit-devel
194- add BuildRequires: gcr-devel
195- remove devel sub package
196- remove compat32 sub packages
197
198* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
199- new upstream release
200
201* Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
202- new upstream release
203
204* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
205- new upstream release
206
207* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
208- new upstream release
209
210* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
211- new upstream release
212- remove Patch3
213
214* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
215- new upstream release
216- change BuildRequires: gtk3-devel instead of gtk2-devel
217- add BuildRequires: openssl-devel, p11-kit-devel, libcap-ng-devel
218- add Patch3 (gnome-keyring-3.1.4-git20110729.patch)
219
220* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
221- new upstream release
222
223* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
224- new upstream release
225- add configure option (--enable-pam)
226- remove configure option (--disable-schemas-install)
227- add Patch2 (%{name}-2.31.91-configure-vine.patch)
228
229* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.3-2
230- build with rpm-4.8.1-1 for pkg-config file
231
232* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
233- new upstream release
234
235* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
236- new upstream release
237
238* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
239- new upstream release
240- remove BuildRequires: hal-devel
241
242* Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
243- new upstream release
244- add BuildRequires: GConf2-devel
245
246* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
247- new upstream release
248
249* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
250- added compat32 package for x86_64 arch support
251
252* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
253- new upstream release
254
255* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
256- new upstream release
257
258* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
259- new upstream release
260
261* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
262- new upstream release
263
264* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
265- new upstream release
266
267* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
268- new upstream release
269
270* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
271- new upstream release
272
273* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
274- new upstream release
275- added BuildRequires: libtasn1-devel
276
277* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
278- new upstream release
279- added a pam subpackage
280
281* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
282- new upstream release
283
284* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
285- new upstream release
286
287* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
288- new upstream release
289
290* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
291- new upstream release
292
293* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
294- new upstream release
295
296* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
297- new upstream version
298
299* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
300- new upstream release
301
302* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
303- initial build for Vine Linux based on fedora's spec file.
304
305* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
306- rebuilt
307
308* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
309- update to 0.2.0
310
311* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
312- update to 0.1.90
313
314* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
315- rebuilt
316
317* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
318- update to 0.1.4
319
320* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
321- rebuilt
322
323* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
324- update to 0.1.3
325
326* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
327- tweak summary
328
329* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
330- devel package only needs glib2-devel, not gtk2-devel
331
332* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
333- First version
Note: See TracBrowser for help on using the repository browser.