source: projects/specs/trunk/g/gnome-keyring/gnome-keyring-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define gtk2_version 2.16.0
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary: A framework for managing user passwords and other secrets
5Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
6Name: gnome-keyring
7Version: 2.28.1
8Release: 1%{?_dist_release}
9License: GPL/LGPL
10Group: System Environment/Libraries
11Source: gnome-keyring-%{version}.tar.bz2
12URL: http://www.gnome.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14Requires: gtk2 >= %{gtk2_version}
15Requires(post,pre,preun): GConf2
16BuildRequires: gtk2-devel >= %{gtk2_version}
17BuildRequires: dbus-devel >= 1.0
18BuildRequires: gettext
19BuildRequires: libgcrypt-devel
20BuildRequires: libtasn1-devel
21BuildRequires: pam-devel
22BuildRequires: hal-devel
23BuildRequires: autoconf, automake, libtool
24BuildRequires: intltool
25BuildRequires: perl(XML::Parser)
26
27# http://bugzilla.gnome.org/show_bug.cgi?id=484612
28Patch0:    gnome-keyring-2.20-selinux-pam.patch
29
30# autounlock does not currently work, see
31# https://bugzilla.redhat.com/show_bug.cgi?id=250147
32Patch1: no-autounlock.patch
33
34%description
35gnome-keyring manages passwords and other types of secrets
36for the user, storing them encrypted with a main password.
37Applications can use the gnome-keyring library to integrate
38with the keyring.
39
40%package devel
41Summary: The files needed for gnome-keyring application development.
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Requires: glib2-devel
45
46%description devel
47The gnome-keyring-devel package contains the libraries and
48include files that you can use to develop applications that
49use gnome-keyring.
50
51%package pam
52Summary: A pam module for unlocking keyrings at login time
53License: LGPLv2+
54Group: System Environment/Libraries
55Requires: %{name} = %{version}-%{release}
56# for /lib/security
57Requires: pam
58
59%description pam
60The gnome-keyring-pam package contains a pam module that can
61automatically unlock the "login" keyring when the user logs in
62and start the keyring daemon.
63
64# compat32
65%package -n compat32-%{name}
66Summary: A framework for managing user passwords and other secrets
67Summary(ja): ユーザのパスワードや秘匿情報を管理するためのフレームワーク
68Group: System Environment/Libraries
69Requires: %{name} = %{version}-%{release}
70
71%description -n compat32-%{name}
72gnome-keyring manages passwords and other types of secrets
73for the user, storing them encrypted with a main password.
74Applications can use the gnome-keyring library to integrate
75with the keyring.
76
77%package -n compat32-%{name}-devel
78Summary: The files needed for gnome-keyring application development.
79Group: Development/Libraries
80Requires: %{name}-devel = %{version}-%{release}
81Requires: compat32-%{name} = %{version}-%{release}
82Requires: compat32-glib2-devel
83
84%description -n compat32-%{name}-devel
85The gnome-keyring-devel package contains the libraries and
86include files that you can use to develop applications that
87use gnome-keyring.
88
89%package -n compat32-%{name}-pam
90Summary: A pam module for unlocking keyrings at login time
91License: LGPLv2+
92Group: System Environment/Libraries
93Requires: %{name}-pam = %{version}-%{release}
94Requires: compat32-%{name} = %{version}-%{release}
95# for /lib/security
96Requires: compat32-pam
97
98%description -n compat32-%{name}-pam
99The gnome-keyring-pam package contains a pam module that can
100automatically unlock the "login" keyring when the user logs in
101and start the keyring daemon.
102
103%prep
104%setup -q -n gnome-keyring-%{version}
105
106#patch0 -p1 -b .selinux_pam
107#patch1 -p1 -b .no-autounlock
108
109%build
110%configure --disable-gtk-doc --with-pam-dir=/%{_lib}/security --disable-schemas-install
111make %{?_smp_mflags}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115make install install-pam DESTDIR=$RPM_BUILD_ROOT
116
117rm -f $RPM_BUILD_ROOT%{_libdir}/pam_gnome_keyring.so
118
119%find_lang %{name}
120
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
122rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*.la
123rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/*/*.la
124rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.la
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post
130export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
131gconftool-2 --makefile-install-rule \
132    %{_sysconfdir}/gconf/schemas/gnome-keyring.schemas \
133    > /dev/null || :
134/sbin/ldconfig
135
136%pre
137if [ "$1" -gt 1 ]; then
138  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
139  gconftool-2 --makefile-install-rule \
140      %{_sysconfdir}/gconf/schemas/gnome-keyring.schemas \
141      > /dev/null || :
142fi
143
144%preun
145if [ "$1" -eq 0 ]; then
146  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
147  gconftool-2 --makefile-uninstall-rule \
148      %{_sysconfdir}/gconf/schemas/gnome-keyring.schemas \
149      > /dev/null || :
150fi
151
152%postun -p /sbin/ldconfig
153
154%post -n compat32-%{name} -p /sbin/ldconfig
155
156%postun -n compat32-%{name} -p /sbin/ldconfig
157
158%files -f %{name}.lang
159%defattr(-, root, root)
160%doc AUTHORS NEWS README COPYING COPYING.LIB
161%{_sysconfdir}/gconf/schemas/*.schemas
162%{_sysconfdir}/xdg/autostart/gnome-keyring-daemon.desktop
163%{_bindir}/*
164%{_libdir}/lib*.so.*
165%dir %{_libdir}/gnome-keyring
166%{_libdir}/gnome-keyring/*.so
167%{_libdir}/gnome-keyring/devel/*.so
168%{_libdir}/gnome-keyring/standalone/*.so
169%{_libexecdir}/*
170%{_datadir}/dbus-1/services/*
171%dir %{_datadir}/gcr
172%{_datadir}/gcr/ui/*.ui
173
174%files devel
175%defattr(-, root, root)
176%{_libdir}/lib*.so
177%{_libdir}/pkgconfig/*
178%{_includedir}/*
179%{_datadir}/gtk-doc/html/gnome-keyring
180%{_datadir}/gtk-doc/html/gp11
181%{_datadir}/gtk-doc/html/gcr
182
183%files pam
184%defattr(-, root, root)
185/%{_lib}/security/*.so
186
187# compat32
188%if %{build_compat32}
189%files -n compat32-%{name}
190%defattr(-, root, root)
191%{_libdir}/lib*.so.*
192%dir %{_libdir}/gnome-keyring
193%{_libdir}/gnome-keyring/*.so
194%{_libdir}/gnome-keyring/devel/*.so
195%{_libdir}/gnome-keyring/standalone/*.so
196
197%files -n compat32-%{name}-devel
198%defattr(-, root, root)
199%{_libdir}/lib*.so
200%{_libdir}/pkgconfig/*
201
202%files -n compat32-%{name}-pam
203%defattr(-, root, root)
204/%{_lib}/security/*.so
205%endif
206
207%changelog
208* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
209- new upstream release
210
211* Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.3-2
212- added compat32 package for x86_64 arch support
213
214* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
215- new upstream release
216
217* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
218- new upstream release
219
220* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
221- new upstream release
222
223* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
224- new upstream release
225
226* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
227- new upstream release
228
229* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
230- new upstream release
231
232* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
233- new upstream release
234
235* Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
236- new upstream release
237- added BuildRequires: libtasn1-devel
238
239* Tue Dec 11 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
240- new upstream release
241- added a pam subpackage
242
243* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-0vl1
244- new upstream release
245
246* Tue May 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-0vl1
247- new upstream release
248
249* Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
250- new upstream release
251
252* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.5-0vl1
253- new upstream release
254
255* Wed Sep 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.4-0vl1
256- new upstream release
257
258* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
259- new upstream version
260
261* Sun Dec 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
262- new upstream release
263
264* Sun Aug 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
265- initial build for Vine Linux based on fedora's spec file.
266
267* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
268- rebuilt
269
270* Thu Apr  1 2004 Alex Larsson <alexl@redhat.com> 0.2.0-1
271- update to 0.2.0
272
273* Wed Mar 10 2004 Alexander Larsson <alexl@redhat.com> 0.1.90-1
274- update to 0.1.90
275
276* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
277- rebuilt
278
279* Tue Feb 24 2004 Alexander Larsson <alexl@redhat.com> 0.1.4-1
280- update to 0.1.4
281
282* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
283- rebuilt
284
285* Fri Jan 30 2004 Alexander Larsson <alexl@redhat.com> 0.1.3-1
286- update to 0.1.3
287
288* Mon Jan 26 2004 Bill Nottingham <notting@redhat.com>
289- tweak summary
290
291* Mon Jan 26 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-2
292- devel package only needs glib2-devel, not gtk2-devel
293
294* Fri Jan 23 2004 Alexander Larsson <alexl@redhat.com> 0.1.2-1
295- First version
Note: See TracBrowser for help on using the repository browser.