source: projects/specs/trunk/g/gnome-games/gnome-games-vl.spec @ 6890

Revision 6890, 16.1 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define gettext_package gnome-games
4
5%define glib2_version 2.34.0
6%define gtk3_version 3.6.0
7%define desktop_file_utils_version 0.2.90
8
9Summary: GNOME games
10Summary(ja): GNOME ゲーム集
11Name: gnome-games
12%define major 3.6
13Version: %{major}.0.2
14Release: 1%{?_dist_release}
15License: GPLv2+ and GFDL+
16Group: Applications/Games
17Source: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/%{major}/%{name}-%{version}.tar.xz
18Patch1: gnome-games-2.19.4-gnometris-rebrand.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Obsoletes: gnome gnome-games-devel
22URL: http://www.gnome.org
23
24Requires(postun,posttrans): desktop-file-utils
25Requires(postun,posttrans): glib2
26
27#Requires: pygtk2
28Requires: pygobject3
29Requires: gnuchess
30Requires: hicolor-icon-theme
31
32BuildRequires: glib2-devel >= %{glib2_version}
33BuildRequires: gtk3-devel >= %{gtk3_version}
34BuildRequires: pygobject3-devel
35BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
36BuildRequires: librsvg2-devel
37BuildRequires: clutter-devel, clutter-gtk-devel
38BuildRequires: libcanberra-gtk3-devel
39BuildRequires: gobject-introspection-devel
40BuildRequires: sqlite3-devel
41BuildRequires: mesa-libGLU-devel
42
43BuildRequires: autoconf >= 2.60
44BuildRequires: yelp-tools
45
46
47Provides: gnome-sudoku
48Obsoletes: gnome-sudoku
49
50Provides: glchess
51Obsoletes: glchess < 2.0
52
53BuildRequires: gcc-c++
54
55Vendor: Project Vine
56Distribution: Vine Linux
57
58%description
59
60The gnome-games package includes some small games that come with the
61GNOME desktop environment but can be used under any desktop.
62
63%description -l ja
64
65gnome-games パッケージにはいくつかの小さなゲームが入っています。
66これらは GNOME に由来するものですが、他のデスクトップ環境でも動きます。
67
68%prep
69%setup -q
70# rebrand gnometris as some think the name is to similar to a trademark
71## %patch1 -p1 -b .rebrand
72
73## sed -i -e 's/Gnometris/GnomeFallingBlocks/g' \
74##   -e 's/GNOMEtris/GnomeFallingBlocks/g' \
75##   po/*.po gnometris/help/*/*.po gnometris/help/C/gnometris.xml \
76##   gnometris/*.cpp gnometris/gnometris.desktop.in.in
77
78%build
79
80autoconf
81export CFLAGS="$RPM_OPT_FLAGS -DNO_HOWL"
82# swell-foop, lightsoff: remove (vine6)
83%configure \
84        --localstatedir=/var/lib \
85        --enable-games="quadrapassel,gnect,gnomine,gnome-mahjongg,gtali,gnotravex,gnotski,glines,iagno,glchess,gnobots2,gnibbles,gnome-sudoku"
86make
87
88# strip unneeded translations from .mo files
89# ideally intltool (ha!) would do that for us
90# http://bugzilla.gnome.org/show_bug.cgi?id=474987
91cd po
92grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
93mv POTFILES.keep POTFILES.in
94intltool-update --pot
95for p in *.po; do
96  msgmerge $p %{gettext_package}.pot > $p.out
97  msgfmt -o `basename $p .po`.gmo $p.out
98done
99
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make install DESTDIR=$RPM_BUILD_ROOT
106unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
107
108## mv $RPM_BUILD_ROOT%{_bindir}/gnometris \
109##   $RPM_BUILD_ROOT%{_bindir}/gnome-falling-blocks
110
111## things we just don't want in the package
112
113rm -rf $RPM_BUILD_ROOT%{_libdir}/libgdkcardimage.*a
114
115## install desktop files
116desktop-file-install --vendor gnome --delete-original       \
117  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
118  --remove-category Application                             \
119  --remove-category PuzzleGame                              \
120  $RPM_BUILD_ROOT%{_datadir}/applications/*
121
122perl -pi -e 's@<default></default>@<default>[Joe,Jim,James]</default>@g' \
123     $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/gtali.schemas
124
125%find_lang %{gettext_package} --all-name --with-gnome
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post
131touch %{_datadir}/icons/hicolor
132if [ -x /usr/bin/gtk-update-icon-cache ]; then
133  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
134fi
135
136%postun
137touch %{_datadir}/icons/hicolor
138if [ -x /usr/bin/gtk-update-icon-cache ]; then
139  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
140fi
141glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
142update-desktop-database -q &> /dev/null || :
143
144%posttrans
145glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
146update-desktop-database -q &> /dev/null || :
147
148
149
150%files -f %{gettext_package}.lang
151%defattr(-, root, root)
152%doc AUTHORS COPYING README
153%{_datadir}/applications/*
154#%{_datadir}/gnome-games-common
155%{_datadir}/glchess
156%{_datadir}/glines
157%{_datadir}/gnect
158%{_datadir}/gnibbles
159%{_datadir}/gnobots2
160%{_datadir}/gnome-sudoku
161%{_datadir}/gnomine
162%{_datadir}/gnotravex
163%{_datadir}/gnotski
164%{_datadir}/gtali
165%{_datadir}/icons/hicolor/*/*/*
166%{_datadir}/iagno
167%{_datadir}/gnome-mahjongg
168%{_datadir}/quadrapassel
169%{_mandir}/man6/*
170%{_datadir}/glib-2.0/schemas/*.xml
171%verify(not md5 size mtime) %config(noreplace) %attr(664, games, games) /var/lib/games/*
172
173#%{python_sitelib}/glchess
174%{python_sitelib}/gnome_sudoku
175
176# these are not setgid games
177%{_bindir}/gnect
178#%{_bindir}/sol
179## %{_bindir}blackjack
180%{_bindir}/glchess
181%{_bindir}/gnome-sudoku
182
183# these are setgid games
184%attr(2551, root, games) %{_bindir}/gnomine
185%attr(2551, root, games) %{_bindir}/gnome-mahjongg
186%attr(2551, root, games) %{_bindir}/gtali
187%attr(2551, root, games) %{_bindir}/gnobots2
188%attr(2551, root, games) %{_bindir}/quadrapassel
189%attr(2551, root, games) %{_bindir}/gnotravex
190%attr(2551, root, games) %{_bindir}/gnotski
191%attr(2551, root, games) %{_bindir}/gnibbles
192%attr(2551, root, games) %{_bindir}/glines
193%attr(2551, root, games) %{_bindir}/iagno
194## %attr(2551, root, games) %{_bindir}/same-gnome
195## %attr(2551, root, games) %{_bindir}/gnome-falling-blocks
196
197
198%changelog
199* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0.2-1
200- new upstream release
201- change BuildRequires: yelp-tools instead of gnome-doc-utils
202- remove old required packages
203
204
205* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
206- new upstream release
207
208* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
209- new upstream release
210- remove Patch2
211- add BuildRequires: itstool
212- remove BuildRequires: GConf2-devel
213
214* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
215- rebuild with python-2.7.2
216
217* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
218- new upstream release
219- add BuildRequires: GConf2-devel
220
221* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
222- new upstream release
223
224* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
225- new upstream release
226
227* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
228- new upstream release
229
230* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
231- new upstream release
232
233* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
234- new upstream release
235- change BuildRequires: gtk3-devel instead of gtk2-devel
236- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
237- add BuildRequires: sqlite3-devel, mesa-libGLU-devel
238
239* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
240- add Requires: gnome-python-rsvg
241
242* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
243- remove Requires: gnome-python-gnomeprint, seed
244- remove swell-foop, lightsoff
245
246* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
247- new upstream release
248
249* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
250- new upstream release
251- remove BuildRequires: gir-repository-devel
252
253* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
254- new upstream release
255
256* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
257- add BuildRequires: gobject-introspection-devel, gir-repository-devel
258- add Requires: seed
259- add Patch2(gnome-games-libs.patch) from FC package
260- remove configure option (--disable-introspection)
261
262* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
263- new upstream release
264
265* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
266- new upstream release
267- add BuildRequires: libcanberra-devel
268- drop Patch1
269
270* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.2-2
271- rebuilt with python-2.6.4-3
272
273* Mon Dec 28 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
274- new upstream release
275- add BuildRequires: docbook-dtds
276
277* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
278- add BuildRequires: clutter-gtk-devel
279
280* Tue Dec 01 2009 Takemikaduchi <bsyamato@sea.plala.or.jp> 2.28.1-1
281- new upstream release
282- add BuildRequires: clutter-devel, libSM-devel, check-devel
283
284* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
285- new upstream release
286
287* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
288- new upstream release
289
290* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
291- new upstream release
292
293* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
294- new upstream release
295
296* Sat Jan 17 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
297- rebuilt (with guile-1.8.6)
298
299* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.24.1-2
300- rebuild with guile-1.8.6
301
302* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
303- new upstream release
304
305* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
306- new upstream release
307
308* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.1.1-2vl5
309- rebuilt with python-2.5.2
310
311* Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
312- new upstream release
313- added Patch1
314  * Sat Jul 21 2007 Hans de Goede <j.w.r.degoede@hhs.nl> - 1:2.19.4-3
315  - Rename / rebrand Gnometris to GnomeFallingBlocks, so that it stays clear of
316    the Tetris trademark, and include it (bz 238651)
317
318* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.13-0vl2
319- add BuildRequires: librsvg2-devel
320
321* Sat Sep  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
322- new upstream release
323- changed Group to Applications/Games
324
325* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
326- new upstream release
327
328* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.8-0vl1
329- new upstream release
330
331* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
332- new upstream release
333
334* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl2
335- fixed gtali schemas
336
337* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
338- new upstream release
339
340* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
341- new upstream release
342
343* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
344- new upstream release
345
346* Wed Sep 29 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.6.2-0vl1
347- new upstream release
348- Patch: fix the bug which leads to failure in starting Freecell from menu.
349- add Japanese description
350- correct License
351- add docs
352- add missing BuildRequires: gcc-c++
353- disable libtoolize: version mismatch is bad
354- Patch1: Fix typo, causing gconf warning at %%post
355
356* Sun Feb  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
357- fix kanji code in spec file.
358
359* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
360- new upstream release
361
362* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
363- new upstream release
364
365* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
366- add missing files
367
368* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
369- new upstream release
370
371* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
372- rebuild with new guile
373
374* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
375- new upstream release
376
377* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
378- new upstream release
379
380* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
381- new upstream release
382- build for Vine Linux
383
384* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
385- add some OnlyShowIn
386
387* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
388- 2.0.3 from gnome 2.0.1
389
390* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
391- 2.0.2
392
393* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
394- gnect doesn't like being setgid games
395- obsolete gnome-games-devel
396
397* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
398- add gnect
399
400* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
401- automated rebuild
402
403* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
404- 2.0.0
405- remove noreplace from the .soundlist files
406- add missing schemas
407- get rid of gnometris again
408- use desktop-file-install
409
410* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
411- rebuild in different environment
412
413* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
414- 1.93.0
415- remove empty NEWS/README
416- fix ldconfig in post
417
418* Sun May 26 2002 Tim Powers <timp@redhat.com>
419- automated rebuild
420
421* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
422- rebuild in different environment
423
424* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
425- 1.92.0
426
427* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
428- 1.91.0
429
430* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
431- GNOME 2 version
432- spec file cleanups
433- no devel package
434- don't run auto*, just use the "rm from buildroot" approach to lose xbill
435
436* Tue Apr 09 2002 Phil Knirsch <pknirsch@redhat.com>
437- Bumped version number for rebuild and relink agains new guile lib
438
439* Tue Aug 14 2001 Jonathan Blandford <jrb@redhat.com>
440- Add BuildRequires on ncurses-devel
441
442* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
443- Add BuildRequires
444
445* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
446- Bump release + rebuild.
447
448* Fri Apr 20 2001  <jrb@redhat.com>
449- New version (1.4.0)
450
451* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
452- New Version.
453
454* Tue Feb 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
455- use %%{_tmppath}
456- langify
457
458* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
459- run ldconfig in post and postun (#16589)
460- don't put the post and postun scripts in the middle of the files list --
461  that tends to break things (oops)
462
463* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
464- Up Epoch and release
465
466* Fri Aug 04 2000 Havoc Pennington <hp@redhat.com>
467- Remove .desktop for gturing
468
469* Mon Jul 17 2000 Jonathan Blandford <jrb@redhat.com>
470- Mark high-score files as %config(noreplace).
471
472* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
473- automatic rebuild
474
475* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
476- rebuild in new environment
477
478* Sat Jul 8 2000 Havoc Pennington <hp@redhat.com>
479- Remove Docdir
480
481* Tue Jul 03 2000 Nalin Dahyabhai <nalin@redhat.com>
482- rebuild in new environment
483
484* Thu Jun 15 2000 Owen Taylor <otaylor@redhat.com>
485- 1.2.0
486- remove gnometris, xbill from subdirs since we don't install
487  them and they cause problems with new C compiler
488- update autoconf stuff
489- remove gturing, add gnotski to the file list
490
491* Thu May 11 2000 Matt Wilson <msw@redhat.com>
492- 1.1.90
493
494* Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
495- mark sound event files as config files
496
497* Tue Sep 21 1999 Michael Fulbright <drmike@redhat.com>
498- fixed gnotravex to not loop infinitely
499
500* Mon Sep 20 1999 Elliot Lee <sopwith@redhat.com>
501- Update to 1.0.40
502
503* Sat Apr 10 1999 Jonathan Blandford <jrb@redhat.com>
504- added new sol games and a fix for the old ones.
505
506* Mon Mar 29 1999 Michael Fulbright <drmike@redhat.com>
507- removed more offending t*tris stuff
508
509* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
510- version 1.0.2
511- made gnibbles have correct attr since its setgid
512- strip binaries
513
514* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
515- added score files to file list
516
517* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
518- Version 1.0.1
519
520* Fri Feb 19 1999 Michael Fulbright <drmike@redhat.com>
521- removed *tris games
522
523* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
524- version 0.99.8
525- added sound event lists to file list
526- touched up file list some more
527
528* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
529- added gnibbles data to file list
530
531* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
532- updated to 0.99.7
533
534* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
535- updated to 0.99.5
536
537* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
538- updated to 0.99.3
539
540* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
541- updated to 0.99.1
542
543* Thu Dec 16 1998 Michael Fulbright <drmike@redhat.com>
544- updated to 0.99.0 in prep for GNOME 1.0
545
546* Sat Nov 21 1998 Michael Fulbright <drmike@redhat.com>
547- updated for 0.30 tree
548
549* Fri Nov 20 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
550- use --localstatedir=/var/lib in config state (score files for games
551  for exemple will go there).
552
553* Mon Mar 16 1998 Marc Ewing <marc@redhat.com>
554- Integrate into gnome-games CVS source tree
555
Note: See TracBrowser for help on using the repository browser.