source: projects/specs/trunk/g/gnome-games/gnome-games-vl.spec @ 6011

Revision 6011, 16.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3%define gettext_package gnome-games
4
5%define glib2_version 2.32.0
6%define pango_version 1.30.0
7%define gtk3_version 3.4.0
8%define desktop_file_utils_version 0.2.90
9%define gnome_python_desktop 2.30.0
10%define gstreamer_version 0.10.30
11
12Summary: GNOME games
13Summary(ja): GNOME ゲーム集
14Name: gnome-games
15%define major 3.4
16Version: %{major}.0
17Release: 1%{?_dist_release}
18License: GPLv2+ and GFDL+
19Group: Applications/Games
20Source: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/%{major}/%{name}-%{version}.tar.xz
21Patch1: gnome-games-2.19.4-gnometris-rebrand.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Obsoletes: gnome gnome-games-devel
25URL: http://www.gnome.org
26
27Requires(post,postun): scrollkeeper >= 0.1.4
28
29Requires: pygtk2
30Requires: pygobject3
31Requires: gnome-python-desktop >= %{gnome_python_desktop}
32Requires: pygtkglext PyOpenGL
33Requires: gnuchess
34Requires: hicolor-icon-theme
35Requires: gnome-python-rsvg
36
37BuildRequires: glib2-devel >= %{glib2_version}
38BuildRequires: pango-devel >= %{pango_version}
39BuildRequires: gtk3-devel >= %{gtk3_version}
40BuildRequires: pygtk2-devel
41BuildRequires: pygtkglext-devel
42BuildRequires: gnome-python-desktop >= %{gnome_python_desktop}
43BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
44BuildRequires: scrollkeeper
45BuildRequires: librsvg2-devel
46BuildRequires: guile-devel >= 1.6.5
47BuildRequires: expat-devel
48BuildRequires: gstreamer-devel >= %{gstreamer_version}
49BuildRequires: clutter-devel, clutter-gtk-devel
50BuildRequires: libSM-devel
51BuildRequires: check-devel
52BuildRequires: libcanberra-gtk3-devel
53BuildRequires: gobject-introspection-devel
54BuildRequires: sqlite3-devel
55BuildRequires: mesa-libGLU-devel
56BuildRequires: docbook-style-xsl
57
58# Newer than internal gettext needed
59BuildRequires: gettext
60# Needed by intltool
61BuildRequires: perl(XML::Parser)
62BuildRequires: autoconf >= 2.60
63BuildRequires: gnome-doc-utils >= 0.3.2
64BuildRequires: itstool
65
66
67Provides: gnome-sudoku
68Obsoletes: gnome-sudoku
69
70Provides: glchess
71Obsoletes: glchess < 2.0
72
73BuildRequires: gcc-c++
74
75Vendor: Project Vine
76Distribution: Vine Linux
77
78%description
79
80The gnome-games package includes some small games that come with the
81GNOME desktop environment but can be used under any desktop.
82
83%description -l ja
84
85gnome-games パッケージにはいくつかの小さなゲームが入っています。
86これらは GNOME に由来するものですが、他のデスクトップ環境でも動きます。
87
88%prep
89%setup -q
90# rebrand gnometris as some think the name is to similar to a trademark
91## %patch1 -p1 -b .rebrand
92
93## sed -i -e 's/Gnometris/GnomeFallingBlocks/g' \
94##   -e 's/GNOMEtris/GnomeFallingBlocks/g' \
95##   po/*.po gnometris/help/*/*.po gnometris/help/C/gnometris.xml \
96##   gnometris/*.cpp gnometris/gnometris.desktop.in.in
97
98%build
99
100autoconf
101export CFLAGS="$RPM_OPT_FLAGS -DNO_HOWL"
102# swell-foop, lightsoff: remove (vine6)
103%configure \
104        --with-gtk=3.0 \
105        --with-sound=gstreamer \
106        --localstatedir=/var/lib \
107        --enable-games="quadrapassel,gnect,gnomine,mahjongg,gtali,gnotravex,gnotski,glines,iagno,glchess,gnobots2,gnibbles,gnome-sudoku" \
108        --disable-gnuchess
109make
110
111# strip unneeded translations from .mo files
112# ideally intltool (ha!) would do that for us
113# http://bugzilla.gnome.org/show_bug.cgi?id=474987
114cd po
115grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
116mv POTFILES.keep POTFILES.in
117intltool-update --pot
118for p in *.po; do
119  msgmerge $p %{gettext_package}.pot > $p.out
120  msgfmt -o `basename $p .po`.gmo $p.out
121done
122
123
124%install
125rm -rf $RPM_BUILD_ROOT
126
127export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
128make install DESTDIR=$RPM_BUILD_ROOT
129unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
130
131## mv $RPM_BUILD_ROOT%{_bindir}/gnometris \
132##   $RPM_BUILD_ROOT%{_bindir}/gnome-falling-blocks
133
134## things we just don't want in the package
135
136rm -rf $RPM_BUILD_ROOT%{_libdir}/libgdkcardimage.*a
137rm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
138
139## install desktop files
140desktop-file-install --vendor gnome --delete-original       \
141  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
142  --remove-category Application                             \
143  --remove-category PuzzleGame                              \
144  $RPM_BUILD_ROOT%{_datadir}/applications/*
145
146perl -pi -e 's@<default></default>@<default>[Joe,Jim,James]</default>@g' \
147     $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/gtali.schemas
148
149%find_lang %{gettext_package} --all-name --with-gnome
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154%post
155touch %{_datadir}/icons/hicolor
156if [ -x /usr/bin/gtk-update-icon-cache ]; then
157  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
158fi
159
160
161%postun
162touch %{_datadir}/icons/hicolor
163if [ -x /usr/bin/gtk-update-icon-cache ]; then
164  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
165fi
166glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
167
168%posttrans
169glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170
171
172
173%files -f %{gettext_package}.lang
174%defattr(-, root, root)
175%doc AUTHORS COPYING README
176%{_datadir}/applications/*
177#%{_datadir}/gnome-games-common
178%{_datadir}/glchess
179%{_datadir}/glines
180%{_datadir}/gnect
181%{_datadir}/gnibbles
182%{_datadir}/gnobots2
183%{_datadir}/gnome-sudoku
184%{_datadir}/gnomine
185%{_datadir}/gnotravex
186%{_datadir}/gnotski
187%{_datadir}/gtali
188%{_datadir}/icons/hicolor/*/*/*
189%{_datadir}/iagno
190%{_datadir}/mahjongg
191%{_datadir}/quadrapassel
192%{_mandir}/man6/*
193%{_datadir}/glib-2.0/schemas/*.xml
194%verify(not md5 size mtime) %config(noreplace) %attr(664, games, games) /var/lib/games/*
195
196%{_libdir}/gnome-games
197#%{_libdir}/girepository-1.0/GnomeGamesSupport-1.0.typelib
198#%{_datadir}/gir-1.0/GnomeGamesSupport-1.0.gir
199
200#%{python_sitelib}/glchess
201%{python_sitelib}/gnome_sudoku
202
203# these are not setgid games
204%{_bindir}/gnect
205#%{_bindir}/sol
206## %{_bindir}blackjack
207%{_bindir}/glchess
208%{_bindir}/gnome-sudoku
209
210# these are setgid games
211%attr(2551, root, games) %{_bindir}/gnomine
212%attr(2551, root, games) %{_bindir}/mahjongg
213%attr(2551, root, games) %{_bindir}/gtali
214%attr(2551, root, games) %{_bindir}/gnobots2
215%attr(2551, root, games) %{_bindir}/quadrapassel
216%attr(2551, root, games) %{_bindir}/gnotravex
217%attr(2551, root, games) %{_bindir}/gnotski
218%attr(2551, root, games) %{_bindir}/gnibbles
219%attr(2551, root, games) %{_bindir}/glines
220%attr(2551, root, games) %{_bindir}/iagno
221## %attr(2551, root, games) %{_bindir}/same-gnome
222## %attr(2551, root, games) %{_bindir}/gnome-falling-blocks
223
224
225%changelog
226* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
227- new upstream release
228- remove Patch2
229- add BuildRequires: itstool
230- remove BuildRequires: GConf2-devel
231
232* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
233- rebuild with python-2.7.2
234
235* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
236- new upstream release
237- add BuildRequires: GConf2-devel
238
239* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
240- new upstream release
241
242* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
243- new upstream release
244
245* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
246- new upstream release
247
248* Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
249- new upstream release
250
251* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
252- new upstream release
253- change BuildRequires: gtk3-devel instead of gtk2-devel
254- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
255- add BuildRequires: sqlite3-devel, mesa-libGLU-devel
256
257* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-3
258- add Requires: gnome-python-rsvg
259
260* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
261- remove Requires: gnome-python-gnomeprint, seed
262- remove swell-foop, lightsoff
263
264* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
265- new upstream release
266
267* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
268- new upstream release
269- remove BuildRequires: gir-repository-devel
270
271* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
272- new upstream release
273
274* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
275- add BuildRequires: gobject-introspection-devel, gir-repository-devel
276- add Requires: seed
277- add Patch2(gnome-games-libs.patch) from FC package
278- remove configure option (--disable-introspection)
279
280* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
281- new upstream release
282
283* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
284- new upstream release
285- add BuildRequires: libcanberra-devel
286- drop Patch1
287
288* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.2-2
289- rebuilt with python-2.6.4-3
290
291* Mon Dec 28 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
292- new upstream release
293- add BuildRequires: docbook-dtds
294
295* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
296- add BuildRequires: clutter-gtk-devel
297
298* Tue Dec 01 2009 Takemikaduchi <bsyamato@sea.plala.or.jp> 2.28.1-1
299- new upstream release
300- add BuildRequires: clutter-devel, libSM-devel, check-devel
301
302* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
303- new upstream release
304
305* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
306- new upstream release
307
308* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
309- new upstream release
310
311* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
312- new upstream release
313
314* Sat Jan 17 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
315- rebuilt (with guile-1.8.6)
316
317* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.24.1-2
318- rebuild with guile-1.8.6
319
320* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
321- new upstream release
322
323* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
324- new upstream release
325
326* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.1.1-2vl5
327- rebuilt with python-2.5.2
328
329* Mon Apr 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
330- new upstream release
331- added Patch1
332  * Sat Jul 21 2007 Hans de Goede <j.w.r.degoede@hhs.nl> - 1:2.19.4-3
333  - Rename / rebrand Gnometris to GnomeFallingBlocks, so that it stays clear of
334    the Tetris trademark, and include it (bz 238651)
335
336* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.13-0vl2
337- add BuildRequires: librsvg2-devel
338
339* Sat Sep  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
340- new upstream release
341- changed Group to Applications/Games
342
343* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
344- new upstream release
345
346* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.8-0vl1
347- new upstream release
348
349* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
350- new upstream release
351
352* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl2
353- fixed gtali schemas
354
355* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
356- new upstream release
357
358* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
359- new upstream release
360
361* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
362- new upstream release
363
364* Wed Sep 29 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.6.2-0vl1
365- new upstream release
366- Patch: fix the bug which leads to failure in starting Freecell from menu.
367- add Japanese description
368- correct License
369- add docs
370- add missing BuildRequires: gcc-c++
371- disable libtoolize: version mismatch is bad
372- Patch1: Fix typo, causing gconf warning at %%post
373
374* Sun Feb  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
375- fix kanji code in spec file.
376
377* Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
378- new upstream release
379
380* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
381- new upstream release
382
383* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl2
384- add missing files
385
386* Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
387- new upstream release
388
389* Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
390- rebuild with new guile
391
392* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
393- new upstream release
394
395* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
396- new upstream release
397
398* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
399- new upstream release
400- build for Vine Linux
401
402* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
403- add some OnlyShowIn
404
405* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
406- 2.0.3 from gnome 2.0.1
407
408* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
409- 2.0.2
410
411* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
412- gnect doesn't like being setgid games
413- obsolete gnome-games-devel
414
415* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
416- add gnect
417
418* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
419- automated rebuild
420
421* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
422- 2.0.0
423- remove noreplace from the .soundlist files
424- add missing schemas
425- get rid of gnometris again
426- use desktop-file-install
427
428* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
429- rebuild in different environment
430
431* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
432- 1.93.0
433- remove empty NEWS/README
434- fix ldconfig in post
435
436* Sun May 26 2002 Tim Powers <timp@redhat.com>
437- automated rebuild
438
439* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
440- rebuild in different environment
441
442* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
443- 1.92.0
444
445* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
446- 1.91.0
447
448* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
449- GNOME 2 version
450- spec file cleanups
451- no devel package
452- don't run auto*, just use the "rm from buildroot" approach to lose xbill
453
454* Tue Apr 09 2002 Phil Knirsch <pknirsch@redhat.com>
455- Bumped version number for rebuild and relink agains new guile lib
456
457* Tue Aug 14 2001 Jonathan Blandford <jrb@redhat.com>
458- Add BuildRequires on ncurses-devel
459
460* Mon Jul 23 2001 Jonathan Blandford <jrb@redhat.com>
461- Add BuildRequires
462
463* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
464- Bump release + rebuild.
465
466* Fri Apr 20 2001  <jrb@redhat.com>
467- New version (1.4.0)
468
469* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
470- New Version.
471
472* Tue Feb 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
473- use %%{_tmppath}
474- langify
475
476* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
477- run ldconfig in post and postun (#16589)
478- don't put the post and postun scripts in the middle of the files list --
479  that tends to break things (oops)
480
481* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
482- Up Epoch and release
483
484* Fri Aug 04 2000 Havoc Pennington <hp@redhat.com>
485- Remove .desktop for gturing
486
487* Mon Jul 17 2000 Jonathan Blandford <jrb@redhat.com>
488- Mark high-score files as %config(noreplace).
489
490* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
491- automatic rebuild
492
493* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
494- rebuild in new environment
495
496* Sat Jul 8 2000 Havoc Pennington <hp@redhat.com>
497- Remove Docdir
498
499* Tue Jul 03 2000 Nalin Dahyabhai <nalin@redhat.com>
500- rebuild in new environment
501
502* Thu Jun 15 2000 Owen Taylor <otaylor@redhat.com>
503- 1.2.0
504- remove gnometris, xbill from subdirs since we don't install
505  them and they cause problems with new C compiler
506- update autoconf stuff
507- remove gturing, add gnotski to the file list
508
509* Thu May 11 2000 Matt Wilson <msw@redhat.com>
510- 1.1.90
511
512* Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
513- mark sound event files as config files
514
515* Tue Sep 21 1999 Michael Fulbright <drmike@redhat.com>
516- fixed gnotravex to not loop infinitely
517
518* Mon Sep 20 1999 Elliot Lee <sopwith@redhat.com>
519- Update to 1.0.40
520
521* Sat Apr 10 1999 Jonathan Blandford <jrb@redhat.com>
522- added new sol games and a fix for the old ones.
523
524* Mon Mar 29 1999 Michael Fulbright <drmike@redhat.com>
525- removed more offending t*tris stuff
526
527* Thu Mar 18 1999 Michael Fulbright <drmike@redhat.com>
528- version 1.0.2
529- made gnibbles have correct attr since its setgid
530- strip binaries
531
532* Sun Mar 14 1999 Michael Fulbright <drmike@redhat.com>
533- added score files to file list
534
535* Thu Mar 04 1999 Michael Fulbright <drmike@redhat.com>
536- Version 1.0.1
537
538* Fri Feb 19 1999 Michael Fulbright <drmike@redhat.com>
539- removed *tris games
540
541* Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
542- version 0.99.8
543- added sound event lists to file list
544- touched up file list some more
545
546* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
547- added gnibbles data to file list
548
549* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
550- updated to 0.99.7
551
552* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
553- updated to 0.99.5
554
555* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
556- updated to 0.99.3
557
558* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
559- updated to 0.99.1
560
561* Thu Dec 16 1998 Michael Fulbright <drmike@redhat.com>
562- updated to 0.99.0 in prep for GNOME 1.0
563
564* Sat Nov 21 1998 Michael Fulbright <drmike@redhat.com>
565- updated for 0.30 tree
566
567* Fri Nov 20 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
568- use --localstatedir=/var/lib in config state (score files for games
569  for exemple will go there).
570
571* Mon Mar 16 1998 Marc Ewing <marc@redhat.com>
572- Integrate into gnome-games CVS source tree
573
Note: See TracBrowser for help on using the repository browser.