source: projects/specs/trunk/g/gnome-do/gnome-do-vl.spec @ 1897

Revision 1897, 8.3 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define                 mainver 0.8.3
2
3Name:                   gnome-do
4Version:                0.8.3.1
5Release:                3%{?_dist_release}
6Summary:                An intelligent launcher tool for Gnome
7Summary(ja):               Gnome 用の高機能ランチャー
8License:                GPLv3+
9Group:                  Applications/Accessories       
10URL:                    http://do.davebsd.com/
11Source0:                http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
12
13BuildRoot:              %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15# Various Mono dependencies are not available for ppc64; see bug 241850.
16ExcludeArch:            ppc64
17
18BuildRequires:          mono-devel, mono-addins
19BuildRequires:          desktop-file-utils
20BuildRequires:          ndesk-dbus
21BuildRequires:          ndesk-dbus-glib
22BuildRequires:          gtk-sharp2
23BuildRequires:          notify-sharp-devel
24BuildRequires:          gnome-sharp2, gnome-desktop-sharp2 >= 2.26
25BuildRequires:          gnome-keyring-sharp-devel
26BuildRequires:          gettext
27BuildRequires:          perl-XML-Parser
28BuildRequires:          intltool
29BuildRequires:          gtk2-devel
30BuildRequires:          desktop-file-utils
31BuildRequires:          wnck-sharp
32BuildRequires:          gconf-sharp2
33BuildRequires:          rsvg2-sharp
34
35Requires(pre):          GConf2
36Requires(post):         GConf2
37Requires(preun):        GConf2
38
39Requires:               gnome-keyring-sharp, gnome-desktop-sharp2
40Requires:               pkgconfig
41
42Packager:               kazutaka
43
44%description
45GNOME Do (Do) is an intelligent launcher tool that makes performing
46common tasks on your computer simple and efficient. Do not only
47allows you to search for items in your desktop environment
48(e.g. applications, contacts, bookmarks, files, music), it also
49allows you to specify actions to perform on search results
50(e.g. run, open, email, chat, play).
51
52%description -l ja
53GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
54般的なタスクをシンプルかつ効率的に実行できるようにします。Do
55はデスクトップ環境の様々なアイテム(例えばアプリケーションや
56連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
57した結果をどう操作するのか(例えば開く、メールに添付、チャット、
58再生する等)を指定することができます。
59
60%package devel
61Summary:                Development files for GNOME Do
62SUmmary(ja):               GNOME Do の開発用ファイル
63Group:                  Development/Libraries
64Requires:               %{name} = %{version}-%{release}
65Requires:               pkgconfig
66
67%description devel
68Development files for GNOME Do
69
70%description devel -l ja
71GNOME Do の開発用ファイルです。
72
73%prep
74%setup -q
75
76%build
77%configure
78make %{?_smp_mflags}
79
80
81%install
82rm -rf ${RPM_BUILD_ROOT}
83export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
84make install DESTDIR=${RPM_BUILD_ROOT}
85
86desktop-file-install    \
87        --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart     \
88        --add-only-show-in=GNOME                                \
89        ${RPM_BUILD_ROOT}%{_datadir}/applications/gnome-do.desktop
90desktop-file-install --delete-original  \
91        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
92        --remove-category Application \
93        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
94
95
96#own this dir:
97mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
98
99%find_lang %{name}
100
101%pre
102if [ "$1" -gt 1 ]; then
103    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
104    gconftool-2 --makefile-uninstall-rule \
105      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
106fi
107
108%post
109export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
110gconftool-2 --makefile-install-rule \
111  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
112
113touch --no-create %{_datadir}/icons/hicolor
114if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
115  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
116fi
117
118%preun
119if [ "$1" -eq 0 ]; then
120    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
121    gconftool-2 --makefile-uninstall-rule \
122      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
123fi
124
125%postun
126touch --no-create %{_datadir}/icons/hicolor
127if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
128  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
129fi
130
131%clean
132rm -rf ${RPM_BUILD_ROOT}
133
134%files -f %{name}.lang
135%defattr(-,root,root,-)
136%doc AUTHORS COPYING COPYRIGHT
137%{_bindir}/gnome-do/
138%{_libdir}/gnome-do/
139%{_datadir}/gnome-do/
140%config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
141%config(noreplace) %{_sysconfdir}/gconf/schemas/*
142%{_datadir}/icons/hicolor/*/apps/gnome-do.*
143%{_datadir}/applications/*
144
145%files devel
146%defattr(-,root,root,-)
147%{_libdir}/pkgconfig/*
148
149%changelog
150* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3.1-3
151- rebuild with rpm-4.8.1 for pkg-config file
152- add BuildRequires: gconf-sharp2, rsvg2-sharp
153
154* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
155- rebuilt with mono-addins-0.5
156
157* Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
158- new upstream release
159
160* Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
161- new upstream release
162- drop Patch0 (merged in upstream)
163
164* Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
165- change Group to Applications/Accessories
166
167* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
168- add BuildRequires: wnck-sharp
169
170* Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
171- initial build for Vine Linux based on fedora development
172
173* Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
174- Fix .desktop issue, install in both autostart and applications
175- Rebuild for new gnome-desktop-sharp
176- Add missing gnome-desktop-sharp requires
177- Fix Ndesk-dbus Requires
178
179* Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
180- Add patch to fix issue where applications wasn't being indexed
181
182* Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
183- New upstream release
184
185* Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
186- Own _datadir/gnome-do
187* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
189
190* Sat Feb  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
191- Rebuild against new mono-addins
192
193* Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
194- New upstream release
195
196* Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
197- Remove Tomboy dependency (bz #481183)
198- Updated description, from Do
199
200* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
201- rebuild against new gnome-sharp
202
203* Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
204- New Upstream Release
205
206* Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
207- New upstream release
208
209* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
210- New upstream release
211
212* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
213- New upstream release
214- Add gnome-desktop-sharp dependency
215
216* Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
217- rebuild for dependancies
218
219* Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
220- New upstream release
221
222* Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
223- #439793 - correct URL
224
225* Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
226- Bump to 0.4.0.1
227- Hopefully bring an end to the endless dups of 432201
228
229* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
230- Fix 432201
231
232* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
233- Bump to 0.3.1
234
235* Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
236- #431589 - Force runtime dependency on ndesk-dbus(-glib)
237
238* Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
239- #431462 - Correctly pull in Tomboy runtime dependency
240
241* Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
242- autostart gnome-do in quiet mode with the user session
243- to invoke gnome-do use super+space
244
245* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
246- Fix BuildRequires
247
248* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
249- bump to 0.3.0.1
250- update patches
251
252* Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
253- updated libdir patch
254- cleaned up desktop-file-install invocation
255- correct BuildRequires
256
257* Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
258- Initial package
Note: See TracBrowser for help on using the repository browser.