source: projects/specs/trunk/g/gnome-do/gnome-do-vl.spec @ 1451

Revision 1451, 8.1 KB checked in by owa, 14 years ago (diff)

rebuilt with mono-addins-0.5

Line 
1%define                 mainver 0.8.3
2
3Name:                   gnome-do
4Version:                0.8.3.1
5Release:                2%{?_dist_release}
6Summary:                An intelligent launcher tool for Gnome
7Summary(ja):               Gnome 用の高機能ランチャー
8License:                GPLv3+
9Group:                  Applications/Accessories       
10URL:                    http://do.davebsd.com/
11Source0:                http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
12
13BuildRoot:              %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15# Various Mono dependencies are not available for ppc64; see bug 241850.
16ExcludeArch:            ppc64
17
18BuildRequires:          mono-devel, mono-addins
19BuildRequires:          desktop-file-utils
20BuildRequires:          ndesk-dbus
21BuildRequires:          ndesk-dbus-glib
22BuildRequires:          gtk-sharp2
23BuildRequires:          notify-sharp-devel
24BuildRequires:          gnome-sharp2, gnome-desktop-sharp2 >= 2.26
25BuildRequires:          gnome-keyring-sharp-devel
26BuildRequires:          gettext
27BuildRequires:          perl-XML-Parser
28BuildRequires:          intltool
29BuildRequires:          gtk2-devel
30BuildRequires:          desktop-file-utils
31BuildRequires:          wnck-sharp
32
33Requires(pre):          GConf2
34Requires(post):         GConf2
35Requires(preun):        GConf2
36
37Requires:               gnome-keyring-sharp, gnome-desktop-sharp2
38Requires:               pkgconfig
39
40Packager:               kazutaka
41
42%description
43GNOME Do (Do) is an intelligent launcher tool that makes performing
44common tasks on your computer simple and efficient. Do not only
45allows you to search for items in your desktop environment
46(e.g. applications, contacts, bookmarks, files, music), it also
47allows you to specify actions to perform on search results
48(e.g. run, open, email, chat, play).
49
50%description -l ja
51GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
52般的なタスクをシンプルかつ効率的に実行できるようにします。Do
53はデスクトップ環境の様々なアイテム(例えばアプリケーションや
54連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
55した結果をどう操作するのか(例えば開く、メールに添付、チャット、
56再生する等)を指定することができます。
57
58%package devel
59Summary:                Development files for GNOME Do
60SUmmary(ja):               GNOME Do の開発用ファイル
61Group:                  Development/Libraries
62Requires:               %{name} = %{version}-%{release}
63Requires:               pkgconfig
64
65%description devel
66Development files for GNOME Do
67
68%description devel -l ja
69GNOME Do の開発用ファイルです。
70
71%prep
72%setup -q
73
74%build
75%configure
76make %{?_smp_mflags}
77
78
79%install
80rm -rf ${RPM_BUILD_ROOT}
81export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
82make install DESTDIR=${RPM_BUILD_ROOT}
83
84desktop-file-install    \
85        --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart     \
86        --add-only-show-in=GNOME                                \
87        ${RPM_BUILD_ROOT}%{_datadir}/applications/gnome-do.desktop
88desktop-file-install --delete-original  \
89        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications   \
90        --remove-category Application \
91        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
92
93
94#own this dir:
95mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
96
97%find_lang %{name}
98
99%pre
100if [ "$1" -gt 1 ]; then
101    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
102    gconftool-2 --makefile-uninstall-rule \
103      %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
104fi
105
106%post
107export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
108gconftool-2 --makefile-install-rule \
109  %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
110
111touch --no-create %{_datadir}/icons/hicolor
112if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
113  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
114fi
115
116%preun
117if [ "$1" -eq 0 ]; then
118    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
119    gconftool-2 --makefile-uninstall-rule \
120      %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
121fi
122
123%postun
124touch --no-create %{_datadir}/icons/hicolor
125if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
126  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
127fi
128
129%clean
130rm -rf ${RPM_BUILD_ROOT}
131
132%files -f %{name}.lang
133%defattr(-,root,root,-)
134%doc AUTHORS COPYING COPYRIGHT
135%{_bindir}/gnome-do/
136%{_libdir}/gnome-do/
137%{_datadir}/gnome-do/
138%config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
139%config(noreplace) %{_sysconfdir}/gconf/schemas/*
140%{_datadir}/icons/hicolor/*/apps/gnome-do.*
141%{_datadir}/applications/*
142
143%files devel
144%defattr(-,root,root,-)
145%{_libdir}/pkgconfig/*
146
147%changelog
148* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
149- rebuilt with mono-addins-0.5
150
151* Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
152- new upstream release
153
154* Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
155- new upstream release
156- drop Patch0 (merged in upstream)
157
158* Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
159- change Group to Applications/Accessories
160
161* Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
162- add BuildRequires: wnck-sharp
163
164* Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
165- initial build for Vine Linux based on fedora development
166
167* Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
168- Fix .desktop issue, install in both autostart and applications
169- Rebuild for new gnome-desktop-sharp
170- Add missing gnome-desktop-sharp requires
171- Fix Ndesk-dbus Requires
172
173* Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
174- Add patch to fix issue where applications wasn't being indexed
175
176* Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
177- New upstream release
178
179* Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
180- Own _datadir/gnome-do
181* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
183
184* Sat Feb  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
185- Rebuild against new mono-addins
186
187* Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
188- New upstream release
189
190* Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
191- Remove Tomboy dependency (bz #481183)
192- Updated description, from Do
193
194* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
195- rebuild against new gnome-sharp
196
197* Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
198- New Upstream Release
199
200* Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
201- New upstream release
202
203* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
204- New upstream release
205
206* Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
207- New upstream release
208- Add gnome-desktop-sharp dependency
209
210* Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
211- rebuild for dependancies
212
213* Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
214- New upstream release
215
216* Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
217- #439793 - correct URL
218
219* Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
220- Bump to 0.4.0.1
221- Hopefully bring an end to the endless dups of 432201
222
223* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
224- Fix 432201
225
226* Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
227- Bump to 0.3.1
228
229* Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
230- #431589 - Force runtime dependency on ndesk-dbus(-glib)
231
232* Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
233- #431462 - Correctly pull in Tomboy runtime dependency
234
235* Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
236- autostart gnome-do in quiet mode with the user session
237- to invoke gnome-do use super+space
238
239* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
240- Fix BuildRequires
241
242* Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
243- bump to 0.3.0.1
244- update patches
245
246* Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
247- updated libdir patch
248- cleaned up desktop-file-install invocation
249- correct BuildRequires
250
251* Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
252- Initial package
Note: See TracBrowser for help on using the repository browser.