source: projects/specs/trunk/g/gnome-compiz-manager/gnome-compiz-manager-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           gnome-compiz-manager
2Version:        0.10.4
3Release: 1%{?_dist_release}
4Summary:        Compiz configuration utility
5Summary(ja):    Compiz Ý’胆[ƒeƒBƒŠƒeƒB
6
7Group:          User Interface/Desktops
8License:        GPL
9URL:            http://gandalfn.wordpress.com/gnome-compiz-manager/
10Source0:        http://download.gna.org/gcm/gnome-compiz-manager/gnome-compiz-manager-%{version}.tar.gz
11Source1:        desktop.png
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  intltool
15BuildRequires:  GConf2
16BuildRequires:  pkgconfig
17BuildRequires:  libglade2-devel
18BuildRequires:  libwnck-devel
19BuildRequires:  libgnomeui-devel
20BuildRequires:  libgnome-devel
21BuildRequires:  gnome-desktop-devel
22BuildRequires:  librsvg2-devel
23BuildRequires:  gob2
24BuildRequires:  gettext
25BuildRequires:  desktop-file-utils
26Requires(post): /sbin/ldconfig
27Requires(postun): /sbin/ldconfig
28Requires(pre): GConf2
29Requires(post): GConf2
30Requires(preun): GConf2
31
32
33%description
34Gnome compiz manager is small utility, which manages GL Desktop configurations
35on XGL/AiGLX. It is composed of two applications :
36
37- compiz-tray-icon : which launches and stops compiz
38- gnome-compiz-preferences : which adjusts GL effects
39
40The goal is not to expose all compiz options but allow a simple
41configuration of compiz.
42
43%package devel
44Summary:  Development files for gnome-compiz-manager
45Summary(ja):  gnome-compiz-manager ‚ÌŠJ”­ƒtƒ@ƒCƒ‹
46Group:    Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: pkgconfig
49%description devel
50Development files for gnome-compiz-manager
51
52%prep
53%setup -q
54
55cp %{SOURCE1} data
56
57%build
58%configure --disable-rpath
59sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
60sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
61make %{?_smp_mflags}
62
63
64%install
65rm -rf $RPM_BUILD_ROOT
66export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
67make install DESTDIR=$RPM_BUILD_ROOT
68desktop-file-install --vendor="fedora"                          \
69        --delete-original                                       \
70        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications         \
71        $RPM_BUILD_ROOT%{_datadir}/applications/gnome-compiz-preferences.desktop
72rm $RPM_BUILD_ROOT/%{_libdir}/*.la
73rm $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
74# kill static libs
75rm $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.a
76rm $RPM_BUILD_ROOT/%{_libdir}/*.a
77# empty
78rm $RPM_BUILD_ROOT/%{_docdir}/%{name}/README
79
80%find_lang %{name}
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%pre
86if [ "$1" -gt 1 ]; then
87export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88gconftool-2 --makefile-uninstall-rule \
89  %{_sysconfdir}/gconf/schemas/gnome-compiz-preferences.schemas >/dev/null || :
90# If the schema file has ever been renamed::
91#gconftool-2 --makefile-uninstall-rule \
92#  %{_sysconfdir}/gconf/schemas/[OLDNAME].schemas > /dev/null || :
93killall -HUP gconfd-2 &> /dev/null || :
94fi
95
96%post
97/sbin/ldconfig
98export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
99gconftool-2 --makefile-install-rule \
100  %{_sysconfdir}/gconf/schemas/gnome-compiz-preferences.schemas > /dev/null || :
101  killall -HUP gconfd-2 &> /dev/null || :
102 
103%preun
104if [ "$1" -eq 0 ]; then
105export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
106gconftool-2 --makefile-uninstall-rule \
107%{_sysconfdir}/gconf/schemas/gnome-compiz-preferences.schemas > /dev/null || :
108killall -HUP gconfd-2 &> /dev/null || :
109fi
110
111%postun -p /sbin/ldconfig
112
113%files -f %{name}.lang
114%defattr(-,root,root,-)
115%doc %{_docdir}/*
116%{_bindir}/*
117%{_mandir}/*/*
118%{_sysconfdir}/gconf/schemas/*
119%{_libdir}/*.so.*
120%dir %{_libdir}/%{name}/
121%{_libdir}/%{name}/*.so
122%{_libdir}/%{name}/*.plugin
123%{_datadir}/%{name}
124%{_datadir}/applications/*
125
126%files devel
127%defattr(-,root,root,-)
128%{_includedir}/%{name}/
129%{_libdir}/*.so
130%{_libdir}/pkgconfig/*
131
132%changelog
133* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.4-1
134- initial build for Vine Linux
135
136* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.10.4-4
137- Autorebuild for GCC 4.3
138
139* Sun Dec  9 2007 Denis Leroy <denis@poolshark.org> - 0.10.4-3
140- Fix duplicate desktop entries
141- Made gconf killall silent
142
143* Fri Oct 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.10.4-2
144- Don't ship Ubuntu branding
145
146* Sat Jul 14 2007 John Mahowald <jpmahowald@gmail.com> - 0.10.4-1
147- 0.10.4
148
149* Wed May 23 2007 John Mahowald <jpmahowald@gmail.com> - 0.9.14-1
150- 0.9.14
151
152* Tue Nov 28 2006 John Mahowald <jpmahowald@gmail.com> - 0.9.13.1-1
153- 0.9.13.1
154- dropped upstreamed libdir patch
155
156* Thu Nov 16 2006 John Mahowald <jpmahowald@gmail.com> - 0.9.10-1
157- initial rpm
Note: See TracBrowser for help on using the repository browser.