source: projects/specs/trunk/g/gnome-color-manager/gnome-color-manager-vl.spec @ 6890

Revision 6890, 7.0 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:   Color management tools for GNOME
4Name:      gnome-color-manager
5Version:   3.6.0
6Release:   1%{?_dist_release}
7License:   GPLv2+
8Group:     Applications/System
9URL:       http://projects.gnome.org/gnome-color-manager/
10Source0:   http://download.gnome.org/sources/gnome-color-manager/3.6/%{name}-%{version}.tar.xz
11
12Requires:  gnome-icon-theme
13Requires:  shared-mime-info
14Requires:  shared-color-profiles
15
16BuildRequires: gtk3-devel >= 3.0.0
17BuildRequires: gnome-doc-utils >= 0.3.2
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: libtool
21BuildRequires: vte3-devel
22BuildRequires: gnome-doc-utils
23BuildRequires: unique3-devel >= 3.0.0
24BuildRequires: intltool
25BuildRequires: libgudev1-devel
26BuildRequires: dbus-glib-devel >= 0.73
27BuildRequires: libXxf86vm-devel
28BuildRequires: libXrandr-devel
29BuildRequires: gnome-desktop3-devel
30BuildRequires: cups-devel
31BuildRequires: sane-devel
32BuildRequires: libtiff-devel
33BuildRequires: libcanberra-gtk3-devel
34BuildRequires: libnotify-devel
35BuildRequires: lcms2-devel
36BuildRequires: gnome-settings-daemon-devel
37BuildRequires: libusb1-devel
38BuildRequires: control-center-devel
39BuildRequires: exiv2-devel
40BuildRequires: colord-gtk-devel
41BuildRequires: clutter-gtk-devel
42BuildRequires: libmash-devel
43BuildRequires: gnome-common
44BuildRequires: yelp-tools
45
46Obsoletes: %{name}-libs < 3.1.0
47Obsoletes: %{name}-devel < 3.1.0
48
49Vendor: Project Vine
50Distribution: Vine Linux
51Packager: Takemikaduchi
52
53%description
54gnome-color-manager is a session framework that makes it easy to manage, install
55and generate color profiles in the GNOME desktop.
56
57
58%prep
59%setup -q
60
61%build
62%configure --disable-static
63make %{?_smp_mflags}
64
65%install
66make install DESTDIR=$RPM_BUILD_ROOT
67
68for i in gcm-import ; do
69  desktop-file-install --delete-original                                \
70    --dir=$RPM_BUILD_ROOT%{_datadir}/applications/                      \
71    $RPM_BUILD_ROOT%{_datadir}/applications/$i.desktop
72done
73
74rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
75rm -f $RPM_BUILD_ROOT%{_libdir}/control-center-1/panels/*.{la,a}
76rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-3.0/*.{la,a}
77
78%find_lang %name --with-gnome
79
80%post
81touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
82update-desktop-database %{_datadir}/applications &> /dev/null || :
83update-mime-database %{_datadir}/mime &> /dev/null || :
84
85%postun
86if [ $1 -eq 0 ]; then
87    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
88    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
89fi
90update-desktop-database %{_datadir}/applications &> /dev/null || :
91update-mime-database %{_datadir}/mime &> /dev/null || :
92glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
93
94%posttrans
95gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
96glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
97
98%files -f %{name}.lang
99%defattr(-,root,root,-)
100%doc AUTHORS COPYING NEWS README
101%{_bindir}/gcm-*
102%{_libexecdir}/gcm-helper-exiv
103%{_datadir}/applications/gcm-*.desktop
104%dir %{_datadir}/%{name}
105%{_datadir}/%{name}/figures/*.png
106%{_datadir}/%{name}/icons/*.svg
107%{_datadir}/%{name}/targets/*.png
108%{_datadir}/%{name}/ti1
109%{_datadir}/icons/hicolor/*/*/*.png
110%{_datadir}/icons/hicolor/scalable/*/*.svg*
111%{_datadir}/man/man1/*.1.gz
112
113
114%changelog
115* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
116- new upstream release
117- change BuildRequires: colord-gtk-devel instead of colord-devel
118- add BuildRequires: yelp-tools
119
120* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
121- rebuild with exiv2-0.23
122
123* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
124- new upstream release
125
126* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-2
127- rebuild with exiv2-0.22
128
129* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
130- new upstream release
131
132* Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
133- new upstream release
134
135* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
136- new upstream release
137
138* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
139- new upstream release
140
141* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
142- new upstream release
143- add BuildRequires: clutter-gtk-devel, libmash-devel, gnome-common
144
145* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
146- new upstream release
147
148* Wed Aug 31 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
149- rebuild with exiv2-0.21.1
150
151* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
152- new upstream release
153- change BuildRequires: gtk3-devel instead of gtk2-devel
154- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
155- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
156- change BuildRequires: unique3-devel instead of unique-devel
157- change BuildRequires: vte3-devel instead of vte-devel
158- add BuildRequires: lcms2-devel, gnome-settings-daemon-devel, libusb1-devel, control-center-devel, exiv2-devel, colord-devel
159- remove -libs and -devel sub package
160
161* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
162- new upstream release
163
164* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
165- new upstream release
166
167* Sat May 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
168- Initial build for Vine Linux
169
170
171* Fri Apr  2 2010 Matthias Clasen <mclasen@redhat.com> 2.30.0-4
172- BR GConf to make the macros work
173- Modernize icon cache handling
174
175* Wed Mar 31 2010 Richard Hughes <richard@hughsie.com> 2.30.0-3
176- Fix up a scriptlet problem.
177- Resolves: #578611
178
179* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-2
180- Add libnotify BR.
181
182* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-1
183- New upstream release.
184
185* Tue Mar 09 2010 Richard Hughes <richard@hughsie.com> 2.29.4-2
186- Update to the latest version of the Fedora Packaging Guidelines
187- Remove the custom BuildRoot
188- Do not clean the buildroot before install
189- Use the gconf_schema defines for the GConf schemas
190- Remove some over-zealous Requires that are already picked up by rpm.
191- Resolves #571658
192
193* Mon Mar 01 2010 Richard Hughes <richard@hughsie.com> 2.29.4-1
194- New upstream release.
195
196* Mon Feb 22 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100222
197- Another new snapshot from upstream with lots of bugs fixed from the Fedora
198  test day.
199
200* Wed Feb 18 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100218
201- Another new snapshot from upstream for the Fedora test day.
202
203* Wed Feb 17 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100217
204- New snapshot from upstream for the Fedora test day.
205
206* Mon Feb 01 2010 Richard Hughes <richard@hughsie.com> 2.29.3-1
207- New upstream release.
208
209* Mon Jan 18 2010 Matthias Clasen <mclasen@redhat.com> 2.29.2-3
210- Rebuild against new gnome-desktop
211
212* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-2
213- Rebuild, hopefully koji has now a working glibc.
214
215* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-1
216- New upstream release.
217
218* Fri Dec 04 2009 Richard Hughes <richard@hughsie.com> 2.29.1-1
219- Initial spec for review.
220
Note: See TracBrowser for help on using the repository browser.