source: projects/specs/trunk/g/gnome-color-manager/gnome-color-manager-vl.spec @ 1231

Revision 1231, 5.8 KB checked in by Takemikaduchi, 14 years ago (diff)

update libchamplain, libgda, anjuta, evolution, ekiga, evolution-data-server, gnome-python-desktop, gmime, glibmm, gtkhtml3, gtksourceview2, gnome-color-manager, gtkmm2, opal, pango, ptlib, tracker, totem-pl-parser

Line 
1%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:   Color management tools for GNOME
4Name:      gnome-color-manager
5Version:   2.30.2
6Release:   1%{?_dist_release}
7License:   GPLv2+
8Group:     Applications/System
9URL:       http://projects.gnome.org/gnome-color-manager/
10Source0:   http://download.gnome.org/sources/gnome-color-manager/2.30/%{name}-%{version}.tar.bz2
11
12Requires:  gnome-icon-theme
13Requires:  shared-mime-info
14Requires:  shared-color-profiles
15Requires(pre):    GConf2
16Requires(post):   GConf2
17Requires(preun):  GConf2
18
19BuildRequires: gtk2-devel >= 2.16.0
20BuildRequires: scrollkeeper
21BuildRequires: gnome-doc-utils >= 0.3.2
22BuildRequires: desktop-file-utils
23BuildRequires: gettext
24BuildRequires: libtool
25BuildRequires: vte-devel
26BuildRequires: gnome-doc-utils
27BuildRequires: unique-devel >= 1.0.0
28BuildRequires: intltool
29BuildRequires: libgudev1-devel
30BuildRequires: dbus-glib-devel >= 0.73
31BuildRequires: libXxf86vm-devel
32BuildRequires: libXrandr-devel
33BuildRequires: gnome-desktop-devel
34BuildRequires: lcms-devel
35BuildRequires: cups-devel
36BuildRequires: sane-devel
37BuildRequires: libtiff-devel
38BuildRequires: libcanberra-devel
39BuildRequires: libnotify-devel
40BuildRequires: GConf2
41
42%description
43gnome-color-manager is a session framework that makes it easy to manage, install
44and generate color profiles in the GNOME desktop.
45
46%prep
47%setup -q
48
49%build
50%configure --disable-scrollkeeper --disable-schemas-install
51make %{?_smp_mflags}
52
53%install
54make install DESTDIR=$RPM_BUILD_ROOT
55
56for i in gcm-prefs gcm-import ; do
57  desktop-file-install --delete-original                                \
58    --dir=$RPM_BUILD_ROOT%{_datadir}/applications/                      \
59    $RPM_BUILD_ROOT%{_datadir}/applications/$i.desktop
60done
61
62%find_lang %name --with-gnome
63
64%post
65export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
66gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gnome-color-manager.schemas > /dev/null
67
68touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
69update-desktop-database %{_datadir}/applications &> /dev/null || :
70update-mime-database %{_datadir}/mime &> /dev/null || :
71
72%pre
73if [ "$1" -gt 1 ]; then
74    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
75    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gnome-color-manager.schemas > /dev/null
76fi
77
78%preun
79if [ "$1" -eq 0 ]; then
80    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
81    gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gnome-color-manager.schemas > /dev/null
82fi
83
84
85%postun
86if [ $1 -eq 0 ]; then
87    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
88    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
89fi
90update-desktop-database %{_datadir}/applications &> /dev/null || :
91update-mime-database %{_datadir}/mime &> /dev/null || :
92
93%posttrans
94gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
95
96%files -f %{name}.lang
97%defattr(-,root,root,-)
98%doc AUTHORS COPYING NEWS README
99/lib/udev/rules.d/*.rules
100%{_bindir}/gcm-*
101%dir %{_datadir}/gnome-color-manager
102%{_datadir}/gnome-color-manager/gcm-*.ui
103%dir %{_datadir}/gnome-color-manager/targets
104%dir %{_datadir}/gnome-color-manager/icons
105%{_datadir}/gnome-color-manager/targets/*.png
106%{_datadir}/gnome-color-manager/icons/*.svg
107%{_datadir}/man/man1/*.1.gz
108%{_datadir}/icons/hicolor/*/*/*.png
109%{_datadir}/icons/hicolor/scalable/*/*.svg*
110%config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
111%{_datadir}/applications/gcm-prefs.desktop
112%{_datadir}/applications/gcm-import.desktop
113%{_sysconfdir}/xdg/autostart/*.desktop
114%{_datadir}/dbus-1/services/org.gnome.ColorManager.service
115%{_sbindir}/gcm-install-system-wide
116%{_datadir}/polkit-1/actions/org.gnome.color.policy
117
118# this is probably better in a shared package
119%dir %{_localstatedir}/lib/color
120
121%changelog
122* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
123- new upstream release
124
125* Sat May 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
126- Initial build for Vine Linux
127
128
129* Fri Apr  2 2010 Matthias Clasen <mclasen@redhat.com> 2.30.0-4
130- BR GConf to make the macros work
131- Modernize icon cache handling
132
133* Wed Mar 31 2010 Richard Hughes <richard@hughsie.com> 2.30.0-3
134- Fix up a scriptlet problem.
135- Resolves: #578611
136
137* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-2
138- Add libnotify BR.
139
140* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-1
141- New upstream release.
142
143* Tue Mar 09 2010 Richard Hughes <richard@hughsie.com> 2.29.4-2
144- Update to the latest version of the Fedora Packaging Guidelines
145- Remove the custom BuildRoot
146- Do not clean the buildroot before install
147- Use the gconf_schema defines for the GConf schemas
148- Remove some over-zealous Requires that are already picked up by rpm.
149- Resolves #571658
150
151* Mon Mar 01 2010 Richard Hughes <richard@hughsie.com> 2.29.4-1
152- New upstream release.
153
154* Mon Feb 22 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100222
155- Another new snapshot from upstream with lots of bugs fixed from the Fedora
156  test day.
157
158* Wed Feb 18 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100218
159- Another new snapshot from upstream for the Fedora test day.
160
161* Wed Feb 17 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100217
162- New snapshot from upstream for the Fedora test day.
163
164* Mon Feb 01 2010 Richard Hughes <richard@hughsie.com> 2.29.3-1
165- New upstream release.
166
167* Mon Jan 18 2010 Matthias Clasen <mclasen@redhat.com> 2.29.2-3
168- Rebuild against new gnome-desktop
169
170* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-2
171- Rebuild, hopefully koji has now a working glibc.
172
173* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-1
174- New upstream release.
175
176* Fri Dec 04 2009 Richard Hughes <richard@hughsie.com> 2.29.1-1
177- Initial spec for review.
178
Note: See TracBrowser for help on using the repository browser.