source: projects/specs/trunk/g/gnome-color-manager/gnome-color-manager-vl.spec @ 4616

Revision 4616, 6.1 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:   Color management tools for GNOME
4Name:      gnome-color-manager
5Version:   3.1.2
6Release:   1%{?_dist_release}
7License:   GPLv2+
8Group:     Applications/System
9URL:       http://projects.gnome.org/gnome-color-manager/
10Source0:   http://download.gnome.org/sources/gnome-color-manager/3.1/%{name}-%{version}.tar.xz
11
12Requires:  gnome-icon-theme
13Requires:  shared-mime-info
14Requires:  shared-color-profiles
15Requires(pre):    GConf2
16Requires(post):   GConf2
17Requires(preun):  GConf2
18
19BuildRequires: gtk3-devel >= 3.0.0
20BuildRequires: scrollkeeper
21BuildRequires: gnome-doc-utils >= 0.3.2
22BuildRequires: desktop-file-utils
23BuildRequires: gettext
24BuildRequires: libtool
25BuildRequires: vte3-devel
26BuildRequires: gnome-doc-utils
27BuildRequires: unique3-devel >= 3.0.0
28BuildRequires: intltool
29BuildRequires: libgudev1-devel
30BuildRequires: dbus-glib-devel >= 0.73
31BuildRequires: libXxf86vm-devel
32BuildRequires: libXrandr-devel
33BuildRequires: gnome-desktop3-devel
34BuildRequires: lcms-devel
35BuildRequires: cups-devel
36BuildRequires: sane-devel
37BuildRequires: libtiff-devel
38BuildRequires: libcanberra-gtk3-devel
39BuildRequires: libnotify-devel
40BuildRequires: lcms2-devel
41BuildRequires: gnome-settings-daemon-devel
42BuildRequires: libusb1-devel
43BuildRequires: control-center-devel
44BuildRequires: exiv2-devel
45BuildRequires: colord-devel
46
47Obsoletes: %{name}-libs < 3.1.0
48Obsoletes: %{name}-devel < 3.1.0
49
50Vendor: Project Vine
51Distribution: Vine Linux
52Packager: Takemikaduchi
53
54%description
55gnome-color-manager is a session framework that makes it easy to manage, install
56and generate color profiles in the GNOME desktop.
57
58
59%prep
60%setup -q
61
62%build
63%configure --disable-scrollkeeper --disable-schemas-install
64make %{?_smp_mflags}
65
66%install
67make install DESTDIR=$RPM_BUILD_ROOT
68
69for i in gcm-import ; do
70  desktop-file-install --delete-original                                \
71    --dir=$RPM_BUILD_ROOT%{_datadir}/applications/                      \
72    $RPM_BUILD_ROOT%{_datadir}/applications/$i.desktop
73done
74
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
76rm -f $RPM_BUILD_ROOT%{_libdir}/control-center-1/panels/*.{la,a}
77rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-3.0/*.{la,a}
78
79%find_lang %name --with-gnome
80
81%post
82touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
83update-desktop-database %{_datadir}/applications &> /dev/null || :
84update-mime-database %{_datadir}/mime &> /dev/null || :
85
86%postun
87if [ $1 -eq 0 ]; then
88    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
89    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
90fi
91update-desktop-database %{_datadir}/applications &> /dev/null || :
92update-mime-database %{_datadir}/mime &> /dev/null || :
93glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
94
95%posttrans
96gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
97glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
98
99%files -f %{name}.lang
100%defattr(-,root,root,-)
101%doc AUTHORS COPYING NEWS README
102%{_sysconfdir}/xdg/autostart/*.desktop
103%{_bindir}/gcm-*
104%{_libexecdir}/gcm-helper-exiv
105%{_datadir}/applications/gcm-*.desktop
106%{_datadir}/dbus-1/interfaces/org.gnome.ColorManager.xml
107%{_datadir}/dbus-1/services/org.gnome.ColorManager.service
108%dir %{_datadir}/%{name}
109%{_datadir}/%{name}/gcm-*.ui
110%{_datadir}/%{name}/figures/*.png
111%{_datadir}/%{name}/icons/*.svg
112%{_datadir}/%{name}/targets/*.png
113%{_datadir}/icons/hicolor/*/*/*.png
114%{_datadir}/icons/hicolor/scalable/*/*.svg*
115%{_datadir}/man/man1/*.1.gz
116
117
118%changelog
119* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
120- new upstream release
121- change BuildRequires: gtk3-devel instead of gtk2-devel
122- change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
123- change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
124- change BuildRequires: unique3-devel instead of unique-devel
125- change BuildRequires: vte3-devel instead of vte-devel
126- add BuildRequires: lcms2-devel, gnome-settings-daemon-devel, libusb1-devel, control-center-devel, exiv2-devel, colord-devel
127- remove -libs and -devel sub package
128
129* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
130- new upstream release
131
132* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
133- new upstream release
134
135* Sat May 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
136- Initial build for Vine Linux
137
138
139* Fri Apr  2 2010 Matthias Clasen <mclasen@redhat.com> 2.30.0-4
140- BR GConf to make the macros work
141- Modernize icon cache handling
142
143* Wed Mar 31 2010 Richard Hughes <richard@hughsie.com> 2.30.0-3
144- Fix up a scriptlet problem.
145- Resolves: #578611
146
147* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-2
148- Add libnotify BR.
149
150* Mon Mar 29 2010 Richard Hughes <richard@hughsie.com> 2.30.0-1
151- New upstream release.
152
153* Tue Mar 09 2010 Richard Hughes <richard@hughsie.com> 2.29.4-2
154- Update to the latest version of the Fedora Packaging Guidelines
155- Remove the custom BuildRoot
156- Do not clean the buildroot before install
157- Use the gconf_schema defines for the GConf schemas
158- Remove some over-zealous Requires that are already picked up by rpm.
159- Resolves #571658
160
161* Mon Mar 01 2010 Richard Hughes <richard@hughsie.com> 2.29.4-1
162- New upstream release.
163
164* Mon Feb 22 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100222
165- Another new snapshot from upstream with lots of bugs fixed from the Fedora
166  test day.
167
168* Wed Feb 18 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100218
169- Another new snapshot from upstream for the Fedora test day.
170
171* Wed Feb 17 2010 Richard Hughes <richard@hughsie.com> 2.29.4-0.1.20100217
172- New snapshot from upstream for the Fedora test day.
173
174* Mon Feb 01 2010 Richard Hughes <richard@hughsie.com> 2.29.3-1
175- New upstream release.
176
177* Mon Jan 18 2010 Matthias Clasen <mclasen@redhat.com> 2.29.2-3
178- Rebuild against new gnome-desktop
179
180* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-2
181- Rebuild, hopefully koji has now a working glibc.
182
183* Mon Jan 04 2010 Richard Hughes <richard@hughsie.com> 2.29.2-1
184- New upstream release.
185
186* Fri Dec 04 2009 Richard Hughes <richard@hughsie.com> 2.29.1-1
187- Initial spec for review.
188
Note: See TracBrowser for help on using the repository browser.