source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 521

Revision 521, 12.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 2.28.6
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/0.11/%{name}-%{version}.tar.bz2
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libgnomeui-devel >= 2.2
19BuildRequires: libbonobo-devel >= 2.0
20BuildRequires: GConf2-devel >= 2.0
21BuildRequires: hal-devel
22BuildRequires: unique-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25
26BuildRequires: intltool, automake, libtool, gettext
27Requires: %{name}-libs = %{version}-%{release}
28Requires(pre): GConf2
29Requires(post): GConf2
30Requires(preun): GConf2
31Requires: bluez >= 4.42
32Requires: obexd
33ExcludeArch: s390 s390x
34
35## Patch1: gnome-bluetooth-0.8.0-desktop.patch
36
37#----------------------------------------------------------------------------
38%description
39This package contains a library with widgets for Bluetooth applications.
40
41%description -l ja
42このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
43ライブラリが含まれます。
44
45#----------------------------------------------------------------------------
46%package libs
47Summary: Libraries for applications, which use gnome-bluetooth
48Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
49Group: Development/Libraries
50
51%description libs
52This package contains the libraries for applications,
53which use gnome-bluetooth.
54
55%description libs -l ja
56このパッケージには Gnome-bluetoothを使用するアプリケーション用の
57ライブラリが含まれています。
58
59#----------------------------------------------------------------------------
60%package devel
61Summary: Files for the development of applications, which use gnome-bluetooth
62Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
63Group:          Development/Libraries
64License:        LGPLv2+
65Requires:       %{name}-libs = %{version}-%{release}
66Requires:       gtk-doc pkgconfig
67Requires:       glib2-devel
68Requires:       libbtctl-devel
69
70
71%description devel
72This package contains the files for the development of applications,
73which will use gnome-bluetooth.
74
75%description devel -l ja
76このパッケージにはGnome-bluetoothを使用するアプリケーションを
77開発するためのヘッダーファイルなどが含まれています(develパッケージ)
78
79#----------------------------------------------------------------------------
80
81%prep
82%setup -q -n gnome-bluetooth-%{version}
83
84## %patch1 -p1 -b .dfix
85
86%build
87%configure --disable-desktop-update --disable-icon-update
88make %{?_smp_mflags}
89
90#----------------------------------------------------------------------------
91%install
92rm -rf $RPM_BUILD_ROOT
93export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
94make DESTDIR=$RPM_BUILD_ROOT install
95
96# we do not want .la files
97rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
98rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
99
100install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
101
102# Remove the gnome-obex-server
103# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
104
105%find_lang gnome-bluetooth2
106%find_lang %{name} --with-gnome
107cat %{name}.lang >> gnome-bluetooth2.lang
108
109# save space by linking identical images in translated docs
110helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
111for f in $helpdir/C/figures/*.png; do
112  b="$(basename $f)"
113  for d in $helpdir/*; do
114    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
115      g="$d/figures/$b"
116      if [ -f "$g" ]; then
117        if cmp -s $f $g; then
118          rm "$g"; ln -s "../../C/figures/$b" "$g"
119        fi
120      fi
121    fi
122  done
123done
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%pre
129#if [ "$1" -gt 1 ]; then
130#    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
131#    if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
132#      gconftool-2 --makefile-uninstall-rule \
133#        %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
134#    fi
135#fi
136if [ "$1" -gt 1 ]; then
137        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
138        if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
139                gconftool-2 --makefile-uninstall-rule \
140                %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
141        fi
142        if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
143                gconftool-2 --makefile-uninstall-rule                           \
144                %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
145                >& /dev/null || :
146        fi
147fi
148
149%post
150scrollkeeper-update -q
151export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
152gconftool-2 --makefile-install-rule                                     \
153        %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
154        >& /dev/null || :
155
156%preun
157#if [ "$1" -eq 0 ]; then
158#    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
159#    if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
160#      gconftool-2 --makefile-uninstall-rule \
161#        %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
162#    fi
163#fi
164if [ "$1" -eq 0 ]; then
165        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
166        if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
167                gconftool-2 --makefile-uninstall-rule \
168                %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
169        fi
170        if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
171                gconftool-2 --makefile-uninstall-rule                           \
172                %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
173                >& /dev/null || :
174        fi
175fi
176
177%postun
178scrollkeeper-update -q
179if [ $1 -eq 0 ] ; then
180        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
181        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
182fi
183
184%post libs
185/sbin/ldconfig
186touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
187
188%posttrans libs
189gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
190
191%postun libs
192/sbin/ldconfig
193if [ $1 -eq 0 ] ; then
194        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
195        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
196fi
197
198#----------------------------------------------------------------------------
199%files -f %{name}.lang
200%defattr(-, root, root)
201%doc README NEWS COPYING
202%{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas
203%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
204%{_bindir}/bluetooth-*
205%{_libdir}/gnome-bluetooth/
206%{_datadir}/applications/*.desktop
207%{_datadir}/gnome-bluetooth/
208%{_datadir}/locale/*
209%{_mandir}/man1/*
210/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
211
212%files libs
213%defattr(-,root,root,-)
214%doc COPYING.LIB
215%{_libdir}/libgnome-bluetooth.so.*
216%{_datadir}/icons/hicolor/*/apps/*
217%{_datadir}/icons/hicolor/*/status/*
218
219%files devel
220%defattr(-,root,root,-)
221%{_includedir}/gnome-bluetooth/
222%{_libdir}/libgnome-bluetooth.so
223%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
224%{_datadir}/gtk-doc/html/gnome-bluetooth/
225
226#----------------------------------------------------------------------------
227# Maintainers: babasaki@mindgear.org
228#
229#----------------------------------------------------------------------------
230%changelog
231* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
232- new upstream release
233- merge spec file from FC package
234
235* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
236- Update to 0.11.0 (VineSeed)
237- added "# Maintainers: " comments.
238- changed UTF-8 encode at gnome-bluetooth.vsc.spec
239- FedoraCore - LOGS
240-- 0.11.0-5
241-- Rebuild against new bluez-libs
242-- 0.11.0-4
243-- Changed name of icon file(#444811)
244-- 0.11.0-3
245-- Remove gnome-obex-server, we should use gnome-user-share now
246-- 0.11.0-1
247-- gcc43 rebuild
248-- 0.11.0 - Update to 0.11.0
249-- 0.10.0 - Update to 0.10.0
250-- 0.9.1-4
251-- marked gnome-obex-server.schemas as config file
252-- changed upstream URL
253-- 0.9.1-3
254-- fixed wrong source URL
255-- 0.9.1-2
256-- rebuilt for F8
257-- changed license tag to GPLv2 and LGPLv2+
258-- 0.9.1-1
259-- Upgrade to 0.9.1 to fix a crasher in the server
260-- 0.9.0-1
261-- Update for 0.9.0
262-- Fix installation of the python bindings
263-- 0.8.0-4
264-- Remove unncessary gconfd killing from scripts (#224561)
265-- 0.8.0-3
266-- corrected BuildRoot
267-- smp flags added
268-- specfile cleanup
269-- fixed desktop file
270- Updated specfile
271
272* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
273- Updated specfile
274
275* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
276- Import gnome-bluetooth - Packager: Babasaki
277- Updated specfile (downgrade -> 0.8.0-0vl1)
278
279#----------------------------------------------------------------------------
280* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
281- version 0.8.0
282
283* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
284- rebuild
285
286* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
287- bump for new openobex
288
289* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
290- Missing automake, libtool, gettext BR
291
292* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
293- Bump for new libbluetooth
294
295* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
296- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
297
298* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
299- install schemata correctly (bug #193518)
300
301* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
302- more build requires (bug #193374)
303
304* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
305- pydir fixes for lib64
306
307* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
308- version 0.7.0
309
310* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
311- bump again for double-long bug on ppc(64)
312
313* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
314- rebuilt for new gcc4.1 snapshot and glibc changes
315
316* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
317- rebuilt
318
319* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
320- Fix relative path for the icons in desktop files which no longer works
321  with the icon cache.
322
323* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
324- new version 0.6.0
325
326* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
327- rebuild for new cairo
328
329* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
330- Minor spec file cleanups.
331- Fix relative path for the icons in desktop files which no longer works
332  with the icon cache.
333- Remove useless zero epochs.
334- Remove explicit python abi requirement, it's automatic for FC4 and up.
335
336* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
337- removed base requirement from libs
338
339* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
340- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
341
342* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
343- rebuilt
344
345* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
346- added gnome hbox patch for bug rh#149215
347
348* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
349- added requires for python-abi
350
351* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
352- split package into app, libs and devel
353
354* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
355- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
356
357* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
358- buildrequire pygtk2-devel (bug 135032)
359- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
360- fixed segfault on file receive (bug 133041)
361
362* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
363- buildrequire libbtctl-devel
364- buildrequire openobex-devel >= 1.0.1
365- pythondir -> pyexecdir
366
367* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
368- added build dependency for librsvg2-devel
369
370* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
371- added pydir patch
372
373* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
374- version 0.5.1
375
376* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
377- rebuilt
378
379* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
380- corrected BuildRequires
381
382* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
383- added EggToolBar patch for gcc34
384
385* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
386- rebuilt
387
388* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
389- rebuilt
390
391* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
392- added autofoo patch
393
394* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
395- add .so to gnome-vfs module, if libtool does not!
396
397* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
398- call libtool finish
399
400* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
401- new version 0.4.1
402
403* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
404- initial RPM
405
406
Note: See TracBrowser for help on using the repository browser.