source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 6890

Revision 6890, 12.4 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.6.0
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.6/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: bluez-libs-devel >= 2.8
15BuildRequires: libbonobo-devel >= 2.32.0
16BuildRequires: libbonoboui-devel >= 2.24.4
17BuildRequires: unique3-devel
18BuildRequires: libnotify-devel
19BuildRequires: nautilus-sendto-devel
20BuildRequires: gnome-doc-utils
21BuildRequires: intltool, automake, libtool, gettext
22BuildRequires: itstool
23
24Requires: %{name}-libs = %{version}-%{release}
25Requires: bluez >= 4.42
26Requires: obexd
27Requires(post): desktop-file-utils
28Requires(postun): desktop-file-utils
29ExcludeArch: s390 s390x
30
31Obsoletes: bluez-gnome < 1.9
32
33# virtual package
34Provides:       dbus-bluez-pin-helper
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: Takemikaduchi
39
40
41%description
42This package contains a library with widgets for Bluetooth applications.
43
44%description -l ja
45このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
46ライブラリが含まれます。
47
48
49%package libs
50Summary: Libraries for applications, which use gnome-bluetooth
51Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
52Group: Development/Libraries
53
54%description libs
55This package contains the libraries for applications,
56which use gnome-bluetooth.
57
58%description libs -l ja
59このパッケージには Gnome-bluetoothを使用するアプリケーション用の
60ライブラリが含まれています。
61
62
63%package devel
64Summary: Files for the development of applications, which use gnome-bluetooth
65Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
66Group:          Development/Libraries
67License:        LGPLv2+
68Requires:       %{name}-libs = %{version}-%{release}
69Requires:       pkgconfig
70Requires:       gtk3-devel
71
72%description devel
73This package contains the files for the development of applications,
74which will use gnome-bluetooth.
75
76%description devel -l ja
77このパッケージにはGnome-bluetoothを使用するアプリケーションを
78開発するためのヘッダーファイルなどが含まれています(develパッケージ)
79
80
81%package -n     nautilus-sendto-gnome-bluetooth
82Summary:        Nautilus-sendto plugin for gnome-bluetooth
83Summary(ja):    gnome-bluetooth 用 nautilus-sendto プラグイン
84Group:          User Interface/Desktop
85License:        LGPLv2+
86Requires:       %{name}-libs = %{version}-%{release}
87Requires:       nautilus-sendto
88
89%description -n nautilus-sendto-gnome-bluetooth
90This package contains nautilus-sendto plugin for the gnome-bluetooth.
91
92%description -n nautilus-sendto-gnome-bluetooth -l ja
93このパッケージには gnome-bluetooth 用の nautilus-sendto プラグインが含まれています。
94
95
96%prep
97%setup -q -n gnome-bluetooth-%{version}
98
99
100%build
101%configure \
102        --disable-desktop-update \
103        --disable-icon-update \
104        --enable-nautilus-sendto \
105        --enable-introspection=yes
106make %{?_smp_mflags}
107
108
109%install
110rm -rf $RPM_BUILD_ROOT
111export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
112make DESTDIR=$RPM_BUILD_ROOT install
113
114# we do not want .la files
115rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
116rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
117rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
118rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
119
120install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
121
122%find_lang gnome-bluetooth2
123%find_lang %{name} --with-gnome
124cat %{name}.lang >> gnome-bluetooth2.lang
125
126find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
127
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132
133%post
134update-desktop-database -q
135
136%postun
137update-desktop-database -q
138if [ $1 -eq 0 ] ; then
139        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
140        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
141fi
142
143
144%post libs
145/sbin/ldconfig
146touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
147
148%posttrans libs
149gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
150
151%postun libs
152/sbin/ldconfig
153if [ $1 -eq 0 ] ; then
154        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
155        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
156fi
157
158%postun -n nautilus-sendto-gnome-bluetooth
159if [ $1 -eq 0 ]; then
160  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
161fi
162
163%posttrans -n nautilus-sendto-gnome-bluetooth
164glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
165
166
167%files -f %{name}.lang
168%defattr(-, root, root)
169%doc README NEWS COPYING
170%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
171%{_bindir}/bluetooth-*
172%{_libdir}/gnome-bluetooth/
173%{_datadir}/applications/*.desktop
174%{_datadir}/gnome-bluetooth/
175%{_datadir}/locale/*
176%{_mandir}/man1/*
177/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
178
179%files libs
180%defattr(-,root,root,-)
181%doc COPYING.LIB
182%{_libdir}/libgnome-bluetooth.so.*
183%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
184%{_datadir}/icons/hicolor/*/apps/*
185%{_datadir}/icons/hicolor/*/status/*
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/gnome-bluetooth/
190%{_libdir}/libgnome-bluetooth.so
191%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
192%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
193%{_datadir}/gtk-doc/html/gnome-bluetooth/
194
195%files -n nautilus-sendto-gnome-bluetooth
196%defattr(-,root,root,-)
197%{_libdir}/nautilus-sendto/plugins/libnstbluetooth.so
198%{_datadir}/GConf/gsettings/gnome-bluetooth-nst
199%{_datadir}/glib-2.0/schemas/org.gnome.Bluetooth.nst.gschema.xml
200
201
202%changelog
203* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
204- new upstream release
205- add Obsoletes: bluez-gnome < 1.9
206- add BuildRequires: itstool
207
208* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
209- fix spec file
210
211* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
212- new upstream release
213
214* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
215- new upstream release
216- add BuildRequires: nautilus-sendto-devel
217- create nautilus-sendto-gnome-bluetooth package
218
219* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
220- new upstream release
221- remove BuildRequires: GConf2-devel
222
223* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
224- new upstream release
225
226* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
227- new upstream release
228
229* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
230- new upstream release
231
232* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
233- new upstream release
234
235* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
236- new upstream release
237- change BuildRequires: unique3-devel instead of unique-devel
238- add BuildRequires: control-center-devel
239
240* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
241- new upstream release
242- remove BuildRequires: gir-repository-devel
243- add Requires(post) and Requires(postun): desktop-file-utils
244
245* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
246- rebuild with rpm-4.8.1 for pkg-config file
247
248* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
249- new upstream release
250- add BuildRequires: gir-repository-devel
251- add configure option (--disable-nautilus-sendto)
252
253* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
254- new upstream release
255- merge spec file from FC package
256
257* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
258- Update to 0.11.0 (VineSeed)
259- added "# Maintainers: " comments.
260- changed UTF-8 encode at gnome-bluetooth.vsc.spec
261- FedoraCore - LOGS
262-- 0.11.0-5
263-- Rebuild against new bluez-libs
264-- 0.11.0-4
265-- Changed name of icon file(#444811)
266-- 0.11.0-3
267-- Remove gnome-obex-server, we should use gnome-user-share now
268-- 0.11.0-1
269-- gcc43 rebuild
270-- 0.11.0 - Update to 0.11.0
271-- 0.10.0 - Update to 0.10.0
272-- 0.9.1-4
273-- marked gnome-obex-server.schemas as config file
274-- changed upstream URL
275-- 0.9.1-3
276-- fixed wrong source URL
277-- 0.9.1-2
278-- rebuilt for F8
279-- changed license tag to GPLv2 and LGPLv2+
280-- 0.9.1-1
281-- Upgrade to 0.9.1 to fix a crasher in the server
282-- 0.9.0-1
283-- Update for 0.9.0
284-- Fix installation of the python bindings
285-- 0.8.0-4
286-- Remove unncessary gconfd killing from scripts (#224561)
287-- 0.8.0-3
288-- corrected BuildRoot
289-- smp flags added
290-- specfile cleanup
291-- fixed desktop file
292- Updated specfile
293
294* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
295- Updated specfile
296
297* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
298- Import gnome-bluetooth - Packager: Babasaki
299- Updated specfile (downgrade -> 0.8.0-0vl1)
300
301#----------------------------------------------------------------------------
302* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
303- version 0.8.0
304
305* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
306- rebuild
307
308* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
309- bump for new openobex
310
311* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
312- Missing automake, libtool, gettext BR
313
314* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
315- Bump for new libbluetooth
316
317* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
318- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
319
320* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
321- install schemata correctly (bug #193518)
322
323* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
324- more build requires (bug #193374)
325
326* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
327- pydir fixes for lib64
328
329* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
330- version 0.7.0
331
332* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
333- bump again for double-long bug on ppc(64)
334
335* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
336- rebuilt for new gcc4.1 snapshot and glibc changes
337
338* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
339- rebuilt
340
341* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
342- Fix relative path for the icons in desktop files which no longer works
343  with the icon cache.
344
345* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
346- new version 0.6.0
347
348* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
349- rebuild for new cairo
350
351* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
352- Minor spec file cleanups.
353- Fix relative path for the icons in desktop files which no longer works
354  with the icon cache.
355- Remove useless zero epochs.
356- Remove explicit python abi requirement, it's automatic for FC4 and up.
357
358* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
359- removed base requirement from libs
360
361* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
362- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
363
364* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
365- rebuilt
366
367* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
368- added gnome hbox patch for bug rh#149215
369
370* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
371- added requires for python-abi
372
373* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
374- split package into app, libs and devel
375
376* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
377- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
378
379* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
380- buildrequire pygtk2-devel (bug 135032)
381- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
382- fixed segfault on file receive (bug 133041)
383
384* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
385- buildrequire libbtctl-devel
386- buildrequire openobex-devel >= 1.0.1
387- pythondir -> pyexecdir
388
389* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
390- added build dependency for librsvg2-devel
391
392* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
393- added pydir patch
394
395* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
396- version 0.5.1
397
398* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
399- rebuilt
400
401* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
402- corrected BuildRequires
403
404* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
405- added EggToolBar patch for gcc34
406
407* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
408- rebuilt
409
410* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
411- rebuilt
412
413* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
414- added autofoo patch
415
416* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
417- add .so to gnome-vfs module, if libtool does not!
418
419* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
420- call libtool finish
421
422* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
423- new version 0.4.1
424
425* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
426- initial RPM
427
428
Note: See TracBrowser for help on using the repository browser.