source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 6539

Revision 6539, 12.6 KB checked in by Takemikaduchi, 12 years ago (diff)

fix spec file

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.4.2
5Release: 2%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.4/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: bluez-libs-devel >= 2.8
15BuildRequires: libbonobo-devel >= 2.32.0
16BuildRequires: libbonoboui-devel >= 2.24.4
17BuildRequires: unique3-devel
18BuildRequires: libnotify-devel
19BuildRequires: nautilus-sendto-devel
20BuildRequires: gnome-doc-utils
21BuildRequires: intltool, automake, libtool, gettext
22
23Requires: %{name}-libs = %{version}-%{release}
24Requires: bluez >= 4.42
25Requires: obexd
26Requires(post): desktop-file-utils
27Requires(postun): desktop-file-utils
28ExcludeArch: s390 s390x
29
30## Patch1: gnome-bluetooth-0.8.0-desktop.patch
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Takemikaduchi
35
36
37%description
38This package contains a library with widgets for Bluetooth applications.
39
40%description -l ja
41このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
42ライブラリが含まれます。
43
44
45%package libs
46Summary: Libraries for applications, which use gnome-bluetooth
47Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
48Group: Development/Libraries
49
50%description libs
51This package contains the libraries for applications,
52which use gnome-bluetooth.
53
54%description libs -l ja
55このパッケージには Gnome-bluetoothを使用するアプリケーション用の
56ライブラリが含まれています。
57
58
59%package devel
60Summary: Files for the development of applications, which use gnome-bluetooth
61Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
62Group:          Development/Libraries
63License:        LGPLv2+
64Requires:       %{name}-libs = %{version}-%{release}
65Requires:       pkgconfig
66Requires:       gtk3-devel
67
68%description devel
69This package contains the files for the development of applications,
70which will use gnome-bluetooth.
71
72%description devel -l ja
73このパッケージにはGnome-bluetoothを使用するアプリケーションを
74開発するためのヘッダーファイルなどが含まれています(develパッケージ)
75
76
77%package -n     nautilus-sendto-gnome-bluetooth
78Summary:        Nautilus-sendto plugin for gnome-bluetooth
79Summary(ja):    gnome-bluetooth 用 nautilus-sendto プラグイン
80Group:          User Interface/Desktop
81License:        LGPLv2+
82Requires:       %{name}-libs = %{version}-%{release}
83Requires:       nautilus-sendto
84
85%description -n nautilus-sendto-gnome-bluetooth
86This package contains nautilus-sendto plugin for the gnome-bluetooth.
87
88%description -n nautilus-sendto-gnome-bluetooth -l ja
89このパッケージには gnome-bluetooth 用の nautilus-sendto プラグインが含まれています。
90
91
92%prep
93%setup -q -n gnome-bluetooth-%{version}
94
95
96%build
97%configure \
98        --disable-desktop-update \
99        --disable-icon-update \
100        --enable-nautilus-sendto \
101        --enable-introspection=yes
102make %{?_smp_mflags}
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
108make DESTDIR=$RPM_BUILD_ROOT install
109
110# we do not want .la files
111rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
112rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
113rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
114rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
115
116install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
117
118%find_lang gnome-bluetooth2
119%find_lang %{name} --with-gnome
120cat %{name}.lang >> gnome-bluetooth2.lang
121
122# save space by linking identical images in translated docs
123helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
124for f in $helpdir/C/figures/*.png; do
125  b="$(basename $f)"
126  for d in $helpdir/*; do
127    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
128      g="$d/figures/$b"
129      if [ -f "$g" ]; then
130        if cmp -s $f $g; then
131          rm "$g"; ln -s "../../C/figures/$b" "$g"
132        fi
133      fi
134    fi
135  done
136done
137
138find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
139
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144
145%post
146update-desktop-database -q
147
148%postun
149update-desktop-database -q
150if [ $1 -eq 0 ] ; then
151        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
152        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
153fi
154
155
156%post libs
157/sbin/ldconfig
158touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
159
160%posttrans libs
161gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
162
163%postun libs
164/sbin/ldconfig
165if [ $1 -eq 0 ] ; then
166        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
167        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
168fi
169
170%postun -n nautilus-sendto-gnome-bluetooth
171if [ $1 -eq 0 ]; then
172  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
173fi
174
175%posttrans -n nautilus-sendto-gnome-bluetooth
176glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
177
178
179%files -f %{name}.lang
180%defattr(-, root, root)
181%doc README NEWS COPYING
182%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
183%{_bindir}/bluetooth-*
184%{_libdir}/gnome-bluetooth/
185%{_datadir}/applications/*.desktop
186%{_datadir}/gnome-bluetooth/
187%{_datadir}/locale/*
188%{_mandir}/man1/*
189/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
190
191%files libs
192%defattr(-,root,root,-)
193%doc COPYING.LIB
194%{_libdir}/libgnome-bluetooth.so.*
195%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
196%{_datadir}/icons/hicolor/*/apps/*
197%{_datadir}/icons/hicolor/*/status/*
198
199%files devel
200%defattr(-,root,root,-)
201%{_includedir}/gnome-bluetooth/
202%{_libdir}/libgnome-bluetooth.so
203%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
204%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
205%{_datadir}/gtk-doc/html/gnome-bluetooth/
206
207%files -n nautilus-sendto-gnome-bluetooth
208%defattr(-,root,root,-)
209%{_libdir}/nautilus-sendto/plugins/libnstbluetooth.so
210%{_datadir}/GConf/gsettings/gnome-bluetooth-nst
211%{_datadir}/glib-2.0/schemas/org.gnome.Bluetooth.nst.gschema.xml
212
213
214%changelog
215* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
216- fix spec file
217
218* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
219- new upstream release
220
221* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
222- new upstream release
223- add BuildRequires: nautilus-sendto-devel
224- create nautilus-sendto-gnome-bluetooth package
225
226* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
227- new upstream release
228- remove BuildRequires: GConf2-devel
229
230* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
231- new upstream release
232
233* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
234- new upstream release
235
236* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
237- new upstream release
238
239* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
240- new upstream release
241
242* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
243- new upstream release
244- change BuildRequires: unique3-devel instead of unique-devel
245- add BuildRequires: control-center-devel
246
247* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
248- new upstream release
249- remove BuildRequires: gir-repository-devel
250- add Requires(post) and Requires(postun): desktop-file-utils
251
252* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
253- rebuild with rpm-4.8.1 for pkg-config file
254
255* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
256- new upstream release
257- add BuildRequires: gir-repository-devel
258- add configure option (--disable-nautilus-sendto)
259
260* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
261- new upstream release
262- merge spec file from FC package
263
264* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
265- Update to 0.11.0 (VineSeed)
266- added "# Maintainers: " comments.
267- changed UTF-8 encode at gnome-bluetooth.vsc.spec
268- FedoraCore - LOGS
269-- 0.11.0-5
270-- Rebuild against new bluez-libs
271-- 0.11.0-4
272-- Changed name of icon file(#444811)
273-- 0.11.0-3
274-- Remove gnome-obex-server, we should use gnome-user-share now
275-- 0.11.0-1
276-- gcc43 rebuild
277-- 0.11.0 - Update to 0.11.0
278-- 0.10.0 - Update to 0.10.0
279-- 0.9.1-4
280-- marked gnome-obex-server.schemas as config file
281-- changed upstream URL
282-- 0.9.1-3
283-- fixed wrong source URL
284-- 0.9.1-2
285-- rebuilt for F8
286-- changed license tag to GPLv2 and LGPLv2+
287-- 0.9.1-1
288-- Upgrade to 0.9.1 to fix a crasher in the server
289-- 0.9.0-1
290-- Update for 0.9.0
291-- Fix installation of the python bindings
292-- 0.8.0-4
293-- Remove unncessary gconfd killing from scripts (#224561)
294-- 0.8.0-3
295-- corrected BuildRoot
296-- smp flags added
297-- specfile cleanup
298-- fixed desktop file
299- Updated specfile
300
301* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
302- Updated specfile
303
304* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
305- Import gnome-bluetooth - Packager: Babasaki
306- Updated specfile (downgrade -> 0.8.0-0vl1)
307
308#----------------------------------------------------------------------------
309* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
310- version 0.8.0
311
312* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
313- rebuild
314
315* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
316- bump for new openobex
317
318* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
319- Missing automake, libtool, gettext BR
320
321* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
322- Bump for new libbluetooth
323
324* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
325- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
326
327* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
328- install schemata correctly (bug #193518)
329
330* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
331- more build requires (bug #193374)
332
333* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
334- pydir fixes for lib64
335
336* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
337- version 0.7.0
338
339* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
340- bump again for double-long bug on ppc(64)
341
342* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
343- rebuilt for new gcc4.1 snapshot and glibc changes
344
345* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
346- rebuilt
347
348* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
349- Fix relative path for the icons in desktop files which no longer works
350  with the icon cache.
351
352* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
353- new version 0.6.0
354
355* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
356- rebuild for new cairo
357
358* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
359- Minor spec file cleanups.
360- Fix relative path for the icons in desktop files which no longer works
361  with the icon cache.
362- Remove useless zero epochs.
363- Remove explicit python abi requirement, it's automatic for FC4 and up.
364
365* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
366- removed base requirement from libs
367
368* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
369- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
370
371* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
372- rebuilt
373
374* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
375- added gnome hbox patch for bug rh#149215
376
377* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
378- added requires for python-abi
379
380* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
381- split package into app, libs and devel
382
383* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
384- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
385
386* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
387- buildrequire pygtk2-devel (bug 135032)
388- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
389- fixed segfault on file receive (bug 133041)
390
391* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
392- buildrequire libbtctl-devel
393- buildrequire openobex-devel >= 1.0.1
394- pythondir -> pyexecdir
395
396* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
397- added build dependency for librsvg2-devel
398
399* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
400- added pydir patch
401
402* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
403- version 0.5.1
404
405* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
406- rebuilt
407
408* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
409- corrected BuildRequires
410
411* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
412- added EggToolBar patch for gcc34
413
414* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
415- rebuilt
416
417* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
418- rebuilt
419
420* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
421- added autofoo patch
422
423* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
424- add .so to gnome-vfs module, if libtool does not!
425
426* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
427- call libtool finish
428
429* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
430- new version 0.4.1
431
432* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
433- initial RPM
434
435
Note: See TracBrowser for help on using the repository browser.