source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 5038

Revision 5038, 12.1 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.1

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.2.1
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.2/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libbonobo-devel >= 2.32.0
19BuildRequires: libbonoboui-devel >= 2.24.4
20BuildRequires: GConf2-devel >= 2.32
21BuildRequires: hal-devel
22BuildRequires: unique3-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25BuildRequires: control-center-devel
26
27BuildRequires: intltool, automake, libtool, gettext
28Requires: %{name}-libs = %{version}-%{release}
29Requires(pre): GConf2
30Requires(post): GConf2
31Requires(preun): GConf2
32Requires: bluez >= 4.42
33Requires: obexd
34Requires(post): desktop-file-utils
35Requires(postun): desktop-file-utils
36ExcludeArch: s390 s390x
37
38## Patch1: gnome-bluetooth-0.8.0-desktop.patch
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: Takemikaduchi
43
44#----------------------------------------------------------------------------
45%description
46This package contains a library with widgets for Bluetooth applications.
47
48%description -l ja
49このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
50ライブラリが含まれます。
51
52#----------------------------------------------------------------------------
53%package libs
54Summary: Libraries for applications, which use gnome-bluetooth
55Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
56Group: Development/Libraries
57
58%description libs
59This package contains the libraries for applications,
60which use gnome-bluetooth.
61
62%description libs -l ja
63このパッケージには Gnome-bluetoothを使用するアプリケーション用の
64ライブラリが含まれています。
65
66#----------------------------------------------------------------------------
67%package devel
68Summary: Files for the development of applications, which use gnome-bluetooth
69Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
70Group:          Development/Libraries
71License:        LGPLv2+
72Requires:       %{name}-libs = %{version}-%{release}
73Requires:       gtk-doc pkgconfig
74Requires:       glib2-devel
75Requires:       libbtctl-devel
76
77
78%description devel
79This package contains the files for the development of applications,
80which will use gnome-bluetooth.
81
82%description devel -l ja
83このパッケージにはGnome-bluetoothを使用するアプリケーションを
84開発するためのヘッダーファイルなどが含まれています(develパッケージ)
85
86#----------------------------------------------------------------------------
87
88%prep
89%setup -q -n gnome-bluetooth-%{version}
90
91## %patch1 -p1 -b .dfix
92
93%build
94%configure \
95        --disable-desktop-update \
96        --disable-icon-update \
97        --disable-nautilus-sendto \
98        --enable-introspection=yes
99make %{?_smp_mflags}
100
101#----------------------------------------------------------------------------
102%install
103rm -rf $RPM_BUILD_ROOT
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make DESTDIR=$RPM_BUILD_ROOT install
106
107# we do not want .la files
108rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
109rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
110rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
111rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
112
113install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
114
115# Remove the gnome-obex-server
116# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
117
118%find_lang gnome-bluetooth2
119%find_lang %{name} --with-gnome
120cat %{name}.lang >> gnome-bluetooth2.lang
121
122# save space by linking identical images in translated docs
123helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
124for f in $helpdir/C/figures/*.png; do
125  b="$(basename $f)"
126  for d in $helpdir/*; do
127    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
128      g="$d/figures/$b"
129      if [ -f "$g" ]; then
130        if cmp -s $f $g; then
131          rm "$g"; ln -s "../../C/figures/$b" "$g"
132        fi
133      fi
134    fi
135  done
136done
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post
142update-desktop-database -q
143
144%postun
145update-desktop-database -q
146if [ $1 -eq 0 ] ; then
147        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
148        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
149fi
150
151%post libs
152/sbin/ldconfig
153touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
154
155%posttrans libs
156gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
157
158%postun libs
159/sbin/ldconfig
160if [ $1 -eq 0 ] ; then
161        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
162        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
163fi
164
165#----------------------------------------------------------------------------
166%files -f %{name}.lang
167%defattr(-, root, root)
168%doc README NEWS COPYING
169%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
170%{_bindir}/bluetooth-*
171%{_libdir}/gnome-bluetooth/
172%{_libdir}/control-center-1/panels/libbluetooth.so
173%{_datadir}/applications/*.desktop
174%{_datadir}/gnome-bluetooth/
175%{_datadir}/locale/*
176%{_mandir}/man1/*
177/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
178
179%files libs
180%defattr(-,root,root,-)
181%doc COPYING.LIB
182%{_libdir}/libgnome-bluetooth.so.*
183%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
184%{_datadir}/icons/hicolor/*/apps/*
185%{_datadir}/icons/hicolor/*/status/*
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/gnome-bluetooth/
190%{_libdir}/libgnome-bluetooth.so
191%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
192%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
193%{_datadir}/gtk-doc/html/gnome-bluetooth/
194
195#----------------------------------------------------------------------------
196%changelog
197* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
198- new upstream release
199
200* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
201- new upstream release
202
203* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
204- new upstream release
205
206* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
207- new upstream release
208- change BuildRequires: unique3-devel instead of unique-devel
209- add BuildRequires: control-center-devel
210
211* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
212- new upstream release
213- remove BuildRequires: gir-repository-devel
214- add Requires(post) and Requires(postun): desktop-file-utils
215
216* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
217- rebuild with rpm-4.8.1 for pkg-config file
218
219* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
220- new upstream release
221- add BuildRequires: gir-repository-devel
222- add configure option (--disable-nautilus-sendto)
223
224* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
225- new upstream release
226- merge spec file from FC package
227
228* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
229- Update to 0.11.0 (VineSeed)
230- added "# Maintainers: " comments.
231- changed UTF-8 encode at gnome-bluetooth.vsc.spec
232- FedoraCore - LOGS
233-- 0.11.0-5
234-- Rebuild against new bluez-libs
235-- 0.11.0-4
236-- Changed name of icon file(#444811)
237-- 0.11.0-3
238-- Remove gnome-obex-server, we should use gnome-user-share now
239-- 0.11.0-1
240-- gcc43 rebuild
241-- 0.11.0 - Update to 0.11.0
242-- 0.10.0 - Update to 0.10.0
243-- 0.9.1-4
244-- marked gnome-obex-server.schemas as config file
245-- changed upstream URL
246-- 0.9.1-3
247-- fixed wrong source URL
248-- 0.9.1-2
249-- rebuilt for F8
250-- changed license tag to GPLv2 and LGPLv2+
251-- 0.9.1-1
252-- Upgrade to 0.9.1 to fix a crasher in the server
253-- 0.9.0-1
254-- Update for 0.9.0
255-- Fix installation of the python bindings
256-- 0.8.0-4
257-- Remove unncessary gconfd killing from scripts (#224561)
258-- 0.8.0-3
259-- corrected BuildRoot
260-- smp flags added
261-- specfile cleanup
262-- fixed desktop file
263- Updated specfile
264
265* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
266- Updated specfile
267
268* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
269- Import gnome-bluetooth - Packager: Babasaki
270- Updated specfile (downgrade -> 0.8.0-0vl1)
271
272#----------------------------------------------------------------------------
273* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
274- version 0.8.0
275
276* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
277- rebuild
278
279* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
280- bump for new openobex
281
282* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
283- Missing automake, libtool, gettext BR
284
285* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
286- Bump for new libbluetooth
287
288* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
289- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
290
291* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
292- install schemata correctly (bug #193518)
293
294* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
295- more build requires (bug #193374)
296
297* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
298- pydir fixes for lib64
299
300* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
301- version 0.7.0
302
303* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
304- bump again for double-long bug on ppc(64)
305
306* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
307- rebuilt for new gcc4.1 snapshot and glibc changes
308
309* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
310- rebuilt
311
312* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
313- Fix relative path for the icons in desktop files which no longer works
314  with the icon cache.
315
316* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
317- new version 0.6.0
318
319* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
320- rebuild for new cairo
321
322* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
323- Minor spec file cleanups.
324- Fix relative path for the icons in desktop files which no longer works
325  with the icon cache.
326- Remove useless zero epochs.
327- Remove explicit python abi requirement, it's automatic for FC4 and up.
328
329* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
330- removed base requirement from libs
331
332* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
333- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
334
335* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
336- rebuilt
337
338* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
339- added gnome hbox patch for bug rh#149215
340
341* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
342- added requires for python-abi
343
344* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
345- split package into app, libs and devel
346
347* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
348- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
349
350* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
351- buildrequire pygtk2-devel (bug 135032)
352- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
353- fixed segfault on file receive (bug 133041)
354
355* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
356- buildrequire libbtctl-devel
357- buildrequire openobex-devel >= 1.0.1
358- pythondir -> pyexecdir
359
360* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
361- added build dependency for librsvg2-devel
362
363* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
364- added pydir patch
365
366* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
367- version 0.5.1
368
369* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
370- rebuilt
371
372* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
373- corrected BuildRequires
374
375* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
376- added EggToolBar patch for gcc34
377
378* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
379- rebuilt
380
381* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
382- rebuilt
383
384* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
385- added autofoo patch
386
387* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
388- add .so to gnome-vfs module, if libtool does not!
389
390* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
391- call libtool finish
392
393* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
394- new version 0.4.1
395
396* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
397- initial RPM
398
399
Note: See TracBrowser for help on using the repository browser.