source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 4850

Revision 4850, 12.1 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 3.2.0
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.2/%{name}-%{version}.tar.xz
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libbonobo-devel >= 2.32.0
19BuildRequires: libbonoboui-devel >= 2.24.4
20BuildRequires: GConf2-devel >= 2.32
21BuildRequires: hal-devel
22BuildRequires: unique3-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25BuildRequires: control-center-devel
26
27BuildRequires: intltool, automake, libtool, gettext
28Requires: %{name}-libs = %{version}-%{release}
29Requires(pre): GConf2
30Requires(post): GConf2
31Requires(preun): GConf2
32Requires: bluez >= 4.42
33Requires: obexd
34Requires(post): desktop-file-utils
35Requires(postun): desktop-file-utils
36ExcludeArch: s390 s390x
37
38## Patch1: gnome-bluetooth-0.8.0-desktop.patch
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: Takemikaduchi
43
44#----------------------------------------------------------------------------
45%description
46This package contains a library with widgets for Bluetooth applications.
47
48%description -l ja
49このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
50ライブラリが含まれます。
51
52#----------------------------------------------------------------------------
53%package libs
54Summary: Libraries for applications, which use gnome-bluetooth
55Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
56Group: Development/Libraries
57
58%description libs
59This package contains the libraries for applications,
60which use gnome-bluetooth.
61
62%description libs -l ja
63このパッケージには Gnome-bluetoothを使用するアプリケーション用の
64ライブラリが含まれています。
65
66#----------------------------------------------------------------------------
67%package devel
68Summary: Files for the development of applications, which use gnome-bluetooth
69Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
70Group:          Development/Libraries
71License:        LGPLv2+
72Requires:       %{name}-libs = %{version}-%{release}
73Requires:       gtk-doc pkgconfig
74Requires:       glib2-devel
75Requires:       libbtctl-devel
76
77
78%description devel
79This package contains the files for the development of applications,
80which will use gnome-bluetooth.
81
82%description devel -l ja
83このパッケージにはGnome-bluetoothを使用するアプリケーションを
84開発するためのヘッダーファイルなどが含まれています(develパッケージ)
85
86#----------------------------------------------------------------------------
87
88%prep
89%setup -q -n gnome-bluetooth-%{version}
90
91## %patch1 -p1 -b .dfix
92
93%build
94%configure \
95        --disable-desktop-update \
96        --disable-icon-update \
97        --disable-nautilus-sendto \
98        --enable-introspection=yes
99make %{?_smp_mflags}
100
101#----------------------------------------------------------------------------
102%install
103rm -rf $RPM_BUILD_ROOT
104export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105make DESTDIR=$RPM_BUILD_ROOT install
106
107# we do not want .la files
108rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
109rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
110rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
111rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
112
113install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
114
115# Remove the gnome-obex-server
116# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
117
118%find_lang gnome-bluetooth2
119%find_lang %{name} --with-gnome
120cat %{name}.lang >> gnome-bluetooth2.lang
121
122# save space by linking identical images in translated docs
123helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
124for f in $helpdir/C/figures/*.png; do
125  b="$(basename $f)"
126  for d in $helpdir/*; do
127    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
128      g="$d/figures/$b"
129      if [ -f "$g" ]; then
130        if cmp -s $f $g; then
131          rm "$g"; ln -s "../../C/figures/$b" "$g"
132        fi
133      fi
134    fi
135  done
136done
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post
142update-desktop-database -q
143
144%postun
145update-desktop-database -q
146if [ $1 -eq 0 ] ; then
147        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
148        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
149fi
150
151%post libs
152/sbin/ldconfig
153touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
154
155%posttrans libs
156gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
157
158%postun libs
159/sbin/ldconfig
160if [ $1 -eq 0 ] ; then
161        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
162        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
163fi
164
165#----------------------------------------------------------------------------
166%files -f %{name}.lang
167%defattr(-, root, root)
168%doc README NEWS COPYING
169%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
170%{_bindir}/bluetooth-*
171%{_libdir}/gnome-bluetooth/
172%{_libdir}/control-center-1/panels/libbluetooth.so
173%{_datadir}/applications/*.desktop
174%{_datadir}/gnome-bluetooth/
175%{_datadir}/locale/*
176%{_mandir}/man1/*
177/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
178
179%files libs
180%defattr(-,root,root,-)
181%doc COPYING.LIB
182%{_libdir}/libgnome-bluetooth.so.*
183%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
184%{_datadir}/icons/hicolor/*/apps/*
185%{_datadir}/icons/hicolor/*/status/*
186
187%files devel
188%defattr(-,root,root,-)
189%{_includedir}/gnome-bluetooth/
190%{_libdir}/libgnome-bluetooth.so
191%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
192%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
193%{_datadir}/gtk-doc/html/gnome-bluetooth/
194
195#----------------------------------------------------------------------------
196%changelog
197* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
198- new upstream release
199
200* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
201- new upstream release
202
203* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
204- new upstream release
205- change BuildRequires: unique3-devel instead of unique-devel
206- add BuildRequires: control-center-devel
207
208* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
209- new upstream release
210- remove BuildRequires: gir-repository-devel
211- add Requires(post) and Requires(postun): desktop-file-utils
212
213* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
214- rebuild with rpm-4.8.1 for pkg-config file
215
216* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
217- new upstream release
218- add BuildRequires: gir-repository-devel
219- add configure option (--disable-nautilus-sendto)
220
221* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
222- new upstream release
223- merge spec file from FC package
224
225* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
226- Update to 0.11.0 (VineSeed)
227- added "# Maintainers: " comments.
228- changed UTF-8 encode at gnome-bluetooth.vsc.spec
229- FedoraCore - LOGS
230-- 0.11.0-5
231-- Rebuild against new bluez-libs
232-- 0.11.0-4
233-- Changed name of icon file(#444811)
234-- 0.11.0-3
235-- Remove gnome-obex-server, we should use gnome-user-share now
236-- 0.11.0-1
237-- gcc43 rebuild
238-- 0.11.0 - Update to 0.11.0
239-- 0.10.0 - Update to 0.10.0
240-- 0.9.1-4
241-- marked gnome-obex-server.schemas as config file
242-- changed upstream URL
243-- 0.9.1-3
244-- fixed wrong source URL
245-- 0.9.1-2
246-- rebuilt for F8
247-- changed license tag to GPLv2 and LGPLv2+
248-- 0.9.1-1
249-- Upgrade to 0.9.1 to fix a crasher in the server
250-- 0.9.0-1
251-- Update for 0.9.0
252-- Fix installation of the python bindings
253-- 0.8.0-4
254-- Remove unncessary gconfd killing from scripts (#224561)
255-- 0.8.0-3
256-- corrected BuildRoot
257-- smp flags added
258-- specfile cleanup
259-- fixed desktop file
260- Updated specfile
261
262* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
263- Updated specfile
264
265* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
266- Import gnome-bluetooth - Packager: Babasaki
267- Updated specfile (downgrade -> 0.8.0-0vl1)
268
269#----------------------------------------------------------------------------
270* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
271- version 0.8.0
272
273* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
274- rebuild
275
276* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
277- bump for new openobex
278
279* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
280- Missing automake, libtool, gettext BR
281
282* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
283- Bump for new libbluetooth
284
285* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
286- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
287
288* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
289- install schemata correctly (bug #193518)
290
291* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
292- more build requires (bug #193374)
293
294* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
295- pydir fixes for lib64
296
297* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
298- version 0.7.0
299
300* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
301- bump again for double-long bug on ppc(64)
302
303* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
304- rebuilt for new gcc4.1 snapshot and glibc changes
305
306* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
307- rebuilt
308
309* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
310- Fix relative path for the icons in desktop files which no longer works
311  with the icon cache.
312
313* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
314- new version 0.6.0
315
316* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
317- rebuild for new cairo
318
319* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
320- Minor spec file cleanups.
321- Fix relative path for the icons in desktop files which no longer works
322  with the icon cache.
323- Remove useless zero epochs.
324- Remove explicit python abi requirement, it's automatic for FC4 and up.
325
326* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
327- removed base requirement from libs
328
329* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
330- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
331
332* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
333- rebuilt
334
335* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
336- added gnome hbox patch for bug rh#149215
337
338* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
339- added requires for python-abi
340
341* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
342- split package into app, libs and devel
343
344* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
345- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
346
347* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
348- buildrequire pygtk2-devel (bug 135032)
349- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
350- fixed segfault on file receive (bug 133041)
351
352* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
353- buildrequire libbtctl-devel
354- buildrequire openobex-devel >= 1.0.1
355- pythondir -> pyexecdir
356
357* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
358- added build dependency for librsvg2-devel
359
360* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
361- added pydir patch
362
363* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
364- version 0.5.1
365
366* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
367- rebuilt
368
369* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
370- corrected BuildRequires
371
372* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
373- added EggToolBar patch for gcc34
374
375* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
376- rebuilt
377
378* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
379- rebuilt
380
381* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
382- added autofoo patch
383
384* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
385- add .so to gnome-vfs module, if libtool does not!
386
387* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
388- call libtool finish
389
390* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
391- new version 0.4.1
392
393* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
394- initial RPM
395
396
Note: See TracBrowser for help on using the repository browser.