source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 894

Revision 894, 13.1 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file for gnome-2.30

Line 
1Summary: GNOME Bluetooth Subsystem
2Summary(ja): GNOME Bluetooth サブシステム
3Name: gnome-bluetooth
4Version: 2.30.0
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://live.gnome.org/GnomeBluetooth
9Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/0.11/%{name}-%{version}.tar.bz2
10Source1: 61-gnome-bluetooth-rfkill.rules
11#----------------------------------------------------------------------------
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14#----------------------------------------------------------------------------
15#BuildRequires: autoconf >= 2.57
16BuildRequires: bluez-libs-devel >= 2.8
17#BuildRequires: bluez-utils
18BuildRequires: libgnomeui-devel >= 2.2
19BuildRequires: libbonobo-devel >= 2.0
20BuildRequires: GConf2-devel >= 2.0
21BuildRequires: hal-devel
22BuildRequires: unique-devel
23BuildRequires: libnotify-devel
24BuildRequires: gnome-doc-utils
25BuildRequires: gir-repository-devel
26
27BuildRequires: intltool, automake, libtool, gettext
28Requires: %{name}-libs = %{version}-%{release}
29Requires(pre): GConf2
30Requires(post): GConf2
31Requires(preun): GConf2
32Requires: bluez >= 4.42
33Requires: obexd
34ExcludeArch: s390 s390x
35
36## Patch1: gnome-bluetooth-0.8.0-desktop.patch
37
38#----------------------------------------------------------------------------
39%description
40This package contains a library with widgets for Bluetooth applications.
41
42%description -l ja
43このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
44ライブラリが含まれます。
45
46#----------------------------------------------------------------------------
47%package libs
48Summary: Libraries for applications, which use gnome-bluetooth
49Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
50Group: Development/Libraries
51
52%description libs
53This package contains the libraries for applications,
54which use gnome-bluetooth.
55
56%description libs -l ja
57このパッケージには Gnome-bluetoothを使用するアプリケーション用の
58ライブラリが含まれています。
59
60#----------------------------------------------------------------------------
61%package devel
62Summary: Files for the development of applications, which use gnome-bluetooth
63Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
64Group:          Development/Libraries
65License:        LGPLv2+
66Requires:       %{name}-libs = %{version}-%{release}
67Requires:       gtk-doc pkgconfig
68Requires:       glib2-devel
69Requires:       libbtctl-devel
70
71
72%description devel
73This package contains the files for the development of applications,
74which will use gnome-bluetooth.
75
76%description devel -l ja
77このパッケージにはGnome-bluetoothを使用するアプリケーションを
78開発するためのヘッダーファイルなどが含まれています(develパッケージ)
79
80#----------------------------------------------------------------------------
81
82%prep
83%setup -q -n gnome-bluetooth-%{version}
84
85## %patch1 -p1 -b .dfix
86
87%build
88%configure --disable-desktop-update --disable-icon-update --disable-nautilus-sendto
89make %{?_smp_mflags}
90
91#----------------------------------------------------------------------------
92%install
93rm -rf $RPM_BUILD_ROOT
94export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
95make DESTDIR=$RPM_BUILD_ROOT install
96
97# we do not want .la files
98rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
99rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
100rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
101rm -f $RPM_BUILD_ROOT/%{_libdir}/nautilus-sendto/plugins/*.la
102
103install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
104
105# Remove the gnome-obex-server
106# rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
107
108%find_lang gnome-bluetooth2
109%find_lang %{name} --with-gnome
110cat %{name}.lang >> gnome-bluetooth2.lang
111
112# save space by linking identical images in translated docs
113helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
114for f in $helpdir/C/figures/*.png; do
115  b="$(basename $f)"
116  for d in $helpdir/*; do
117    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
118      g="$d/figures/$b"
119      if [ -f "$g" ]; then
120        if cmp -s $f $g; then
121          rm "$g"; ln -s "../../C/figures/$b" "$g"
122        fi
123      fi
124    fi
125  done
126done
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%pre
132#if [ "$1" -gt 1 ]; then
133#    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
134#    if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
135#      gconftool-2 --makefile-uninstall-rule \
136#        %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
137#    fi
138#fi
139if [ "$1" -gt 1 ]; then
140        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
141        if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
142                gconftool-2 --makefile-uninstall-rule \
143                %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
144        fi
145        if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
146                gconftool-2 --makefile-uninstall-rule                           \
147                %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
148                >& /dev/null || :
149        fi
150fi
151
152%post
153scrollkeeper-update -q
154export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
155gconftool-2 --makefile-install-rule                                     \
156        %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
157        >& /dev/null || :
158
159%preun
160#if [ "$1" -eq 0 ]; then
161#    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
162#    if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
163#      gconftool-2 --makefile-uninstall-rule \
164#        %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
165#    fi
166#fi
167if [ "$1" -eq 0 ]; then
168        export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
169        if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
170                gconftool-2 --makefile-uninstall-rule \
171                %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
172        fi
173        if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
174                gconftool-2 --makefile-uninstall-rule                           \
175                %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
176                >& /dev/null || :
177        fi
178fi
179
180%postun
181scrollkeeper-update -q
182if [ $1 -eq 0 ] ; then
183        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
184        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
185fi
186
187%post libs
188/sbin/ldconfig
189touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
190
191%posttrans libs
192gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
193
194%postun libs
195/sbin/ldconfig
196if [ $1 -eq 0 ] ; then
197        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
198        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
199fi
200
201#----------------------------------------------------------------------------
202%files -f %{name}.lang
203%defattr(-, root, root)
204%doc README NEWS COPYING
205%{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas
206%{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
207%{_bindir}/bluetooth-*
208%{_libdir}/gnome-bluetooth/
209%{_datadir}/applications/*.desktop
210%{_datadir}/gnome-bluetooth/
211%{_datadir}/locale/*
212%{_mandir}/man1/*
213/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
214
215%files libs
216%defattr(-,root,root,-)
217%doc COPYING.LIB
218%{_libdir}/libgnome-bluetooth.so.*
219%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
220%{_datadir}/icons/hicolor/*/apps/*
221%{_datadir}/icons/hicolor/*/status/*
222
223%files devel
224%defattr(-,root,root,-)
225%{_includedir}/gnome-bluetooth/
226%{_libdir}/libgnome-bluetooth.so
227%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
228%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
229%{_datadir}/gtk-doc/html/gnome-bluetooth/
230
231#----------------------------------------------------------------------------
232# Maintainers: babasaki@mindgear.org
233#
234#----------------------------------------------------------------------------
235%changelog
236* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
237- new upstream release
238- add BuildRequires: gir-repository-devel
239- add configure option (--disable-nautilus-sendto)
240
241* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
242- new upstream release
243- merge spec file from FC package
244
245* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
246- Update to 0.11.0 (VineSeed)
247- added "# Maintainers: " comments.
248- changed UTF-8 encode at gnome-bluetooth.vsc.spec
249- FedoraCore - LOGS
250-- 0.11.0-5
251-- Rebuild against new bluez-libs
252-- 0.11.0-4
253-- Changed name of icon file(#444811)
254-- 0.11.0-3
255-- Remove gnome-obex-server, we should use gnome-user-share now
256-- 0.11.0-1
257-- gcc43 rebuild
258-- 0.11.0 - Update to 0.11.0
259-- 0.10.0 - Update to 0.10.0
260-- 0.9.1-4
261-- marked gnome-obex-server.schemas as config file
262-- changed upstream URL
263-- 0.9.1-3
264-- fixed wrong source URL
265-- 0.9.1-2
266-- rebuilt for F8
267-- changed license tag to GPLv2 and LGPLv2+
268-- 0.9.1-1
269-- Upgrade to 0.9.1 to fix a crasher in the server
270-- 0.9.0-1
271-- Update for 0.9.0
272-- Fix installation of the python bindings
273-- 0.8.0-4
274-- Remove unncessary gconfd killing from scripts (#224561)
275-- 0.8.0-3
276-- corrected BuildRoot
277-- smp flags added
278-- specfile cleanup
279-- fixed desktop file
280- Updated specfile
281
282* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
283- Updated specfile
284
285* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
286- Import gnome-bluetooth - Packager: Babasaki
287- Updated specfile (downgrade -> 0.8.0-0vl1)
288
289#----------------------------------------------------------------------------
290* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
291- version 0.8.0
292
293* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
294- rebuild
295
296* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
297- bump for new openobex
298
299* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
300- Missing automake, libtool, gettext BR
301
302* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
303- Bump for new libbluetooth
304
305* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
306- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
307
308* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
309- install schemata correctly (bug #193518)
310
311* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
312- more build requires (bug #193374)
313
314* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
315- pydir fixes for lib64
316
317* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
318- version 0.7.0
319
320* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
321- bump again for double-long bug on ppc(64)
322
323* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
324- rebuilt for new gcc4.1 snapshot and glibc changes
325
326* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
327- rebuilt
328
329* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
330- Fix relative path for the icons in desktop files which no longer works
331  with the icon cache.
332
333* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
334- new version 0.6.0
335
336* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
337- rebuild for new cairo
338
339* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
340- Minor spec file cleanups.
341- Fix relative path for the icons in desktop files which no longer works
342  with the icon cache.
343- Remove useless zero epochs.
344- Remove explicit python abi requirement, it's automatic for FC4 and up.
345
346* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
347- removed base requirement from libs
348
349* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
350- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
351
352* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
353- rebuilt
354
355* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
356- added gnome hbox patch for bug rh#149215
357
358* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
359- added requires for python-abi
360
361* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
362- split package into app, libs and devel
363
364* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
365- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
366
367* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
368- buildrequire pygtk2-devel (bug 135032)
369- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
370- fixed segfault on file receive (bug 133041)
371
372* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
373- buildrequire libbtctl-devel
374- buildrequire openobex-devel >= 1.0.1
375- pythondir -> pyexecdir
376
377* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
378- added build dependency for librsvg2-devel
379
380* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
381- added pydir patch
382
383* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
384- version 0.5.1
385
386* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
387- rebuilt
388
389* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
390- corrected BuildRequires
391
392* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
393- added EggToolBar patch for gcc34
394
395* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
396- rebuilt
397
398* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
399- rebuilt
400
401* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
402- added autofoo patch
403
404* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
405- add .so to gnome-vfs module, if libtool does not!
406
407* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
408- call libtool finish
409
410* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
411- new version 0.4.1
412
413* Wed Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
414- initial RPM
415
416
Note: See TracBrowser for help on using the repository browser.