source: projects/specs/trunk/g/gnome-bluetooth/gnome-bluetooth-vl.spec @ 12005

Revision 12005, 12.3 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define _unpackaged_files_terminate_build 1
2%global _vpath_srcdir .
3%global _vpath_builddir build
4%global __global_cflags %{optflags}
5%global __global_ldflags ""
6
7Summary: GNOME Bluetooth Subsystem
8Summary(ja): GNOME Bluetooth サブシステム
9Name: gnome-bluetooth
10Version: 3.28.2
11Release: 1%{?_dist_release}
12License: GPLv2+
13Group: System Environment/Libraries
14URL: http://live.gnome.org/GnomeBluetooth
15Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.20/%{name}-%{version}.tar.xz
16Source1: 61-gnome-bluetooth-rfkill.rules
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: meson
21BuildRequires: bluez-libs-devel >= 2.8
22BuildRequires: libbonobo-devel >= 2.32.0
23BuildRequires: libbonoboui-devel >= 2.24.4
24BuildRequires: unique3-devel
25BuildRequires: libnotify-devel
26BuildRequires: eudev-libudev-devel
27BuildRequires: libcanberra-gtk3-devel
28BuildRequires: gnome-doc-utils
29BuildRequires: intltool, automake, libtool, gettext
30BuildRequires: itstool
31
32Requires: %{name}-libs = %{version}-%{release}
33Requires: bluez >= 4.42
34Requires: obexd
35Requires(post): desktop-file-utils
36Requires(postun): desktop-file-utils
37ExcludeArch: s390 s390x
38
39Obsoletes: bluez-gnome < 1.9
40Obsoletes: nautilus-sendto-gnome-bluetooth < 3.7
41
42# virtual package
43Provides:       dbus-bluez-pin-helper
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48
49%description
50This package contains a library with widgets for Bluetooth applications.
51
52%description -l ja
53このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
54ライブラリが含まれます。
55
56
57%package libs
58Summary: Libraries for applications, which use gnome-bluetooth
59Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
60Group: Development/Libraries
61
62%description libs
63This package contains the libraries for applications,
64which use gnome-bluetooth.
65
66%description libs -l ja
67このパッケージには Gnome-bluetoothを使用するアプリケーション用の
68ライブラリが含まれています。
69
70
71%package devel
72Summary: Files for the development of applications, which use gnome-bluetooth
73Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
74Group:          Development/Libraries
75License:        LGPLv2+
76Requires:       %{name}-libs = %{version}-%{release}
77Requires:       pkgconfig
78Requires:       gtk3-devel
79
80%description devel
81This package contains the files for the development of applications,
82which will use gnome-bluetooth.
83
84%description devel -l ja
85このパッケージにはGnome-bluetoothを使用するアプリケーションを
86開発するためのヘッダーファイルなどが含まれています(develパッケージ)
87
88
89%prep
90%setup -q -n gnome-bluetooth-%{version}
91
92
93%build
94%meson \
95  -Dicon_update=false \
96  -Dgtk_doc=true
97%meson_build
98
99%install
100rm -rf $RPM_BUILD_ROOT
101%meson_install
102
103install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
104
105%find_lang gnome-bluetooth2
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110
111%post
112update-desktop-database -q
113
114%postun
115update-desktop-database -q
116if [ $1 -eq 0 ] ; then
117        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
118        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
119fi
120
121
122%post libs
123/sbin/ldconfig
124touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
125
126%posttrans libs
127gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
128
129%postun libs
130/sbin/ldconfig
131if [ $1 -eq 0 ] ; then
132        touch --no-create %{_datadir}/icons/hicolor &>/dev/null
133        gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
134fi
135
136
137%files -f gnome-bluetooth2.lang
138%defattr(-, root, root)
139%doc README NEWS COPYING
140%{_bindir}/bluetooth-*
141%{_datadir}/applications/*.desktop
142%{_datadir}/gnome-bluetooth/
143%{_mandir}/man1/*
144/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
145
146%files libs
147%defattr(-,root,root,-)
148%doc COPYING.LIB
149%{_libdir}/libgnome-bluetooth.so.*
150%{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
151%{_datadir}/icons/hicolor/*/apps/*
152%{_datadir}/icons/hicolor/*/status/*
153
154%files devel
155%defattr(-,root,root,-)
156%{_includedir}/gnome-bluetooth/
157%{_libdir}/libgnome-bluetooth.so
158%{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
159%{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
160%{_datadir}/gtk-doc/html/gnome-bluetooth/
161
162
163%changelog
164* Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.28.2-1
165- new upstream release.
166
167* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
168- new upstream release
169
170* Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
171- new upstream release
172
173* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
174- new upstream release
175
176* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.0-1
177- new upstream release
178- add BuildRequires: libcanberra-gtk3-devel
179
180* Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
181- new upstream release
182
183* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
184- new upstream release
185
186* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
187- new upstream release
188- add BuildRequires: eudev-libudev-devel
189
190* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-2
191- rebuild with VineSeed environment
192
193* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
194- new upstream release
195
196* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
197- new upstream release
198
199* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
200- new upstream release
201- remove BuildRequires: nautilus-sendto-devel
202
203* Fri Nov 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
204- new upstream release
205
206* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
207- new upstream release
208- add Obsoletes: bluez-gnome < 1.9
209- add BuildRequires: itstool
210
211* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
212- fix spec file
213
214* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
215- new upstream release
216
217* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
218- new upstream release
219- add BuildRequires: nautilus-sendto-devel
220- create nautilus-sendto-gnome-bluetooth package
221
222* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
223- new upstream release
224- remove BuildRequires: GConf2-devel
225
226* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
227- new upstream release
228
229* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
230- new upstream release
231
232* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
233- new upstream release
234
235* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
236- new upstream release
237
238* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
239- new upstream release
240- change BuildRequires: unique3-devel instead of unique-devel
241- add BuildRequires: control-center-devel
242
243* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
244- new upstream release
245- remove BuildRequires: gir-repository-devel
246- add Requires(post) and Requires(postun): desktop-file-utils
247
248* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
249- rebuild with rpm-4.8.1 for pkg-config file
250
251* Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
252- new upstream release
253- add BuildRequires: gir-repository-devel
254- add configure option (--disable-nautilus-sendto)
255
256* Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
257- new upstream release
258- merge spec file from FC package
259
260* Fri Oct 24  2008 Seiichirou Babasaki 0.11.0-6
261- Update to 0.11.0 (VineSeed)
262- added "# Maintainers: " comments.
263- changed UTF-8 encode at gnome-bluetooth.vsc.spec
264- FedoraCore - LOGS
265-- 0.11.0-5
266-- Rebuild against new bluez-libs
267-- 0.11.0-4
268-- Changed name of icon file(#444811)
269-- 0.11.0-3
270-- Remove gnome-obex-server, we should use gnome-user-share now
271-- 0.11.0-1
272-- gcc43 rebuild
273-- 0.11.0 - Update to 0.11.0
274-- 0.10.0 - Update to 0.10.0
275-- 0.9.1-4
276-- marked gnome-obex-server.schemas as config file
277-- changed upstream URL
278-- 0.9.1-3
279-- fixed wrong source URL
280-- 0.9.1-2
281-- rebuilt for F8
282-- changed license tag to GPLv2 and LGPLv2+
283-- 0.9.1-1
284-- Upgrade to 0.9.1 to fix a crasher in the server
285-- 0.9.0-1
286-- Update for 0.9.0
287-- Fix installation of the python bindings
288-- 0.8.0-4
289-- Remove unncessary gconfd killing from scripts (#224561)
290-- 0.8.0-3
291-- corrected BuildRoot
292-- smp flags added
293-- specfile cleanup
294-- fixed desktop file
295- Updated specfile
296
297* Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
298- Updated specfile
299
300* Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
301- Import gnome-bluetooth - Packager: Babasaki
302- Updated specfile (downgrade -> 0.8.0-0vl1)
303
304#----------------------------------------------------------------------------
305* Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
306- version 0.8.0
307
308* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
309- rebuild
310
311* Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
312- bump for new openobex
313
314* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
315- Missing automake, libtool, gettext BR
316
317* Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
318- Bump for new libbluetooth
319
320* Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
321- add dependency on bluez-utils, cosmetic tweaks (bug #190280)
322
323* Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
324- install schemata correctly (bug #193518)
325
326* Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
327- more build requires (bug #193374)
328
329* Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
330- pydir fixes for lib64
331
332* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
333- version 0.7.0
334
335* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
336- bump again for double-long bug on ppc(64)
337
338* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
339- rebuilt for new gcc4.1 snapshot and glibc changes
340
341* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
342- rebuilt
343
344* Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
345- Fix relative path for the icons in desktop files which no longer works
346  with the icon cache.
347
348* Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
349- new version 0.6.0
350
351* Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
352- rebuild for new cairo
353
354* Thu Jul  7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
355- Minor spec file cleanups.
356- Fix relative path for the icons in desktop files which no longer works
357  with the icon cache.
358- Remove useless zero epochs.
359- Remove explicit python abi requirement, it's automatic for FC4 and up.
360
361* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
362- removed base requirement from libs
363
364* Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
365- devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
366
367* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
368- rebuilt
369
370* Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
371- added gnome hbox patch for bug rh#149215
372
373* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
374- added requires for python-abi
375
376* Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
377- split package into app, libs and devel
378
379* Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
380- fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
381
382* Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
383- buildrequire pygtk2-devel (bug 135032)
384- fixed gnome-bluetooth-manager script for 64bit (bug 134864)
385- fixed segfault on file receive (bug 133041)
386
387* Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
388- buildrequire libbtctl-devel
389- buildrequire openobex-devel >= 1.0.1
390- pythondir -> pyexecdir
391
392* Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
393- added build dependency for librsvg2-devel
394
395* Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
396- added pydir patch
397
398* Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
399- version 0.5.1
400
401* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
402- rebuilt
403
404* Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
405- corrected BuildRequires
406
407* Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
408- added EggToolBar patch for gcc34
409
410* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
411- rebuilt
412
413* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
414- rebuilt
415
416* Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
417- added autofoo patch
418
419* Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
420- add .so to gnome-vfs module, if libtool does not!
421
422* Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
423- call libtool finish
424
425* Wed Aug  6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
426- new version 0.4.1
427
428* Thu Jun  5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
429- initial RPM
430
431
Note: See TracBrowser for help on using the repository browser.