source: projects/specs/trunk/g/gnome-applets/gnome-applets-vl.spec @ 12159

Revision 12159, 16.1 KB checked in by tomop, 5 years ago (diff)

gnome-applets-3.30.0-3

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%define glib2_version 2.44.0
4%define pango_version 1.38.0
5%define gtk3_version 3.15.2
6%define libgnome_version 2.32.0
7%define gnome_panel_version 3.18.0
8%define libgtop2_version 2.40.0
9%define gnome_desktop3_version 3.18.0
10%define libxklavier_version 5.0
11%define libwnck3_version 3.0.0
12%define gnome_doc_utils_version 0.3.2
13%define libgnomekbd_version 3.4.0
14%define libgweather_version 3.17.1
15%define dbus_version 1.4.16
16%define dbus_glib_version 0.96
17%define libnotify_version 0.7.4
18%define adwaita_icon_theme_version 3.14.0
19%define gucharmap_version 3.2.0
20
21%define po_package gnome-applets-3.0
22
23
24Summary:        Small applications for the GNOME panel.
25Summary(ja):    GNOME パネル用の小さなアプリケーション(GNOMEパネルアプレット)
26Name:           gnome-applets
27Version:        3.30.0
28Release:        3%{?_dist_release}
29License:        GPL
30Group:          User Interface/Desktops
31URL:            http://www.gnome.org/
32
33%define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
34Source:         http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{major_minor}/%{name}-%{version}.tar.xz
35Source10:       cpufreq-selector.app
36Source11:       cpufreq-selector.pam
37
38BuildRoot:      %{_tmppath}/%{name}-%{version}-root
39
40BuildRequires:  gnome-common
41BuildRequires:  glib2-devel >= %{glib2_version}
42BuildRequires:  gtk3-devel >= %{gtk3_version}
43BuildRequires:  libgnome-devel >= %{libgnome_version}
44BuildRequires:  gnome-panel-devel >= %{gnome_panel_version}
45BuildRequires:  libgtop2-devel >= %{libgtop2_version}
46BuildRequires:  pango-devel >= %{pango_version}
47BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
48BuildRequires:  gnome-settings-daemon-devel
49BuildRequires:  libxklavier-devel >= %{libxklavier_version}
50BuildRequires:  libwnck3-devel >= %{libwnck3_version}
51BuildRequires:  gnome-doc-utils >= %{gnome_doc_utils_version}
52BuildRequires:  libgnomekbd-devel >= %{libgnomekbd_version}
53BuildRequires:  libnotify-devel >= %{libnotify_version}
54BuildRequires:  dbus-devel >= %{dbus_version}
55BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
56BuildRequires:  xorg-x11-proto-devel
57# for patch 39
58BuildRequires:  NetworkManager-libnm-devel
59BuildRequires:  libgweather-devel >= %{libgweather_version}
60# For cpufreq
61BuildRequires:  dbus-devel
62BuildRequires:  polkit-devel
63BuildRequires:  adwaita-icon-theme >= %{adwaita_icon_theme_version}
64BuildRequires:  gucharmap-devel >= %{gucharmap_version}
65BuildRequires:  libSM-devel
66BuildRequires:  python3-devel
67BuildRequires:  python3-pygobject
68BuildRequires:  pygobject3-devel
69BuildRequires:  upower-devel
70BuildRequires:  tracker-devel
71BuildRequires:  yelp-tools
72
73Requires(posttrans,postun):     glib2
74Requires(posttrans,postun):     gtk2
75Requires:       gnome-panel >= %{gnome_panel_version}
76Requires:       gnome-desktop3 >= %{gnome_desktop3_version}
77Requires:       libxklavier >= %{libxklavier_version}
78Requires:       libwnck3 >= %{libwnck3_version}
79Requires:       polkit-gnome
80Obsoletes:      battstat_applet
81
82Vendor: Project Vine
83Distribution: Vine Linux
84
85%description
86GNOME (GNU Network Object Model Environment) is a user-friendly set of
87applications and desktop tools to be used in conjunction with a window
88manager for the X Window System. The gnome-applets package provides
89small utilities for the GNOME panel.
90
91%prep
92%setup -q
93
94%build
95autoreconf -if
96%configure \
97       --disable-static \
98           --enable-mini-commander
99%__make %{?_smp_mflags}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103make install DESTDIR=$RPM_BUILD_ROOT
104
105%find_lang %{po_package} --all-name --with-gnome
106
107# remove unpackaged files
108find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
109
110# drop non-XKB support files
111rm -rf $RPM_BUILD_ROOT%{_datadir}/xmodmap
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117
118%postun
119/sbin/ldconfig
120if [ $1 -eq 0 ]; then
121  touch --no-create %{_datadir}/icons/hicolor
122  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
123  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
124fi
125
126%posttrans
127touch --no-create %{_datadir}/icons/hicolor
128gtk-update-icon-cache -q %{_datadir}/icons/hicolor
129glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
130
131
132%files -f %{po_package}.lang
133%defattr(-, root, root)
134%license COPYING
135%doc AUTHORS ChangeLog NEWS README
136%{_libdir}/%{name}/*.so
137%dir %{_sysconfdir}/sound
138%dir %{_sysconfdir}/sound/events
139%{_sysconfdir}/sound/events/*
140%{_datadir}/glib-2.0/schemas/org.gnome.gnome-applets.*.xml
141%dir %{_datadir}/gnome-panel
142%dir %{_datadir}/gnome-panel/applets
143%{_datadir}/gnome-panel/applets/*.panel-applet
144%{_datadir}/%{name}
145%{_datadir}/icons/hicolor/*/*/*
146%{_datadir}/pixmaps/*
147
148%changelog
149* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-3
150- rebuilt with NM-1.20.0 and tracker-2.2.2.
151
152* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-2
153- rebuilt with libgtop2-2.40.0.
154
155* Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
156- new upstream release.
157
158* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
159- new upstream release
160
161* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.0-1
162- new upstream release
163- change BuildRequires: adwaita-icon-theme instead of gnome-icon-theme
164- add BuildRequires: python3-devel, python3-pygobject, pygobject3-devel, upower-devel, tracker-devel, yelp-tools
165- remove old patches
166
167* Sun Sep 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.91-1
168- new upstream release
169- remove BuildRequires: libgweather-devel
170
171* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
172- new upstream release
173
174* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
175- remove BuildRequires: gnome-python-applets, gnome-python-devel
176- remove Requires: gnome-python-applets, gnome-python-libegg
177
178* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
179- new upstream release
180- add BuildRequires: gnome-settings-daemon-devel
181
182* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
183- new upstream release
184
185* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
186- new upstream release
187- change BuildRequires: polkit-devel instead of polkit-gnome-devel
188
189* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
190- new upstream release
191
192* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
193- new upstream release
194
195* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
196- new upstream release
197- add BuildRequires: pygtk2-devel
198
199* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1.1-1
200- new upstream release
201
202* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
203- new upstream release
204- change BuildRequires: gnome-panel-devel instead of gnome-panel
205- fix %files
206
207* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
208- new upstream release
209- drop Patch31
210- remove BuildRequires: hal-devel
211- remove Requires: hal
212- add BuildRequires: gnome-icons-theme, gucharmap-devel, libSM-devel
213
214* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.0-2
215- rebuilt with python-2.6.4-3
216
217* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
218- new upstream release
219- added BR: polkit-gnome-devel (instead of PolicyKit-gnome-devel)
220
221* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
222- new upstream release
223
224* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
225- new upstream release
226
227* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
228- new upstream release
229
230* Tue Mar 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.0-3
231- use builtin copy of apmlib instead of adding an external dependency
232  (from RH bugzilla #155125)
233
234* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
235- fix %%pre/%%post/%%preun scripts
236  - mixer applet is removed.
237
238* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
239- new upstream release
240
241* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
242- new upstream release
243
244* Tue Oct 14 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.24.0.1-3
245- removed BuildRequires: gail-devel
246- fixed typo at %%define gnome_python_version
247
248* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 2.24.0.1-2
249- built with gucharmap-2.24.0
250
251* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
252- new upstream release
253
254* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
255- new upstream release
256
257* Tue Jul 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
258- new upstream release
259
260* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
261- new upstream release
262- added BuildRequires: libgweather-devel
263
264* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
265- new upstream release
266
267* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
268- new upstream release
269
270* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
271- new upstream release
272
273* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
274- new upstream release
275
276* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
277- new upstream release
278
279* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
280- new upstream release
281
282* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.90-0vl1
283- new upstream release
284
285* Fri Dec 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl1
286- new upstream release
287- drop obsolete patch0
288
289* Sun Oct 16 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.1-0vl2
290- add BuildRequires:
291  - gnome-desktop-devel, libxklavier-devel, libwnck-devel, gnome-doc-utils,
292    system-tools-backends, libxml2-python, hal-devel, gstreamer-plugins-devel
293- add Requires:
294  - gnome-desktop-libs, libxklavier, libwnck, hal, gstreamer-plugins
295- add patch0 to fix mixer2 applet
296  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=316922
297
298* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
299- new upstream release
300
301* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
302- new upstream release
303
304* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
305- new upstream release
306
307* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
308- new upstream release
309
310* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl3
311- rebuild
312
313* Wed Apr 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
314- fixed %%post script
315
316* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
317- new upstream release
318
319* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
320- new upstream version
321
322* Sat Feb 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
323- new upstream release
324- fixed %post section
325
326* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1.1-0vl1
327- new upstream release
328
329* Mon Nov  8 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl3
330- rebuild with libgtop2-2.8.1
331
332* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
333- rebuild with openssl-0.9.7d
334
335* Fri Oct  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
336- new upstream release
337- dropped Source10
338
339* Fri Oct  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-0vl1
340- new upstream release
341
342* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
343- new upstream release
344
345* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
346- new upstream release
347
348* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
349- new upstream release
350
351* Tue May 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
352- new upstream release
353
354* Tue Jan 28 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.0-0vl3
355- clause BuildRequires: apmd  with %%ifnarch %%{no_apm_archs}
356
357* Mon Jan 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
358- disable panelmenu again
359- update ja.po
360
361* Mon Jan 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
362- new upstream release
363- remove obsolete patch
364- clean up specs.
365
366* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
367- new upstream release
368
369* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
370- build for Vine Linux
371- new upstream release from gnome-2.1.4
372
373* Tue Aug 27 2002 Owen Taylor <otaylor@redhat.com>
374- Register the cd player per-device (#72645).
375
376* Fri Aug 23 2002 Owen Taylor <otaylor@redhat.com>
377- Keep the CD device closed except when actually accessing it
378  (bugzilla.gnome.org 91512)
379- Register CD player so we can start only one CD player
380  for display from magicdev. (#39208)
381
382* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
383- add ppc ppc64 to no_apm_arches #67564
384
385* Wed Jul 31 2002 Nalin Dahyabhai <nalin@redhat.com>
386- include applets in libexecdir
387
388* Mon Jul 29 2002 Havoc Pennington <hp@redhat.com>
389- 2.0.1, and build with new gail
390- 69971 (use correct ppp on/off commands)
391- remove scrollkeeper dtd-compliance patch,
392  fixed upstream apparently (patch doesn't apply anymore)
393
394* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
395- Fix %%find_lang
396
397* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
398- rebuild with new libs
399- remove temporary hack for too-old libgnomeui
400- add /etc/sound stuff to file list
401
402* Thu Jun 13 2002 Nalin Dahyabhai <nalin@redhat.com>
403- rebuild in different environment
404
405* Thu Jun 13 2002 Nalin Dahyabhai <nalin@redhat.com>
406- fix a scrollkeeper validation bug
407
408* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
409- remove panel-menu.schemas from the list of schemas.
410- 2.0.0
411
412* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
413- rebuild in different environment
414
415* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
416- 1.105.0
417
418* Sun May 26 2002 Tim Powers <timp@redhat.com>
419- automated rebuild
420
421* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
422- rebuild in different environment
423
424* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
425- 1.103.0
426
427* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
428- 1.100.0
429
430* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
431- GNOME 2 version
432
433* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
434- merge translations
435
436* Thu Apr 11 2002 Havoc Pennington <hp@redhat.com>
437- default battstat applet to vertical mode
438
439* Thu Mar 21 2002 Havoc Pennington <hp@redhat.com>
440- add patch to adapt to yahoo web site changes, #61561
441
442* Tue Mar  5 2002 Havoc Pennington <hp@redhat.com>
443- remove requires libghttp4
444
445* Mon Mar  4 2002 Havoc Pennington <hp@redhat.com>
446- no apm on sparc, #60538
447- obsolete battstat_applet for Ximian compat, #51427
448- use ifup/ifdown ppp0 instead of pppon/pppoff for default
449  ppp command in modemlights, #54199
450
451* Tue Feb 12 2002 Havoc Pennington <hp@redhat.com>
452- 1.4.0.5, cross fingers
453- add gconf-devel buildreq, though this is dubious as hell
454  (pulled in by gtik using gnome-vfs, but if gtik actually
455   accessed gconf it would fail due to gnorba conflict)
456- patch totally busted charpick Makefile.am cflags override
457
458* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
459- automake14
460
461* Thu Aug 30 2001 Alex Larsson <alexl@redhat.com>
462- Removed annoying broken battery full dialog #52861
463- Also fix mixer applet for USB sound #52603
464
465* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
466- Add po files from sources.redhat.com
467
468* Wed Aug 15 2001 Alexander Larsson <alexl@redhat.com>
469- Own /usr/share/gnome/gkb and /usr/share/gnome/help/*
470
471* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
472- add some build requires
473- remove ifarch build requires, replace with check in setup
474
475* Wed Jul 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
476- sanitize specfile to RH style
477- do not require apmd for s390 s390x
478
479* Mon Jul  9 2001 Jonathan Blandford <jrb@redhat.com>
480- new version
481
482* Sun Jul 08 2001 Havoc Pennington <hp@redhat.com>
483- remove extra .desktop file for battstat
484
485* Sat Jul 07 2001 Havoc Pennington <hp@redhat.com>
486- add battstat applet
487- rearrange .desktop files for applets
488
489* Tue Jun 12 2001 Than Ngo <than@redhat.com>
490- fix isdn stuff to build against kernel-2.4.x
491- use %%{_tmppath}
492
493* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
494- allow newer gettext versions
495
496* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
497- translations
498
499* Mon Feb 12 2001 Akira TAGOH <tagoh@redhat.com>
500- Updated Japanese translation (ja.po, .desktop).
501  Note: Please remove Source[23]: when release the next upstream version.
502
503* Fri Jan 19 2001 Havoc Pennington <hp@redhat.com>
504- 1.2.4
505
506* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
507- Update Epoch
508
509* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
510- Change slashapp to gnome-news app.
511
512* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
513- automatic rebuild
514
515* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com
516- %%defattr fixes
517- Remove Docdir:
518
519* Thu Jun 15 2000 Havoc Pennington <hp@redhat.com>
520- 1.2.1
521- use %%makeinstall
Note: See TracBrowser for help on using the repository browser.