source: projects/specs/trunk/g/gnome-applets/gnome-applets-vl.spec @ 12111

Revision 12111, 16.0 KB checked in by tomop, 5 years ago (diff)

gnome-applets-3.30.0-2

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%define glib2_version 2.44.0
4%define pango_version 1.38.0
5%define gtk3_version 3.15.2
6%define libgnome_version 2.32.0
7%define gnome_panel_version 3.18.0
8%define libgtop2_version 2.40.0
9%define gnome_desktop3_version 3.18.0
10%define libxklavier_version 5.0
11%define libwnck3_version 3.0.0
12%define gnome_doc_utils_version 0.3.2
13%define libgnomekbd_version 3.4.0
14%define libgweather_version 3.17.1
15%define dbus_version 1.4.16
16%define dbus_glib_version 0.96
17%define libnotify_version 0.7.4
18%define adwaita_icon_theme_version 3.14.0
19%define gucharmap_version 3.2.0
20
21%define po_package gnome-applets-3.0
22
23
24Summary:        Small applications for the GNOME panel.
25Summary(ja):    GNOME パネル用の小さなアプリケーション(GNOMEパネルアプレット)
26Name:           gnome-applets
27Version:        3.30.0
28Release:        2%{?_dist_release}
29License:        GPL
30Group:          User Interface/Desktops
31URL:            http://www.gnome.org/
32
33Source:         http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.18/%{name}-%{version}.tar.xz
34Source10:       cpufreq-selector.app
35Source11:       cpufreq-selector.pam
36
37BuildRoot:      %{_tmppath}/%{name}-%{version}-root
38
39BuildRequires:  gnome-common
40BuildRequires:  glib2-devel >= %{glib2_version}
41BuildRequires:  gtk3-devel >= %{gtk3_version}
42BuildRequires:  libgnome-devel >= %{libgnome_version}
43BuildRequires:  gnome-panel-devel >= %{gnome_panel_version}
44BuildRequires:  libgtop2-devel >= %{libgtop2_version}
45BuildRequires:  pango-devel >= %{pango_version}
46BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
47BuildRequires:  gnome-settings-daemon-devel
48BuildRequires:  libxklavier-devel >= %{libxklavier_version}
49BuildRequires:  libwnck3-devel >= %{libwnck3_version}
50BuildRequires:  gnome-doc-utils >= %{gnome_doc_utils_version}
51BuildRequires:  libgnomekbd-devel >= %{libgnomekbd_version}
52BuildRequires:  libnotify-devel >= %{libnotify_version}
53BuildRequires:  dbus-devel >= %{dbus_version}
54BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
55BuildRequires:  xorg-x11-proto-devel
56# for patch 39
57BuildRequires:  NetworkManager-devel
58BuildRequires:  libgweather-devel >= %{libgweather_version}
59# For cpufreq
60BuildRequires:  dbus-devel
61BuildRequires:  polkit-devel
62BuildRequires:  adwaita-icon-theme >= %{adwaita_icon_theme_version}
63BuildRequires:  gucharmap-devel >= %{gucharmap_version}
64BuildRequires:  libSM-devel
65BuildRequires:  python3-devel
66BuildRequires:  python3-pygobject
67BuildRequires:  pygobject3-devel
68BuildRequires:  upower-devel
69BuildRequires:  tracker-devel
70BuildRequires:  yelp-tools
71
72Requires(posttrans,postun):     glib2
73Requires(posttrans,postun):     gtk2
74Requires:       gnome-panel >= %{gnome_panel_version}
75Requires:       gnome-desktop3 >= %{gnome_desktop3_version}
76Requires:       libxklavier >= %{libxklavier_version}
77Requires:       libwnck3 >= %{libwnck3_version}
78Requires:       polkit-gnome
79Obsoletes:      battstat_applet
80
81Vendor: Project Vine
82Distribution: Vine Linux
83
84%description
85GNOME (GNU Network Object Model Environment) is a user-friendly set of
86applications and desktop tools to be used in conjunction with a window
87manager for the X Window System. The gnome-applets package provides
88small utilities for the GNOME panel.
89
90%prep
91%setup -q
92
93%build
94autoreconf -if
95%configure \
96       --disable-static \
97           --enable-mini-commander
98%__make %{?_smp_mflags}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install DESTDIR=$RPM_BUILD_ROOT
103
104%find_lang %{po_package} --all-name --with-gnome
105
106# remove unpackaged files
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
108
109# drop non-XKB support files
110rm -rf $RPM_BUILD_ROOT%{_datadir}/xmodmap
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116
117%postun
118/sbin/ldconfig
119if [ $1 -eq 0 ]; then
120  touch --no-create %{_datadir}/icons/hicolor
121  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
122  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
123fi
124
125%posttrans
126touch --no-create %{_datadir}/icons/hicolor
127gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
129
130
131%files -f %{po_package}.lang
132%defattr(-, root, root)
133%license COPYING
134%doc AUTHORS ChangeLog NEWS README
135%{_libdir}/%{name}/*.so
136%dir %{_sysconfdir}/sound
137%dir %{_sysconfdir}/sound/events
138%{_sysconfdir}/sound/events/*
139%{_datadir}/glib-2.0/schemas/org.gnome.gnome-applets.*.xml
140%dir %{_datadir}/gnome-panel
141%dir %{_datadir}/gnome-panel/applets
142%{_datadir}/gnome-panel/applets/*.panel-applet
143%{_datadir}/%{name}
144%{_datadir}/icons/hicolor/*/*/*
145%{_datadir}/pixmaps/*
146
147%changelog
148* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-2
149- rebuilt with libgtop2-2.40.0.
150
151* Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
152- new upstream release.
153
154* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
155- new upstream release
156
157* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.0-1
158- new upstream release
159- change BuildRequires: adwaita-icon-theme instead of gnome-icon-theme
160- add BuildRequires: python3-devel, python3-pygobject, pygobject3-devel, upower-devel, tracker-devel, yelp-tools
161- remove old patches
162
163* Sun Sep 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.91-1
164- new upstream release
165- remove BuildRequires: libgweather-devel
166
167* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
168- new upstream release
169
170* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
171- remove BuildRequires: gnome-python-applets, gnome-python-devel
172- remove Requires: gnome-python-applets, gnome-python-libegg
173
174* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
175- new upstream release
176- add BuildRequires: gnome-settings-daemon-devel
177
178* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
179- new upstream release
180
181* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
182- new upstream release
183- change BuildRequires: polkit-devel instead of polkit-gnome-devel
184
185* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
186- new upstream release
187
188* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
189- new upstream release
190
191* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
192- new upstream release
193- add BuildRequires: pygtk2-devel
194
195* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1.1-1
196- new upstream release
197
198* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
199- new upstream release
200- change BuildRequires: gnome-panel-devel instead of gnome-panel
201- fix %files
202
203* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
204- new upstream release
205- drop Patch31
206- remove BuildRequires: hal-devel
207- remove Requires: hal
208- add BuildRequires: gnome-icons-theme, gucharmap-devel, libSM-devel
209
210* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.0-2
211- rebuilt with python-2.6.4-3
212
213* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
214- new upstream release
215- added BR: polkit-gnome-devel (instead of PolicyKit-gnome-devel)
216
217* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
218- new upstream release
219
220* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
221- new upstream release
222
223* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
224- new upstream release
225
226* Tue Mar 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.0-3
227- use builtin copy of apmlib instead of adding an external dependency
228  (from RH bugzilla #155125)
229
230* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
231- fix %%pre/%%post/%%preun scripts
232  - mixer applet is removed.
233
234* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
235- new upstream release
236
237* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
238- new upstream release
239
240* Tue Oct 14 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.24.0.1-3
241- removed BuildRequires: gail-devel
242- fixed typo at %%define gnome_python_version
243
244* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 2.24.0.1-2
245- built with gucharmap-2.24.0
246
247* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
248- new upstream release
249
250* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
251- new upstream release
252
253* Tue Jul 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
254- new upstream release
255
256* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
257- new upstream release
258- added BuildRequires: libgweather-devel
259
260* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
261- new upstream release
262
263* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
264- new upstream release
265
266* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
267- new upstream release
268
269* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
270- new upstream release
271
272* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
273- new upstream release
274
275* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
276- new upstream release
277
278* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.90-0vl1
279- new upstream release
280
281* Fri Dec 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl1
282- new upstream release
283- drop obsolete patch0
284
285* Sun Oct 16 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.1-0vl2
286- add BuildRequires:
287  - gnome-desktop-devel, libxklavier-devel, libwnck-devel, gnome-doc-utils,
288    system-tools-backends, libxml2-python, hal-devel, gstreamer-plugins-devel
289- add Requires:
290  - gnome-desktop-libs, libxklavier, libwnck, hal, gstreamer-plugins
291- add patch0 to fix mixer2 applet
292  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=316922
293
294* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
295- new upstream release
296
297* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
298- new upstream release
299
300* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
301- new upstream release
302
303* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
304- new upstream release
305
306* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl3
307- rebuild
308
309* Wed Apr 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
310- fixed %%post script
311
312* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
313- new upstream release
314
315* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
316- new upstream version
317
318* Sat Feb 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
319- new upstream release
320- fixed %post section
321
322* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1.1-0vl1
323- new upstream release
324
325* Mon Nov  8 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl3
326- rebuild with libgtop2-2.8.1
327
328* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
329- rebuild with openssl-0.9.7d
330
331* Fri Oct  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
332- new upstream release
333- dropped Source10
334
335* Fri Oct  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-0vl1
336- new upstream release
337
338* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
339- new upstream release
340
341* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
342- new upstream release
343
344* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
345- new upstream release
346
347* Tue May 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
348- new upstream release
349
350* Tue Jan 28 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.0-0vl3
351- clause BuildRequires: apmd  with %%ifnarch %%{no_apm_archs}
352
353* Mon Jan 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
354- disable panelmenu again
355- update ja.po
356
357* Mon Jan 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
358- new upstream release
359- remove obsolete patch
360- clean up specs.
361
362* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
363- new upstream release
364
365* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
366- build for Vine Linux
367- new upstream release from gnome-2.1.4
368
369* Tue Aug 27 2002 Owen Taylor <otaylor@redhat.com>
370- Register the cd player per-device (#72645).
371
372* Fri Aug 23 2002 Owen Taylor <otaylor@redhat.com>
373- Keep the CD device closed except when actually accessing it
374  (bugzilla.gnome.org 91512)
375- Register CD player so we can start only one CD player
376  for display from magicdev. (#39208)
377
378* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
379- add ppc ppc64 to no_apm_arches #67564
380
381* Wed Jul 31 2002 Nalin Dahyabhai <nalin@redhat.com>
382- include applets in libexecdir
383
384* Mon Jul 29 2002 Havoc Pennington <hp@redhat.com>
385- 2.0.1, and build with new gail
386- 69971 (use correct ppp on/off commands)
387- remove scrollkeeper dtd-compliance patch,
388  fixed upstream apparently (patch doesn't apply anymore)
389
390* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
391- Fix %%find_lang
392
393* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
394- rebuild with new libs
395- remove temporary hack for too-old libgnomeui
396- add /etc/sound stuff to file list
397
398* Thu Jun 13 2002 Nalin Dahyabhai <nalin@redhat.com>
399- rebuild in different environment
400
401* Thu Jun 13 2002 Nalin Dahyabhai <nalin@redhat.com>
402- fix a scrollkeeper validation bug
403
404* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
405- remove panel-menu.schemas from the list of schemas.
406- 2.0.0
407
408* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
409- rebuild in different environment
410
411* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
412- 1.105.0
413
414* Sun May 26 2002 Tim Powers <timp@redhat.com>
415- automated rebuild
416
417* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
418- rebuild in different environment
419
420* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
421- 1.103.0
422
423* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
424- 1.100.0
425
426* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
427- GNOME 2 version
428
429* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
430- merge translations
431
432* Thu Apr 11 2002 Havoc Pennington <hp@redhat.com>
433- default battstat applet to vertical mode
434
435* Thu Mar 21 2002 Havoc Pennington <hp@redhat.com>
436- add patch to adapt to yahoo web site changes, #61561
437
438* Tue Mar  5 2002 Havoc Pennington <hp@redhat.com>
439- remove requires libghttp4
440
441* Mon Mar  4 2002 Havoc Pennington <hp@redhat.com>
442- no apm on sparc, #60538
443- obsolete battstat_applet for Ximian compat, #51427
444- use ifup/ifdown ppp0 instead of pppon/pppoff for default
445  ppp command in modemlights, #54199
446
447* Tue Feb 12 2002 Havoc Pennington <hp@redhat.com>
448- 1.4.0.5, cross fingers
449- add gconf-devel buildreq, though this is dubious as hell
450  (pulled in by gtik using gnome-vfs, but if gtik actually
451   accessed gconf it would fail due to gnorba conflict)
452- patch totally busted charpick Makefile.am cflags override
453
454* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
455- automake14
456
457* Thu Aug 30 2001 Alex Larsson <alexl@redhat.com>
458- Removed annoying broken battery full dialog #52861
459- Also fix mixer applet for USB sound #52603
460
461* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
462- Add po files from sources.redhat.com
463
464* Wed Aug 15 2001 Alexander Larsson <alexl@redhat.com>
465- Own /usr/share/gnome/gkb and /usr/share/gnome/help/*
466
467* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
468- add some build requires
469- remove ifarch build requires, replace with check in setup
470
471* Wed Jul 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
472- sanitize specfile to RH style
473- do not require apmd for s390 s390x
474
475* Mon Jul  9 2001 Jonathan Blandford <jrb@redhat.com>
476- new version
477
478* Sun Jul 08 2001 Havoc Pennington <hp@redhat.com>
479- remove extra .desktop file for battstat
480
481* Sat Jul 07 2001 Havoc Pennington <hp@redhat.com>
482- add battstat applet
483- rearrange .desktop files for applets
484
485* Tue Jun 12 2001 Than Ngo <than@redhat.com>
486- fix isdn stuff to build against kernel-2.4.x
487- use %%{_tmppath}
488
489* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
490- allow newer gettext versions
491
492* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
493- translations
494
495* Mon Feb 12 2001 Akira TAGOH <tagoh@redhat.com>
496- Updated Japanese translation (ja.po, .desktop).
497  Note: Please remove Source[23]: when release the next upstream version.
498
499* Fri Jan 19 2001 Havoc Pennington <hp@redhat.com>
500- 1.2.4
501
502* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
503- Update Epoch
504
505* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
506- Change slashapp to gnome-news app.
507
508* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
509- automatic rebuild
510
511* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com
512- %%defattr fixes
513- Remove Docdir:
514
515* Thu Jun 15 2000 Havoc Pennington <hp@redhat.com>
516- 1.2.1
517- use %%makeinstall
Note: See TracBrowser for help on using the repository browser.