source: projects/specs/trunk/g/gnome-applets/gnome-applets-vl.spec @ 12005

Revision 12005, 15.9 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%define glib2_version 2.44.0
4%define pango_version 1.38.0
5%define gtk3_version 3.15.2
6%define libgnome_version 2.32.0
7%define gnome_panel_version 3.18.0
8%define libgtop2_version 2.11.92
9%define gnome_desktop3_version 3.18.0
10%define libxklavier_version 5.0
11%define libwnck3_version 3.0.0
12%define gnome_doc_utils_version 0.3.2
13%define libgnomekbd_version 3.4.0
14%define libgweather_version 3.17.1
15%define dbus_version 1.4.16
16%define dbus_glib_version 0.96
17%define libnotify_version 0.7.4
18%define adwaita_icon_theme_version 3.14.0
19%define gucharmap_version 3.2.0
20
21%define po_package gnome-applets-3.0
22
23
24Summary:        Small applications for the GNOME panel.
25Summary(ja):    GNOME パネル用の小さなアプリケーション(GNOMEパネルアプレット)
26Name:           gnome-applets
27Version:        3.30.0
28Release:        1%{?_dist_release}
29License:        GPL
30Group:          User Interface/Desktops
31URL:            http://www.gnome.org/
32
33Source:         http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.18/%{name}-%{version}.tar.xz
34Source10:       cpufreq-selector.app
35Source11:       cpufreq-selector.pam
36
37BuildRoot:      %{_tmppath}/%{name}-%{version}-root
38
39BuildRequires:  gnome-common
40BuildRequires:  glib2-devel >= %{glib2_version}
41BuildRequires:  gtk3-devel >= %{gtk3_version}
42BuildRequires:  libgnome-devel >= %{libgnome_version}
43BuildRequires:  gnome-panel-devel >= %{gnome_panel_version}
44BuildRequires:  libgtop2-devel >= %{libgtop2_version}
45BuildRequires:  pango-devel >= %{pango_version}
46BuildRequires:  gnome-desktop3-devel >= %{gnome_desktop3_version}
47BuildRequires:  gnome-settings-daemon-devel
48BuildRequires:  libxklavier-devel >= %{libxklavier_version}
49BuildRequires:  libwnck3-devel >= %{libwnck3_version}
50BuildRequires:  gnome-doc-utils >= %{gnome_doc_utils_version}
51BuildRequires:  libgnomekbd-devel >= %{libgnomekbd_version}
52BuildRequires:  libnotify-devel >= %{libnotify_version}
53BuildRequires:  dbus-devel >= %{dbus_version}
54BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
55BuildRequires:  xorg-x11-proto-devel
56# for patch 39
57BuildRequires:  NetworkManager-devel
58BuildRequires:  libgweather-devel >= %{libgweather_version}
59# For cpufreq
60BuildRequires:  dbus-devel
61BuildRequires:  polkit-devel
62BuildRequires:  adwaita-icon-theme >= %{adwaita_icon_theme_version}
63BuildRequires:  gucharmap-devel >= %{gucharmap_version}
64BuildRequires:  libSM-devel
65BuildRequires:  python3-devel
66BuildRequires:  python3-pygobject
67BuildRequires:  pygobject3-devel
68BuildRequires:  upower-devel
69BuildRequires:  tracker-devel
70BuildRequires:  yelp-tools
71
72Requires(posttrans,postun):     glib2
73Requires(posttrans,postun):     gtk2
74Requires:       gnome-panel >= %{gnome_panel_version}
75Requires:       gnome-desktop3 >= %{gnome_desktop3_version}
76Requires:       libxklavier >= %{libxklavier_version}
77Requires:       libwnck3 >= %{libwnck3_version}
78Requires:       polkit-gnome
79Obsoletes:      battstat_applet
80
81Vendor: Project Vine
82Distribution: Vine Linux
83
84%description
85GNOME (GNU Network Object Model Environment) is a user-friendly set of
86applications and desktop tools to be used in conjunction with a window
87manager for the X Window System. The gnome-applets package provides
88small utilities for the GNOME panel.
89
90%prep
91%setup -q
92
93%build
94autoreconf -if
95%configure \
96       --disable-static \
97           --enable-mini-commander
98%__make %{?_smp_mflags}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install DESTDIR=$RPM_BUILD_ROOT
103
104%find_lang %{po_package} --all-name --with-gnome
105
106# remove unpackaged files
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
108
109# drop non-XKB support files
110rm -rf $RPM_BUILD_ROOT%{_datadir}/xmodmap
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116
117%postun
118/sbin/ldconfig
119if [ $1 -eq 0 ]; then
120  touch --no-create %{_datadir}/icons/hicolor
121  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
122  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
123fi
124
125%posttrans
126touch --no-create %{_datadir}/icons/hicolor
127gtk-update-icon-cache -q %{_datadir}/icons/hicolor
128glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
129
130
131%files -f %{po_package}.lang
132%defattr(-, root, root)
133%license COPYING
134%doc AUTHORS ChangeLog NEWS README
135%{_libdir}/%{name}/*.so
136%dir %{_sysconfdir}/sound
137%dir %{_sysconfdir}/sound/events
138%{_sysconfdir}/sound/events/*
139%{_datadir}/glib-2.0/schemas/org.gnome.gnome-applets.*.xml
140%dir %{_datadir}/gnome-panel
141%dir %{_datadir}/gnome-panel/applets
142%{_datadir}/gnome-panel/applets/*.panel-applet
143%{_datadir}/%{name}
144%{_datadir}/icons/hicolor/*/*/*
145%{_datadir}/pixmaps/*
146
147%changelog
148* Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
149- new upstream release.
150
151* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
152- new upstream release
153
154* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.0-1
155- new upstream release
156- change BuildRequires: adwaita-icon-theme instead of gnome-icon-theme
157- add BuildRequires: python3-devel, python3-pygobject, pygobject3-devel, upower-devel, tracker-devel, yelp-tools
158- remove old patches
159
160* Sun Sep 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.91-1
161- new upstream release
162- remove BuildRequires: libgweather-devel
163
164* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
165- new upstream release
166
167* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
168- remove BuildRequires: gnome-python-applets, gnome-python-devel
169- remove Requires: gnome-python-applets, gnome-python-libegg
170
171* Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
172- new upstream release
173- add BuildRequires: gnome-settings-daemon-devel
174
175* Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
176- new upstream release
177
178* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
179- new upstream release
180- change BuildRequires: polkit-devel instead of polkit-gnome-devel
181
182* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
183- new upstream release
184
185* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
186- new upstream release
187
188* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
189- new upstream release
190- add BuildRequires: pygtk2-devel
191
192* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1.1-1
193- new upstream release
194
195* Mon Oct 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
196- new upstream release
197- change BuildRequires: gnome-panel-devel instead of gnome-panel
198- fix %files
199
200* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
201- new upstream release
202- drop Patch31
203- remove BuildRequires: hal-devel
204- remove Requires: hal
205- add BuildRequires: gnome-icons-theme, gucharmap-devel, libSM-devel
206
207* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.0-2
208- rebuilt with python-2.6.4-3
209
210* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
211- new upstream release
212- added BR: polkit-gnome-devel (instead of PolicyKit-gnome-devel)
213
214* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
215- new upstream release
216
217* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
218- new upstream release
219
220* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
221- new upstream release
222
223* Tue Mar 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.0-3
224- use builtin copy of apmlib instead of adding an external dependency
225  (from RH bugzilla #155125)
226
227* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
228- fix %%pre/%%post/%%preun scripts
229  - mixer applet is removed.
230
231* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
232- new upstream release
233
234* Tue Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
235- new upstream release
236
237* Tue Oct 14 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.24.0.1-3
238- removed BuildRequires: gail-devel
239- fixed typo at %%define gnome_python_version
240
241* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 2.24.0.1-2
242- built with gucharmap-2.24.0
243
244* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
245- new upstream release
246
247* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
248- new upstream release
249
250* Tue Jul 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
251- new upstream release
252
253* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
254- new upstream release
255- added BuildRequires: libgweather-devel
256
257* Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
258- new upstream release
259
260* Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
261- new upstream release
262
263* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
264- new upstream release
265
266* Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
267- new upstream release
268
269* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
270- new upstream release
271
272* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
273- new upstream release
274
275* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.90-0vl1
276- new upstream release
277
278* Fri Dec 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.2-0vl1
279- new upstream release
280- drop obsolete patch0
281
282* Sun Oct 16 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.12.1-0vl2
283- add BuildRequires:
284  - gnome-desktop-devel, libxklavier-devel, libwnck-devel, gnome-doc-utils,
285    system-tools-backends, libxml2-python, hal-devel, gstreamer-plugins-devel
286- add Requires:
287  - gnome-desktop-libs, libxklavier, libwnck, hal, gstreamer-plugins
288- add patch0 to fix mixer2 applet
289  - cf. http://bugzilla.gnome.org/show_bug.cgi?id=316922
290
291* Thu Oct 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
292- new upstream release
293
294* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
295- new upstream release
296
297* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.91-0vl1
298- new upstream release
299
300* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
301- new upstream release
302
303* Fri Jul 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl3
304- rebuild
305
306* Wed Apr 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl2
307- fixed %%post script
308
309* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
310- new upstream release
311
312* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
313- new upstream version
314
315* Sat Feb 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
316- new upstream release
317- fixed %post section
318
319* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1.1-0vl1
320- new upstream release
321
322* Mon Nov  8 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl3
323- rebuild with libgtop2-2.8.1
324
325* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
326- rebuild with openssl-0.9.7d
327
328* Fri Oct  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
329- new upstream release
330- dropped Source10
331
332* Fri Oct  3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-0vl1
333- new upstream release
334
335* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
336- new upstream release
337
338* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
339- new upstream release
340
341* Wed Jun 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
342- new upstream release
343
344* Tue May 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
345- new upstream release
346
347* Tue Jan 28 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.0-0vl3
348- clause BuildRequires: apmd  with %%ifnarch %%{no_apm_archs}
349
350* Mon Jan 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl2
351- disable panelmenu again
352- update ja.po
353
354* Mon Jan 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
355- new upstream release
356- remove obsolete patch
357- clean up specs.
358
359* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
360- new upstream release
361
362* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-0vl1
363- build for Vine Linux
364- new upstream release from gnome-2.1.4
365
366* Tue Aug 27 2002 Owen Taylor <otaylor@redhat.com>
367- Register the cd player per-device (#72645).
368
369* Fri Aug 23 2002 Owen Taylor <otaylor@redhat.com>
370- Keep the CD device closed except when actually accessing it
371  (bugzilla.gnome.org 91512)
372- Register CD player so we can start only one CD player
373  for display from magicdev. (#39208)
374
375* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
376- add ppc ppc64 to no_apm_arches #67564
377
378* Wed Jul 31 2002 Nalin Dahyabhai <nalin@redhat.com>
379- include applets in libexecdir
380
381* Mon Jul 29 2002 Havoc Pennington <hp@redhat.com>
382- 2.0.1, and build with new gail
383- 69971 (use correct ppp on/off commands)
384- remove scrollkeeper dtd-compliance patch,
385  fixed upstream apparently (patch doesn't apply anymore)
386
387* Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
388- Fix %%find_lang
389
390* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
391- rebuild with new libs
392- remove temporary hack for too-old libgnomeui
393- add /etc/sound stuff to file list
394
395* Thu Jun 13 2002 Nalin Dahyabhai <nalin@redhat.com>
396- rebuild in different environment
397
398* Thu Jun 13 2002 Nalin Dahyabhai <nalin@redhat.com>
399- fix a scrollkeeper validation bug
400
401* Wed Jun 12 2002 Havoc Pennington <hp@redhat.com>
402- remove panel-menu.schemas from the list of schemas.
403- 2.0.0
404
405* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
406- rebuild in different environment
407
408* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
409- 1.105.0
410
411* Sun May 26 2002 Tim Powers <timp@redhat.com>
412- automated rebuild
413
414* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
415- rebuild in different environment
416
417* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
418- 1.103.0
419
420* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
421- 1.100.0
422
423* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
424- GNOME 2 version
425
426* Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
427- merge translations
428
429* Thu Apr 11 2002 Havoc Pennington <hp@redhat.com>
430- default battstat applet to vertical mode
431
432* Thu Mar 21 2002 Havoc Pennington <hp@redhat.com>
433- add patch to adapt to yahoo web site changes, #61561
434
435* Tue Mar  5 2002 Havoc Pennington <hp@redhat.com>
436- remove requires libghttp4
437
438* Mon Mar  4 2002 Havoc Pennington <hp@redhat.com>
439- no apm on sparc, #60538
440- obsolete battstat_applet for Ximian compat, #51427
441- use ifup/ifdown ppp0 instead of pppon/pppoff for default
442  ppp command in modemlights, #54199
443
444* Tue Feb 12 2002 Havoc Pennington <hp@redhat.com>
445- 1.4.0.5, cross fingers
446- add gconf-devel buildreq, though this is dubious as hell
447  (pulled in by gtik using gnome-vfs, but if gtik actually
448   accessed gconf it would fail due to gnorba conflict)
449- patch totally busted charpick Makefile.am cflags override
450
451* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
452- automake14
453
454* Thu Aug 30 2001 Alex Larsson <alexl@redhat.com>
455- Removed annoying broken battery full dialog #52861
456- Also fix mixer applet for USB sound #52603
457
458* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
459- Add po files from sources.redhat.com
460
461* Wed Aug 15 2001 Alexander Larsson <alexl@redhat.com>
462- Own /usr/share/gnome/gkb and /usr/share/gnome/help/*
463
464* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
465- add some build requires
466- remove ifarch build requires, replace with check in setup
467
468* Wed Jul 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
469- sanitize specfile to RH style
470- do not require apmd for s390 s390x
471
472* Mon Jul  9 2001 Jonathan Blandford <jrb@redhat.com>
473- new version
474
475* Sun Jul 08 2001 Havoc Pennington <hp@redhat.com>
476- remove extra .desktop file for battstat
477
478* Sat Jul 07 2001 Havoc Pennington <hp@redhat.com>
479- add battstat applet
480- rearrange .desktop files for applets
481
482* Tue Jun 12 2001 Than Ngo <than@redhat.com>
483- fix isdn stuff to build against kernel-2.4.x
484- use %%{_tmppath}
485
486* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
487- allow newer gettext versions
488
489* Thu Mar 15 2001 Havoc Pennington <hp@redhat.com>
490- translations
491
492* Mon Feb 12 2001 Akira TAGOH <tagoh@redhat.com>
493- Updated Japanese translation (ja.po, .desktop).
494  Note: Please remove Source[23]: when release the next upstream version.
495
496* Fri Jan 19 2001 Havoc Pennington <hp@redhat.com>
497- 1.2.4
498
499* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
500- Update Epoch
501
502* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
503- Change slashapp to gnome-news app.
504
505* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
506- automatic rebuild
507
508* Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com
509- %%defattr fixes
510- Remove Docdir:
511
512* Thu Jun 15 2000 Havoc Pennington <hp@redhat.com>
513- 1.2.1
514- use %%makeinstall
Note: See TracBrowser for help on using the repository browser.