source: projects/specs/trunk/g/gnokii/gnokii-vl.spec @ 4632

Revision 4632, 15.3 KB checked in by Takemikaduchi, 13 years ago (diff)

colord,gnokii,gnome-phone-manager: new upstream release, others: rebuild with evolution-data-server-3.1.4

Line 
1# TODO: merge patches upstream where applicable
2
3Name:           gnokii
4Version:        0.6.30
5Release:        1%{?_dist_release}
6Summary:        Linux/Unix tool suite for various mobile phones
7Summary(ja): Linux/Unix tool suite for various mobile phones
8
9Group:          Applications/Communications
10License:        GPLv2+
11URL:            http://www.gnokii.org/
12Source0:        http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
13#----------------------------------------------------------------------------
14
15Source2:        gnokii-smsd.init
16Source3:        gnokii-smsd.sysconfig
17Source4:        gnokii-smsd.logrotate
18Source5:        gnokii-smsd2mail.sh
19Source6:        gnokii-smsd-README.smsd2mail
20
21# Patch to remove port locking and apply the system-wide /usr/sbin directory
22# to the path instead of the default /usr/local
23Patch1:         gnokii-config.patch
24
25#----------------------------------------------------------------------------
26
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29#----------------------------------------------------------------------------
30
31BuildRequires:  flex
32BuildRequires:  gettext
33BuildRequires:  ImageMagick
34
35BuildRequires:  bluez-libs-devel
36BuildRequires:  desktop-file-utils
37BuildRequires:  gtk2-devel
38BuildRequires:  libusb-devel
39BuildRequires:  mysql-devel
40BuildRequires:  postgresql-devel
41BuildRequires:  readline-devel
42BuildRequires:  sqlite3-devel
43BuildRequires:  zlib-devel
44
45BuildRequires:  libical-devel >= 0.24
46
47# VineSeed
48BuildRequires:  libXt-devel
49BuildRequires:  libXpm-devel
50## VineLinux-4.x
51## BuildRequires: XOrg, XOrg-libs, XOrg-sdk
52
53BuildRequires:  perl(XML::Parser)
54Requires(pre):  %{_sbindir}/groupadd
55
56#----------------------------------------------------------------------------
57%description
58Gnokii provides tools and a user space driver for use with mobile
59phones under Linux, various unices and Win32. With gnokii you can do
60such things as make data calls, update your address book, change
61calendar entries, send and receive SMS messages and load ring tones
62depending on the phone you have.
63
64#----------------------------------------------------------------------------
65%package     -n xgnokii
66Summary:        Graphical Linux/Unix tool suite for various mobile phones
67Group:          Applications/Communications
68Requires:       %{name} = %{version}-%{release}
69
70%description -n xgnokii
71Xgnokii is graphical Linux/Unix tool suite for various mobile
72phones. It allows you to edit your contacts book, send/read SMS's
73from/in computer and more other features.
74
75#----------------------------------------------------------------------------
76%package        smsd
77Summary:        Gnokii SMS daemon
78Group:          System Environment/Daemons
79Requires:       %{name} = %{version}-%{release}
80Requires(pre):  %{_sbindir}/useradd
81Requires(post): /sbin/chkconfig
82Requires(preun): /sbin/chkconfig
83
84%description    smsd
85The Gnokii SMS daemon receives and sends SMS messages.
86
87#----------------------------------------------------------------------------
88%package        smsd-pgsql
89Summary:        PostgreSQL support for Gnokii SMS daemon
90Group:          System Environment/Daemons
91Requires:       %{name}-smsd = %{version}-%{release}
92Obsoletes:      %{name}-smsd-postgresql < 0.6.4-0.lvn.2
93
94%description    smsd-pgsql
95%{summary}.
96
97#----------------------------------------------------------------------------
98%package        smsd-mysql
99Summary:        MySQL support for Gnokii SMS daemon
100Group:          System Environment/Daemons
101Requires:       %{name}-smsd = %{version}-%{release}
102
103%description    smsd-mysql
104%{summary}.
105
106#----------------------------------------------------------------------------
107%package        devel
108Summary:        Gnokii development files
109Group:          Development/Libraries
110Requires:       %{name} = %{version}-%{release}
111Requires:       pkgconfig
112
113%description    devel
114%{summary}.
115
116
117#----------------------------------------------------------------------------
118%prep
119%setup -q
120%patch1 -p0
121install -pm 644 %{SOURCE5} smsd2mail.sh
122install -pm 644 %{SOURCE6} README.smsd2mail
123
124%build
125%configure --enable-security --disable-rpath --disable-static \
126                --enable-libical
127make %{?_smp_mflags}
128
129
130#----------------------------------------------------------------------------
131%install
132make install DESTDIR=$RPM_BUILD_ROOT
133
134# Rename smsd to gnokii-smsd
135mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
136mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
137sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
138sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
139
140# Remove libtool droppings
141rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
142
143# Fix up the default desktop file
144desktop-file-install \
145  --delete-original \
146  --vendor "" \
147  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
148  --mode 644 \
149  --add-category X-VineLinux \
150  $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
151
152# Convert the default icons to PNG
153install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
154convert Docs/sample/logo/gnokii.xpm \
155  $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
156chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
157
158# Install the configuration files
159install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
160install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
161install -Dpm 644 %{SOURCE4} \
162  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
163cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
164
165# Install the docs
166mkdir -p temporary-gnokii-docs/
167mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
168
169%find_lang %{name}
170
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175
176#----------------------------------------------------------------------------
177%pre
178%{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
179
180%pre smsd
181%{_sbindir}/useradd -r -M -d / -g gnokii \
182  -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
183
184%post -p /sbin/ldconfig
185
186%postun -p /sbin/ldconfig
187
188%post smsd
189/sbin/chkconfig --add gnokii-smsd
190
191%preun smsd
192if [ $1 -eq 0 ] ; then
193  %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
194  /sbin/chkconfig --del gnokii-smsd
195fi
196
197%postun smsd
198if [ $1 -ge 1 ] ; then
199  %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
200fi
201
202
203#----------------------------------------------------------------------------
204%files -f %{name}.lang
205%defattr(-,root,root,-)
206%doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
207%config(noreplace) %{_sysconfdir}/gnokiirc
208%attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
209%{_bindir}/gnokii
210%{_bindir}/sendsms
211%{_bindir}/gnokiid
212%{_libdir}/libgnokii.so.*
213%{_mandir}/man1/gnokii.1*
214%{_mandir}/man1/sendsms.1*
215%{_mandir}/man8/gnokiid.8*
216%{_mandir}/man8/mgnokiidev.8*
217
218%files -n xgnokii
219%defattr(-,root,root,-)
220%doc xgnokii/ChangeLog xgnokii/README.vcard
221%{_bindir}/xgnokii
222%{_datadir}/pixmaps/xgnokii.png
223%{_datadir}/applications/*xgnokii.desktop
224%{_mandir}/man1/xgnokii.1*
225
226%files smsd
227%defattr(-,root,root,-)
228%doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
229%attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
230%config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
231%{_initrddir}/gnokii-smsd
232%{_bindir}/gnokii-smsd
233%{_mandir}/man8/gnokii-smsd.8*
234%dir %{_libdir}/smsd/
235%{_libdir}/smsd/libsmsd_file.so
236%{_libdir}/smsd/libsmsd_sqlite.so
237
238%files smsd-pgsql
239%defattr(-,root,root,-)
240%doc smsd/sms.tables.pq.sql
241%{_libdir}/smsd/libsmsd_pq.so
242
243%files smsd-mysql
244%defattr(-,root,root,-)
245%doc smsd/sms.tables.mysql.sql
246%{_libdir}/smsd/libsmsd_mysql.so
247
248%files devel
249%defattr(-,root,root,-)
250%{_includedir}/gnokii*
251%{_libdir}/libgnokii.so
252%{_libdir}/pkgconfig/gnokii.pc
253%{_libdir}/pkgconfig/xgnokii.pc
254
255#----------------------------------------------------------------------------
256# Maintainers: babasaki@mindgear.org
257#
258#----------------------------------------------------------------------------
259%changelog
260* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
261- new upstream release
262- remove Patch0
263- add BuildRequires: sqlite3-devel
264
265* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.27-7
266- add BuildRequires: readline-devel
267
268* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
269- rebuilt with postgresql-9.0.3
270
271* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
272- rebuilt with rpm-4.8.1 for pkg-config
273
274* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
275- rebuilt with MySQL-5.1.34.
276
277* Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
278- Import gnokii - Packager: Babasaki
279- Updated specfile
280
281#----------------------------------------------------------------------------
282* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
283- Fix htmlview patch
284
285* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
286- Update to 0.6.27
287
288* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
289- Rebuild
290
291* Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
292- Rebuild with libical support
293
294* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
295- Update to 0.6.26
296
297* Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
298- Set empty --vendor rather none for using desktop-file-install
299- Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
300
301* Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
302- Update to 0.6.25
303
304* Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
305- Update to 0.6.24
306
307* Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
308- Rebuild for GCC 4.3.
309
310* Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
311- Pick up new libssl .solib version dependency.
312
313* Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
314- Update to 0.6.22
315
316* Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
317- Update to 0.6.20
318
319* Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
320- Even better multilib fixing (#335161)
321
322* Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
323- Quick fix to multilib conflict (#335161)
324
325* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
326- New upstream release
327
328* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
329- Update license field from GPL to GPLv2+
330
331* Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
332- New upstream release
333
334* Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
335- New upstream release
336- Update smsd name change patch
337- ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
338  upstream
339
340* Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
341- Rebuild to pick up new libpq IF
342
343* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
344 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
345
346* Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
347- New upstream release.
348
349* Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
350- Rebuild for Fedora Extras 6.
351
352* Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
353- Bump because tagged before committing sources and I just
354  dont know how the f* you delete a tag in CVS at the moment
355  and it does seem like a too big endavour to find out just
356  in order to have a nice release tag.
357
358* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
359- New upstream release.
360- New dependency on libusb for USB serial, DKU no longer needed/wanted
361  so now we have that troublesome issue resolved once and for all.
362- Remove patches to SQL files: these are now fixed upstream!
363
364* Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
365- Rebuilding due to changed interface on libbluetooth.
366
367* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
368- Goofed up. Fixit it...
369
370* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
371- Post-import updates.
372
373* Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
374- Updated after comments from Ville.
375
376* Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
377- New upstream tarball
378
379* Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
380- Updated after comments from Ville.
381
382* Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
383- 0.6.11
384- Modified to drop into the Fedora Extras as the nice package it now is
385- Based work off Ville's good olde package
386
387* Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
388- 0.6.10.
389- Clean up pkgconfig file and -devel dependencies from bits needed only
390  for static libs.
391
392* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
393- 0.6.9, desktop entry file included upstream.
394- Drop zero Epochs.
395
396* Sat Aug  6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
397- 0.6.8.
398- Don't ship static libraries.
399- Rename smsd to gnokii-smsd to avoid conflicts with smstools.
400- Remove not included files instead of using %%exclude.
401
402* Sat Jun  4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
403- BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
404
405* Thu Jun  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
406- 0.6.7.
407- Build unconditionally with bluetooth support.
408
409* Mon May  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
410- 0.6.5.
411
412* Fri Nov  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
413- Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
414  packages in FC/Extras.
415
416* Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
417- Update to 0.6.4, perms and pgsql patches applied upstream.
418- Xgnokii help locale symlink hack no longer necessary.
419- Don't remove user/group on last erase, move smsd user to -smsd subpackage.
420- Add libical support (disabled), rebuild with "--with libical" to enable.
421
422* Mon Jul  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
423- Update to 0.6.3.
424
425* Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
426- Improve Xgnokii desktop entry according to GNOME HIG.
427
428* Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
429- Remove duplicate gettext build dependency (bug 95).
430
431* Sun Jun  6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
432- Fix chown syntax in smsd init script.
433- Summary and description improvements.
434- Trim $RPM_OPT_FLAGS out from gnokii.pc.
435- Make -devel require XFree86-devel.
436
437* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
438- Update to 0.6.1.
439
440* Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
441- Make -devel require pkgconfig.
442
443* Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
444- Update to 0.6.0.
445
446* Mon Feb  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
447- Update to 0.5.10.
448
449* Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
450- Update to 0.5.9.
451- Specfile cleanups, small init script enhancements.
452
453* Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
454- Update to 0.5.7.
455- Move smsd man page into -smsd subpackage.
456
457* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
458- Update to 0.5.6.
459- Include sample action script for forwarding SMSD messages to mail.
460- s/fedora/livna/.
461- Specfile and init script cleanups.
462
463* Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
464- Disable smp flags to prevent build failure
465
466* Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
467- Update to 0.5.2.
468
469* Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
470- Update to 0.5.1.
471- Include init script, sysconfig and logrotate config for smsd.
472
473* Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
474- Update to 0.5.0.
475
476* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
477- RedHat'ified PLD version.
Note: See TracBrowser for help on using the repository browser.