source: projects/specs/trunk/g/gnokii/gnokii-vl.spec @ 3418

Revision 3418, 15.1 KB checked in by owa, 13 years ago (diff)

rebuild with postgresql-9.0.3

Line 
1# TODO: merge patches upstream where applicable
2
3Name:           gnokii
4Version:        0.6.27
5Release:        6%{?_dist_release}
6Summary:        Linux/Unix tool suite for various mobile phones
7Summary(ja): Linux/Unix tool suite for various mobile phones
8
9Group:          Applications/Communications
10License:        GPLv2+
11URL:            http://www.gnokii.org/
12Source0:        http://www.gnokii.org/download/gnokii/%{name}-%{version}.tar.bz2
13#----------------------------------------------------------------------------
14
15Source2:        gnokii-smsd.init
16Source3:        gnokii-smsd.sysconfig
17Source4:        gnokii-smsd.logrotate
18Source5:        gnokii-smsd2mail.sh
19Source6:        gnokii-smsd-README.smsd2mail
20
21# Patch to make gnokii use "htmlview" instead of "mozilla" as default browser
22Patch0:         gnokii-htmlview.patch
23# Patch to remove port locking and apply the system-wide /usr/sbin directory
24# to the path instead of the default /usr/local
25Patch1:         gnokii-config.patch
26
27#----------------------------------------------------------------------------
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30
31#----------------------------------------------------------------------------
32
33BuildRequires:  flex
34BuildRequires:  gettext
35BuildRequires:  gtk2-devel
36BuildRequires:  desktop-file-utils
37BuildRequires:  ImageMagick
38BuildRequires:  postgresql-devel
39BuildRequires:  mysql-devel
40BuildRequires:  zlib-devel
41BuildRequires:  bluez-libs-devel
42BuildRequires:  libusb-devel
43
44BuildRequires:  libical-devel >= 0.24
45
46# VineSeed
47BuildRequires:  libXt-devel
48BuildRequires:  libXpm-devel
49## VineLinux-4.x
50## BuildRequires: XOrg, XOrg-libs, XOrg-sdk
51
52BuildRequires:  perl(XML::Parser)
53Requires(pre):  %{_sbindir}/groupadd
54
55#----------------------------------------------------------------------------
56%description
57Gnokii provides tools and a user space driver for use with mobile
58phones under Linux, various unices and Win32. With gnokii you can do
59such things as make data calls, update your address book, change
60calendar entries, send and receive SMS messages and load ring tones
61depending on the phone you have.
62
63#----------------------------------------------------------------------------
64%package     -n xgnokii
65Summary:        Graphical Linux/Unix tool suite for various mobile phones
66Group:          Applications/Communications
67Requires:       %{name} = %{version}-%{release}
68
69%description -n xgnokii
70Xgnokii is graphical Linux/Unix tool suite for various mobile
71phones. It allows you to edit your contacts book, send/read SMS's
72from/in computer and more other features.
73
74#----------------------------------------------------------------------------
75%package        smsd
76Summary:        Gnokii SMS daemon
77Group:          System Environment/Daemons
78Requires:       %{name} = %{version}-%{release}
79Requires(pre):  %{_sbindir}/useradd
80Requires(post): /sbin/chkconfig
81Requires(preun): /sbin/chkconfig
82
83%description    smsd
84The Gnokii SMS daemon receives and sends SMS messages.
85
86#----------------------------------------------------------------------------
87%package        smsd-pgsql
88Summary:        PostgreSQL support for Gnokii SMS daemon
89Group:          System Environment/Daemons
90Requires:       %{name}-smsd = %{version}-%{release}
91Obsoletes:      %{name}-smsd-postgresql < 0.6.4-0.lvn.2
92
93%description    smsd-pgsql
94%{summary}.
95
96#----------------------------------------------------------------------------
97%package        smsd-mysql
98Summary:        MySQL support for Gnokii SMS daemon
99Group:          System Environment/Daemons
100Requires:       %{name}-smsd = %{version}-%{release}
101
102%description    smsd-mysql
103%{summary}.
104
105#----------------------------------------------------------------------------
106%package        devel
107Summary:        Gnokii development files
108Group:          Development/Libraries
109Requires:       %{name} = %{version}-%{release}
110Requires:       pkgconfig
111
112%description    devel
113%{summary}.
114
115
116#----------------------------------------------------------------------------
117%prep
118%setup -q
119%patch0 -p0
120%patch1 -p0
121install -pm 644 %{SOURCE5} smsd2mail.sh
122install -pm 644 %{SOURCE6} README.smsd2mail
123
124%build
125%configure --enable-security --disable-rpath --disable-static \
126                --enable-libical
127make %{?_smp_mflags}
128
129
130#----------------------------------------------------------------------------
131%install
132make install DESTDIR=$RPM_BUILD_ROOT
133
134# Rename smsd to gnokii-smsd
135mv $RPM_BUILD_ROOT%{_bindir}/{,gnokii-}smsd
136mv $RPM_BUILD_ROOT%{_mandir}/man8/{,gnokii-}smsd.8
137sed -i 's,smsd ,gnokii-smsd ,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
138sed -i 's,smsd.,gnokii-smsd.,' $RPM_BUILD_ROOT%{_mandir}/man8/gnokii-smsd.8
139
140# Remove libtool droppings
141rm $RPM_BUILD_ROOT%{_libdir}{,/smsd}/lib*.la
142
143# Fix up the default desktop file
144desktop-file-install \
145  --delete-original \
146  --vendor "" \
147  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
148  --mode 644 \
149  --add-category X-VineLinux \
150  $RPM_BUILD_ROOT%{_datadir}/applications/xgnokii.desktop
151
152# Convert the default icons to PNG
153install -dm 755 $RPM_BUILD_ROOT%{_datadir}/pixmaps
154convert Docs/sample/logo/gnokii.xpm \
155  $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
156chmod 644 $RPM_BUILD_ROOT%{_datadir}/pixmaps/xgnokii.png
157
158# Install the configuration files
159install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/gnokii-smsd
160install -Dpm 640 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/gnokii-smsd
161install -Dpm 644 %{SOURCE4} \
162  $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/gnokii-smsd
163cp -a Docs/sample/gnokiirc $RPM_BUILD_ROOT%{_sysconfdir}/
164
165# Install the docs
166mkdir -p temporary-gnokii-docs/
167mv $RPM_BUILD_ROOT%{_datadir}/doc/gnokii/ temporary-gnokii-docs/
168
169%find_lang %{name}
170
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175
176#----------------------------------------------------------------------------
177%pre
178%{_sbindir}/groupadd -r gnokii >/dev/null 2>&1 || :
179
180%pre smsd
181%{_sbindir}/useradd -r -M -d / -g gnokii \
182  -s /sbin/nologin -c "Gnokii system user" gnokii >/dev/null 2>&1 || :
183
184%post -p /sbin/ldconfig
185
186%postun -p /sbin/ldconfig
187
188%post smsd
189/sbin/chkconfig --add gnokii-smsd
190
191%preun smsd
192if [ $1 -eq 0 ] ; then
193  %{_initrddir}/gnokii-smsd stop >/dev/null 2>&1 || :
194  /sbin/chkconfig --del gnokii-smsd
195fi
196
197%postun smsd
198if [ $1 -ge 1 ] ; then
199  %{_initrddir}/gnokii-smsd try-restart >/dev/null 2>&1 || :
200fi
201
202
203#----------------------------------------------------------------------------
204%files -f %{name}.lang
205%defattr(-,root,root,-)
206%doc ChangeLog COPY* MAINTAINERS TODO temporary-gnokii-docs/*
207%config(noreplace) %{_sysconfdir}/gnokiirc
208%attr(4750,root,gnokii) %{_sbindir}/mgnokiidev
209%{_bindir}/gnokii
210%{_bindir}/sendsms
211%{_bindir}/gnokiid
212%{_libdir}/libgnokii.so.*
213%{_mandir}/man1/gnokii.1*
214%{_mandir}/man1/sendsms.1*
215%{_mandir}/man8/gnokiid.8*
216%{_mandir}/man8/mgnokiidev.8*
217
218%files -n xgnokii
219%defattr(-,root,root,-)
220%doc xgnokii/ChangeLog xgnokii/README.vcard
221%{_bindir}/xgnokii
222%{_datadir}/pixmaps/xgnokii.png
223%{_datadir}/applications/*xgnokii.desktop
224%{_mandir}/man1/xgnokii.1*
225%{_prefix}/share/xgnokii/
226
227%files smsd
228%defattr(-,root,root,-)
229%doc smsd/action smsd/ChangeLog smsd/README README.smsd2mail smsd2mail.sh
230%attr(-,gnokii,gnokii) %config(noreplace) %{_sysconfdir}/sysconfig/gnokii-smsd
231%config(noreplace) %{_sysconfdir}/logrotate.d/gnokii-smsd
232%{_initrddir}/gnokii-smsd
233%{_bindir}/gnokii-smsd
234%{_mandir}/man8/gnokii-smsd.8*
235%dir %{_libdir}/smsd/
236%{_libdir}/smsd/libsmsd_file.so
237
238%files smsd-pgsql
239%defattr(-,root,root,-)
240%doc smsd/sms.tables.pq.sql
241%{_libdir}/smsd/libsmsd_pq.so
242
243%files smsd-mysql
244%defattr(-,root,root,-)
245%doc smsd/sms.tables.mysql.sql
246%{_libdir}/smsd/libsmsd_mysql.so
247
248%files devel
249%defattr(-,root,root,-)
250%{_includedir}/gnokii*
251%{_libdir}/libgnokii.so
252%{_libdir}/pkgconfig/gnokii.pc
253%{_libdir}/pkgconfig/xgnokii.pc
254
255#----------------------------------------------------------------------------
256# Maintainers: babasaki@mindgear.org
257#
258#----------------------------------------------------------------------------
259%changelog
260* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 0.6.27-6
261- rebuilt with postgresql-9.0.3
262
263* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.27-5
264- rebuilt with rpm-4.8.1 for pkg-config
265
266* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.27-4
267- rebuilt with MySQL-5.1.34.
268
269* Mon Oct 27 2008 Seiichirou Babasaki - 0.6.27-3
270- Import gnokii - Packager: Babasaki
271- Updated specfile
272
273#----------------------------------------------------------------------------
274* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-2
275- Fix htmlview patch
276
277* Mon Oct 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.27-1
278- Update to 0.6.27
279
280* Thu Sep 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-3
281- Rebuild
282
283* Thu Jun 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-2
284- Rebuild with libical support
285
286* Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.26-1
287- Update to 0.6.26
288
289* Fri May 23 2008 Robert Scheck <robert@fedoraproject.org> 0.6.25-2
290- Set empty --vendor rather none for using desktop-file-install
291- Fixed initscript as gnokii-smsd stays in /usr/bin not /usr/sbin
292
293* Mon May 19 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.25-1
294- Update to 0.6.25
295
296* Thu Mar 20 2008 - Bastien Nocera <bnocera@redhat.com> - 0.6.24-1
297- Update to 0.6.24
298
299* Mon Feb 11 2008 - Linus Walleij <triad@df.lth.se> - 0.6.22-3
300- Rebuild for GCC 4.3.
301
302* Thu Dec 6 2007 - Linus Walleij <triad@df.lth.se> - 0.6.22-2
303- Pick up new libssl .solib version dependency.
304
305* Thu Nov 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.22-1
306- Update to 0.6.22
307
308* Thu Nov 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.20-1
309- Update to 0.6.20
310
311* Sun Oct 28 2007 Jeremy Katz <katzj@redhat.com> - 0.6.18-3
312- Even better multilib fixing (#335161)
313
314* Tue Oct 23 2007 - Jeremy Katz <katzj@redhat.com> - 0.6.18-2
315- Quick fix to multilib conflict (#335161)
316
317* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.18-1
318- New upstream release
319
320* Fri Aug 17 2007 - Linus Walleij <triad@df.lth.se> - 0.6.17-2
321- Update license field from GPL to GPLv2+
322
323* Wed Jul 04 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.17-1
324- New upstream release
325
326* Mon Jul 02 2007 - Bastien Nocera <bnocera@redhat.com> - 0.6.16-1
327- New upstream release
328- Update smsd name change patch
329- ppm2nokia, waitcall and todologo have moved to gnokii-extras, as per
330  upstream
331
332* Wed Dec 06 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-3
333- Rebuild to pick up new libpq IF
334
335* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.6.14-2
336 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
337
338* Sat Sep 23 2006 Linus Walleij <triad@df.lth.se> - 0.6.14-1
339- New upstream release.
340
341* Tue Aug 29 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-3
342- Rebuild for Fedora Extras 6.
343
344* Fri Aug 11 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-2
345- Bump because tagged before committing sources and I just
346  dont know how the f* you delete a tag in CVS at the moment
347  and it does seem like a too big endavour to find out just
348  in order to have a nice release tag.
349
350* Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> - 0.6.13-1
351- New upstream release.
352- New dependency on libusb for USB serial, DKU no longer needed/wanted
353  so now we have that troublesome issue resolved once and for all.
354- Remove patches to SQL files: these are now fixed upstream!
355
356* Mon Jun 12 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
357- Rebuilding due to changed interface on libbluetooth.
358
359* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-4
360- Goofed up. Fixit it...
361
362* Sun Apr 2 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-3
363- Post-import updates.
364
365* Thu Mar 31 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-2
366- Updated after comments from Ville.
367
368* Thu Mar 16 2006 Linus Walleij <triad@df.lth.se> - 0.6.12-1
369- New upstream tarball
370
371* Wed Mar 8 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-2
372- Updated after comments from Ville.
373
374* Sun Mar 5 2006 Linus Walleij <triad@df.lth.se> - 0.6.11-1
375- 0.6.11
376- Modified to drop into the Fedora Extras as the nice package it now is
377- Based work off Ville's good olde package
378
379* Sun Nov 13 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.10-0.lvn.1
380- 0.6.10.
381- Clean up pkgconfig file and -devel dependencies from bits needed only
382  for static libs.
383
384* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.6.9-0.lvn.1
385- 0.6.9, desktop entry file included upstream.
386- Drop zero Epochs.
387
388* Sat Aug  6 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.lvn.1
389- 0.6.8.
390- Don't ship static libraries.
391- Rename smsd to gnokii-smsd to avoid conflicts with smstools.
392- Remove not included files instead of using %%exclude.
393
394* Sat Jun  4 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.2
395- BuildRequire openssl-devel to work around https://bugzilla.redhat.com/159569
396
397* Thu Jun  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.7-0.lvn.1
398- 0.6.7.
399- Build unconditionally with bluetooth support.
400
401* Mon May  2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.5-0.lvn.1
402- 0.6.5.
403
404* Fri Nov  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.2
405- Rename -smsd-postgresql to -smsd-pgsql for consistency with other similar
406  packages in FC/Extras.
407
408* Fri Oct 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.4-0.lvn.1
409- Update to 0.6.4, perms and pgsql patches applied upstream.
410- Xgnokii help locale symlink hack no longer necessary.
411- Don't remove user/group on last erase, move smsd user to -smsd subpackage.
412- Add libical support (disabled), rebuild with "--with libical" to enable.
413
414* Mon Jul  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.3-0.lvn.1
415- Update to 0.6.3.
416
417* Sun Jun 20 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.4
418- Improve Xgnokii desktop entry according to GNOME HIG.
419
420* Sun Jun 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.3
421- Remove duplicate gettext build dependency (bug 95).
422
423* Sun Jun  6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.2
424- Fix chown syntax in smsd init script.
425- Summary and description improvements.
426- Trim $RPM_OPT_FLAGS out from gnokii.pc.
427- Make -devel require XFree86-devel.
428
429* Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.1-0.lvn.1
430- Update to 0.6.1.
431
432* Thu Mar 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.2
433- Make -devel require pkgconfig.
434
435* Mon Feb 23 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.0-0.lvn.1
436- Update to 0.6.0.
437
438* Mon Feb  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.10-0.lvn.1
439- Update to 0.5.10.
440
441* Tue Jan 27 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.9-0.lvn.1
442- Update to 0.5.9.
443- Specfile cleanups, small init script enhancements.
444
445* Sat Dec 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.7-0.lvn.1
446- Update to 0.5.7.
447- Move smsd man page into -smsd subpackage.
448
449* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.6-0.lvn.1
450- Update to 0.5.6.
451- Include sample action script for forwarding SMSD messages to mail.
452- s/fedora/livna/.
453- Specfile and init script cleanups.
454
455* Sat Jul 19 2003 Warren Togami <warren@togami.com> - 0:0.5.2-0.fdr.2
456- Disable smp flags to prevent build failure
457
458* Sun Jun 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.2-0.fdr.1
459- Update to 0.5.2.
460
461* Thu May 29 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.1-0.fdr.1
462- Update to 0.5.1.
463- Include init script, sysconfig and logrotate config for smsd.
464
465* Tue May 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.5.0-0.fdr.1
466- Update to 0.5.0.
467
468* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 0.4.3-1cr
469- RedHat'ified PLD version.
Note: See TracBrowser for help on using the repository browser.