source: projects/specs/trunk/g/gmime/gmime-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Library for creating and parsing MIME messages
2Summary(ja):    MIMEメッセージを生成またパースするためのライブラリ
3Name:           gmime
4Version:        2.2.23
5Release:        1%{?_dist_release}
6Group:          System Environment/Libraries
7License:        GPL
8URL:            http://spruce.sourceforge.net/gmime/
9Source0:        http://spruce.sourceforge.net/gmime/sources/v2.2/gmime-%{version}.tar.bz2
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11
12BuildRequires:  glib2-devel >= 2.10.0
13BuildRequires:  zlib-devel >= 1.2.1.1
14BuildRequires:  automake, libtool, gettext, gtk-doc
15
16Patch1: gmime-2.2.3-use-pkg-config.patch
17Patch2: gmime-2.2.3-libdir.patch
18Patch3: gmime-2.2.3-automake.patch
19Patch4: gmime-2.2.23-gacutil.patch
20
21# Mono only availible on these:
22%define mono_archs %ix86 x86_64 ppc ia64 armv4l sparc
23# no mono on s390 for now: s390 s390x
24
25%ifarch %mono_archs
26BuildRequires:  mono-devel gtk-sharp2-gapi
27BuildRequires:  gtk-sharp2 >= 2.8.0
28%define monodir %{_prefix}/lib/mono
29%endif
30
31%description
32The GMime suite provides a core library and set of utilities which may be
33used for the creation and parsing of messages using the Multipurpose
34Internet Mail Extension (MIME).
35
36
37%package        devel
38Summary:        Header files to develop libgmime applications
39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41Requires:       glib2-devel
42
43%description    devel
44The GMime suite provides a core library and set of utilities which may be
45used for the creation and parsing of messages using the Multipurpose
46Internet Mail Extension (MIME). The devel-package contains header files
47to develop applications that use libgmime.
48
49%ifarch %mono_archs
50%package        sharp
51Summary:        mono bindings for gmime
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       gtk-sharp2
55
56%description    sharp
57The GMime suite provides a core library and set of utilities which may be
58used for the creation and parsing of messages using the Multipurpose
59Internet Mail Extension (MIME). The devel-package contains support
60for developing mono applications that use libgmime.
61%endif
62
63%prep
64%setup -q
65%patch1 -p1 -b .use-pkg-config
66#%patch2 -p1 -b .libdir
67#%patch3 -p0 -b .automake
68
69%ifarch %mono_archs
70%patch4 -p1 -b .gacutil
71%endif
72
73%build
74cp %{_datadir}/gettext/config.rpath .
75autoreconf --force --install
76
77%ifarch %mono_archs
78export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
79MONO_ARGS="--enable-mono"
80%endif
81
82%configure $MONO_ARGS
83make %{?_smp_mflags}
84
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
89make install DESTDIR=$RPM_BUILD_ROOT
90
91find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
92
93# Don't conflict with sharutils:
94mv $RPM_BUILD_ROOT%{_bindir}/uuencode $RPM_BUILD_ROOT%{_bindir}/gmime-uuencode
95mv $RPM_BUILD_ROOT%{_bindir}/uudecode $RPM_BUILD_ROOT%{_bindir}/gmime-uudecode
96
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105
106%files
107%defattr(-,root,root,-)
108%doc AUTHORS COPYING ChangeLog README TODO
109%{_bindir}/gmime-uu??code
110%{_libdir}/lib*.so.*
111
112%files devel
113%defattr(-,root,root,-)
114%{_bindir}/gmime-config
115%{_libdir}/lib*.a
116%{_libdir}/lib*.so
117%{_libdir}/gmimeConf.sh
118%{_libdir}/pkgconfig/gmime-2.0.pc
119%{_includedir}/gmime-2.0
120%{_datadir}/gtk-doc/html/gmime
121
122%ifarch %mono_archs
123%files sharp
124%defattr(-,root,root,-)
125%{_libdir}/pkgconfig/gmime-sharp.pc
126%{monodir}/gac/gmime-sharp
127%{monodir}/gmime-sharp
128%{_datadir}/gapi-2.0/gmime-api.xml
129%endif
130
131
132%changelog
133* Thu Sep 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.23-1vl5
134- new upstream release
135- rebuilt with mono-2.0
136- added gmime-2.2.23-gacutil.patch
137
138* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-1vl5
139- applied new versioning policy, spec in utf-8
140- updated gmime to 2.2.9
141- dropt gmime-2.2.3-libdir.patch
142- dropt gmime-2.2.3-automake.patch
143
144* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
145- initial build for Vine Linux
146
147* Tue Feb  6 2007 Alexander Larsson <alexl@redhat.com> - 2.2.3-5
148- Fix build with new automake (#224157)
149
150* Thu Oct 12 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-4
151- Bump glib requirement to 2.6 (#209565)
152
153* Tue Sep  5 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-3
154- fix gmime-config multilib conflict (#205208)
155
156* Sat Aug 19 2006 Matthias Clasen <mclasen@redhat.com> - 2.2.3-2
157- Rebuild
158
159* Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-1
160- Upgrade to 2.2.3
161- Use the new mono libdir
162
163* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
164- rebuild
165
166* Fri Jun  9 2006 Alexander Larsson <alexl@redhat.com> - 2.2.1-2
167- Disable mono parts on s390* as mono doesn't build on s390 atm
168
169* Tue May 23 2006 Alexander Larsson <alexl@redhat.com> - 2.2.1-1
170- Update to 2.2.1
171- Fix multilib -devel conflict by using pkg-config in gmime-config (#192675)
172
173* Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.1.19-4
174- BuildRequires: gtk-sharp2 on mono archs only
175
176* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 2.1.19-3
177- Rebuild
178
179* Tue Feb  7 2006 Jesse Keating <jkeating@redhat.com> - 2.1.19-2.1
180- rebuilt for new gcc4.1 snapshot and glibc changes
181
182* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 2.1.19-2
183- Rebuild
184
185* Sun Jan 22 2006 Alexander Larsson <alexl@redhat.com> - 2.1.19-1
186- Update to 2.1.19 (needed by beagle 0.2.0)
187
188* Thu Jan 19 2006 Alexander Larsson <alexl@redhat.com> 2.1.17-3
189- Build on s390x
190
191* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> 2.1.17-2
192- build gmime-sharp conditionally on mono arches
193
194* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 2.1.17-1
195- Move from Extras to Core, Update to 2.1.17, add gmime-sharp subpackage
196
197* Wed Aug 10 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.15-1
198- Update to 2.1.15
199- Use dist
200
201* Wed May 18 2005 Colin Charles <colin@fedoraproject.org> - 2.1.9-5
202- bump release, request build on ppc
203
204* Thu Mar 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.1.9-4
205- add dep glib2-devel for pkgconfig in -devel package
206
207* Mon Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.3
208- Remove ldconfig from Requires pre and post
209
210* Mon Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.2
211- BR zlib-devel
212- Don't ship empty news file
213- Fixes to the files section
214- Change ldconfig in post* calls to -p /sbin/ldconfig
215
216
217* Sun Oct 17 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.1
218- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.