source: projects/specs/trunk/g/glslang/glslang-vl.spec @ 12440

Revision 12440, 5.8 KB checked in by tomop, 4 years ago (diff)

updated 10 packages

glslang-8.13.3743-1

libva-intel-driver-2.4.1-1

libva-2.8.0-1

mesa-20.1.4-1

spirv-headers-1.5.3-1

spirv-tools-2020.3-1

vulkan-headers-1.2.135.0-2

vulkan-loader-1.2.135.0-2

vulkan-tools-1.2.135.0-2

vulkan-validation-layers-1.2.135.0-2

Line 
1#global commit c9b28b9f3388c607ea5506f5e6197b7150238ad3
2#global shortcommit %(c=%{commit}; echo ${c:0:7})
3#global commit_date 2020421
4#global gitrel .%{commit_date}.git%{shortcommit}
5
6Name:           glslang
7Summary:        OpenGL and OpenGL ES shader front end and validator
8Version:        8.13.3743
9Release:        1%{?gitrel}%{?_dist_release}
10Vendor:         Project Vine
11Distribution:   Vine Linux
12
13License:        BSD and GPLv3+ and ASL 2.0
14URL:            https://github.com/KhronosGroup
15%if 0%{?commit_date}
16Source0:        %url/%{name}/archive/%{commit}/%{name}-%{commit}.tar.gz
17%else
18Source0:        %url/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
19%endif
20Patch1:         glslang-default-resource-limits_staticlib.patch
21# Patch to build against system spirv-tools (rebased locally)
22#Patch3:         https://patch-diff.githubusercontent.com/raw/KhronosGroup/glslang/pull/1722.patch#/0001-pkg-config-compatibility.patch
23Patch3:         0001-pkg-config-compatibility.patch
24
25BuildRequires:  cmake
26BuildRequires:  gcc-c++
27BuildRequires:  ninja
28BuildRequires:  spirv-tools-devel
29
30%description
31%{name} is the official reference compiler front end for the OpenGL
32ES and OpenGL shading languages. It implements a strict
33interpretation of the specifications for these languages.
34
35%package        devel
36Summary:        Development files for %{name}
37Requires:       %{name}%{?_isa} = %{version}-%{release}
38
39%description    devel
40%{name} is the official reference compiler front end for the OpenGL
41ES and OpenGL shading languages. It implements a strict
42interpretation of the specifications for these languages.
43
44%prep
45%if 0%{?commit_date}
46%autosetup -p1 -n %{name}-%{commit}
47%else
48%autosetup -p1 -n %{name}-%{version}
49%endif
50# Fix rpmlint warning on debuginfo
51find . -name '*.h' -or -name '*.cpp' -or -name '*.hpp'| xargs chmod a-x
52
53%build
54%__mkdir_p build
55pushd build
56%cmake -DCMAKE_BUILD_TYPE=Release \
57        -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
58        -DCMAKE_SKIP_RPATH:BOOL=yes \
59        -DBUILD_SHARED_LIBS=OFF \
60        -GNinja ..
61%{ninja_build}
62popd
63
64%install
65%{ninja_install} -C build
66
67# we don't want them in here
68rm -rf %{buildroot}%{_includedir}/SPIRV
69
70%ifnarch s390x ppc64
71%check
72pushd Test
73./runtests localResults ../build/StandAlone/glslangValidator ../build/StandAlone/spirv-remap
74popd
75%endif
76
77# Install libglslang-default-resource-limits.a
78install -pm 0644 build/StandAlone/libglslang-default-resource-limits.a %{buildroot}%{_libdir}/
79
80%files
81%doc README.md README-spirv-remap.txt
82%{_bindir}/glslangValidator
83%{_bindir}/spirv-remap
84
85%files devel
86%{_includedir}/glslang/
87%{_libdir}/libHLSL.a
88%{_libdir}/libOGLCompiler.a
89%{_libdir}/libOSDependent.a
90%{_libdir}/libSPIRV.a
91%{_libdir}/libSPVRemapper.a
92%{_libdir}/libglslang.a
93%{_libdir}/libglslang-default-resource-limits.a
94%{_libdir}/pkgconfig/glslang.pc
95%{_libdir}/pkgconfig/spirv.pc
96%{_libdir}/cmake/*
97
98%changelog
99* Wed Jul 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.13.3743-1
100- initial build for Vine Linux.
101- new upstream release.
102
103* Wed Apr 22 2020 Dave Airlie <airlied@redhat.com> - 8.13.3559-2
104- Update to latest git snapshot
105
106* Wed Jan 29 2020 Dave Airlie <airlied@redhat.com> - 8.13.3559-1
107- Update to latest git snapshot
108
109* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.13.3496-3.20191102.git7f77b2e
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
111
112* Thu Dec 19 2019 Leigh Scott <leigh123linux@googlemail.com> - 7.13.3496-2.20191102.git7f77b2e
113- Add patch for 'Fix a couple relative header paths in header'
114
115* Wed Nov 13 2019 Dave Airlie <airlied@redhat.com> - 7.13.3496-1
116- Latest upstream snapshot for validation layers build
117
118* Sat Aug 03 2019 Dave Airlie <airlied@redhat.com> - 7.11.3214-3
119- Latest upstream snapshot for validation layers build
120
121* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.11.3214-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
123
124* Mon Jun 10 2019 Robert-André Mauchin <zebob.m@gmail.com> - 7.11.3214-1
125- Release 7.11.3214
126- Add patch to build against system spirv-tools
127
128* Fri Mar 29 2019 Dave Airlie <airlied@redhat.com> - 3.1-0.13.20190329.gite0d59bb
129- Update for vulkan 1.1.101.0
130
131* Tue Feb 12 2019 Dave Airlie <airlied@redhat.com> - 3.1-0.12.20190212.git05d12a9
132- Update for vulkan 1.1.92.0
133
134* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.11.20180727.gite99a268
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
136
137* Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.10.20180727.gite99a268
138- Update for vulkan 1.1.82.0
139
140* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.9.20180416.git3bb4c48
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
142
143* Mon Apr 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.8.20180416.git3bb4c48
144- Update for vulkan 1.1.73.0
145
146* Wed Mar 07 2018 Adam Williamson <awilliam@redhat.com> - 3.1-0.7.20180205.git2651cca
147- Rebuild to fix GCC 8 mis-compilation
148  See https://da.gd/YJVwk ("GCC 8 ABI change on x86_64")
149
150* Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.6.20180205.git2651cca
151- Update for vulkan 1.0.68.0
152
153* Fri Feb 09 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.5.20171028.git715c353
154- Use ninja to build
155
156* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1-0.4.20171028.git715c353
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
158
159* Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.3.20171028.git715c353
160- Exclude s390x and ppc64 from check section
161
162* Wed Jan 03 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.2.20171028.git715c353
163- Add check section to run tests
164- Split binaries into main package
165
166* Thu Jul 13 2017 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.1.20171028.git715c353
167- First build
Note: See TracBrowser for help on using the repository browser.