source: projects/specs/trunk/g/glpk/glpk-vl.spec @ 521

Revision 521, 4.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           glpk
2Version:        4.37
3Release:        1%{?_dist_release}
4Summary:        GNU Linear Programming Kit
5Summary(ja):    GNU 線形計画法キット
6
7Group:          System Environment/Libraries
8License:        GPLv3
9URL:            http://www.gnu.org/software/glpk/glpk.html
10Source0:        ftp://ftp.gnu.org/gnu/glpk/%{name}-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  gmp-devel
14BuildRequires:  zlib-devel
15
16%description
17The GLPK (GNU Linear Programming Kit) package is intended for solving
18large-scale linear programming (LP), mixed integer programming (MIP),
19and other related problems. It is a set of routines written in ANSI C
20and organized in the form of a callable library.
21
22GLPK supports the GNU MathProg language, which is a subset of the AMPL
23language.
24
25The GLPK package includes the following main components:
26
27 * Revised simplex method.
28 * Primal-dual interior point method.
29 * Branch-and-bound method.
30 * Translator for GNU MathProg.
31 * Application program interface (API).
32 * Stand-alone LP/MIP solver.
33
34%package devel
35Summary:        Development headers and files for GLPK
36Summary(ja):    GLPK の開発用ファイル
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       gmp-devel
40
41%description devel
42The glpk-devel package contains libraries and headers for developing
43applications which use GLPK (GNU Linear Programming Kit).
44
45
46%package utils
47Summary:        GLPK-related utilities and examples
48Summary(ja):    GLPK に関連するユーティリティとサンプル集
49Group:          Applications/Engineering
50Requires:       %{name} = %{version}-%{release}
51
52%description utils
53The glpk-utils package contains the standalone solver programs glpksol
54and tspsol that use GLPK (GNU Linear Programming Kit).
55
56#package static
57#Summary:        Static version of GLPK libraries
58#Group:          Development/Libraries
59#Requires:       %{name}-devel = %{version}-%{release}
60#
61#description static
62#The glpk-static package contains the statically linkable version of
63#the GLPK (GNU Linear Programming Kit) libraries.
64
65%prep
66%setup -q
67
68%build
69%configure --disable-static --with-gmp --with-zlib
70make %{?_smp_mflags}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install prefix=$RPM_BUILD_ROOT%{_prefix} \
75        bindir=$RPM_BUILD_ROOT%{_bindir} libdir=$RPM_BUILD_ROOT%{_libdir} \
76        includedir=$RPM_BUILD_ROOT%{_includedir}/%{name}
77
78rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
79
80## Clean up directories that are included in docs
81make clean
82rm -Rf examples/.deps examples/Makefile* doc/*.dvi doc/*.latex
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root)
93%doc AUTHORS ChangeLog COPYING NEWS README doc
94%{_libdir}/*.so.*
95
96%files devel
97%defattr(-,root,root)
98%doc AUTHORS ChangeLog COPYING NEWS README doc
99%{_includedir}/glpk
100%{_libdir}/*.so
101#{_libdir}/*.a
102#exclude %{_libdir}/*.la
103
104%files utils
105%defattr(-,root,root)
106%doc COPYING examples
107%{_bindir}/*
108
109%changelog
110* Wed Apr 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.37-1
111- new upstream release
112- added --with-gmp and --with-zlib
113- built with libtool-2.2.6a
114- removed static library
115- added Japanese summary
116
117* Fri May 16 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.28-1
118- new upstream release
119
120* Wed Jan 02 2008 NAKAMURA Kenta <kenta@vinelinux.org> 4.24-1vl1
121- New release.
122
123* Wed Aug 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.20-1vl3
124- rebuilt for VineSeed
125
126* Wed Aug 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.20-1vl2
127- added BuildRequires: gmp-devel
128
129* Mon Aug  6 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.20-1vl1
130- initial build for Vine
131
132* Fri Jul 27 2007 Quentin Spencer <qspencer@users.sf.net> 4.20-1
133- New release.
134- Split static libs into separate package.
135
136* Thu Jun 28 2007 Quentin Spencer <qspencer@users.sf.net> 4.18-1
137- New release.
138
139* Wed Mar 28 2007 Quentin Spencer <qspencer@users.sf.net> 4.15-1
140- New release. Shared libraries are now supported.
141
142* Tue Dec 12 2006 Quentin Spencer <qspencer@users.sf.net> 4.13-1
143- New release.
144
145* Tue Aug 29 2006 Quentin Spencer <qspencer@users.sf.net> 4.11-2
146- Rebuild for FC6.
147
148* Tue Jul 25 2006 Quentin Spencer <qspencer@users.sf.net> 4.11-1
149- New release.
150
151* Fri May 12 2006 Quentin Spencer <qspencer@users.sf.net> 4.10-1
152- New release.
153
154* Tue Feb 14 2006 Quentin Spencer <qspencer@users.sf.net> 4.9-2
155- Add dist tag
156
157* Tue Feb 14 2006 Quentin Spencer <qspencer@users.sf.net> 4.9-1
158- New release.
159
160* Tue Aug 09 2005 Quentin Spencer <qspencer@users.sf.net> 4.8-3
161- Remove utils dependency on base package, since it doesn't exist until
162  shared libraries are enabled.
163
164* Tue Aug 09 2005 Quentin Spencer <qspencer@users.sf.net> 4.8-2
165- Add -fPIC to compile flags.
166
167* Fri Jul 22 2005 Quentin Spencer <qspencer@users.sf.net> 4.8-1
168- First version.
Note: See TracBrowser for help on using the repository browser.