source: projects/specs/trunk/g/global/global-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#%define priority 30
2
3Summary: GNU GLOBAL is a source code tag system
4Summary(ja): GNU GLOBAL ソースコードタグシステム
5Name: global
6Version: 5.7.7
7Release: 1%{?_dist_release}
8License: GPLv3
9Group: Development/Tools
10URL: http://www.gnu.org/software/global/
11Source0: ftp://ftp.gnu.org/pub/gnu/global/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: perl
14Requires(post,preun): /sbin/install-info
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20GNU GLOBAL is a source code tag system that works the same way across diverse
21environments. It supports C, C++, Yacc and Java source code.
22
23%description -l ja
24GNU GLOBAL はソースコードに索引付けを行います.
25C, C++, Yacc, Java のソースコードをサポートします.
26
27%prep
28%setup -q
29
30%build
31%configure
32make
33
34%install
35rm -rf %{buildroot}
36%makeinstall
37
38# gctags command conflicts emacs package.
39#%__mv %{buildroot}%{_bindir}/gctags %{buildroot}%{_bindir}/gctags.global
40#%__mv %{buildroot}%{_mandir}/man1/gctags.1 %{buildroot}%{_mandir}/man1/gctags.global.1
41
42pushd $RPM_BUILD_ROOT%{_datadir}/gtags
43rm -f AUTHORS BOKIN_* COPYING ChangeLog DONORS FAQ \
44    INSTALL LICENSE NEWS README THANKS
45popd
46
47rm -f $RPM_BUILD_ROOT%{_infodir}/dir
48
49%clean
50rm -rf %{buildroot}
51
52%post
53#/sbin/update-alternatives --install /usr/bin/gctags gctags /usr/bin/gctags.global %{priority}
54#/sbin/update-alternatives --config gctags
55/sbin/install-info %{_infodir}/global.info.* %{_infodir}/dir
56
57%preun
58if [ $1 = 0 ]; then
59#    /sbin/update-alternatives --remove gctags /usr/bin/gctags.global
60    /sbin/install-info --delete %{_infodir}/global.info.* %{_infodir}/dir
61fi
62
63%files
64%defattr(-,root,root)
65%doc AUTHORS BOKIN_* COPYING ChangeLog DONORS FAQ INSTALL
66%doc LICENSE NEWS README THANKS
67%doc globash.rc gtags.conf gtags.el gtags.pl
68%{_bindir}/*
69%{_mandir}/man?/*
70%{_datadir}/gtags
71%{_infodir}/global.info*
72
73%changelog
74* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.7.7-1
75- new upstream release
76
77* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.7.5-1
78- new upstream release
79- spec in UTF-8
80
81* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.7.1-1
82- new upstream release
83
84* Fri Jan 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.6.2-0vl1
85- new upstream release
86
87* Wed Aug  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.6-0vl1
88- new upstream release
89
90* Tue Oct  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 5.2-0vl1
91- new upstream release
92
93* Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.8.7-0vl1
94- new upstream release
95- this version is not necessary to use alternatives
96
97* Wed Aug  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 4.6-0vl2
98- use alternatives for gctags
99- fix typo in URL
100
101* Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 4.6-0vl1
102- update to 4.6
103- rename gctags.1 to gctags.global.1
104
105* Sat Jul 19 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 4.5.3-0vl1
106- update to 4.5.3
107- changed URL
108- removed gctags.1* (conflict emacs package)
109
110* Mon May  5 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 4.5.2-0vl1
111- Initial build.
112
Note: See TracBrowser for help on using the repository browser.