source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 9475

Revision 9475, 21.6 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of handy utility functions.
4Name: glib2
5Version: 2.44.0
6Release: 1%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.44/glib-%{version}.tar.xz
10Source2: glib2.sh
11Source3: glib2.csh
12
13Patch0: glib-2.32.1-dconf-path.patch
14
15BuildRoot: %{_tmppath}/glib-%{version}-root
16
17BuildRequires: pkgconfig >= 0.14
18BuildRequires: dbus-devel
19BuildRequires: gamin-devel
20BuildRequires: libffi-devel
21BuildRequires: zlib-devel
22BuildRequires: python-devel
23BuildRequires: gtk-doc
24Obsoletes: glib-gtkbeta
25URL: http://www.gtk.org
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
30
31%description
32GLib is the low-level core library that forms the basis
33for projects such as GTK+ and GNOME. It provides data structure
34handling for C, portability wrappers, and interfaces for such runtime
35functionality as an event loop, threads, dynamic loading, and an
36object system.
37
38This package provides version 2.44 of GLib.
39
40%package devel
41Summary: Development files for the GLib library
42Group: Development/Libraries
43Requires: %{name} = %{version}
44Requires: pkgconfig >= 0.14
45Requires: libffi-devel
46Requires: zlib-devel
47
48Obsoletes: glib-gtkbeta-devel
49Conflicts: glib-devel <= 1.2.8
50
51%description devel
52The glib-devel package includes the header files for
53version 2.44 of the GLib library.
54
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary: A library of handy utility functions.
59Group: System Environment/Libraries
60
61%description -n compat32-%{name}
62GLib is the low-level core library that forms the basis
63for projects such as GTK+ and GNOME. It provides data structure
64handling for C, portability wrappers, and interfaces for such runtime
65functionality as an event loop, threads, dynamic loading, and an
66object system.
67
68This package provides version 2.44 of GLib.
69
70%package -n compat32-%{name}-devel
71Summary: Development files for the GLib library
72Group: Development/Libraries
73Requires: pkgconfig >= 0.14
74Requires: compat32-%{name} = %{version}
75
76Conflicts: glib-devel <= 1.2.8
77
78%description -n compat32-%{name}-devel
79The glib-devel package includes the header files for
80version 2.44 of the GLib library.
81
82
83%prep
84%setup -q -n glib-%{version}
85%patch0 -p1
86
87%build
88NOCONFIGURE=1 ./autogen.sh
89%configure --disable-selinux --enable-static --enable-systemtap
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
96make install DESTDIR=$RPM_BUILD_ROOT
97
98## glib2.sh and glib2.csh
99mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
103#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
120
121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
133%{_bindir}/gapplication
134%{_bindir}/gdbus
135%{_bindir}/gio-querymodules
136%{_bindir}/glib-compile-schemas
137%{_bindir}/gsettings
138%{_libdir}/libglib-2.0.so.*
139%{_libdir}/libgthread-2.0.so.*
140%{_libdir}/libgmodule-2.0.so.*
141%{_libdir}/libgobject-2.0.so.*
142%{_libdir}/libgio-2.0.so.*
143%{_libdir}/gio/modules/lib*.so
144%{_sysconfdir}/profile.d/*
145%{_datadir}/bash-completion/completions/gapplication
146%{_datadir}/bash-completion/completions/gdbus
147%{_datadir}/bash-completion/completions/gsettings
148
149%files devel
150%defattr(-, root, root)
151%{_bindir}/gdbus-codegen
152%{_bindir}/glib-compile-resources
153%{_bindir}/glib-genmarshal
154%{_bindir}/glib-gettextize
155%{_bindir}/glib-mkenums
156%{_bindir}/gobject-query
157%{_bindir}/gresource
158%{_bindir}/gtester
159%{_bindir}/gtester-report
160%{_libdir}/lib*.so
161%{_libdir}/lib*.a
162#%{_libdir}/gdbus-2.0/codegen/*
163%{_libdir}/glib-2.0
164%{_libdir}/pkgconfig/*
165#%{python_sitearch}/codegen
166%{_includedir}/*
167%{_datadir}/aclocal/*
168%{_datadir}/glib-2.0
169%doc %{_datadir}/gtk-doc/html/*
170%doc %{_mandir}/man1/*
171%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
172%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
173%{_datadir}/bash-completion/completions/gresource
174
175%if %{build_compat32}
176%files -n compat32-%{name}
177%defattr(-, root, root)
178%{_libdir}/libglib-2.0.so.*
179%{_libdir}/libgthread-2.0.so.*
180%{_libdir}/libgmodule-2.0.so.*
181%{_libdir}/libgobject-2.0.so.*
182%{_libdir}/libgio-2.0.so.*
183%{_libdir}/gio/modules/lib*.so
184
185%files -n compat32-%{name}-devel
186%defattr(-, root, root)
187%{_libdir}/lib*.so
188%{_libdir}/lib*.a
189%{_libdir}/glib-2.0
190%endif
191
192%changelog
193* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
194- new upstream release
195
196* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
197- new upstream release
198
199* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
200- new upstream release
201
202* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
203- new upstream release
204
205* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
206- rebuild with libffi-3.0.13
207
208* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
209- new upstream release
210
211* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
212- new upstream release
213
214* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
215- new upstream release
216
217* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
218- new upstream release
219- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
220
221* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
222- new upstream release
223- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
224
225* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
226- new upstream release
227
228* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
229- new upstream release
230
231* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
232- new upstream release
233
234* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
235- new upstream release
236
237* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
238- new upstream release
239
240* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
241- new upstream release
242
243* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
244- new upstream release
245
246* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
247- new upstream release
248
249* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
250- new upstream release
251
252* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
253- new upstream release
254- add BuildRequires: python-devel
255- add Patch0 (glib-2.32.1-dconf-path.patch)
256
257* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
258- new upstream release
259
260* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
261- new upstream release
262
263* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
264- new upstream release
265- add Requires: libffi-devel, zlib-devel (-devel sub package)
266
267* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
268- new upstream release
269
270* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
271- new upstream release
272- remove Patch0,1
273
274* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
275- new upstream release
276- Patch0: glib-2.29.16-fixes-bug-656387.patch
277- Patch1: glib-2.29.16-fixes-bug-656675.patch
278
279* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
280- new upstream release
281- add BuildRequires: libffi-devel, dbus-devel
282
283* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
284- new upstream release
285
286* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
287- new upstream release
288
289* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
290- new upstream release
291
292* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
293- new upstream release
294
295* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
296- new upstream release
297
298* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
299- new upstream release
300
301* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
302- new upstream release
303
304* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
305- new upstream release
306
307* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
308- move the following files from glib2-devel to glib2 package
309   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
310
311* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
312- new upstream release
313
314* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
315- new upstream release
316- fix Source (add URL)
317- fix %files to add /etc/bash_completion.d files
318
319* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
320- build with rpm-4.8.1-1 for pkg-config file
321
322* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
323- new upstream release
324
325* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
326- new upstream release
327
328* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
329- new upstream release
330- add BuildRequires: zlib-devel
331
332* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
333- new upstream release
334
335* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
336- new upstream release
337
338* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
339- new upstream release
340
341* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
342- new upstream release
343
344* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
345- new upstream release
346
347* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
348- new upstream release
349
350* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
351- new upstream release
352
353* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
354- new upstream release
355
356* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
357- new upstream release
358
359* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
360- new upstream release
361
362* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
363- new upstream release
364
365* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
366- new upstream release
367
368* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
369- new upstream release
370
371* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
372- new upstream release
373
374* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
375- new upstream release
376
377* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
378- new upstream release
379
380* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
381- updated %%if %%{build_compat32} case related statements
382
383* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
384- new upstream release
385- removed lib*.la files from devel package
386
387* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
388- new upstream release
389
390* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
391- added %%{?_dist_release}
392- BuildRequires: gamin-devel
393
394* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
395- new upstream release
396
397* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
398- new upstream release
399
400* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
401- new upstream release
402
403* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
404- new upstream release
405
406* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
407- new upstream release
408- removed BuildRequires: automake17
409
410* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
411- new upstream release
412
413* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
414- new upstream release
415
416* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
417- new upstream release
418
419* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
420- rebuild with new environment
421
422* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
423- new upstream release
424
425* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
426- new upstream release
427
428* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
429- new upstream release
430
431* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
432- new upstream release
433
434* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
435- new upstream release
436
437* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
438- new upstream release
439
440* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
441- new upstream release
442
443* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
444- rebuild
445
446* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
447- update glib2.{sh,csh}
448  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
449
450* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
451- new upstream release
452
453* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
454- new upstream release
455
456* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
457- new upstream release
458
459* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
460- new upstream release
461
462* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
463- added compat32-* packages for x86_64 architecture support
464- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
465
466* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
467- new upstream release
468
469* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
470- new upstream release
471
472* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
473- new upstream release
474
475* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
476- new upstream release
477
478* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
479- fixed typo in glib2.csh
480
481* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
482- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
483  G_BROKEN_FILENAMES.
484
485* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
486- new upstream release
487
488* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
489- new upstream release
490
491* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
492- new upstream release
493
494* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
495- new upstream release
496
497* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
498- new upstream release
499
500* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
501- new upstream release
502- add *.la to build arts (should be fixed in arts?)
503
504* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
505- new upstream release
506
507* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
508- new upstream release
509
510* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
511- new upstream release
512
513* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
514- new upstream release
515
516* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
517- new upstream release
518
519* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
520- rebuilt
521
522* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
523- new upstream release
524
525* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
526- new upstream release
527
528* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
529- new upstream release
530
531* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
532- new upstream release
533
534* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
535- new upstream release
536
537* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
538- new upstream release
539
540* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
541- new upstream release
542
543* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
544- rebuild with new toolchain
545
546* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
547- new upstream release
548
549* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
550- new upstream release
551
552* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
553- new upstream release
554
555* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
556- new upstream release
557
558* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
559- new upstream release
560- build for Vine Linux
561
562* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
563- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
564- blow away unpackaged files in install
565
566* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
567- Version 2.0.6
568- Remove fixed-ltmain.sh; shouldn't be needed any more.
569
570* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
571- automated rebuild
572
573* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
574- 2.0.4
575
576* Thu May 23 2002 Tim Powers <timp@redhat.com>
577- automated rebuild
578
579* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
580 - rebuild in different environment
581
582* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
583- Fix missing .po files (#63336)
584
585* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
586- Update to version 2.0.1
587
588* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
589- Version 2.0.0
590
591* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
592- Update to 1.3.15
593
594* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
595- Bump for rebuild
596
597* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
598- Update to 1.3.14
599
600* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
601- add horrible buildrequires hack
602
603* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
604- 1.3.13.91 cvs snap
605
606* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
607- rebuild from CVS snapshot
608- use setup -q
609
610* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
611- rebuild
612
613* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
614- 1.3.13
615
616* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
617- attempting rebuild in rawhide
618
619* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
620- remove 64-bit patch now upstream, 1.3.12.90
621
622* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
623- add some missing files to file list, langify
624
625* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
626- add temporary patch to fix GTypeFundamentals on 64-bit
627
628* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
629- Version 1.3.11
630
631* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
632- Version 1.3.10
633
634* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
635- Version 1.3.9
636
637* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
638- Version 1.3.8
639
640* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
641- Make -devel package require main package (#45388)
642- Fix description and summary
643- Configure with --disable-gtk-doc
644
645* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
646- add some portability fixes needed at least on s390
647- copy config.{guess,sub} instead of calling libtoolize
648
649* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
650- try a new glib tarball with Makefile changes to work around
651  libtool linking to installed .la files
652- make -devel require pkgconfig
653
654* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
655- either libtool or the bad libtool hacks caused link
656  against glib-gobject 1.3.2, rebuild
657
658* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
659- 1.3.6
660- bad libtool workarounds
661
662* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
663- 1.3.5, rename to glib2
664
665* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
666- Final 1.3.2
667
668* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
669- Version 1.3.2pre1
670- Remove pkgconfig
671
672* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
673- Call 1.3.1b instead of snap... the snap* naming doesn't
674  order correctly.
675
676* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
677- new snapshot with fixed .pc files
678
679* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
680- include .pc files in file list
681
682* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
683- Include pkg-config
684- Upgrade to a glib CVS snapshot
685
686* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
687- rebuild to cope with glibc locale binary incompatibility
688
689* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
690- Remove glib-config.1 manpage from build since
691  it conflicts with glib-devel. When we go to
692  glib glib1.2 setup, we should add it back
693
694* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
695- Version 1.3.1
696- Move back to standard %{prefix}
697
698* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
699- Rebuild in /opt/gtk-beta
700
701* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
702- New version (adds gobject)
703
704* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
705- Don't blow away /etc/ld.so.conf (sorry!)
706
707* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
708- Snapshot RPM for Pango testing
709
710* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
711- Added fixes from stable branch of CVS
712
713* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
714- version 1.2.6
715
716* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
717- version 1.2.5
718
719* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
720- version 1.2.4
721
722* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
723- version 1.2.3
724
725* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
726- version 1.2.1
727
728* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
729- Version 1.2
730
731* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
732- version 1.2.0pre1
733
734* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
735- new description tags
736
737* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
738- removed libtoolize from %build
739
740* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
741- added libgthread to file list
742
743* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
744- version 1.1.15
745
746* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
747- version 1.1.14
748
749* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
750- version 1.1.13
751
752* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
753- version 1.1.12
754
755* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
756- updated in preparation for the GNOME freeze
757
758* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
759- Split out glib package
760
Note: See TracBrowser for help on using the repository browser.