source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 9092

Revision 9092, 21.4 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of handy utility functions.
4Name: glib2
5Version: 2.42.1
6Release: 1%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.42/glib-%{version}.tar.xz
10Source2: glib2.sh
11Source3: glib2.csh
12
13Patch0: glib-2.32.1-dconf-path.patch
14
15BuildRoot: %{_tmppath}/glib-%{version}-root
16
17BuildRequires: pkgconfig >= 0.14
18BuildRequires: dbus-devel
19BuildRequires: gamin-devel
20BuildRequires: libffi-devel
21BuildRequires: zlib-devel
22BuildRequires: python-devel
23BuildRequires: gtk-doc
24Obsoletes: glib-gtkbeta
25URL: http://www.gtk.org
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
30
31%description
32GLib is the low-level core library that forms the basis
33for projects such as GTK+ and GNOME. It provides data structure
34handling for C, portability wrappers, and interfaces for such runtime
35functionality as an event loop, threads, dynamic loading, and an
36object system.
37
38This package provides version 2.42 of GLib.
39
40%package devel
41Summary: Development files for the GLib library
42Group: Development/Libraries
43Requires: %{name} = %{version}
44Requires: pkgconfig >= 0.14
45Requires: libffi-devel
46Requires: zlib-devel
47
48Obsoletes: glib-gtkbeta-devel
49Conflicts: glib-devel <= 1.2.8
50
51%description devel
52The glib-devel package includes the header files for
53version 2.42 of the GLib library.
54
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary: A library of handy utility functions.
59Group: System Environment/Libraries
60
61%description -n compat32-%{name}
62GLib is the low-level core library that forms the basis
63for projects such as GTK+ and GNOME. It provides data structure
64handling for C, portability wrappers, and interfaces for such runtime
65functionality as an event loop, threads, dynamic loading, and an
66object system.
67
68This package provides version 2.42 of GLib.
69
70%package -n compat32-%{name}-devel
71Summary: Development files for the GLib library
72Group: Development/Libraries
73Requires: pkgconfig >= 0.14
74Requires: compat32-%{name} = %{version}
75
76Conflicts: glib-devel <= 1.2.8
77
78%description -n compat32-%{name}-devel
79The glib-devel package includes the header files for
80version 2.42 of the GLib library.
81
82
83%prep
84%setup -q -n glib-%{version}
85%patch0 -p1
86
87%build
88NOCONFIGURE=1 ./autogen.sh
89%configure --disable-selinux --enable-static --enable-systemtap
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
96make install DESTDIR=$RPM_BUILD_ROOT
97
98## glib2.sh and glib2.csh
99mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
103#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
120
121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
133%{_bindir}/gapplication
134%{_bindir}/gdbus
135%{_bindir}/gio-querymodules
136%{_bindir}/glib-compile-schemas
137%{_bindir}/gsettings
138%{_libdir}/libglib-2.0.so.*
139%{_libdir}/libgthread-2.0.so.*
140%{_libdir}/libgmodule-2.0.so.*
141%{_libdir}/libgobject-2.0.so.*
142%{_libdir}/libgio-2.0.so.*
143%{_libdir}/gio/modules/lib*.so
144%{_sysconfdir}/profile.d/*
145%{_datadir}/bash-completion/completions/gapplication
146%{_datadir}/bash-completion/completions/gdbus
147%{_datadir}/bash-completion/completions/gsettings
148
149%files devel
150%defattr(-, root, root)
151%{_bindir}/gdbus-codegen
152%{_bindir}/glib-compile-resources
153%{_bindir}/glib-genmarshal
154%{_bindir}/glib-gettextize
155%{_bindir}/glib-mkenums
156%{_bindir}/gobject-query
157%{_bindir}/gresource
158%{_bindir}/gtester
159%{_bindir}/gtester-report
160%{_libdir}/lib*.so
161%{_libdir}/lib*.a
162#%{_libdir}/gdbus-2.0/codegen/*
163%{_libdir}/glib-2.0
164%{_libdir}/pkgconfig/*
165#%{python_sitearch}/codegen
166%{_includedir}/*
167%{_datadir}/aclocal/*
168%{_datadir}/glib-2.0
169%doc %{_datadir}/gtk-doc/html/*
170%doc %{_mandir}/man1/*
171%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
172%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
173%{_datadir}/bash-completion/completions/gresource
174
175%if %{build_compat32}
176%files -n compat32-%{name}
177%defattr(-, root, root)
178%{_libdir}/libglib-2.0.so.*
179%{_libdir}/libgthread-2.0.so.*
180%{_libdir}/libgmodule-2.0.so.*
181%{_libdir}/libgobject-2.0.so.*
182%{_libdir}/libgio-2.0.so.*
183%{_libdir}/gio/modules/lib*.so
184
185%files -n compat32-%{name}-devel
186%defattr(-, root, root)
187%{_libdir}/lib*.so
188%{_libdir}/lib*.a
189%{_libdir}/glib-2.0
190%endif
191
192%changelog
193* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
194- new upstream release
195
196* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
197- new upstream release
198
199* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
200- rebuild with libffi-3.0.13
201
202* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
203- new upstream release
204
205* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
206- new upstream release
207
208* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
209- new upstream release
210
211* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
212- new upstream release
213- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
214
215* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
216- new upstream release
217- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
218
219* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
220- new upstream release
221
222* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
223- new upstream release
224
225* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
226- new upstream release
227
228* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
229- new upstream release
230
231* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
232- new upstream release
233
234* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
235- new upstream release
236
237* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
238- new upstream release
239
240* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
241- new upstream release
242
243* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
244- new upstream release
245
246* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
247- new upstream release
248- add BuildRequires: python-devel
249- add Patch0 (glib-2.32.1-dconf-path.patch)
250
251* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
252- new upstream release
253
254* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
255- new upstream release
256
257* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
258- new upstream release
259- add Requires: libffi-devel, zlib-devel (-devel sub package)
260
261* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
262- new upstream release
263
264* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
265- new upstream release
266- remove Patch0,1
267
268* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
269- new upstream release
270- Patch0: glib-2.29.16-fixes-bug-656387.patch
271- Patch1: glib-2.29.16-fixes-bug-656675.patch
272
273* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
274- new upstream release
275- add BuildRequires: libffi-devel, dbus-devel
276
277* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
278- new upstream release
279
280* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
281- new upstream release
282
283* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
284- new upstream release
285
286* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
287- new upstream release
288
289* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
290- new upstream release
291
292* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
293- new upstream release
294
295* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
296- new upstream release
297
298* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
299- new upstream release
300
301* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
302- move the following files from glib2-devel to glib2 package
303   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
304
305* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
306- new upstream release
307
308* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
309- new upstream release
310- fix Source (add URL)
311- fix %files to add /etc/bash_completion.d files
312
313* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
314- build with rpm-4.8.1-1 for pkg-config file
315
316* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
317- new upstream release
318
319* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
320- new upstream release
321
322* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
323- new upstream release
324- add BuildRequires: zlib-devel
325
326* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
327- new upstream release
328
329* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
330- new upstream release
331
332* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
333- new upstream release
334
335* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
336- new upstream release
337
338* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
339- new upstream release
340
341* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
342- new upstream release
343
344* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
345- new upstream release
346
347* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
348- new upstream release
349
350* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
351- new upstream release
352
353* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
354- new upstream release
355
356* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
357- new upstream release
358
359* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
360- new upstream release
361
362* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
363- new upstream release
364
365* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
366- new upstream release
367
368* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
369- new upstream release
370
371* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
372- new upstream release
373
374* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
375- updated %%if %%{build_compat32} case related statements
376
377* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
378- new upstream release
379- removed lib*.la files from devel package
380
381* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
382- new upstream release
383
384* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
385- added %%{?_dist_release}
386- BuildRequires: gamin-devel
387
388* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
389- new upstream release
390
391* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
392- new upstream release
393
394* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
395- new upstream release
396
397* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
398- new upstream release
399
400* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
401- new upstream release
402- removed BuildRequires: automake17
403
404* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
405- new upstream release
406
407* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
408- new upstream release
409
410* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
411- new upstream release
412
413* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
414- rebuild with new environment
415
416* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
417- new upstream release
418
419* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
420- new upstream release
421
422* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
423- new upstream release
424
425* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
426- new upstream release
427
428* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
429- new upstream release
430
431* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
432- new upstream release
433
434* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
435- new upstream release
436
437* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
438- rebuild
439
440* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
441- update glib2.{sh,csh}
442  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
443
444* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
445- new upstream release
446
447* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
448- new upstream release
449
450* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
451- new upstream release
452
453* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
454- new upstream release
455
456* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
457- added compat32-* packages for x86_64 architecture support
458- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
459
460* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
461- new upstream release
462
463* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
464- new upstream release
465
466* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
467- new upstream release
468
469* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
470- new upstream release
471
472* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
473- fixed typo in glib2.csh
474
475* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
476- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
477  G_BROKEN_FILENAMES.
478
479* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
480- new upstream release
481
482* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
483- new upstream release
484
485* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
486- new upstream release
487
488* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
489- new upstream release
490
491* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
492- new upstream release
493
494* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
495- new upstream release
496- add *.la to build arts (should be fixed in arts?)
497
498* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
499- new upstream release
500
501* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
502- new upstream release
503
504* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
505- new upstream release
506
507* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
508- new upstream release
509
510* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
511- new upstream release
512
513* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
514- rebuilt
515
516* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
517- new upstream release
518
519* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
520- new upstream release
521
522* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
523- new upstream release
524
525* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
526- new upstream release
527
528* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
529- new upstream release
530
531* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
532- new upstream release
533
534* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
535- new upstream release
536
537* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
538- rebuild with new toolchain
539
540* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
541- new upstream release
542
543* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
544- new upstream release
545
546* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
547- new upstream release
548
549* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
550- new upstream release
551
552* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
553- new upstream release
554- build for Vine Linux
555
556* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
557- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
558- blow away unpackaged files in install
559
560* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
561- Version 2.0.6
562- Remove fixed-ltmain.sh; shouldn't be needed any more.
563
564* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
565- automated rebuild
566
567* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
568- 2.0.4
569
570* Thu May 23 2002 Tim Powers <timp@redhat.com>
571- automated rebuild
572
573* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
574 - rebuild in different environment
575
576* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
577- Fix missing .po files (#63336)
578
579* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
580- Update to version 2.0.1
581
582* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
583- Version 2.0.0
584
585* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
586- Update to 1.3.15
587
588* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
589- Bump for rebuild
590
591* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
592- Update to 1.3.14
593
594* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
595- add horrible buildrequires hack
596
597* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
598- 1.3.13.91 cvs snap
599
600* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
601- rebuild from CVS snapshot
602- use setup -q
603
604* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
605- rebuild
606
607* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
608- 1.3.13
609
610* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
611- attempting rebuild in rawhide
612
613* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
614- remove 64-bit patch now upstream, 1.3.12.90
615
616* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
617- add some missing files to file list, langify
618
619* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
620- add temporary patch to fix GTypeFundamentals on 64-bit
621
622* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
623- Version 1.3.11
624
625* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
626- Version 1.3.10
627
628* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
629- Version 1.3.9
630
631* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
632- Version 1.3.8
633
634* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
635- Make -devel package require main package (#45388)
636- Fix description and summary
637- Configure with --disable-gtk-doc
638
639* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
640- add some portability fixes needed at least on s390
641- copy config.{guess,sub} instead of calling libtoolize
642
643* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
644- try a new glib tarball with Makefile changes to work around
645  libtool linking to installed .la files
646- make -devel require pkgconfig
647
648* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
649- either libtool or the bad libtool hacks caused link
650  against glib-gobject 1.3.2, rebuild
651
652* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
653- 1.3.6
654- bad libtool workarounds
655
656* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
657- 1.3.5, rename to glib2
658
659* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
660- Final 1.3.2
661
662* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
663- Version 1.3.2pre1
664- Remove pkgconfig
665
666* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
667- Call 1.3.1b instead of snap... the snap* naming doesn't
668  order correctly.
669
670* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
671- new snapshot with fixed .pc files
672
673* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
674- include .pc files in file list
675
676* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
677- Include pkg-config
678- Upgrade to a glib CVS snapshot
679
680* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
681- rebuild to cope with glibc locale binary incompatibility
682
683* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
684- Remove glib-config.1 manpage from build since
685  it conflicts with glib-devel. When we go to
686  glib glib1.2 setup, we should add it back
687
688* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
689- Version 1.3.1
690- Move back to standard %{prefix}
691
692* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
693- Rebuild in /opt/gtk-beta
694
695* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
696- New version (adds gobject)
697
698* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
699- Don't blow away /etc/ld.so.conf (sorry!)
700
701* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
702- Snapshot RPM for Pango testing
703
704* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
705- Added fixes from stable branch of CVS
706
707* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
708- version 1.2.6
709
710* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
711- version 1.2.5
712
713* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
714- version 1.2.4
715
716* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
717- version 1.2.3
718
719* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
720- version 1.2.1
721
722* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
723- Version 1.2
724
725* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
726- version 1.2.0pre1
727
728* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
729- new description tags
730
731* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
732- removed libtoolize from %build
733
734* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
735- added libgthread to file list
736
737* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
738- version 1.1.15
739
740* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
741- version 1.1.14
742
743* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
744- version 1.1.13
745
746* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
747- version 1.1.12
748
749* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
750- updated in preparation for the GNOME freeze
751
752* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
753- Split out glib package
754
Note: See TracBrowser for help on using the repository browser.