source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 8011

Revision 8011, 21.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of handy utility functions.
4Name: glib2
5Version: 2.38.2
6Release: 1%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.38/glib-%{version}.tar.xz
10Source2: glib2.sh
11Source3: glib2.csh
12
13Patch0: glib-2.32.1-dconf-path.patch
14
15BuildRoot: %{_tmppath}/glib-%{version}-root
16
17BuildRequires: pkgconfig >= 0.14
18BuildRequires: dbus-devel
19BuildRequires: gamin-devel
20BuildRequires: libffi-devel
21BuildRequires: zlib-devel
22BuildRequires: python-devel
23BuildRequires: gtk-doc
24Obsoletes: glib-gtkbeta
25URL: http://www.gtk.org
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
30
31%description
32GLib is the low-level core library that forms the basis
33for projects such as GTK+ and GNOME. It provides data structure
34handling for C, portability wrappers, and interfaces for such runtime
35functionality as an event loop, threads, dynamic loading, and an
36object system.
37
38This package provides version 2.38 of GLib.
39
40%package devel
41Summary: Development files for the GLib library
42Group: Development/Libraries
43Requires: %{name} = %{version}
44Requires: pkgconfig >= 0.14
45Requires: libffi-devel
46Requires: zlib-devel
47
48Obsoletes: glib-gtkbeta-devel
49Conflicts: glib-devel <= 1.2.8
50
51%description devel
52The glib-devel package includes the header files for
53version 2.38 of the GLib library.
54
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary: A library of handy utility functions.
59Group: System Environment/Libraries
60
61%description -n compat32-%{name}
62GLib is the low-level core library that forms the basis
63for projects such as GTK+ and GNOME. It provides data structure
64handling for C, portability wrappers, and interfaces for such runtime
65functionality as an event loop, threads, dynamic loading, and an
66object system.
67
68This package provides version 2.38 of GLib.
69
70%package -n compat32-%{name}-devel
71Summary: Development files for the GLib library
72Group: Development/Libraries
73Requires: pkgconfig >= 0.14
74Requires: compat32-%{name} = %{version}
75
76Conflicts: glib-devel <= 1.2.8
77
78%description -n compat32-%{name}-devel
79The glib-devel package includes the header files for
80version 2.38 of the GLib library.
81
82
83%prep
84%setup -q -n glib-%{version}
85%patch0 -p1
86
87%build
88NOCONFIGURE=1 ./autogen.sh
89%configure --disable-selinux --enable-static --enable-systemtap
90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
96make install DESTDIR=$RPM_BUILD_ROOT
97
98## glib2.sh and glib2.csh
99mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
103#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
120
121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
133%{_bindir}/gdbus
134%{_bindir}/gio-querymodules
135%{_bindir}/glib-compile-schemas
136%{_bindir}/gsettings
137%{_libdir}/libglib-2.0.so.*
138%{_libdir}/libgthread-2.0.so.*
139%{_libdir}/libgmodule-2.0.so.*
140%{_libdir}/libgobject-2.0.so.*
141%{_libdir}/libgio-2.0.so.*
142%{_libdir}/gio/modules/lib*.so
143%{_sysconfdir}/profile.d/*
144%{_datadir}/bash-completion/completions/gdbus
145%{_datadir}/bash-completion/completions/gsettings
146
147%files devel
148%defattr(-, root, root)
149%{_bindir}/gdbus-codegen
150%{_bindir}/glib-compile-resources
151%{_bindir}/glib-genmarshal
152%{_bindir}/glib-gettextize
153%{_bindir}/glib-mkenums
154%{_bindir}/gobject-query
155%{_bindir}/gresource
156%{_bindir}/gtester
157%{_bindir}/gtester-report
158%{_libdir}/lib*.so
159%{_libdir}/lib*.a
160#%{_libdir}/gdbus-2.0/codegen/*
161%{_libdir}/glib-2.0
162%{_libdir}/pkgconfig/*
163#%{python_sitearch}/codegen
164%{_includedir}/*
165%{_datadir}/aclocal/*
166%{_datadir}/glib-2.0
167%doc %{_datadir}/gtk-doc/html/*
168%doc %{_mandir}/man1/*
169%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
170%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
171%{_datadir}/bash-completion/completions/gresource
172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-, root, root)
176%{_libdir}/libglib-2.0.so.*
177%{_libdir}/libgthread-2.0.so.*
178%{_libdir}/libgmodule-2.0.so.*
179%{_libdir}/libgobject-2.0.so.*
180%{_libdir}/libgio-2.0.so.*
181%{_libdir}/gio/modules/lib*.so
182
183%files -n compat32-%{name}-devel
184%defattr(-, root, root)
185%{_libdir}/lib*.so
186%{_libdir}/lib*.a
187%{_libdir}/glib-2.0
188%endif
189
190%changelog
191* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
192- new upstream release
193
194* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
195- new upstream release
196
197* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
198- new upstream release
199- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
200
201* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
202- new upstream release
203- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
204
205* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
206- new upstream release
207
208* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
209- new upstream release
210
211* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
212- new upstream release
213
214* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
215- new upstream release
216
217* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
218- new upstream release
219
220* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
221- new upstream release
222
223* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
224- new upstream release
225
226* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
227- new upstream release
228
229* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
230- new upstream release
231
232* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
233- new upstream release
234- add BuildRequires: python-devel
235- add Patch0 (glib-2.32.1-dconf-path.patch)
236
237* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
238- new upstream release
239
240* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
241- new upstream release
242
243* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
244- new upstream release
245- add Requires: libffi-devel, zlib-devel (-devel sub package)
246
247* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
248- new upstream release
249
250* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
251- new upstream release
252- remove Patch0,1
253
254* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
255- new upstream release
256- Patch0: glib-2.29.16-fixes-bug-656387.patch
257- Patch1: glib-2.29.16-fixes-bug-656675.patch
258
259* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
260- new upstream release
261- add BuildRequires: libffi-devel, dbus-devel
262
263* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
264- new upstream release
265
266* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
267- new upstream release
268
269* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
270- new upstream release
271
272* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
273- new upstream release
274
275* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
276- new upstream release
277
278* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
279- new upstream release
280
281* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
282- new upstream release
283
284* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
285- new upstream release
286
287* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
288- move the following files from glib2-devel to glib2 package
289   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
290
291* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
292- new upstream release
293
294* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
295- new upstream release
296- fix Source (add URL)
297- fix %files to add /etc/bash_completion.d files
298
299* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
300- build with rpm-4.8.1-1 for pkg-config file
301
302* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
303- new upstream release
304
305* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
306- new upstream release
307
308* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
309- new upstream release
310- add BuildRequires: zlib-devel
311
312* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
313- new upstream release
314
315* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
316- new upstream release
317
318* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
319- new upstream release
320
321* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
322- new upstream release
323
324* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
325- new upstream release
326
327* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
328- new upstream release
329
330* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
331- new upstream release
332
333* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
334- new upstream release
335
336* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
337- new upstream release
338
339* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
340- new upstream release
341
342* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
343- new upstream release
344
345* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
346- new upstream release
347
348* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
349- new upstream release
350
351* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
352- new upstream release
353
354* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
355- new upstream release
356
357* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
358- new upstream release
359
360* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
361- updated %%if %%{build_compat32} case related statements
362
363* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
364- new upstream release
365- removed lib*.la files from devel package
366
367* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
368- new upstream release
369
370* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
371- added %%{?_dist_release}
372- BuildRequires: gamin-devel
373
374* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
375- new upstream release
376
377* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
378- new upstream release
379
380* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
381- new upstream release
382
383* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
384- new upstream release
385
386* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
387- new upstream release
388- removed BuildRequires: automake17
389
390* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
391- new upstream release
392
393* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
394- new upstream release
395
396* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
397- new upstream release
398
399* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
400- rebuild with new environment
401
402* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
403- new upstream release
404
405* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
406- new upstream release
407
408* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
409- new upstream release
410
411* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
412- new upstream release
413
414* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
415- new upstream release
416
417* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
418- new upstream release
419
420* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
421- new upstream release
422
423* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
424- rebuild
425
426* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
427- update glib2.{sh,csh}
428  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
429
430* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
431- new upstream release
432
433* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
434- new upstream release
435
436* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
437- new upstream release
438
439* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
440- new upstream release
441
442* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
443- added compat32-* packages for x86_64 architecture support
444- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
445
446* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
447- new upstream release
448
449* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
450- new upstream release
451
452* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
453- new upstream release
454
455* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
456- new upstream release
457
458* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
459- fixed typo in glib2.csh
460
461* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
462- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
463  G_BROKEN_FILENAMES.
464
465* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
466- new upstream release
467
468* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
469- new upstream release
470
471* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
472- new upstream release
473
474* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
475- new upstream release
476
477* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
478- new upstream release
479
480* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
481- new upstream release
482- add *.la to build arts (should be fixed in arts?)
483
484* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
485- new upstream release
486
487* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
488- new upstream release
489
490* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
491- new upstream release
492
493* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
494- new upstream release
495
496* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
497- new upstream release
498
499* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
500- rebuilt
501
502* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
503- new upstream release
504
505* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
506- new upstream release
507
508* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
509- new upstream release
510
511* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
512- new upstream release
513
514* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
515- new upstream release
516
517* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
518- new upstream release
519
520* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
521- new upstream release
522
523* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
524- rebuild with new toolchain
525
526* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
527- new upstream release
528
529* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
530- new upstream release
531
532* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
533- new upstream release
534
535* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
536- new upstream release
537
538* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
539- new upstream release
540- build for Vine Linux
541
542* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
543- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
544- blow away unpackaged files in install
545
546* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
547- Version 2.0.6
548- Remove fixed-ltmain.sh; shouldn't be needed any more.
549
550* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
551- automated rebuild
552
553* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
554- 2.0.4
555
556* Thu May 23 2002 Tim Powers <timp@redhat.com>
557- automated rebuild
558
559* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
560 - rebuild in different environment
561
562* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
563- Fix missing .po files (#63336)
564
565* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
566- Update to version 2.0.1
567
568* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
569- Version 2.0.0
570
571* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
572- Update to 1.3.15
573
574* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
575- Bump for rebuild
576
577* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
578- Update to 1.3.14
579
580* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
581- add horrible buildrequires hack
582
583* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
584- 1.3.13.91 cvs snap
585
586* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
587- rebuild from CVS snapshot
588- use setup -q
589
590* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
591- rebuild
592
593* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
594- 1.3.13
595
596* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
597- attempting rebuild in rawhide
598
599* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
600- remove 64-bit patch now upstream, 1.3.12.90
601
602* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
603- add some missing files to file list, langify
604
605* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
606- add temporary patch to fix GTypeFundamentals on 64-bit
607
608* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
609- Version 1.3.11
610
611* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
612- Version 1.3.10
613
614* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
615- Version 1.3.9
616
617* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
618- Version 1.3.8
619
620* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
621- Make -devel package require main package (#45388)
622- Fix description and summary
623- Configure with --disable-gtk-doc
624
625* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
626- add some portability fixes needed at least on s390
627- copy config.{guess,sub} instead of calling libtoolize
628
629* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
630- try a new glib tarball with Makefile changes to work around
631  libtool linking to installed .la files
632- make -devel require pkgconfig
633
634* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
635- either libtool or the bad libtool hacks caused link
636  against glib-gobject 1.3.2, rebuild
637
638* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
639- 1.3.6
640- bad libtool workarounds
641
642* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
643- 1.3.5, rename to glib2
644
645* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
646- Final 1.3.2
647
648* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
649- Version 1.3.2pre1
650- Remove pkgconfig
651
652* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
653- Call 1.3.1b instead of snap... the snap* naming doesn't
654  order correctly.
655
656* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
657- new snapshot with fixed .pc files
658
659* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
660- include .pc files in file list
661
662* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
663- Include pkg-config
664- Upgrade to a glib CVS snapshot
665
666* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
667- rebuild to cope with glibc locale binary incompatibility
668
669* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
670- Remove glib-config.1 manpage from build since
671  it conflicts with glib-devel. When we go to
672  glib glib1.2 setup, we should add it back
673
674* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
675- Version 1.3.1
676- Move back to standard %{prefix}
677
678* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
679- Rebuild in /opt/gtk-beta
680
681* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
682- New version (adds gobject)
683
684* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
685- Don't blow away /etc/ld.so.conf (sorry!)
686
687* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
688- Snapshot RPM for Pango testing
689
690* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
691- Added fixes from stable branch of CVS
692
693* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
694- version 1.2.6
695
696* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
697- version 1.2.5
698
699* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
700- version 1.2.4
701
702* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
703- version 1.2.3
704
705* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
706- version 1.2.1
707
708* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
709- Version 1.2
710
711* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
712- version 1.2.0pre1
713
714* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
715- new description tags
716
717* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
718- removed libtoolize from %build
719
720* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
721- added libgthread to file list
722
723* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
724- version 1.1.15
725
726* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
727- version 1.1.14
728
729* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
730- version 1.1.13
731
732* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
733- version 1.1.12
734
735* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
736- updated in preparation for the GNOME freeze
737
738* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
739- Split out glib package
740
Note: See TracBrowser for help on using the repository browser.