source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 5168

Revision 5168, 19.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of handy utility functions.
4Name: glib2
5Version: 2.30.2
6Release: 1%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.30/glib-%{version}.tar.xz
10Source2: glib2.sh
11Source3: glib2.csh
12
13BuildRoot: %{_tmppath}/glib-%{version}-root
14
15BuildRequires: pkgconfig >= 0.14
16BuildRequires: dbus-devel
17BuildRequires: gamin-devel
18BuildRequires: libffi-devel
19BuildRequires: zlib-devel
20BuildRequires: gtk-doc
21Obsoletes: glib-gtkbeta
22URL: http://www.gtk.org
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
27
28%description
29GLib is the low-level core library that forms the basis
30for projects such as GTK+ and GNOME. It provides data structure
31handling for C, portability wrappers, and interfaces for such runtime
32functionality as an event loop, threads, dynamic loading, and an
33object system.
34
35This package provides version 2.30 of GLib.
36
37%package devel
38Summary: Development files for the GLib library
39Group: Development/Libraries
40Requires: %{name} = %{version}
41Requires: pkgconfig >= 0.14
42Requires: libffi-devel
43Requires: zlib-devel
44
45Obsoletes: glib-gtkbeta-devel
46Conflicts: glib-devel <= 1.2.8
47
48%description devel
49The glib-devel package includes the header files for
50version 2.30 of the GLib library.
51
52
53## to build compat32 for x86_64 architecture support
54%package -n compat32-%{name}
55Summary: A library of handy utility functions.
56Group: System Environment/Libraries
57
58%description -n compat32-%{name}
59GLib is the low-level core library that forms the basis
60for projects such as GTK+ and GNOME. It provides data structure
61handling for C, portability wrappers, and interfaces for such runtime
62functionality as an event loop, threads, dynamic loading, and an
63object system.
64
65This package provides version 2.30 of GLib.
66
67%package -n compat32-%{name}-devel
68Summary: Development files for the GLib library
69Group: Development/Libraries
70Requires: pkgconfig >= 0.14
71Requires: compat32-%{name} = %{version}
72
73Conflicts: glib-devel <= 1.2.8
74
75%description -n compat32-%{name}-devel
76The glib-devel package includes the header files for
77version 2.30 of the GLib library.
78
79%prep
80%setup -q -n glib-%{version}
81
82%build
83%configure --disable-selinux --enable-static
84make %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89mkdir -p $RPM_BUILD_ROOT%{_bindir}
90%makeinstall
91
92## glib2.sh and glib2.csh
93./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
94install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
95install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
96
97rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
98rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
99rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
100
101%find_lang glib20
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%post -n compat32-%{name} -p /sbin/ldconfig
111
112%postun -n compat32-%{name} -p /sbin/ldconfig
113
114
115%files -f glib20.lang
116%defattr(-, root, root)
117%doc AUTHORS COPYING ChangeLog NEWS README
118%{_bindir}/gdbus
119%{_bindir}/gio-querymodules
120%{_bindir}/glib-compile-schemas
121%{_bindir}/gsettings
122%{_libdir}/libglib-2.0.so.*
123%{_libdir}/libgthread-2.0.so.*
124%{_libdir}/libgmodule-2.0.so.*
125%{_libdir}/libgobject-2.0.so.*
126%{_libdir}/libgio-2.0.so.*
127%{_libdir}/gdbus-2.0/codegen/*
128%{_libdir}/gio/modules/lib*.so
129%{_sysconfdir}/profile.d/*
130%{_sysconfdir}/bash_completion.d/*
131
132%files devel
133%defattr(-, root, root)
134%{_bindir}/gdbus-codegen
135%{_bindir}/glib-genmarshal
136%{_bindir}/glib-gettextize
137%{_bindir}/glib-mkenums
138%{_bindir}/gobject-query
139%{_bindir}/gtester
140%{_bindir}/gtester-report
141%{_libdir}/lib*.so
142%{_libdir}/lib*.a
143%{_libdir}/glib-2.0
144%{_includedir}/*
145%{_datadir}/aclocal/*
146%{_libdir}/pkgconfig/*
147%{_datadir}/glib-2.0
148%doc %{_datadir}/gtk-doc/html/*
149%doc %{_mandir}/man1/*
150%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
151%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
152
153%if %{build_compat32}
154%files -n compat32-%{name}
155%defattr(-, root, root)
156%{_libdir}/libglib-2.0.so.*
157%{_libdir}/libgthread-2.0.so.*
158%{_libdir}/libgmodule-2.0.so.*
159%{_libdir}/libgobject-2.0.so.*
160%{_libdir}/libgio-2.0.so.*
161%{_libdir}/gio/modules/lib*.so
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/lib*.so
166%{_libdir}/lib*.a
167%{_libdir}/glib-2.0
168%{_libdir}/pkgconfig/*
169%endif
170
171%changelog
172* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
173- new upstream release
174
175* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
176- new upstream release
177
178* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
179- new upstream release
180- add Requires: libffi-devel, zlib-devel (-devel sub package)
181
182* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
183- new upstream release
184
185* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
186- new upstream release
187- remove Patch0,1
188
189* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
190- new upstream release
191- Patch0: glib-2.29.16-fixes-bug-656387.patch
192- Patch1: glib-2.29.16-fixes-bug-656675.patch
193
194* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
195- new upstream release
196- add BuildRequires: libffi-devel, dbus-devel
197
198* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
199- new upstream release
200
201* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
202- new upstream release
203
204* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
205- new upstream release
206
207* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
208- new upstream release
209
210* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
211- new upstream release
212
213* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
214- new upstream release
215
216* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
217- new upstream release
218
219* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
220- new upstream release
221
222* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
223- move the following files from glib2-devel to glib2 package
224   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
225
226* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
227- new upstream release
228
229* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
230- new upstream release
231- fix Source (add URL)
232- fix %files to add /etc/bash_completion.d files
233
234* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
235- build with rpm-4.8.1-1 for pkg-config file
236
237* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
238- new upstream release
239
240* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
241- new upstream release
242
243* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
244- new upstream release
245- add BuildRequires: zlib-devel
246
247* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
248- new upstream release
249
250* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
251- new upstream release
252
253* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
254- new upstream release
255
256* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
257- new upstream release
258
259* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
260- new upstream release
261
262* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
263- new upstream release
264
265* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
266- new upstream release
267
268* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
269- new upstream release
270
271* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
272- new upstream release
273
274* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
275- new upstream release
276
277* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
278- new upstream release
279
280* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
281- new upstream release
282
283* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
284- new upstream release
285
286* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
287- new upstream release
288
289* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
290- new upstream release
291
292* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
293- new upstream release
294
295* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
296- updated %%if %%{build_compat32} case related statements
297
298* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
299- new upstream release
300- removed lib*.la files from devel package
301
302* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
303- new upstream release
304
305* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
306- added %%{?_dist_release}
307- BuildRequires: gamin-devel
308
309* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
310- new upstream release
311
312* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
313- new upstream release
314
315* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
316- new upstream release
317
318* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
319- new upstream release
320
321* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
322- new upstream release
323- removed BuildRequires: automake17
324
325* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
326- new upstream release
327
328* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
329- new upstream release
330
331* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
332- new upstream release
333
334* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
335- rebuild with new environment
336
337* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
338- new upstream release
339
340* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
341- new upstream release
342
343* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
344- new upstream release
345
346* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
347- new upstream release
348
349* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
350- new upstream release
351
352* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
353- new upstream release
354
355* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
356- new upstream release
357
358* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
359- rebuild
360
361* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
362- update glib2.{sh,csh}
363  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
364
365* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
366- new upstream release
367
368* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
369- new upstream release
370
371* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
372- new upstream release
373
374* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
375- new upstream release
376
377* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
378- added compat32-* packages for x86_64 architecture support
379- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
380
381* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
382- new upstream release
383
384* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
385- new upstream release
386
387* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
388- new upstream release
389
390* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
391- new upstream release
392
393* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
394- fixed typo in glib2.csh
395
396* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
397- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
398  G_BROKEN_FILENAMES.
399
400* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
401- new upstream release
402
403* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
404- new upstream release
405
406* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
407- new upstream release
408
409* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
410- new upstream release
411
412* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
413- new upstream release
414
415* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
416- new upstream release
417- add *.la to build arts (should be fixed in arts?)
418
419* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
420- new upstream release
421
422* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
423- new upstream release
424
425* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
426- new upstream release
427
428* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
429- new upstream release
430
431* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
432- new upstream release
433
434* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
435- rebuilt
436
437* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
438- new upstream release
439
440* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
441- new upstream release
442
443* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
444- new upstream release
445
446* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
447- new upstream release
448
449* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
450- new upstream release
451
452* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
453- new upstream release
454
455* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
456- new upstream release
457
458* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
459- rebuild with new toolchain
460
461* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
462- new upstream release
463
464* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
465- new upstream release
466
467* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
468- new upstream release
469
470* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
471- new upstream release
472
473* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
474- new upstream release
475- build for Vine Linux
476
477* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
478- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
479- blow away unpackaged files in install
480
481* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
482- Version 2.0.6
483- Remove fixed-ltmain.sh; shouldn't be needed any more.
484
485* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
486- automated rebuild
487
488* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
489- 2.0.4
490
491* Thu May 23 2002 Tim Powers <timp@redhat.com>
492- automated rebuild
493
494* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
495 - rebuild in different environment
496
497* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
498- Fix missing .po files (#63336)
499
500* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
501- Update to version 2.0.1
502
503* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
504- Version 2.0.0
505
506* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
507- Update to 1.3.15
508
509* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
510- Bump for rebuild
511
512* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
513- Update to 1.3.14
514
515* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
516- add horrible buildrequires hack
517
518* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
519- 1.3.13.91 cvs snap
520
521* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
522- rebuild from CVS snapshot
523- use setup -q
524
525* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
526- rebuild
527
528* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
529- 1.3.13
530
531* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
532- attempting rebuild in rawhide
533
534* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
535- remove 64-bit patch now upstream, 1.3.12.90
536
537* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
538- add some missing files to file list, langify
539
540* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
541- add temporary patch to fix GTypeFundamentals on 64-bit
542
543* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
544- Version 1.3.11
545
546* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
547- Version 1.3.10
548
549* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
550- Version 1.3.9
551
552* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
553- Version 1.3.8
554
555* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
556- Make -devel package require main package (#45388)
557- Fix description and summary
558- Configure with --disable-gtk-doc
559
560* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
561- add some portability fixes needed at least on s390
562- copy config.{guess,sub} instead of calling libtoolize
563
564* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
565- try a new glib tarball with Makefile changes to work around
566  libtool linking to installed .la files
567- make -devel require pkgconfig
568
569* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
570- either libtool or the bad libtool hacks caused link
571  against glib-gobject 1.3.2, rebuild
572
573* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
574- 1.3.6
575- bad libtool workarounds
576
577* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
578- 1.3.5, rename to glib2
579
580* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
581- Final 1.3.2
582
583* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
584- Version 1.3.2pre1
585- Remove pkgconfig
586
587* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
588- Call 1.3.1b instead of snap... the snap* naming doesn't
589  order correctly.
590
591* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
592- new snapshot with fixed .pc files
593
594* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
595- include .pc files in file list
596
597* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
598- Include pkg-config
599- Upgrade to a glib CVS snapshot
600
601* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
602- rebuild to cope with glibc locale binary incompatibility
603
604* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
605- Remove glib-config.1 manpage from build since
606  it conflicts with glib-devel. When we go to
607  glib glib1.2 setup, we should add it back
608
609* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
610- Version 1.3.1
611- Move back to standard %{prefix}
612
613* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
614- Rebuild in /opt/gtk-beta
615
616* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
617- New version (adds gobject)
618
619* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
620- Don't blow away /etc/ld.so.conf (sorry!)
621
622* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
623- Snapshot RPM for Pango testing
624
625* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
626- Added fixes from stable branch of CVS
627
628* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
629- version 1.2.6
630
631* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
632- version 1.2.5
633
634* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
635- version 1.2.4
636
637* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
638- version 1.2.3
639
640* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
641- version 1.2.1
642
643* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
644- Version 1.2
645
646* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
647- version 1.2.0pre1
648
649* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
650- new description tags
651
652* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
653- removed libtoolize from %build
654
655* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
656- added libgthread to file list
657
658* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
659- version 1.1.15
660
661* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
662- version 1.1.14
663
664* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
665- version 1.1.13
666
667* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
668- version 1.1.12
669
670* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
671- updated in preparation for the GNOME freeze
672
673* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
674- Split out glib package
675
Note: See TracBrowser for help on using the repository browser.