source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 12413

Revision 12413, 23.5 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

cyrus-sasl-2.1.27-2

dnsmasq-2.81-1

freerdp-2.1.1-1

glib2-2.64.3-1

libmariadb-3.1.8-1

openssh-8.3p1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary:        A library of handy utility functions.
5Name:           glib2
6Version:        2.64.3
7Release:        1%{?_dist_release}
8Group:          System Environment/Libraries
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       daisuke
12
13License:        LGPLv2+
14URL:            http://www.gtk.org
15%define         shortver %(echo %{version} | cut -d. -f1-2)
16Source:         https://download.gnome.org/sources/glib/%{shortver}/glib-%{version}.tar.xz
17Source2:        glib2.sh
18Source3:        glib2.csh
19
20BuildRoot:      %{_tmppath}/glib-%{version}-root
21
22BuildRequires: dbus-devel
23BuildRequires: docbook-style-xsl
24BuildRequires: gamin-devel
25BuildRequires: libattr-devel
26BuildRequires: libffi-devel
27BuildRequires: libmount-devel
28BuildRequires: libxslt
29BuildRequires: meson
30BuildRequires: pcre-devel >= 8.13
31BuildRequires: pkgconfig >= 0.14
32BuildRequires: python3-devel
33BuildRequires: zlib-devel
34Obsoletes: glib-gtkbeta
35
36# for gio-querymodules
37Requires(post,postun): libffi
38
39
40%description
41GLib is the low-level core library that forms the basis
42for projects such as GTK+ and GNOME. It provides data structure
43handling for C, portability wrappers, and interfaces for such runtime
44functionality as an event loop, threads, dynamic loading, and an
45object system.
46
47This package provides version %{shortver} of GLib.
48
49%package devel
50Summary: Development files for the GLib library
51Group: Development/Libraries
52Requires: %{name} = %{version}
53Requires: pkgconfig >= 0.14
54Requires: libffi-devel
55Requires: zlib-devel
56Requires: python3
57
58Obsoletes: glib-gtkbeta-devel
59Conflicts: glib-devel <= 1.2.8
60
61%description devel
62The glib-devel package includes the header files for
63version %{shortver} of the GLib library.
64
65
66## to build compat32 for x86_64 architecture support
67%package -n compat32-%{name}
68Summary: A library of handy utility functions.
69Group: System Environment/Libraries
70
71%description -n compat32-%{name}
72GLib is the low-level core library that forms the basis
73for projects such as GTK+ and GNOME. It provides data structure
74handling for C, portability wrappers, and interfaces for such runtime
75functionality as an event loop, threads, dynamic loading, and an
76object system.
77
78This package provides version %{shortver} of GLib.
79
80%package -n compat32-%{name}-devel
81Summary: Development files for the GLib library
82Group: Development/Libraries
83Requires: pkgconfig >= 0.14
84Requires: compat32-%{name} = %{version}
85
86Conflicts: glib-devel <= 1.2.8
87
88%description -n compat32-%{name}-devel
89The glib-devel package includes the header files for
90version %{shortver} of the GLib library.
91
92
93%debug_package
94
95
96%prep
97%setup -q -n glib-%{version}
98
99%build
100%meson \
101        -Dselinux=disabled \
102        -Dman=true
103
104%meson_build
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109%meson_install
110
111## glib2.sh and glib2.csh
112mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
113install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
114install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
115
116#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
117#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
118
119mkdir -p $RPM_BUILD_ROOT%{_libdir}/gio/modules
120touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
121
122rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
123rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
124rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
125
126%find_lang glib20
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post
132/sbin/ldconfig
133gio-querymodules %{_libdir}/gio/modules
134
135%postun
136/sbin/ldconfig
137gio-querymodules %{_libdir}/gio/modules
138
139%post -n compat32-%{name} -p /sbin/ldconfig
140
141%postun -n compat32-%{name} -p /sbin/ldconfig
142
143
144%files -f glib20.lang
145%defattr(-, root, root)
146%license COPYING
147%doc AUTHORS NEWS README*
148%{_bindir}/gapplication
149%{_bindir}/gdbus
150%{_bindir}/gio
151#{_bindir}/gio-launch-desktop
152%{_bindir}/gio-querymodules
153%{_bindir}/glib-compile-schemas
154%{_bindir}/gsettings
155%{_libdir}/libglib-2.0.so.*
156%{_libdir}/libgthread-2.0.so.*
157%{_libdir}/libgmodule-2.0.so.*
158%{_libdir}/libgobject-2.0.so.*
159%{_libdir}/libgio-2.0.so.*
160%dir %{_libdir}/gio
161%dir %{_libdir}/gio/modules
162#%{_libdir}/gio/modules/giomodule.cache
163#%{_libdir}/gio/modules/lib*.so
164%{_sysconfdir}/profile.d/*
165%dir %{_datadir}/bash-completion/completions
166%dir %{_datadir}/bash-completion
167%{_datadir}/bash-completion/completions/gapplication
168%{_datadir}/bash-completion/completions/gdbus
169%{_datadir}/bash-completion/completions/gio
170%{_datadir}/bash-completion/completions/gsettings
171
172%files devel
173%defattr(-, root, root)
174%{_bindir}/gdbus-codegen
175%{_bindir}/glib-compile-resources
176%{_bindir}/glib-genmarshal
177%{_bindir}/glib-gettextize
178%{_bindir}/glib-mkenums
179%{_bindir}/gobject-query
180%{_bindir}/gresource
181%{_bindir}/gtester
182%{_bindir}/gtester-report
183%{_libdir}/lib*.so
184#%{_libdir}/lib*.a
185#%{_libdir}/gdbus-2.0/codegen/*
186%{_libdir}/glib-2.0
187%{_libdir}/pkgconfig/*
188#%{python_sitearch}/codegen
189%{_includedir}/*
190%{_datadir}/aclocal/*
191%{_datadir}/glib-2.0
192%{_datadir}/gettext/its/gschema.its
193%{_datadir}/gettext/its/gschema.loc
194#%doc %{_datadir}/gtk-doc/html/*
195%doc %{_mandir}/man1/*
196%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
197%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
198%dir %{_datadir}/bash-completion/completions
199%dir %{_datadir}/bash-completion
200%{_datadir}/bash-completion/completions/gresource
201
202%if %{build_compat32}
203%files -n compat32-%{name}
204%defattr(-, root, root)
205%{_libdir}/libglib-2.0.so.*
206%{_libdir}/libgthread-2.0.so.*
207%{_libdir}/libgmodule-2.0.so.*
208%{_libdir}/libgobject-2.0.so.*
209%{_libdir}/libgio-2.0.so.*
210%dir %{_libdir}/gio
211%dir %{_libdir}/gio/modules
212
213%files -n compat32-%{name}-devel
214%defattr(-, root, root)
215%{_libdir}/lib*.so
216%{_libdir}/glib-2.0
217%endif
218
219%changelog
220* Sat May 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.3-1
221- new upstream release.
222
223* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-2
224- rebuilt with libffi-3.3.
225
226* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-1
227- new upstream release.
228
229* Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
230- new upstream release.
231
232* Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
233- new upstream release.
234
235* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
236- new upstream release.
237
238* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
239- new upstream release.
240- dropped Patch0: fixed in upstream.
241- added BR:libmount-devel.
242
243* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
244- new upstream release
245- add BuildRequires: pcre-devel
246
247* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
248- add Requires: libffi
249
250* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
251- new upstream release
252
253* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
254- new upstream release
255
256* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
257- new upstream release
258
259* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
260- new upstream release
261
262* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
263- new upstream release
264
265* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
266- new upstream release
267
268* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
269- new upstream release
270
271* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
272- rebuild with libffi-3.0.13
273
274* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
275- new upstream release
276
277* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
278- new upstream release
279
280* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
281- new upstream release
282
283* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
284- new upstream release
285- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
286
287* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
288- new upstream release
289- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
290
291* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
292- new upstream release
293
294* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
295- new upstream release
296
297* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
298- new upstream release
299
300* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
301- new upstream release
302
303* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
304- new upstream release
305
306* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
307- new upstream release
308
309* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
310- new upstream release
311
312* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
313- new upstream release
314
315* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
316- new upstream release
317
318* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
319- new upstream release
320- add BuildRequires: python-devel
321- add Patch0 (glib-2.32.1-dconf-path.patch)
322
323* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
324- new upstream release
325
326* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
327- new upstream release
328
329* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
330- new upstream release
331- add Requires: libffi-devel, zlib-devel (-devel sub package)
332
333* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
334- new upstream release
335
336* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
337- new upstream release
338- remove Patch0,1
339
340* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
341- new upstream release
342- Patch0: glib-2.29.16-fixes-bug-656387.patch
343- Patch1: glib-2.29.16-fixes-bug-656675.patch
344
345* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
346- new upstream release
347- add BuildRequires: libffi-devel, dbus-devel
348
349* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
350- new upstream release
351
352* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
353- new upstream release
354
355* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
356- new upstream release
357
358* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
359- new upstream release
360
361* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
362- new upstream release
363
364* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
365- new upstream release
366
367* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
368- new upstream release
369
370* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
371- new upstream release
372
373* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
374- move the following files from glib2-devel to glib2 package
375   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
376
377* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
378- new upstream release
379
380* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
381- new upstream release
382- fix Source (add URL)
383- fix %files to add /etc/bash_completion.d files
384
385* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
386- build with rpm-4.8.1-1 for pkg-config file
387
388* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
389- new upstream release
390
391* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
392- new upstream release
393
394* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
395- new upstream release
396- add BuildRequires: zlib-devel
397
398* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
399- new upstream release
400
401* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
402- new upstream release
403
404* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
405- new upstream release
406
407* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
408- new upstream release
409
410* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
411- new upstream release
412
413* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
414- new upstream release
415
416* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
417- new upstream release
418
419* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
420- new upstream release
421
422* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
423- new upstream release
424
425* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
426- new upstream release
427
428* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
429- new upstream release
430
431* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
432- new upstream release
433
434* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
435- new upstream release
436
437* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
438- new upstream release
439
440* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
441- new upstream release
442
443* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
444- new upstream release
445
446* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
447- updated %%if %%{build_compat32} case related statements
448
449* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
450- new upstream release
451- removed lib*.la files from devel package
452
453* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
454- new upstream release
455
456* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
457- added %%{?_dist_release}
458- BuildRequires: gamin-devel
459
460* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
461- new upstream release
462
463* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
464- new upstream release
465
466* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
467- new upstream release
468
469* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
470- new upstream release
471
472* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
473- new upstream release
474- removed BuildRequires: automake17
475
476* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
477- new upstream release
478
479* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
480- new upstream release
481
482* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
483- new upstream release
484
485* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
486- rebuild with new environment
487
488* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
489- new upstream release
490
491* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
492- new upstream release
493
494* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
495- new upstream release
496
497* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
498- new upstream release
499
500* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
501- new upstream release
502
503* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
504- new upstream release
505
506* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
507- new upstream release
508
509* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
510- rebuild
511
512* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
513- update glib2.{sh,csh}
514  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
515
516* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
517- new upstream release
518
519* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
520- new upstream release
521
522* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
523- new upstream release
524
525* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
526- new upstream release
527
528* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
529- added compat32-* packages for x86_64 architecture support
530- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
531
532* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
533- new upstream release
534
535* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
536- new upstream release
537
538* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
539- new upstream release
540
541* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
542- new upstream release
543
544* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
545- fixed typo in glib2.csh
546
547* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
548- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
549  G_BROKEN_FILENAMES.
550
551* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
552- new upstream release
553
554* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
555- new upstream release
556
557* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
558- new upstream release
559
560* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
561- new upstream release
562
563* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
564- new upstream release
565
566* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
567- new upstream release
568- add *.la to build arts (should be fixed in arts?)
569
570* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
571- new upstream release
572
573* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
574- new upstream release
575
576* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
577- new upstream release
578
579* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
580- new upstream release
581
582* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
583- new upstream release
584
585* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
586- rebuilt
587
588* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
589- new upstream release
590
591* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
592- new upstream release
593
594* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
595- new upstream release
596
597* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
598- new upstream release
599
600* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
601- new upstream release
602
603* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
604- new upstream release
605
606* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
607- new upstream release
608
609* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
610- rebuild with new toolchain
611
612* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
613- new upstream release
614
615* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
616- new upstream release
617
618* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
619- new upstream release
620
621* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
622- new upstream release
623
624* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
625- new upstream release
626- build for Vine Linux
627
628* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
629- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
630- blow away unpackaged files in install
631
632* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
633- Version 2.0.6
634- Remove fixed-ltmain.sh; shouldn't be needed any more.
635
636* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
637- automated rebuild
638
639* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
640- 2.0.4
641
642* Thu May 23 2002 Tim Powers <timp@redhat.com>
643- automated rebuild
644
645* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
646 - rebuild in different environment
647
648* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
649- Fix missing .po files (#63336)
650
651* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
652- Update to version 2.0.1
653
654* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
655- Version 2.0.0
656
657* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
658- Update to 1.3.15
659
660* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
661- Bump for rebuild
662
663* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
664- Update to 1.3.14
665
666* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
667- add horrible buildrequires hack
668
669* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
670- 1.3.13.91 cvs snap
671
672* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
673- rebuild from CVS snapshot
674- use setup -q
675
676* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
677- rebuild
678
679* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
680- 1.3.13
681
682* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
683- attempting rebuild in rawhide
684
685* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
686- remove 64-bit patch now upstream, 1.3.12.90
687
688* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
689- add some missing files to file list, langify
690
691* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
692- add temporary patch to fix GTypeFundamentals on 64-bit
693
694* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
695- Version 1.3.11
696
697* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
698- Version 1.3.10
699
700* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
701- Version 1.3.9
702
703* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
704- Version 1.3.8
705
706* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
707- Make -devel package require main package (#45388)
708- Fix description and summary
709- Configure with --disable-gtk-doc
710
711* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
712- add some portability fixes needed at least on s390
713- copy config.{guess,sub} instead of calling libtoolize
714
715* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
716- try a new glib tarball with Makefile changes to work around
717  libtool linking to installed .la files
718- make -devel require pkgconfig
719
720* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
721- either libtool or the bad libtool hacks caused link
722  against glib-gobject 1.3.2, rebuild
723
724* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
725- 1.3.6
726- bad libtool workarounds
727
728* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
729- 1.3.5, rename to glib2
730
731* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
732- Final 1.3.2
733
734* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
735- Version 1.3.2pre1
736- Remove pkgconfig
737
738* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
739- Call 1.3.1b instead of snap... the snap* naming doesn't
740  order correctly.
741
742* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
743- new snapshot with fixed .pc files
744
745* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
746- include .pc files in file list
747
748* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
749- Include pkg-config
750- Upgrade to a glib CVS snapshot
751
752* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
753- rebuild to cope with glibc locale binary incompatibility
754
755* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
756- Remove glib-config.1 manpage from build since
757  it conflicts with glib-devel. When we go to
758  glib glib1.2 setup, we should add it back
759
760* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
761- Version 1.3.1
762- Move back to standard %{prefix}
763
764* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
765- Rebuild in /opt/gtk-beta
766
767* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
768- New version (adds gobject)
769
770* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
771- Don't blow away /etc/ld.so.conf (sorry!)
772
773* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
774- Snapshot RPM for Pango testing
775
776* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
777- Added fixes from stable branch of CVS
778
779* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
780- version 1.2.6
781
782* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
783- version 1.2.5
784
785* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
786- version 1.2.4
787
788* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
789- version 1.2.3
790
791* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
792- version 1.2.1
793
794* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
795- Version 1.2
796
797* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
798- version 1.2.0pre1
799
800* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
801- new description tags
802
803* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
804- removed libtoolize from %build
805
806* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
807- added libgthread to file list
808
809* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
810- version 1.1.15
811
812* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
813- version 1.1.14
814
815* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
816- version 1.1.13
817
818* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
819- version 1.1.12
820
821* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
822- updated in preparation for the GNOME freeze
823
824* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
825- Split out glib package
826
Note: See TracBrowser for help on using the repository browser.