source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 12005

Revision 12005, 22.7 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: A library of handy utility functions.
5Name: glib2
6Version: 2.58.2
7Release: 1%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.48/glib-%{version}.tar.xz
11Source2: glib2.sh
12Source3: glib2.csh
13
14BuildRoot: %{_tmppath}/glib-%{version}-root
15
16BuildRequires: pkgconfig >= 0.14
17BuildRequires: dbus-devel
18BuildRequires: gamin-devel
19BuildRequires: libffi-devel
20BuildRequires: zlib-devel
21BuildRequires: python-devel
22BuildRequires: pcre-devel >= 8.13
23BuildRequires: libmount-devel
24BuildRequires: gtk-doc
25Obsoletes: glib-gtkbeta
26
27# for gio-querymodules
28Requires(post,postun): libffi
29
30URL: http://www.gtk.org
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
35
36%description
37GLib is the low-level core library that forms the basis
38for projects such as GTK+ and GNOME. It provides data structure
39handling for C, portability wrappers, and interfaces for such runtime
40functionality as an event loop, threads, dynamic loading, and an
41object system.
42
43This package provides version 2.48 of GLib.
44
45%package devel
46Summary: Development files for the GLib library
47Group: Development/Libraries
48Requires: %{name} = %{version}
49Requires: pkgconfig >= 0.14
50Requires: libffi-devel
51Requires: zlib-devel
52
53Obsoletes: glib-gtkbeta-devel
54Conflicts: glib-devel <= 1.2.8
55
56%description devel
57The glib-devel package includes the header files for
58version 2.48 of the GLib library.
59
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary: A library of handy utility functions.
64Group: System Environment/Libraries
65
66%description -n compat32-%{name}
67GLib is the low-level core library that forms the basis
68for projects such as GTK+ and GNOME. It provides data structure
69handling for C, portability wrappers, and interfaces for such runtime
70functionality as an event loop, threads, dynamic loading, and an
71object system.
72
73This package provides version 2.48 of GLib.
74
75%package -n compat32-%{name}-devel
76Summary: Development files for the GLib library
77Group: Development/Libraries
78Requires: pkgconfig >= 0.14
79Requires: compat32-%{name} = %{version}
80
81Conflicts: glib-devel <= 1.2.8
82
83%description -n compat32-%{name}-devel
84The glib-devel package includes the header files for
85version 2.48 of the GLib library.
86
87
88%prep
89%setup -q -n glib-%{version}
90
91%build
92NOCONFIGURE=1 ./autogen.sh
93%configure --disable-selinux --enable-static --enable-systemtap
94make %{?_smp_mflags}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99mkdir -p $RPM_BUILD_ROOT%{_bindir}
100make install DESTDIR=$RPM_BUILD_ROOT
101
102## glib2.sh and glib2.csh
103mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
104install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
105install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
106
107#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
108#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
109
110touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
111
112rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
113rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
114rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
115
116%find_lang glib20
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
124
125%postun
126/sbin/ldconfig
127gio-querymodules %{_libdir}/gio/modules
128
129%post -n compat32-%{name} -p /sbin/ldconfig
130
131%postun -n compat32-%{name} -p /sbin/ldconfig
132
133
134%files -f glib20.lang
135%defattr(-, root, root)
136%doc AUTHORS COPYING NEWS README*
137%{_bindir}/gapplication
138%{_bindir}/gdbus
139%{_bindir}/gio
140%{_bindir}/gio-launch-desktop
141%{_bindir}/gio-querymodules
142%{_bindir}/glib-compile-schemas
143%{_bindir}/gsettings
144%{_libdir}/libglib-2.0.so.*
145%{_libdir}/libgthread-2.0.so.*
146%{_libdir}/libgmodule-2.0.so.*
147%{_libdir}/libgobject-2.0.so.*
148%{_libdir}/libgio-2.0.so.*
149%{_libdir}/gio/modules/lib*.so
150%{_sysconfdir}/profile.d/*
151%dir %{_datadir}/bash-completion/completions
152%dir %{_datadir}/bash-completion
153%{_datadir}/bash-completion/completions/gapplication
154%{_datadir}/bash-completion/completions/gdbus
155%{_datadir}/bash-completion/completions/gio
156%{_datadir}/bash-completion/completions/gsettings
157
158%files devel
159%defattr(-, root, root)
160%{_bindir}/gdbus-codegen
161%{_bindir}/glib-compile-resources
162%{_bindir}/glib-genmarshal
163%{_bindir}/glib-gettextize
164%{_bindir}/glib-mkenums
165%{_bindir}/gobject-query
166%{_bindir}/gresource
167%{_bindir}/gtester
168%{_bindir}/gtester-report
169%{_libdir}/lib*.so
170%{_libdir}/lib*.a
171#%{_libdir}/gdbus-2.0/codegen/*
172%{_libdir}/glib-2.0
173%{_libdir}/pkgconfig/*
174#%{python_sitearch}/codegen
175%{_includedir}/*
176%{_datadir}/aclocal/*
177%{_datadir}/glib-2.0
178%{_datadir}/gettext/its/gschema.its
179%{_datadir}/gettext/its/gschema.loc
180#%doc %{_datadir}/gtk-doc/html/*
181%doc %{_mandir}/man1/*
182%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
183%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
184%dir %{_datadir}/bash-completion/completions
185%dir %{_datadir}/bash-completion
186%{_datadir}/bash-completion/completions/gresource
187
188%if %{build_compat32}
189%files -n compat32-%{name}
190%defattr(-, root, root)
191%{_libdir}/libglib-2.0.so.*
192%{_libdir}/libgthread-2.0.so.*
193%{_libdir}/libgmodule-2.0.so.*
194%{_libdir}/libgobject-2.0.so.*
195%{_libdir}/libgio-2.0.so.*
196%{_libdir}/gio/modules/lib*.so
197
198%files -n compat32-%{name}-devel
199%defattr(-, root, root)
200%{_libdir}/lib*.so
201%{_libdir}/lib*.a
202%{_libdir}/glib-2.0
203%endif
204
205%changelog
206* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
207- new upstream release.
208
209* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
210- new upstream release.
211- dropped Patch0: fixed in upstream.
212- added BR:libmount-devel.
213
214* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
215- new upstream release
216- add BuildRequires: pcre-devel
217
218* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
219- add Requires: libffi
220
221* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
222- new upstream release
223
224* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
225- new upstream release
226
227* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
228- new upstream release
229
230* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
231- new upstream release
232
233* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
234- new upstream release
235
236* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
237- new upstream release
238
239* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
240- new upstream release
241
242* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
243- rebuild with libffi-3.0.13
244
245* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
246- new upstream release
247
248* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
249- new upstream release
250
251* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
252- new upstream release
253
254* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
255- new upstream release
256- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
257
258* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
259- new upstream release
260- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
261
262* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
263- new upstream release
264
265* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
266- new upstream release
267
268* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
269- new upstream release
270
271* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
272- new upstream release
273
274* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
275- new upstream release
276
277* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
278- new upstream release
279
280* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
281- new upstream release
282
283* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
284- new upstream release
285
286* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
287- new upstream release
288
289* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
290- new upstream release
291- add BuildRequires: python-devel
292- add Patch0 (glib-2.32.1-dconf-path.patch)
293
294* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
295- new upstream release
296
297* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
298- new upstream release
299
300* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
301- new upstream release
302- add Requires: libffi-devel, zlib-devel (-devel sub package)
303
304* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
305- new upstream release
306
307* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
308- new upstream release
309- remove Patch0,1
310
311* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
312- new upstream release
313- Patch0: glib-2.29.16-fixes-bug-656387.patch
314- Patch1: glib-2.29.16-fixes-bug-656675.patch
315
316* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
317- new upstream release
318- add BuildRequires: libffi-devel, dbus-devel
319
320* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
321- new upstream release
322
323* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
324- new upstream release
325
326* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
327- new upstream release
328
329* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
330- new upstream release
331
332* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
333- new upstream release
334
335* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
336- new upstream release
337
338* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
339- new upstream release
340
341* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
342- new upstream release
343
344* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
345- move the following files from glib2-devel to glib2 package
346   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
347
348* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
349- new upstream release
350
351* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
352- new upstream release
353- fix Source (add URL)
354- fix %files to add /etc/bash_completion.d files
355
356* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
357- build with rpm-4.8.1-1 for pkg-config file
358
359* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
360- new upstream release
361
362* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
363- new upstream release
364
365* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
366- new upstream release
367- add BuildRequires: zlib-devel
368
369* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
370- new upstream release
371
372* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
373- new upstream release
374
375* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
376- new upstream release
377
378* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
379- new upstream release
380
381* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
382- new upstream release
383
384* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
385- new upstream release
386
387* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
388- new upstream release
389
390* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
391- new upstream release
392
393* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
394- new upstream release
395
396* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
397- new upstream release
398
399* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
400- new upstream release
401
402* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
403- new upstream release
404
405* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
406- new upstream release
407
408* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
409- new upstream release
410
411* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
412- new upstream release
413
414* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
415- new upstream release
416
417* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
418- updated %%if %%{build_compat32} case related statements
419
420* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
421- new upstream release
422- removed lib*.la files from devel package
423
424* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
425- new upstream release
426
427* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
428- added %%{?_dist_release}
429- BuildRequires: gamin-devel
430
431* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
432- new upstream release
433
434* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
435- new upstream release
436
437* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
438- new upstream release
439
440* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
441- new upstream release
442
443* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
444- new upstream release
445- removed BuildRequires: automake17
446
447* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
448- new upstream release
449
450* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
451- new upstream release
452
453* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
454- new upstream release
455
456* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
457- rebuild with new environment
458
459* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
460- new upstream release
461
462* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
463- new upstream release
464
465* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
466- new upstream release
467
468* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
469- new upstream release
470
471* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
472- new upstream release
473
474* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
475- new upstream release
476
477* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
478- new upstream release
479
480* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
481- rebuild
482
483* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
484- update glib2.{sh,csh}
485  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
486
487* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
488- new upstream release
489
490* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
491- new upstream release
492
493* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
494- new upstream release
495
496* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
497- new upstream release
498
499* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
500- added compat32-* packages for x86_64 architecture support
501- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
502
503* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
504- new upstream release
505
506* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
507- new upstream release
508
509* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
510- new upstream release
511
512* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
513- new upstream release
514
515* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
516- fixed typo in glib2.csh
517
518* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
519- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
520  G_BROKEN_FILENAMES.
521
522* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
523- new upstream release
524
525* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
526- new upstream release
527
528* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
529- new upstream release
530
531* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
532- new upstream release
533
534* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
535- new upstream release
536
537* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
538- new upstream release
539- add *.la to build arts (should be fixed in arts?)
540
541* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
542- new upstream release
543
544* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
545- new upstream release
546
547* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
548- new upstream release
549
550* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
551- new upstream release
552
553* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
554- new upstream release
555
556* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
557- rebuilt
558
559* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
560- new upstream release
561
562* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
563- new upstream release
564
565* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
566- new upstream release
567
568* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
569- new upstream release
570
571* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
572- new upstream release
573
574* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
575- new upstream release
576
577* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
578- new upstream release
579
580* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
581- rebuild with new toolchain
582
583* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
584- new upstream release
585
586* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
587- new upstream release
588
589* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
590- new upstream release
591
592* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
593- new upstream release
594
595* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
596- new upstream release
597- build for Vine Linux
598
599* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
600- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
601- blow away unpackaged files in install
602
603* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
604- Version 2.0.6
605- Remove fixed-ltmain.sh; shouldn't be needed any more.
606
607* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
608- automated rebuild
609
610* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
611- 2.0.4
612
613* Thu May 23 2002 Tim Powers <timp@redhat.com>
614- automated rebuild
615
616* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
617 - rebuild in different environment
618
619* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
620- Fix missing .po files (#63336)
621
622* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
623- Update to version 2.0.1
624
625* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
626- Version 2.0.0
627
628* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
629- Update to 1.3.15
630
631* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
632- Bump for rebuild
633
634* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
635- Update to 1.3.14
636
637* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
638- add horrible buildrequires hack
639
640* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
641- 1.3.13.91 cvs snap
642
643* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
644- rebuild from CVS snapshot
645- use setup -q
646
647* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
648- rebuild
649
650* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
651- 1.3.13
652
653* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
654- attempting rebuild in rawhide
655
656* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
657- remove 64-bit patch now upstream, 1.3.12.90
658
659* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
660- add some missing files to file list, langify
661
662* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
663- add temporary patch to fix GTypeFundamentals on 64-bit
664
665* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
666- Version 1.3.11
667
668* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
669- Version 1.3.10
670
671* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
672- Version 1.3.9
673
674* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
675- Version 1.3.8
676
677* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
678- Make -devel package require main package (#45388)
679- Fix description and summary
680- Configure with --disable-gtk-doc
681
682* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
683- add some portability fixes needed at least on s390
684- copy config.{guess,sub} instead of calling libtoolize
685
686* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
687- try a new glib tarball with Makefile changes to work around
688  libtool linking to installed .la files
689- make -devel require pkgconfig
690
691* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
692- either libtool or the bad libtool hacks caused link
693  against glib-gobject 1.3.2, rebuild
694
695* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
696- 1.3.6
697- bad libtool workarounds
698
699* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
700- 1.3.5, rename to glib2
701
702* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
703- Final 1.3.2
704
705* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
706- Version 1.3.2pre1
707- Remove pkgconfig
708
709* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
710- Call 1.3.1b instead of snap... the snap* naming doesn't
711  order correctly.
712
713* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
714- new snapshot with fixed .pc files
715
716* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
717- include .pc files in file list
718
719* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
720- Include pkg-config
721- Upgrade to a glib CVS snapshot
722
723* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
724- rebuild to cope with glibc locale binary incompatibility
725
726* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
727- Remove glib-config.1 manpage from build since
728  it conflicts with glib-devel. When we go to
729  glib glib1.2 setup, we should add it back
730
731* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
732- Version 1.3.1
733- Move back to standard %{prefix}
734
735* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
736- Rebuild in /opt/gtk-beta
737
738* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
739- New version (adds gobject)
740
741* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
742- Don't blow away /etc/ld.so.conf (sorry!)
743
744* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
745- Snapshot RPM for Pango testing
746
747* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
748- Added fixes from stable branch of CVS
749
750* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
751- version 1.2.6
752
753* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
754- version 1.2.5
755
756* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
757- version 1.2.4
758
759* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
760- version 1.2.3
761
762* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
763- version 1.2.1
764
765* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
766- Version 1.2
767
768* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
769- version 1.2.0pre1
770
771* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
772- new description tags
773
774* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
775- removed libtoolize from %build
776
777* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
778- added libgthread to file list
779
780* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
781- version 1.1.15
782
783* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
784- version 1.1.14
785
786* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
787- version 1.1.13
788
789* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
790- version 1.1.12
791
792* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
793- updated in preparation for the GNOME freeze
794
795* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
796- Split out glib package
797
Note: See TracBrowser for help on using the repository browser.