source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 521

Revision 521, 15.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: A library of handy utility functions.
3Name: glib2
4Version: 2.22.4
5Release: 1%{?_dist_release}
6License: LGPLv2+
7Group: System Environment/Libraries
8Source: glib-%{version}.tar.bz2
9Source2: glib2.sh
10Source3: glib2.csh
11BuildRoot: %{_tmppath}/glib-%{version}-root
12BuildRequires: pkgconfig >= 0.14
13BuildRequires: gamin-devel
14BuildRequires: gtk-doc
15Obsoletes: glib-gtkbeta
16URL: http://www.gtk.org
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
21
22%description
23GLib is the low-level core library that forms the basis
24for projects such as GTK+ and GNOME. It provides data structure
25handling for C, portability wrappers, and interfaces for such runtime
26functionality as an event loop, threads, dynamic loading, and an
27object system.
28
29This package provides version 2.20 of GLib.
30
31%package devel
32Summary: Development files for the GLib library
33Group: Development/Libraries
34Obsoletes: glib-gtkbeta-devel
35Requires: pkgconfig >= 0.14
36Requires: %{name} = %{version}
37Conflicts: glib-devel <= 1.2.8
38
39%description devel
40The glib-devel package includes the header files for
41version 2.20 of the GLib library.
42
43
44## to build compat32 for x86_64 architecture support
45%package -n compat32-%{name}
46Summary: A library of handy utility functions.
47Group: System Environment/Libraries
48
49%description -n compat32-%{name}
50GLib is the low-level core library that forms the basis
51for projects such as GTK+ and GNOME. It provides data structure
52handling for C, portability wrappers, and interfaces for such runtime
53functionality as an event loop, threads, dynamic loading, and an
54object system.
55
56This package provides version 2.20 of GLib.
57
58%package -n compat32-%{name}-devel
59Summary: Development files for the GLib library
60Group: Development/Libraries
61Requires: pkgconfig >= 0.14
62Requires: compat32-%{name} = %{version}
63Conflicts: glib-devel <= 1.2.8
64
65%description -n compat32-%{name}-devel
66The glib-devel package includes the header files for
67version 2.20 of the GLib library.
68
69%prep
70%setup -q -n glib-%{version}
71
72%build
73%configure --disable-selinux --enable-static
74make %{?_smp_mflags}
75
76%install
77rm -rf $RPM_BUILD_ROOT
78
79mkdir -p $RPM_BUILD_ROOT%{_bindir}
80%makeinstall
81
82## glib2.sh and glib2.csh
83./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
84install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
85install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
86
87rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
88rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
89
90%find_lang glib20
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%post -n compat32-%{name} -p /sbin/ldconfig
100
101%postun -n compat32-%{name} -p /sbin/ldconfig
102
103
104%files -f glib20.lang
105%defattr(-, root, root)
106%doc AUTHORS COPYING ChangeLog NEWS README
107%{_libdir}/libglib-2.0.so.*
108%{_libdir}/libgthread-2.0.so.*
109%{_libdir}/libgmodule-2.0.so.*
110%{_libdir}/libgobject-2.0.so.*
111%{_libdir}/libgio-2.0.so.*
112%{_libdir}/gio/modules/lib*.so
113%{_sysconfdir}/profile.d/*
114
115%files devel
116%defattr(-, root, root)
117%{_libdir}/lib*.so
118%{_libdir}/lib*.a
119%{_libdir}/glib-2.0
120%{_includedir}/*
121%{_datadir}/aclocal/*
122%{_libdir}/pkgconfig/*
123%{_datadir}/glib-2.0
124%{_bindir}/*
125%doc %{_datadir}/gtk-doc/html/*
126%doc %{_mandir}/man1/*
127%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
128%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
129
130%if %{build_compat32}
131%files -n compat32-%{name}
132%defattr(-, root, root)
133%{_libdir}/libglib-2.0.so.*
134%{_libdir}/libgthread-2.0.so.*
135%{_libdir}/libgmodule-2.0.so.*
136%{_libdir}/libgobject-2.0.so.*
137%{_libdir}/libgio-2.0.so.*
138%{_libdir}/gio/modules/lib*.so
139
140%files -n compat32-%{name}-devel
141%defattr(-, root, root)
142%{_libdir}/lib*.so
143%{_libdir}/lib*.a
144%{_libdir}/glib-2.0
145%{_libdir}/pkgconfig/*
146%endif
147
148%changelog
149* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
150- new upstream release
151
152* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
153- new upstream release
154
155* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
156- new upstream release
157
158* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
159- new upstream release
160
161* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
162- new upstream release
163
164* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
165- new upstream release
166
167* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
168- new upstream release
169
170* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
171- new upstream release
172
173* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
174- new upstream release
175
176* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
177- new upstream release
178
179* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
180- new upstream release
181
182* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
183- new upstream release
184
185* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
186- new upstream release
187
188* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
189- new upstream release
190
191* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
192- new upstream release
193
194* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
195- updated %%if %%{build_compat32} case related statements
196
197* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
198- new upstream release
199- removed lib*.la files from devel package
200
201* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
202- new upstream release
203
204* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
205- added %%{?_dist_release}
206- BuildRequires: gamin-devel
207
208* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
209- new upstream release
210
211* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
212- new upstream release
213
214* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
215- new upstream release
216
217* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
218- new upstream release
219
220* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
221- new upstream release
222- removed BuildRequires: automake17
223
224* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
225- new upstream release
226
227* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
228- new upstream release
229
230* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
231- new upstream release
232
233* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
234- rebuild with new environment
235
236* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
237- new upstream release
238
239* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
240- new upstream release
241
242* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
243- new upstream release
244
245* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
246- new upstream release
247
248* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
249- new upstream release
250
251* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
252- new upstream release
253
254* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
255- new upstream release
256
257* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
258- rebuild
259
260* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
261- update glib2.{sh,csh}
262  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
263
264* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
265- new upstream release
266
267* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
268- new upstream release
269
270* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
271- new upstream release
272
273* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
274- new upstream release
275
276* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
277- added compat32-* packages for x86_64 architecture support
278- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
279
280* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
281- new upstream release
282
283* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
284- new upstream release
285
286* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
287- new upstream release
288
289* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
290- new upstream release
291
292* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
293- fixed typo in glib2.csh
294
295* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
296- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
297  G_BROKEN_FILENAMES.
298
299* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
300- new upstream release
301
302* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
303- new upstream release
304
305* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
306- new upstream release
307
308* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
309- new upstream release
310
311* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
312- new upstream release
313
314* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
315- new upstream release
316- add *.la to build arts (should be fixed in arts?)
317
318* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
319- new upstream release
320
321* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
322- new upstream release
323
324* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
325- new upstream release
326
327* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
328- new upstream release
329
330* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
331- new upstream release
332
333* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
334- rebuilt
335
336* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
337- new upstream release
338
339* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
340- new upstream release
341
342* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
343- new upstream release
344
345* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
346- new upstream release
347
348* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
349- new upstream release
350
351* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
352- new upstream release
353
354* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
355- new upstream release
356
357* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
358- rebuild with new toolchain
359
360* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
361- new upstream release
362
363* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
364- new upstream release
365
366* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
367- new upstream release
368
369* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
370- new upstream release
371
372* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
373- new upstream release
374- build for Vine Linux
375
376* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
377- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
378- blow away unpackaged files in install
379
380* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
381- Version 2.0.6
382- Remove fixed-ltmain.sh; shouldn't be needed any more.
383
384* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
385- automated rebuild
386
387* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
388- 2.0.4
389
390* Thu May 23 2002 Tim Powers <timp@redhat.com>
391- automated rebuild
392
393* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
394 - rebuild in different environment
395
396* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
397- Fix missing .po files (#63336)
398
399* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
400- Update to version 2.0.1
401
402* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
403- Version 2.0.0
404
405* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
406- Update to 1.3.15
407
408* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
409- Bump for rebuild
410
411* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
412- Update to 1.3.14
413
414* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
415- add horrible buildrequires hack
416
417* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
418- 1.3.13.91 cvs snap
419
420* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
421- rebuild from CVS snapshot
422- use setup -q
423
424* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
425- rebuild
426
427* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
428- 1.3.13
429
430* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
431- attempting rebuild in rawhide
432
433* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
434- remove 64-bit patch now upstream, 1.3.12.90
435
436* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
437- add some missing files to file list, langify
438
439* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
440- add temporary patch to fix GTypeFundamentals on 64-bit
441
442* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
443- Version 1.3.11
444
445* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
446- Version 1.3.10
447
448* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
449- Version 1.3.9
450
451* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
452- Version 1.3.8
453
454* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
455- Make -devel package require main package (#45388)
456- Fix description and summary
457- Configure with --disable-gtk-doc
458
459* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
460- add some portability fixes needed at least on s390
461- copy config.{guess,sub} instead of calling libtoolize
462
463* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
464- try a new glib tarball with Makefile changes to work around
465  libtool linking to installed .la files
466- make -devel require pkgconfig
467
468* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
469- either libtool or the bad libtool hacks caused link
470  against glib-gobject 1.3.2, rebuild
471
472* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
473- 1.3.6
474- bad libtool workarounds
475
476* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
477- 1.3.5, rename to glib2
478
479* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
480- Final 1.3.2
481
482* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
483- Version 1.3.2pre1
484- Remove pkgconfig
485
486* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
487- Call 1.3.1b instead of snap... the snap* naming doesn't
488  order correctly.
489
490* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
491- new snapshot with fixed .pc files
492
493* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
494- include .pc files in file list
495
496* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
497- Include pkg-config
498- Upgrade to a glib CVS snapshot
499
500* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
501- rebuild to cope with glibc locale binary incompatibility
502
503* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
504- Remove glib-config.1 manpage from build since
505  it conflicts with glib-devel. When we go to
506  glib glib1.2 setup, we should add it back
507
508* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
509- Version 1.3.1
510- Move back to standard %{prefix}
511
512* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
513- Rebuild in /opt/gtk-beta
514
515* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
516- New version (adds gobject)
517
518* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
519- Don't blow away /etc/ld.so.conf (sorry!)
520
521* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
522- Snapshot RPM for Pango testing
523
524* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
525- Added fixes from stable branch of CVS
526
527* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
528- version 1.2.6
529
530* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
531- version 1.2.5
532
533* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
534- version 1.2.4
535
536* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
537- version 1.2.3
538
539* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
540- version 1.2.1
541
542* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
543- Version 1.2
544
545* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
546- version 1.2.0pre1
547
548* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
549- new description tags
550
551* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
552- removed libtoolize from %build
553
554* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
555- added libgthread to file list
556
557* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
558- version 1.1.15
559
560* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
561- version 1.1.14
562
563* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
564- version 1.1.13
565
566* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
567- version 1.1.12
568
569* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
570- updated in preparation for the GNOME freeze
571
572* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
573- Split out glib package
574
Note: See TracBrowser for help on using the repository browser.