source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 4850

Revision 4850, 18.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of handy utility functions.
4Name: glib2
5Version: 2.30.0
6Release: 1%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.30/glib-%{version}.tar.xz
10Source2: glib2.sh
11Source3: glib2.csh
12
13BuildRoot: %{_tmppath}/glib-%{version}-root
14
15BuildRequires: pkgconfig >= 0.14
16BuildRequires: dbus-devel
17BuildRequires: gamin-devel
18BuildRequires: libffi-devel
19BuildRequires: zlib-devel
20BuildRequires: gtk-doc
21Obsoletes: glib-gtkbeta
22URL: http://www.gtk.org
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
27
28%description
29GLib is the low-level core library that forms the basis
30for projects such as GTK+ and GNOME. It provides data structure
31handling for C, portability wrappers, and interfaces for such runtime
32functionality as an event loop, threads, dynamic loading, and an
33object system.
34
35This package provides version 2.30 of GLib.
36
37%package devel
38Summary: Development files for the GLib library
39Group: Development/Libraries
40Requires: %{name} = %{version}
41Requires: pkgconfig >= 0.14
42Requires: libffi-devel
43Requires: zlib-devel
44
45Obsoletes: glib-gtkbeta-devel
46Conflicts: glib-devel <= 1.2.8
47
48%description devel
49The glib-devel package includes the header files for
50version 2.30 of the GLib library.
51
52
53## to build compat32 for x86_64 architecture support
54%package -n compat32-%{name}
55Summary: A library of handy utility functions.
56Group: System Environment/Libraries
57
58%description -n compat32-%{name}
59GLib is the low-level core library that forms the basis
60for projects such as GTK+ and GNOME. It provides data structure
61handling for C, portability wrappers, and interfaces for such runtime
62functionality as an event loop, threads, dynamic loading, and an
63object system.
64
65This package provides version 2.30 of GLib.
66
67%package -n compat32-%{name}-devel
68Summary: Development files for the GLib library
69Group: Development/Libraries
70Requires: pkgconfig >= 0.14
71Requires: compat32-%{name} = %{version}
72
73Conflicts: glib-devel <= 1.2.8
74
75%description -n compat32-%{name}-devel
76The glib-devel package includes the header files for
77version 2.30 of the GLib library.
78
79%prep
80%setup -q -n glib-%{version}
81
82%build
83%configure --disable-selinux --enable-static
84make %{?_smp_mflags}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89mkdir -p $RPM_BUILD_ROOT%{_bindir}
90%makeinstall
91
92## glib2.sh and glib2.csh
93./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
94install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
95install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
96
97rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
98rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
99rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
100
101%find_lang glib20
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%post -n compat32-%{name} -p /sbin/ldconfig
111
112%postun -n compat32-%{name} -p /sbin/ldconfig
113
114
115%files -f glib20.lang
116%defattr(-, root, root)
117%doc AUTHORS COPYING ChangeLog NEWS README
118%{_bindir}/gdbus
119%{_bindir}/gio-querymodules
120%{_bindir}/glib-compile-schemas
121%{_bindir}/gsettings
122%{_libdir}/libglib-2.0.so.*
123%{_libdir}/libgthread-2.0.so.*
124%{_libdir}/libgmodule-2.0.so.*
125%{_libdir}/libgobject-2.0.so.*
126%{_libdir}/libgio-2.0.so.*
127%{_libdir}/gdbus-2.0/codegen/*
128%{_libdir}/gio/modules/lib*.so
129%{_sysconfdir}/profile.d/*
130%{_sysconfdir}/bash_completion.d/*
131
132%files devel
133%defattr(-, root, root)
134%{_bindir}/gdbus-codegen
135%{_bindir}/glib-genmarshal
136%{_bindir}/glib-gettextize
137%{_bindir}/glib-mkenums
138%{_bindir}/gobject-query
139%{_bindir}/gtester
140%{_bindir}/gtester-report
141%{_libdir}/lib*.so
142%{_libdir}/lib*.a
143%{_libdir}/glib-2.0
144%{_includedir}/*
145%{_datadir}/aclocal/*
146%{_libdir}/pkgconfig/*
147%{_datadir}/glib-2.0
148%doc %{_datadir}/gtk-doc/html/*
149%doc %{_mandir}/man1/*
150%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
151%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
152
153%if %{build_compat32}
154%files -n compat32-%{name}
155%defattr(-, root, root)
156%{_libdir}/libglib-2.0.so.*
157%{_libdir}/libgthread-2.0.so.*
158%{_libdir}/libgmodule-2.0.so.*
159%{_libdir}/libgobject-2.0.so.*
160%{_libdir}/libgio-2.0.so.*
161%{_libdir}/gio/modules/lib*.so
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/lib*.so
166%{_libdir}/lib*.a
167%{_libdir}/glib-2.0
168%{_libdir}/pkgconfig/*
169%endif
170
171%changelog
172* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
173- new upstream release
174- add Requires: libffi-devel, zlib-devel (-devel sub package)
175
176* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
177- new upstream release
178
179* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
180- new upstream release
181- remove Patch0,1
182
183* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
184- new upstream release
185- Patch0: glib-2.29.16-fixes-bug-656387.patch
186- Patch1: glib-2.29.16-fixes-bug-656675.patch
187
188* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
189- new upstream release
190- add BuildRequires: libffi-devel, dbus-devel
191
192* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
193- new upstream release
194
195* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
196- new upstream release
197
198* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
199- new upstream release
200
201* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
202- new upstream release
203
204* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
205- new upstream release
206
207* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
208- new upstream release
209
210* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
211- new upstream release
212
213* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
214- new upstream release
215
216* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
217- move the following files from glib2-devel to glib2 package
218   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
219
220* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
221- new upstream release
222
223* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
224- new upstream release
225- fix Source (add URL)
226- fix %files to add /etc/bash_completion.d files
227
228* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
229- build with rpm-4.8.1-1 for pkg-config file
230
231* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
232- new upstream release
233
234* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
235- new upstream release
236
237* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
238- new upstream release
239- add BuildRequires: zlib-devel
240
241* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
242- new upstream release
243
244* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
245- new upstream release
246
247* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
248- new upstream release
249
250* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
251- new upstream release
252
253* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
254- new upstream release
255
256* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
257- new upstream release
258
259* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
260- new upstream release
261
262* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
263- new upstream release
264
265* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
266- new upstream release
267
268* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
269- new upstream release
270
271* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
272- new upstream release
273
274* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
275- new upstream release
276
277* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
278- new upstream release
279
280* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
281- new upstream release
282
283* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
284- new upstream release
285
286* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
287- new upstream release
288
289* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
290- updated %%if %%{build_compat32} case related statements
291
292* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
293- new upstream release
294- removed lib*.la files from devel package
295
296* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
297- new upstream release
298
299* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
300- added %%{?_dist_release}
301- BuildRequires: gamin-devel
302
303* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
304- new upstream release
305
306* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
307- new upstream release
308
309* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
310- new upstream release
311
312* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
313- new upstream release
314
315* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
316- new upstream release
317- removed BuildRequires: automake17
318
319* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
320- new upstream release
321
322* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
323- new upstream release
324
325* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
326- new upstream release
327
328* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
329- rebuild with new environment
330
331* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
332- new upstream release
333
334* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
335- new upstream release
336
337* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
338- new upstream release
339
340* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
341- new upstream release
342
343* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
344- new upstream release
345
346* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
347- new upstream release
348
349* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
350- new upstream release
351
352* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
353- rebuild
354
355* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
356- update glib2.{sh,csh}
357  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
358
359* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
360- new upstream release
361
362* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
363- new upstream release
364
365* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
366- new upstream release
367
368* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
369- new upstream release
370
371* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
372- added compat32-* packages for x86_64 architecture support
373- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
374
375* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
376- new upstream release
377
378* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
379- new upstream release
380
381* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
382- new upstream release
383
384* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
385- new upstream release
386
387* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
388- fixed typo in glib2.csh
389
390* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
391- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
392  G_BROKEN_FILENAMES.
393
394* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
395- new upstream release
396
397* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
398- new upstream release
399
400* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
401- new upstream release
402
403* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
404- new upstream release
405
406* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
407- new upstream release
408
409* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
410- new upstream release
411- add *.la to build arts (should be fixed in arts?)
412
413* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
414- new upstream release
415
416* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
417- new upstream release
418
419* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
420- new upstream release
421
422* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
423- new upstream release
424
425* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
426- new upstream release
427
428* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
429- rebuilt
430
431* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
432- new upstream release
433
434* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
435- new upstream release
436
437* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
438- new upstream release
439
440* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
441- new upstream release
442
443* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
444- new upstream release
445
446* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
447- new upstream release
448
449* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
450- new upstream release
451
452* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
453- rebuild with new toolchain
454
455* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
456- new upstream release
457
458* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
459- new upstream release
460
461* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
462- new upstream release
463
464* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
465- new upstream release
466
467* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
468- new upstream release
469- build for Vine Linux
470
471* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
472- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
473- blow away unpackaged files in install
474
475* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
476- Version 2.0.6
477- Remove fixed-ltmain.sh; shouldn't be needed any more.
478
479* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
480- automated rebuild
481
482* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
483- 2.0.4
484
485* Thu May 23 2002 Tim Powers <timp@redhat.com>
486- automated rebuild
487
488* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
489 - rebuild in different environment
490
491* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
492- Fix missing .po files (#63336)
493
494* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
495- Update to version 2.0.1
496
497* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
498- Version 2.0.0
499
500* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
501- Update to 1.3.15
502
503* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
504- Bump for rebuild
505
506* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
507- Update to 1.3.14
508
509* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
510- add horrible buildrequires hack
511
512* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
513- 1.3.13.91 cvs snap
514
515* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
516- rebuild from CVS snapshot
517- use setup -q
518
519* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
520- rebuild
521
522* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
523- 1.3.13
524
525* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
526- attempting rebuild in rawhide
527
528* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
529- remove 64-bit patch now upstream, 1.3.12.90
530
531* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
532- add some missing files to file list, langify
533
534* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
535- add temporary patch to fix GTypeFundamentals on 64-bit
536
537* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
538- Version 1.3.11
539
540* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
541- Version 1.3.10
542
543* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
544- Version 1.3.9
545
546* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
547- Version 1.3.8
548
549* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
550- Make -devel package require main package (#45388)
551- Fix description and summary
552- Configure with --disable-gtk-doc
553
554* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
555- add some portability fixes needed at least on s390
556- copy config.{guess,sub} instead of calling libtoolize
557
558* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
559- try a new glib tarball with Makefile changes to work around
560  libtool linking to installed .la files
561- make -devel require pkgconfig
562
563* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
564- either libtool or the bad libtool hacks caused link
565  against glib-gobject 1.3.2, rebuild
566
567* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
568- 1.3.6
569- bad libtool workarounds
570
571* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
572- 1.3.5, rename to glib2
573
574* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
575- Final 1.3.2
576
577* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
578- Version 1.3.2pre1
579- Remove pkgconfig
580
581* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
582- Call 1.3.1b instead of snap... the snap* naming doesn't
583  order correctly.
584
585* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
586- new snapshot with fixed .pc files
587
588* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
589- include .pc files in file list
590
591* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
592- Include pkg-config
593- Upgrade to a glib CVS snapshot
594
595* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
596- rebuild to cope with glibc locale binary incompatibility
597
598* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
599- Remove glib-config.1 manpage from build since
600  it conflicts with glib-devel. When we go to
601  glib glib1.2 setup, we should add it back
602
603* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
604- Version 1.3.1
605- Move back to standard %{prefix}
606
607* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
608- Rebuild in /opt/gtk-beta
609
610* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
611- New version (adds gobject)
612
613* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
614- Don't blow away /etc/ld.so.conf (sorry!)
615
616* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
617- Snapshot RPM for Pango testing
618
619* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
620- Added fixes from stable branch of CVS
621
622* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
623- version 1.2.6
624
625* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
626- version 1.2.5
627
628* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
629- version 1.2.4
630
631* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
632- version 1.2.3
633
634* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
635- version 1.2.1
636
637* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
638- Version 1.2
639
640* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
641- version 1.2.0pre1
642
643* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
644- new description tags
645
646* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
647- removed libtoolize from %build
648
649* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
650- added libgthread to file list
651
652* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
653- version 1.1.15
654
655* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
656- version 1.1.14
657
658* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
659- version 1.1.13
660
661* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
662- version 1.1.12
663
664* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
665- updated in preparation for the GNOME freeze
666
667* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
668- Split out glib package
669
Note: See TracBrowser for help on using the repository browser.