source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 7294

Revision 7294, 20.4 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

RevLine 
[6011]1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
[521]3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
[4704]4
[521]5Summary: A library of handy utility functions.
6Name: glib2
[7294]7Version: 2.34.3
[2678]8Release: 1%{?_dist_release}
[521]9License: LGPLv2+
10Group: System Environment/Libraries
[6890]11Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.34/glib-%{version}.tar.xz
[521]12Source2: glib2.sh
13Source3: glib2.csh
[4616]14
[6078]15Patch0: glib-2.32.1-dconf-path.patch
16
[521]17BuildRoot: %{_tmppath}/glib-%{version}-root
[4616]18
[521]19BuildRequires: pkgconfig >= 0.14
[4616]20BuildRequires: dbus-devel
[521]21BuildRequires: gamin-devel
[4616]22BuildRequires: libffi-devel
23BuildRequires: zlib-devel
[6011]24BuildRequires: python-devel
[521]25BuildRequires: gtk-doc
26Obsoletes: glib-gtkbeta
27URL: http://www.gtk.org
28
29Vendor: Project Vine
30Distribution: Vine Linux
[2678]31Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
[521]32
33%description
34GLib is the low-level core library that forms the basis
35for projects such as GTK+ and GNOME. It provides data structure
36handling for C, portability wrappers, and interfaces for such runtime
37functionality as an event loop, threads, dynamic loading, and an
38object system.
39
[6890]40This package provides version 2.34 of GLib.
[521]41
42%package devel
43Summary: Development files for the GLib library
44Group: Development/Libraries
[4616]45Requires: %{name} = %{version}
46Requires: pkgconfig >= 0.14
[4850]47Requires: libffi-devel
48Requires: zlib-devel
[4616]49
[521]50Obsoletes: glib-gtkbeta-devel
51Conflicts: glib-devel <= 1.2.8
52
53%description devel
54The glib-devel package includes the header files for
[6890]55version 2.34 of the GLib library.
[521]56
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A library of handy utility functions.
61Group: System Environment/Libraries
62
63%description -n compat32-%{name}
64GLib is the low-level core library that forms the basis
65for projects such as GTK+ and GNOME. It provides data structure
66handling for C, portability wrappers, and interfaces for such runtime
67functionality as an event loop, threads, dynamic loading, and an
68object system.
69
[6890]70This package provides version 2.34 of GLib.
[521]71
72%package -n compat32-%{name}-devel
73Summary: Development files for the GLib library
74Group: Development/Libraries
75Requires: pkgconfig >= 0.14
76Requires: compat32-%{name} = %{version}
[4616]77
[521]78Conflicts: glib-devel <= 1.2.8
79
80%description -n compat32-%{name}-devel
81The glib-devel package includes the header files for
[6890]82version 2.34 of the GLib library.
[521]83
84%prep
85%setup -q -n glib-%{version}
[6078]86%patch0 -p1
[521]87
88%build
[6078]89%configure --disable-selinux --enable-static --enable-systemtap
[521]90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
[6078]96make install DESTDIR=$RPM_BUILD_ROOT
[521]97
98## glib2.sh and glib2.csh
99./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
[6011]103mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
[6078]106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
[521]108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
[6078]117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
[521]120
[6078]121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
[521]124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
[2323]133%{_bindir}/gdbus
134%{_bindir}/gio-querymodules
135%{_bindir}/glib-compile-schemas
136%{_bindir}/gsettings
[521]137%{_libdir}/libglib-2.0.so.*
138%{_libdir}/libgthread-2.0.so.*
139%{_libdir}/libgmodule-2.0.so.*
140%{_libdir}/libgobject-2.0.so.*
141%{_libdir}/libgio-2.0.so.*
142%{_libdir}/gio/modules/lib*.so
143%{_sysconfdir}/profile.d/*
[6581]144%{_datadir}/bash-completion/completions/gdbus
145%{_datadir}/bash-completion/completions/gsettings
[521]146
147%files devel
148%defattr(-, root, root)
[4616]149%{_bindir}/gdbus-codegen
[6011]150%{_bindir}/glib-compile-resources
[2323]151%{_bindir}/glib-genmarshal
152%{_bindir}/glib-gettextize
153%{_bindir}/glib-mkenums
154%{_bindir}/gobject-query
[6011]155%{_bindir}/gresource
[2323]156%{_bindir}/gtester
157%{_bindir}/gtester-report
[521]158%{_libdir}/lib*.so
159%{_libdir}/lib*.a
[6011]160%{_libdir}/gdbus-2.0/codegen/*
[521]161%{_libdir}/glib-2.0
[6011]162%{_libdir}/pkgconfig/*
163%{python_sitearch}/codegen
[521]164%{_includedir}/*
165%{_datadir}/aclocal/*
166%{_datadir}/glib-2.0
167%doc %{_datadir}/gtk-doc/html/*
168%doc %{_mandir}/man1/*
169%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
170%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
[6581]171%{_datadir}/bash-completion/completions/gresource
[521]172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-, root, root)
176%{_libdir}/libglib-2.0.so.*
177%{_libdir}/libgthread-2.0.so.*
178%{_libdir}/libgmodule-2.0.so.*
179%{_libdir}/libgobject-2.0.so.*
180%{_libdir}/libgio-2.0.so.*
181%{_libdir}/gio/modules/lib*.so
182
183%files -n compat32-%{name}-devel
184%defattr(-, root, root)
185%{_libdir}/lib*.so
186%{_libdir}/lib*.a
187%{_libdir}/glib-2.0
188%endif
189
190%changelog
[7294]191* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
192- new upstream release
193
[7105]194* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
195- new upstream release
196
[6951]197* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
198- new upstream release
199
[6890]200* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
201- new upstream release
202
[6581]203* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
204- new upstream release
205
[6201]206* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
207- new upstream release
208
[6123]209* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
210- new upstream release
211
[6011]212* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
213- new upstream release
214- add BuildRequires: python-devel
[6078]215- add Patch0 (glib-2.32.1-dconf-path.patch)
[6011]216
[5168]217* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
218- new upstream release
219
[5007]220* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
221- new upstream release
222
[4850]223* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
224- new upstream release
225- add Requires: libffi-devel, zlib-devel (-devel sub package)
226
[4812]227* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
228- new upstream release
229
[4704]230* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
231- new upstream release
232- remove Patch0,1
233
[4650]234* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
235- new upstream release
236- Patch0: glib-2.29.16-fixes-bug-656387.patch
237- Patch1: glib-2.29.16-fixes-bug-656675.patch
238
[4616]239* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
240- new upstream release
241- add BuildRequires: libffi-devel, dbus-devel
242
243* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
244- new upstream release
245
[3685]246* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
247- new upstream release
248
[3263]249* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
250- new upstream release
251
[3079]252* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
253- new upstream release
254
[3014]255* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
256- new upstream release
257
[3003]258* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
259- new upstream release
260
[2721]261* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
262- new upstream release
263
[2678]264* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
265- new upstream release
266
[2323]267* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
268- move the following files from glib2-devel to glib2 package
269   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
270
[2219]271* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
272- new upstream release
273
[2041]274* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
275- new upstream release
276- fix Source (add URL)
277- fix %files to add /etc/bash_completion.d files
278
[1851]279* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
280- build with rpm-4.8.1-1 for pkg-config file
281
[1571]282* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
283- new upstream release
284
[991]285* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
286- new upstream release
287
[805]288* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
289- new upstream release
290- add BuildRequires: zlib-devel
291
[697]292* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
293- new upstream release
294
[521]295* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
296- new upstream release
297
298* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
299- new upstream release
300
301* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
302- new upstream release
303
304* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
305- new upstream release
306
307* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
308- new upstream release
309
310* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
311- new upstream release
312
313* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
314- new upstream release
315
316* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
317- new upstream release
318
319* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
320- new upstream release
321
322* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
323- new upstream release
324
325* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
326- new upstream release
327
328* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
329- new upstream release
330
331* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
332- new upstream release
333
334* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
335- new upstream release
336
337* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
338- new upstream release
339
340* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
341- updated %%if %%{build_compat32} case related statements
342
343* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
344- new upstream release
345- removed lib*.la files from devel package
346
347* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
348- new upstream release
349
350* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
351- added %%{?_dist_release}
352- BuildRequires: gamin-devel
353
354* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
355- new upstream release
356
357* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
358- new upstream release
359
360* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
361- new upstream release
362
363* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
364- new upstream release
365
366* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
367- new upstream release
368- removed BuildRequires: automake17
369
370* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
371- new upstream release
372
373* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
374- new upstream release
375
376* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
377- new upstream release
378
379* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
380- rebuild with new environment
381
382* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
383- new upstream release
384
385* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
386- new upstream release
387
388* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
389- new upstream release
390
391* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
392- new upstream release
393
394* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
395- new upstream release
396
397* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
398- new upstream release
399
400* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
401- new upstream release
402
403* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
404- rebuild
405
406* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
407- update glib2.{sh,csh}
408  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
409
410* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
411- new upstream release
412
413* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
414- new upstream release
415
416* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
417- new upstream release
418
419* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
420- new upstream release
421
422* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
423- added compat32-* packages for x86_64 architecture support
424- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
425
426* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
427- new upstream release
428
429* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
430- new upstream release
431
432* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
433- new upstream release
434
435* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
436- new upstream release
437
438* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
439- fixed typo in glib2.csh
440
441* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
442- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
443  G_BROKEN_FILENAMES.
444
445* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
446- new upstream release
447
448* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
449- new upstream release
450
451* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
452- new upstream release
453
454* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
455- new upstream release
456
457* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
458- new upstream release
459
460* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
461- new upstream release
462- add *.la to build arts (should be fixed in arts?)
463
464* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
465- new upstream release
466
467* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
468- new upstream release
469
470* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
471- new upstream release
472
473* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
474- new upstream release
475
476* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
477- new upstream release
478
479* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
480- rebuilt
481
482* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
483- new upstream release
484
485* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
486- new upstream release
487
488* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
489- new upstream release
490
491* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
492- new upstream release
493
494* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
495- new upstream release
496
497* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
498- new upstream release
499
500* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
501- new upstream release
502
503* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
504- rebuild with new toolchain
505
506* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
507- new upstream release
508
509* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
510- new upstream release
511
512* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
513- new upstream release
514
515* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
516- new upstream release
517
518* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
519- new upstream release
520- build for Vine Linux
521
522* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
523- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
524- blow away unpackaged files in install
525
526* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
527- Version 2.0.6
528- Remove fixed-ltmain.sh; shouldn't be needed any more.
529
530* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
531- automated rebuild
532
533* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
534- 2.0.4
535
536* Thu May 23 2002 Tim Powers <timp@redhat.com>
537- automated rebuild
538
539* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
540 - rebuild in different environment
541
542* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
543- Fix missing .po files (#63336)
544
545* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
546- Update to version 2.0.1
547
548* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
549- Version 2.0.0
550
551* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
552- Update to 1.3.15
553
554* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
555- Bump for rebuild
556
557* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
558- Update to 1.3.14
559
560* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
561- add horrible buildrequires hack
562
563* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
564- 1.3.13.91 cvs snap
565
566* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
567- rebuild from CVS snapshot
568- use setup -q
569
570* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
571- rebuild
572
573* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
574- 1.3.13
575
576* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
577- attempting rebuild in rawhide
578
579* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
580- remove 64-bit patch now upstream, 1.3.12.90
581
582* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
583- add some missing files to file list, langify
584
585* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
586- add temporary patch to fix GTypeFundamentals on 64-bit
587
588* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
589- Version 1.3.11
590
591* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
592- Version 1.3.10
593
594* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
595- Version 1.3.9
596
597* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
598- Version 1.3.8
599
600* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
601- Make -devel package require main package (#45388)
602- Fix description and summary
603- Configure with --disable-gtk-doc
604
605* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
606- add some portability fixes needed at least on s390
607- copy config.{guess,sub} instead of calling libtoolize
608
609* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
610- try a new glib tarball with Makefile changes to work around
611  libtool linking to installed .la files
612- make -devel require pkgconfig
613
614* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
615- either libtool or the bad libtool hacks caused link
616  against glib-gobject 1.3.2, rebuild
617
618* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
619- 1.3.6
620- bad libtool workarounds
621
622* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
623- 1.3.5, rename to glib2
624
625* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
626- Final 1.3.2
627
628* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
629- Version 1.3.2pre1
630- Remove pkgconfig
631
632* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
633- Call 1.3.1b instead of snap... the snap* naming doesn't
634  order correctly.
635
636* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
637- new snapshot with fixed .pc files
638
639* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
640- include .pc files in file list
641
642* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
643- Include pkg-config
644- Upgrade to a glib CVS snapshot
645
646* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
647- rebuild to cope with glibc locale binary incompatibility
648
649* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
650- Remove glib-config.1 manpage from build since
651  it conflicts with glib-devel. When we go to
652  glib glib1.2 setup, we should add it back
653
654* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
655- Version 1.3.1
656- Move back to standard %{prefix}
657
658* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
659- Rebuild in /opt/gtk-beta
660
661* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
662- New version (adds gobject)
663
664* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
665- Don't blow away /etc/ld.so.conf (sorry!)
666
667* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
668- Snapshot RPM for Pango testing
669
670* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
671- Added fixes from stable branch of CVS
672
673* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
674- version 1.2.6
675
676* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
677- version 1.2.5
678
679* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
680- version 1.2.4
681
682* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
683- version 1.2.3
684
685* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
686- version 1.2.1
687
688* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
689- Version 1.2
690
691* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
692- version 1.2.0pre1
693
694* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
695- new description tags
696
697* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
698- removed libtoolize from %build
699
700* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
701- added libgthread to file list
702
703* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
704- version 1.1.15
705
706* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
707- version 1.1.14
708
709* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
710- version 1.1.13
711
712* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
713- version 1.1.12
714
715* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
716- updated in preparation for the GNOME freeze
717
718* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
719- Split out glib package
720
Note: See TracBrowser for help on using the repository browser.