source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 6201

Revision 6201, 20.0 KB checked in by Takemikaduchi, 12 years ago (diff)

gnome-themes: fix Vine theme
metacity: fix theme
others: new upstream release

RevLine 
[6011]1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
[521]3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
[4704]4
[521]5Summary: A library of handy utility functions.
6Name: glib2
[6201]7Version: 2.32.3
[2678]8Release: 1%{?_dist_release}
[521]9License: LGPLv2+
10Group: System Environment/Libraries
[6011]11Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-%{version}.tar.xz
[521]12Source2: glib2.sh
13Source3: glib2.csh
[4616]14
[6078]15Patch0: glib-2.32.1-dconf-path.patch
16
[521]17BuildRoot: %{_tmppath}/glib-%{version}-root
[4616]18
[521]19BuildRequires: pkgconfig >= 0.14
[4616]20BuildRequires: dbus-devel
[521]21BuildRequires: gamin-devel
[4616]22BuildRequires: libffi-devel
23BuildRequires: zlib-devel
[6011]24BuildRequires: python-devel
[521]25BuildRequires: gtk-doc
26Obsoletes: glib-gtkbeta
27URL: http://www.gtk.org
28
29Vendor: Project Vine
30Distribution: Vine Linux
[2678]31Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
[521]32
33%description
34GLib is the low-level core library that forms the basis
35for projects such as GTK+ and GNOME. It provides data structure
36handling for C, portability wrappers, and interfaces for such runtime
37functionality as an event loop, threads, dynamic loading, and an
38object system.
39
[6011]40This package provides version 2.32 of GLib.
[521]41
42%package devel
43Summary: Development files for the GLib library
44Group: Development/Libraries
[4616]45Requires: %{name} = %{version}
46Requires: pkgconfig >= 0.14
[4850]47Requires: libffi-devel
48Requires: zlib-devel
[4616]49
[521]50Obsoletes: glib-gtkbeta-devel
51Conflicts: glib-devel <= 1.2.8
52
53%description devel
54The glib-devel package includes the header files for
[6011]55version 2.32 of the GLib library.
[521]56
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A library of handy utility functions.
61Group: System Environment/Libraries
62
63%description -n compat32-%{name}
64GLib is the low-level core library that forms the basis
65for projects such as GTK+ and GNOME. It provides data structure
66handling for C, portability wrappers, and interfaces for such runtime
67functionality as an event loop, threads, dynamic loading, and an
68object system.
69
[6011]70This package provides version 2.32 of GLib.
[521]71
72%package -n compat32-%{name}-devel
73Summary: Development files for the GLib library
74Group: Development/Libraries
75Requires: pkgconfig >= 0.14
76Requires: compat32-%{name} = %{version}
[4616]77
[521]78Conflicts: glib-devel <= 1.2.8
79
80%description -n compat32-%{name}-devel
81The glib-devel package includes the header files for
[6011]82version 2.32 of the GLib library.
[521]83
84%prep
85%setup -q -n glib-%{version}
[6078]86%patch0 -p1
[521]87
88%build
[6078]89%configure --disable-selinux --enable-static --enable-systemtap
[521]90make %{?_smp_mflags}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95mkdir -p $RPM_BUILD_ROOT%{_bindir}
[6078]96make install DESTDIR=$RPM_BUILD_ROOT
[521]97
98## glib2.sh and glib2.csh
99./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
100install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
101install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
102
[6011]103mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
104ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
105
[6078]106touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
107
[521]108rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]110rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]111
112%find_lang glib20
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
[6078]117%post
118/sbin/ldconfig
119gio-querymodules %{_libdir}/gio/modules
[521]120
[6078]121%postun
122/sbin/ldconfig
123gio-querymodules %{_libdir}/gio/modules
[521]124
125%post -n compat32-%{name} -p /sbin/ldconfig
126
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129
130%files -f glib20.lang
131%defattr(-, root, root)
132%doc AUTHORS COPYING ChangeLog NEWS README
[2323]133%{_bindir}/gdbus
134%{_bindir}/gio-querymodules
135%{_bindir}/glib-compile-schemas
136%{_bindir}/gsettings
[521]137%{_libdir}/libglib-2.0.so.*
138%{_libdir}/libgthread-2.0.so.*
139%{_libdir}/libgmodule-2.0.so.*
140%{_libdir}/libgobject-2.0.so.*
141%{_libdir}/libgio-2.0.so.*
142%{_libdir}/gio/modules/lib*.so
143%{_sysconfdir}/profile.d/*
[6011]144%{_sysconfdir}/bash_completion.d/gdbus-bash-completion.sh
145%{_sysconfdir}/bash_completion.d/gsettings-bash-completion.sh
[521]146
147%files devel
148%defattr(-, root, root)
[4616]149%{_bindir}/gdbus-codegen
[6011]150%{_bindir}/glib-compile-resources
[2323]151%{_bindir}/glib-genmarshal
152%{_bindir}/glib-gettextize
153%{_bindir}/glib-mkenums
154%{_bindir}/gobject-query
[6011]155%{_bindir}/gresource
[2323]156%{_bindir}/gtester
157%{_bindir}/gtester-report
[521]158%{_libdir}/lib*.so
159%{_libdir}/lib*.a
[6011]160%{_libdir}/gdbus-2.0/codegen/*
[521]161%{_libdir}/glib-2.0
[6011]162%{_libdir}/pkgconfig/*
163%{python_sitearch}/codegen
[521]164%{_includedir}/*
165%{_datadir}/aclocal/*
166%{_datadir}/glib-2.0
167%doc %{_datadir}/gtk-doc/html/*
168%doc %{_mandir}/man1/*
169%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
170%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
[6011]171%{_sysconfdir}/bash_completion.d/gresource-bash-completion.sh
[521]172
173%if %{build_compat32}
174%files -n compat32-%{name}
175%defattr(-, root, root)
176%{_libdir}/libglib-2.0.so.*
177%{_libdir}/libgthread-2.0.so.*
178%{_libdir}/libgmodule-2.0.so.*
179%{_libdir}/libgobject-2.0.so.*
180%{_libdir}/libgio-2.0.so.*
181%{_libdir}/gio/modules/lib*.so
182
183%files -n compat32-%{name}-devel
184%defattr(-, root, root)
185%{_libdir}/lib*.so
186%{_libdir}/lib*.a
187%{_libdir}/glib-2.0
188%{_libdir}/pkgconfig/*
189%endif
190
191%changelog
[6201]192* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
193- new upstream release
194
[6123]195* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
196- new upstream release
197
[6011]198* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
199- new upstream release
200- add BuildRequires: python-devel
[6078]201- add Patch0 (glib-2.32.1-dconf-path.patch)
[6011]202
[5168]203* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
204- new upstream release
205
[5007]206* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
207- new upstream release
208
[4850]209* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
210- new upstream release
211- add Requires: libffi-devel, zlib-devel (-devel sub package)
212
[4812]213* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
214- new upstream release
215
[4704]216* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
217- new upstream release
218- remove Patch0,1
219
[4650]220* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
221- new upstream release
222- Patch0: glib-2.29.16-fixes-bug-656387.patch
223- Patch1: glib-2.29.16-fixes-bug-656675.patch
224
[4616]225* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
226- new upstream release
227- add BuildRequires: libffi-devel, dbus-devel
228
229* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
230- new upstream release
231
[3685]232* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
233- new upstream release
234
[3263]235* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
236- new upstream release
237
[3079]238* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
239- new upstream release
240
[3014]241* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
242- new upstream release
243
[3003]244* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
245- new upstream release
246
[2721]247* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
248- new upstream release
249
[2678]250* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
251- new upstream release
252
[2323]253* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
254- move the following files from glib2-devel to glib2 package
255   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
256
[2219]257* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
258- new upstream release
259
[2041]260* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
261- new upstream release
262- fix Source (add URL)
263- fix %files to add /etc/bash_completion.d files
264
[1851]265* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
266- build with rpm-4.8.1-1 for pkg-config file
267
[1571]268* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
269- new upstream release
270
[991]271* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
272- new upstream release
273
[805]274* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
275- new upstream release
276- add BuildRequires: zlib-devel
277
[697]278* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
279- new upstream release
280
[521]281* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
282- new upstream release
283
284* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
285- new upstream release
286
287* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
288- new upstream release
289
290* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
291- new upstream release
292
293* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
294- new upstream release
295
296* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
297- new upstream release
298
299* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
300- new upstream release
301
302* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
303- new upstream release
304
305* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
306- new upstream release
307
308* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
309- new upstream release
310
311* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
312- new upstream release
313
314* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
315- new upstream release
316
317* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
318- new upstream release
319
320* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
321- new upstream release
322
323* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
324- new upstream release
325
326* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
327- updated %%if %%{build_compat32} case related statements
328
329* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
330- new upstream release
331- removed lib*.la files from devel package
332
333* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
334- new upstream release
335
336* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
337- added %%{?_dist_release}
338- BuildRequires: gamin-devel
339
340* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
341- new upstream release
342
343* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
344- new upstream release
345
346* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
347- new upstream release
348
349* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
350- new upstream release
351
352* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
353- new upstream release
354- removed BuildRequires: automake17
355
356* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
357- new upstream release
358
359* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
360- new upstream release
361
362* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
363- new upstream release
364
365* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
366- rebuild with new environment
367
368* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
369- new upstream release
370
371* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
372- new upstream release
373
374* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
375- new upstream release
376
377* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
378- new upstream release
379
380* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
381- new upstream release
382
383* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
384- new upstream release
385
386* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
387- new upstream release
388
389* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
390- rebuild
391
392* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
393- update glib2.{sh,csh}
394  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
395
396* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
397- new upstream release
398
399* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
400- new upstream release
401
402* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
403- new upstream release
404
405* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
406- new upstream release
407
408* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
409- added compat32-* packages for x86_64 architecture support
410- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
411
412* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
413- new upstream release
414
415* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
416- new upstream release
417
418* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
419- new upstream release
420
421* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
422- new upstream release
423
424* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
425- fixed typo in glib2.csh
426
427* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
428- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
429  G_BROKEN_FILENAMES.
430
431* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
432- new upstream release
433
434* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
435- new upstream release
436
437* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
438- new upstream release
439
440* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
441- new upstream release
442
443* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
444- new upstream release
445
446* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
447- new upstream release
448- add *.la to build arts (should be fixed in arts?)
449
450* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
451- new upstream release
452
453* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
454- new upstream release
455
456* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
457- new upstream release
458
459* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
460- new upstream release
461
462* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
463- new upstream release
464
465* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
466- rebuilt
467
468* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
469- new upstream release
470
471* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
472- new upstream release
473
474* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
475- new upstream release
476
477* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
478- new upstream release
479
480* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
481- new upstream release
482
483* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
484- new upstream release
485
486* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
487- new upstream release
488
489* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
490- rebuild with new toolchain
491
492* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
493- new upstream release
494
495* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
496- new upstream release
497
498* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
499- new upstream release
500
501* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
502- new upstream release
503
504* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
505- new upstream release
506- build for Vine Linux
507
508* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
509- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
510- blow away unpackaged files in install
511
512* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
513- Version 2.0.6
514- Remove fixed-ltmain.sh; shouldn't be needed any more.
515
516* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
517- automated rebuild
518
519* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
520- 2.0.4
521
522* Thu May 23 2002 Tim Powers <timp@redhat.com>
523- automated rebuild
524
525* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
526 - rebuild in different environment
527
528* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
529- Fix missing .po files (#63336)
530
531* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
532- Update to version 2.0.1
533
534* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
535- Version 2.0.0
536
537* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
538- Update to 1.3.15
539
540* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
541- Bump for rebuild
542
543* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
544- Update to 1.3.14
545
546* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
547- add horrible buildrequires hack
548
549* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
550- 1.3.13.91 cvs snap
551
552* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
553- rebuild from CVS snapshot
554- use setup -q
555
556* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
557- rebuild
558
559* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
560- 1.3.13
561
562* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
563- attempting rebuild in rawhide
564
565* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
566- remove 64-bit patch now upstream, 1.3.12.90
567
568* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
569- add some missing files to file list, langify
570
571* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
572- add temporary patch to fix GTypeFundamentals on 64-bit
573
574* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
575- Version 1.3.11
576
577* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
578- Version 1.3.10
579
580* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
581- Version 1.3.9
582
583* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
584- Version 1.3.8
585
586* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
587- Make -devel package require main package (#45388)
588- Fix description and summary
589- Configure with --disable-gtk-doc
590
591* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
592- add some portability fixes needed at least on s390
593- copy config.{guess,sub} instead of calling libtoolize
594
595* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
596- try a new glib tarball with Makefile changes to work around
597  libtool linking to installed .la files
598- make -devel require pkgconfig
599
600* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
601- either libtool or the bad libtool hacks caused link
602  against glib-gobject 1.3.2, rebuild
603
604* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
605- 1.3.6
606- bad libtool workarounds
607
608* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
609- 1.3.5, rename to glib2
610
611* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
612- Final 1.3.2
613
614* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
615- Version 1.3.2pre1
616- Remove pkgconfig
617
618* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
619- Call 1.3.1b instead of snap... the snap* naming doesn't
620  order correctly.
621
622* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
623- new snapshot with fixed .pc files
624
625* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
626- include .pc files in file list
627
628* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
629- Include pkg-config
630- Upgrade to a glib CVS snapshot
631
632* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
633- rebuild to cope with glibc locale binary incompatibility
634
635* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
636- Remove glib-config.1 manpage from build since
637  it conflicts with glib-devel. When we go to
638  glib glib1.2 setup, we should add it back
639
640* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
641- Version 1.3.1
642- Move back to standard %{prefix}
643
644* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
645- Rebuild in /opt/gtk-beta
646
647* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
648- New version (adds gobject)
649
650* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
651- Don't blow away /etc/ld.so.conf (sorry!)
652
653* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
654- Snapshot RPM for Pango testing
655
656* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
657- Added fixes from stable branch of CVS
658
659* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
660- version 1.2.6
661
662* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
663- version 1.2.5
664
665* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
666- version 1.2.4
667
668* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
669- version 1.2.3
670
671* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
672- version 1.2.1
673
674* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
675- Version 1.2
676
677* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
678- version 1.2.0pre1
679
680* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
681- new description tags
682
683* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
684- removed libtoolize from %build
685
686* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
687- added libgthread to file list
688
689* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
690- version 1.1.15
691
692* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
693- version 1.1.14
694
695* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
696- version 1.1.13
697
698* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
699- version 1.1.12
700
701* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
702- updated in preparation for the GNOME freeze
703
704* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
705- Split out glib package
706
Note: See TracBrowser for help on using the repository browser.