source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 6011

Revision 6011, 19.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

RevLine 
[6011]1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
[521]3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
[4704]4
[521]5Summary: A library of handy utility functions.
6Name: glib2
[6011]7Version: 2.32.1
[2678]8Release: 1%{?_dist_release}
[521]9License: LGPLv2+
10Group: System Environment/Libraries
[6011]11Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-%{version}.tar.xz
[521]12Source2: glib2.sh
13Source3: glib2.csh
[4616]14
[521]15BuildRoot: %{_tmppath}/glib-%{version}-root
[4616]16
[521]17BuildRequires: pkgconfig >= 0.14
[4616]18BuildRequires: dbus-devel
[521]19BuildRequires: gamin-devel
[4616]20BuildRequires: libffi-devel
21BuildRequires: zlib-devel
[6011]22BuildRequires: python-devel
[521]23BuildRequires: gtk-doc
24Obsoletes: glib-gtkbeta
25URL: http://www.gtk.org
26
27Vendor: Project Vine
28Distribution: Vine Linux
[2678]29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
[521]30
31%description
32GLib is the low-level core library that forms the basis
33for projects such as GTK+ and GNOME. It provides data structure
34handling for C, portability wrappers, and interfaces for such runtime
35functionality as an event loop, threads, dynamic loading, and an
36object system.
37
[6011]38This package provides version 2.32 of GLib.
[521]39
40%package devel
41Summary: Development files for the GLib library
42Group: Development/Libraries
[4616]43Requires: %{name} = %{version}
44Requires: pkgconfig >= 0.14
[4850]45Requires: libffi-devel
46Requires: zlib-devel
[4616]47
[521]48Obsoletes: glib-gtkbeta-devel
49Conflicts: glib-devel <= 1.2.8
50
51%description devel
52The glib-devel package includes the header files for
[6011]53version 2.32 of the GLib library.
[521]54
55
56## to build compat32 for x86_64 architecture support
57%package -n compat32-%{name}
58Summary: A library of handy utility functions.
59Group: System Environment/Libraries
60
61%description -n compat32-%{name}
62GLib is the low-level core library that forms the basis
63for projects such as GTK+ and GNOME. It provides data structure
64handling for C, portability wrappers, and interfaces for such runtime
65functionality as an event loop, threads, dynamic loading, and an
66object system.
67
[6011]68This package provides version 2.32 of GLib.
[521]69
70%package -n compat32-%{name}-devel
71Summary: Development files for the GLib library
72Group: Development/Libraries
73Requires: pkgconfig >= 0.14
74Requires: compat32-%{name} = %{version}
[4616]75
[521]76Conflicts: glib-devel <= 1.2.8
77
78%description -n compat32-%{name}-devel
79The glib-devel package includes the header files for
[6011]80version 2.32 of the GLib library.
[521]81
82%prep
83%setup -q -n glib-%{version}
84
85%build
86%configure --disable-selinux --enable-static
87make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92mkdir -p $RPM_BUILD_ROOT%{_bindir}
93%makeinstall
94
95## glib2.sh and glib2.csh
96./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
97install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
98install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
99
[6011]100mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
101ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
102
[521]103rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
104rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]105rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]106
107%find_lang glib20
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post -p /sbin/ldconfig
113
114%postun -p /sbin/ldconfig
115
116%post -n compat32-%{name} -p /sbin/ldconfig
117
118%postun -n compat32-%{name} -p /sbin/ldconfig
119
120
121%files -f glib20.lang
122%defattr(-, root, root)
123%doc AUTHORS COPYING ChangeLog NEWS README
[2323]124%{_bindir}/gdbus
125%{_bindir}/gio-querymodules
126%{_bindir}/glib-compile-schemas
127%{_bindir}/gsettings
[521]128%{_libdir}/libglib-2.0.so.*
129%{_libdir}/libgthread-2.0.so.*
130%{_libdir}/libgmodule-2.0.so.*
131%{_libdir}/libgobject-2.0.so.*
132%{_libdir}/libgio-2.0.so.*
133%{_libdir}/gio/modules/lib*.so
134%{_sysconfdir}/profile.d/*
[6011]135%{_sysconfdir}/bash_completion.d/gdbus-bash-completion.sh
136%{_sysconfdir}/bash_completion.d/gsettings-bash-completion.sh
[521]137
138%files devel
139%defattr(-, root, root)
[4616]140%{_bindir}/gdbus-codegen
[6011]141%{_bindir}/glib-compile-resources
[2323]142%{_bindir}/glib-genmarshal
143%{_bindir}/glib-gettextize
144%{_bindir}/glib-mkenums
145%{_bindir}/gobject-query
[6011]146%{_bindir}/gresource
[2323]147%{_bindir}/gtester
148%{_bindir}/gtester-report
[521]149%{_libdir}/lib*.so
150%{_libdir}/lib*.a
[6011]151%{_libdir}/gdbus-2.0/codegen/*
[521]152%{_libdir}/glib-2.0
[6011]153%{_libdir}/pkgconfig/*
154%{python_sitearch}/codegen
[521]155%{_includedir}/*
156%{_datadir}/aclocal/*
157%{_datadir}/glib-2.0
158%doc %{_datadir}/gtk-doc/html/*
159%doc %{_mandir}/man1/*
160%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
161%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
[6011]162%{_sysconfdir}/bash_completion.d/gresource-bash-completion.sh
[521]163
164%if %{build_compat32}
165%files -n compat32-%{name}
166%defattr(-, root, root)
167%{_libdir}/libglib-2.0.so.*
168%{_libdir}/libgthread-2.0.so.*
169%{_libdir}/libgmodule-2.0.so.*
170%{_libdir}/libgobject-2.0.so.*
171%{_libdir}/libgio-2.0.so.*
172%{_libdir}/gio/modules/lib*.so
173
174%files -n compat32-%{name}-devel
175%defattr(-, root, root)
176%{_libdir}/lib*.so
177%{_libdir}/lib*.a
178%{_libdir}/glib-2.0
179%{_libdir}/pkgconfig/*
180%endif
181
182%changelog
[6011]183* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
184- new upstream release
185- add BuildRequires: python-devel
186
[5168]187* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
188- new upstream release
189
[5007]190* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
191- new upstream release
192
[4850]193* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
194- new upstream release
195- add Requires: libffi-devel, zlib-devel (-devel sub package)
196
[4812]197* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
198- new upstream release
199
[4704]200* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
201- new upstream release
202- remove Patch0,1
203
[4650]204* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
205- new upstream release
206- Patch0: glib-2.29.16-fixes-bug-656387.patch
207- Patch1: glib-2.29.16-fixes-bug-656675.patch
208
[4616]209* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
210- new upstream release
211- add BuildRequires: libffi-devel, dbus-devel
212
213* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
214- new upstream release
215
[3685]216* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
217- new upstream release
218
[3263]219* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
220- new upstream release
221
[3079]222* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
223- new upstream release
224
[3014]225* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
226- new upstream release
227
[3003]228* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
229- new upstream release
230
[2721]231* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
232- new upstream release
233
[2678]234* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
235- new upstream release
236
[2323]237* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
238- move the following files from glib2-devel to glib2 package
239   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
240
[2219]241* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
242- new upstream release
243
[2041]244* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
245- new upstream release
246- fix Source (add URL)
247- fix %files to add /etc/bash_completion.d files
248
[1851]249* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
250- build with rpm-4.8.1-1 for pkg-config file
251
[1571]252* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
253- new upstream release
254
[991]255* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
256- new upstream release
257
[805]258* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
259- new upstream release
260- add BuildRequires: zlib-devel
261
[697]262* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
263- new upstream release
264
[521]265* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
266- new upstream release
267
268* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
269- new upstream release
270
271* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
272- new upstream release
273
274* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
275- new upstream release
276
277* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
278- new upstream release
279
280* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
281- new upstream release
282
283* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
284- new upstream release
285
286* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
287- new upstream release
288
289* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
290- new upstream release
291
292* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
293- new upstream release
294
295* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
296- new upstream release
297
298* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
299- new upstream release
300
301* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
302- new upstream release
303
304* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
305- new upstream release
306
307* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
308- new upstream release
309
310* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
311- updated %%if %%{build_compat32} case related statements
312
313* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
314- new upstream release
315- removed lib*.la files from devel package
316
317* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
318- new upstream release
319
320* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
321- added %%{?_dist_release}
322- BuildRequires: gamin-devel
323
324* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
325- new upstream release
326
327* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
328- new upstream release
329
330* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
331- new upstream release
332
333* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
334- new upstream release
335
336* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
337- new upstream release
338- removed BuildRequires: automake17
339
340* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
341- new upstream release
342
343* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
344- new upstream release
345
346* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
347- new upstream release
348
349* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
350- rebuild with new environment
351
352* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
353- new upstream release
354
355* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
356- new upstream release
357
358* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
359- new upstream release
360
361* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
362- new upstream release
363
364* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
365- new upstream release
366
367* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
368- new upstream release
369
370* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
371- new upstream release
372
373* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
374- rebuild
375
376* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
377- update glib2.{sh,csh}
378  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
379
380* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
381- new upstream release
382
383* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
384- new upstream release
385
386* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
387- new upstream release
388
389* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
390- new upstream release
391
392* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
393- added compat32-* packages for x86_64 architecture support
394- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
395
396* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
397- new upstream release
398
399* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
400- new upstream release
401
402* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
403- new upstream release
404
405* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
406- new upstream release
407
408* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
409- fixed typo in glib2.csh
410
411* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
412- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
413  G_BROKEN_FILENAMES.
414
415* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
416- new upstream release
417
418* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
419- new upstream release
420
421* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
422- new upstream release
423
424* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
425- new upstream release
426
427* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
428- new upstream release
429
430* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
431- new upstream release
432- add *.la to build arts (should be fixed in arts?)
433
434* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
435- new upstream release
436
437* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
438- new upstream release
439
440* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
441- new upstream release
442
443* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
444- new upstream release
445
446* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
447- new upstream release
448
449* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
450- rebuilt
451
452* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
453- new upstream release
454
455* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
456- new upstream release
457
458* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
459- new upstream release
460
461* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
462- new upstream release
463
464* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
465- new upstream release
466
467* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
468- new upstream release
469
470* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
471- new upstream release
472
473* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
474- rebuild with new toolchain
475
476* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
477- new upstream release
478
479* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
480- new upstream release
481
482* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
483- new upstream release
484
485* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
486- new upstream release
487
488* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
489- new upstream release
490- build for Vine Linux
491
492* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
493- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
494- blow away unpackaged files in install
495
496* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
497- Version 2.0.6
498- Remove fixed-ltmain.sh; shouldn't be needed any more.
499
500* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
501- automated rebuild
502
503* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
504- 2.0.4
505
506* Thu May 23 2002 Tim Powers <timp@redhat.com>
507- automated rebuild
508
509* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
510 - rebuild in different environment
511
512* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
513- Fix missing .po files (#63336)
514
515* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
516- Update to version 2.0.1
517
518* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
519- Version 2.0.0
520
521* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
522- Update to 1.3.15
523
524* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
525- Bump for rebuild
526
527* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
528- Update to 1.3.14
529
530* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
531- add horrible buildrequires hack
532
533* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
534- 1.3.13.91 cvs snap
535
536* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
537- rebuild from CVS snapshot
538- use setup -q
539
540* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
541- rebuild
542
543* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
544- 1.3.13
545
546* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
547- attempting rebuild in rawhide
548
549* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
550- remove 64-bit patch now upstream, 1.3.12.90
551
552* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
553- add some missing files to file list, langify
554
555* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
556- add temporary patch to fix GTypeFundamentals on 64-bit
557
558* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
559- Version 1.3.11
560
561* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
562- Version 1.3.10
563
564* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
565- Version 1.3.9
566
567* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
568- Version 1.3.8
569
570* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
571- Make -devel package require main package (#45388)
572- Fix description and summary
573- Configure with --disable-gtk-doc
574
575* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
576- add some portability fixes needed at least on s390
577- copy config.{guess,sub} instead of calling libtoolize
578
579* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
580- try a new glib tarball with Makefile changes to work around
581  libtool linking to installed .la files
582- make -devel require pkgconfig
583
584* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
585- either libtool or the bad libtool hacks caused link
586  against glib-gobject 1.3.2, rebuild
587
588* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
589- 1.3.6
590- bad libtool workarounds
591
592* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
593- 1.3.5, rename to glib2
594
595* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
596- Final 1.3.2
597
598* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
599- Version 1.3.2pre1
600- Remove pkgconfig
601
602* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
603- Call 1.3.1b instead of snap... the snap* naming doesn't
604  order correctly.
605
606* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
607- new snapshot with fixed .pc files
608
609* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
610- include .pc files in file list
611
612* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
613- Include pkg-config
614- Upgrade to a glib CVS snapshot
615
616* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
617- rebuild to cope with glibc locale binary incompatibility
618
619* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
620- Remove glib-config.1 manpage from build since
621  it conflicts with glib-devel. When we go to
622  glib glib1.2 setup, we should add it back
623
624* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
625- Version 1.3.1
626- Move back to standard %{prefix}
627
628* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
629- Rebuild in /opt/gtk-beta
630
631* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
632- New version (adds gobject)
633
634* Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
635- Don't blow away /etc/ld.so.conf (sorry!)
636
637* Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
638- Snapshot RPM for Pango testing
639
640* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
641- Added fixes from stable branch of CVS
642
643* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
644- version 1.2.6
645
646* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
647- version 1.2.5
648
649* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
650- version 1.2.4
651
652* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
653- version 1.2.3
654
655* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
656- version 1.2.1
657
658* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
659- Version 1.2
660
661* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
662- version 1.2.0pre1
663
664* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
665- new description tags
666
667* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
668- removed libtoolize from %build
669
670* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
671- added libgthread to file list
672
673* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
674- version 1.1.15
675
676* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
677- version 1.1.14
678
679* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
680- version 1.1.13
681
682* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
683- version 1.1.12
684
685* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
686- updated in preparation for the GNOME freeze
687
688* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
689- Split out glib package
690
Note: See TracBrowser for help on using the repository browser.