source: projects/specs/trunk/g/glib2/glib2-vl.spec @ 12492

Revision 12492, 23.6 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

glib2-2.66.0-1

gvfs-1.46.0-1

libcddb-1.3.2-10

libcdio-paranoia-10.2+2.0.1-1

libcdio-2.1.0-1

RevLine 
[521]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
[11324]2%define _unpackaged_files_terminate_build 1
[4704]3
[12310]4Summary:        A library of handy utility functions.
5Name:           glib2
[12492]6Version:        2.66.0
[12413]7Release:        1%{?_dist_release}
[12492]8Group:          system
[12310]9Vendor:         Project Vine
10Distribution:   Vine Linux
[12376]11Packager:       daisuke
[4616]12
[12310]13License:        LGPLv2+
14URL:            http://www.gtk.org
15%define         shortver %(echo %{version} | cut -d. -f1-2)
16Source:         https://download.gnome.org/sources/glib/%{shortver}/glib-%{version}.tar.xz
17Source2:        glib2.sh
18Source3:        glib2.csh
19
20BuildRoot:      %{_tmppath}/glib-%{version}-root
21
[4616]22BuildRequires: dbus-devel
[12310]23BuildRequires: docbook-style-xsl
[521]24BuildRequires: gamin-devel
[12310]25BuildRequires: libattr-devel
[4616]26BuildRequires: libffi-devel
[12310]27BuildRequires: libmount-devel
28BuildRequires: libxslt
29BuildRequires: meson
30BuildRequires: pcre-devel >= 8.13
31BuildRequires: pkgconfig >= 0.14
32BuildRequires: python3-devel
[4616]33BuildRequires: zlib-devel
[521]34Obsoletes: glib-gtkbeta
[10256]35
36# for gio-querymodules
37Requires(post,postun): libffi
38
[521]39
40%description
41GLib is the low-level core library that forms the basis
42for projects such as GTK+ and GNOME. It provides data structure
43handling for C, portability wrappers, and interfaces for such runtime
44functionality as an event loop, threads, dynamic loading, and an
45object system.
46
[12310]47This package provides version %{shortver} of GLib.
[521]48
49%package devel
50Summary: Development files for the GLib library
[12492]51Group: programming
[4616]52Requires: %{name} = %{version}
53Requires: pkgconfig >= 0.14
[4850]54Requires: libffi-devel
55Requires: zlib-devel
[12376]56Requires: python3
[4616]57
[521]58Obsoletes: glib-gtkbeta-devel
59Conflicts: glib-devel <= 1.2.8
60
61%description devel
62The glib-devel package includes the header files for
[12310]63version %{shortver} of the GLib library.
[521]64
65
66## to build compat32 for x86_64 architecture support
67%package -n compat32-%{name}
68Summary: A library of handy utility functions.
[12492]69Group: system
[521]70
71%description -n compat32-%{name}
72GLib is the low-level core library that forms the basis
73for projects such as GTK+ and GNOME. It provides data structure
74handling for C, portability wrappers, and interfaces for such runtime
75functionality as an event loop, threads, dynamic loading, and an
76object system.
77
[12310]78This package provides version %{shortver} of GLib.
[521]79
[12492]80
[521]81%package -n compat32-%{name}-devel
82Summary: Development files for the GLib library
[12492]83Group: programming
[521]84Requires: pkgconfig >= 0.14
85Requires: compat32-%{name} = %{version}
[4616]86
[521]87Conflicts: glib-devel <= 1.2.8
88
89%description -n compat32-%{name}-devel
90The glib-devel package includes the header files for
[12310]91version %{shortver} of the GLib library.
[521]92
[7938]93
[12413]94%debug_package
95
96
[521]97%prep
98%setup -q -n glib-%{version}
99
100%build
[12310]101%meson \
102        -Dselinux=disabled \
103        -Dman=true
[521]104
[12310]105%meson_build
106
[521]107%install
108rm -rf $RPM_BUILD_ROOT
109
[12310]110%meson_install
[521]111
112## glib2.sh and glib2.csh
[7633]113mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
[521]114install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
115install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
116
[7633]117#mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
118#ln -sf %{_libdir}/gdbus-2.0/codegen  $RPM_BUILD_ROOT%{python_sitearch}/codegen
[6011]119
[12310]120mkdir -p $RPM_BUILD_ROOT%{_libdir}/gio/modules
[6078]121touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
122
[521]123rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
[2041]125rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
[521]126
127%find_lang glib20
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
[6078]132%post
133/sbin/ldconfig
134gio-querymodules %{_libdir}/gio/modules
[521]135
[6078]136%postun
137/sbin/ldconfig
138gio-querymodules %{_libdir}/gio/modules
[521]139
140%post -n compat32-%{name} -p /sbin/ldconfig
141
142%postun -n compat32-%{name} -p /sbin/ldconfig
143
144
145%files -f glib20.lang
146%defattr(-, root, root)
[12057]147%license COPYING
148%doc AUTHORS NEWS README*
[8353]149%{_bindir}/gapplication
[2323]150%{_bindir}/gdbus
[11324]151%{_bindir}/gio
[12376]152#{_bindir}/gio-launch-desktop
[2323]153%{_bindir}/gio-querymodules
154%{_bindir}/glib-compile-schemas
155%{_bindir}/gsettings
[521]156%{_libdir}/libglib-2.0.so.*
157%{_libdir}/libgthread-2.0.so.*
158%{_libdir}/libgmodule-2.0.so.*
159%{_libdir}/libgobject-2.0.so.*
160%{_libdir}/libgio-2.0.so.*
[12310]161%dir %{_libdir}/gio
162%dir %{_libdir}/gio/modules
163#%{_libdir}/gio/modules/giomodule.cache
164#%{_libdir}/gio/modules/lib*.so
[521]165%{_sysconfdir}/profile.d/*
[12005]166%dir %{_datadir}/bash-completion/completions
167%dir %{_datadir}/bash-completion
[8353]168%{_datadir}/bash-completion/completions/gapplication
[6581]169%{_datadir}/bash-completion/completions/gdbus
[12005]170%{_datadir}/bash-completion/completions/gio
[6581]171%{_datadir}/bash-completion/completions/gsettings
[521]172
173%files devel
174%defattr(-, root, root)
[4616]175%{_bindir}/gdbus-codegen
[6011]176%{_bindir}/glib-compile-resources
[2323]177%{_bindir}/glib-genmarshal
178%{_bindir}/glib-gettextize
179%{_bindir}/glib-mkenums
180%{_bindir}/gobject-query
[6011]181%{_bindir}/gresource
[2323]182%{_bindir}/gtester
183%{_bindir}/gtester-report
[521]184%{_libdir}/lib*.so
[12310]185#%{_libdir}/lib*.a
[7633]186#%{_libdir}/gdbus-2.0/codegen/*
[521]187%{_libdir}/glib-2.0
[6011]188%{_libdir}/pkgconfig/*
[7633]189#%{python_sitearch}/codegen
[521]190%{_includedir}/*
191%{_datadir}/aclocal/*
192%{_datadir}/glib-2.0
[10716]193%{_datadir}/gettext/its/gschema.its
194%{_datadir}/gettext/its/gschema.loc
[12005]195#%doc %{_datadir}/gtk-doc/html/*
[521]196%doc %{_mandir}/man1/*
197%{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
198%{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
[12005]199%dir %{_datadir}/bash-completion/completions
200%dir %{_datadir}/bash-completion
[6581]201%{_datadir}/bash-completion/completions/gresource
[521]202
203%if %{build_compat32}
204%files -n compat32-%{name}
205%defattr(-, root, root)
206%{_libdir}/libglib-2.0.so.*
207%{_libdir}/libgthread-2.0.so.*
208%{_libdir}/libgmodule-2.0.so.*
209%{_libdir}/libgobject-2.0.so.*
210%{_libdir}/libgio-2.0.so.*
[12310]211%dir %{_libdir}/gio
212%dir %{_libdir}/gio/modules
[521]213
214%files -n compat32-%{name}-devel
215%defattr(-, root, root)
216%{_libdir}/lib*.so
217%{_libdir}/glib-2.0
218%endif
219
220%changelog
[12492]221* Mon Sep 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.66.0-1
222- new upstream release.
223
[12439]224* Wed Jul 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.4-1
225- new upstream release.
226
[12413]227* Sat May 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.3-1
228- new upstream release.
229
[12376]230* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-2
231- rebuilt with libffi-3.3.
232
233* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-1
234- new upstream release.
235
[12310]236* Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
237- new upstream release.
238
[12057]239* Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
240- new upstream release.
241
[12005]242* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
243- new upstream release.
244
[11324]245* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
246- new upstream release.
247- dropped Patch0: fixed in upstream.
248- added BR:libmount-devel.
249
[10716]250* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
251- new upstream release
252- add BuildRequires: pcre-devel
253
[10256]254* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
255- add Requires: libffi
256
[9804]257* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
258- new upstream release
259
[9791]260* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
261- new upstream release
262
[9569]263* Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
264- new upstream release
265
[9475]266* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
267- new upstream release
268
[9415]269* Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
270- new upstream release
271
[9092]272* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
273- new upstream release
274
[9073]275* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
276- new upstream release
277
[8758]278* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
279- rebuild with libffi-3.0.13
280
[8353]281* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
282- new upstream release
283
[8011]284* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
285- new upstream release
286
[7938]287* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
288- new upstream release
289
[7756]290* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
291- new upstream release
292- remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
293
294* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
295- new upstream release
296- add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
297
[7681]298* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
299- new upstream release
300
[7633]301* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
302- new upstream release
303
[7294]304* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
305- new upstream release
306
[7105]307* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
308- new upstream release
309
[6951]310* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
311- new upstream release
312
[6890]313* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
314- new upstream release
315
[6581]316* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
317- new upstream release
318
[6201]319* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
320- new upstream release
321
[6123]322* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
323- new upstream release
324
[6011]325* Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
326- new upstream release
327- add BuildRequires: python-devel
[6078]328- add Patch0 (glib-2.32.1-dconf-path.patch)
[6011]329
[5168]330* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
331- new upstream release
332
[5007]333* Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
334- new upstream release
335
[4850]336* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
337- new upstream release
338- add Requires: libffi-devel, zlib-devel (-devel sub package)
339
[4812]340* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
341- new upstream release
342
[4704]343* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
344- new upstream release
345- remove Patch0,1
346
[4650]347* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
348- new upstream release
349- Patch0: glib-2.29.16-fixes-bug-656387.patch
350- Patch1: glib-2.29.16-fixes-bug-656675.patch
351
[4616]352* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
353- new upstream release
354- add BuildRequires: libffi-devel, dbus-devel
355
356* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
357- new upstream release
358
[3685]359* Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
360- new upstream release
361
[3263]362* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
363- new upstream release
364
[3079]365* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
366- new upstream release
367
[3014]368* Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
369- new upstream release
370
[3003]371* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
372- new upstream release
373
[2721]374* Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
375- new upstream release
376
[2678]377* Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
378- new upstream release
379
[2323]380* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
381- move the following files from glib2-devel to glib2 package
382   (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
383
[2219]384* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
385- new upstream release
386
[2041]387* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
388- new upstream release
389- fix Source (add URL)
390- fix %files to add /etc/bash_completion.d files
391
[1851]392* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
393- build with rpm-4.8.1-1 for pkg-config file
394
[1571]395* Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
396- new upstream release
397
[991]398* Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
399- new upstream release
400
[805]401* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
402- new upstream release
403- add BuildRequires: zlib-devel
404
[697]405* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
406- new upstream release
407
[521]408* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
409- new upstream release
410
411* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
412- new upstream release
413
414* Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
415- new upstream release
416
417* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
418- new upstream release
419
420* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
421- new upstream release
422
423* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
424- new upstream release
425
426* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
427- new upstream release
428
429* Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
430- new upstream release
431
432* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
433- new upstream release
434
435* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
436- new upstream release
437
438* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
439- new upstream release
440
441* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
442- new upstream release
443
444* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
445- new upstream release
446
447* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
448- new upstream release
449
450* Mon Jul  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
451- new upstream release
452
453* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
454- updated %%if %%{build_compat32} case related statements
455
456* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
457- new upstream release
458- removed lib*.la files from devel package
459
460* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
461- new upstream release
462
463* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
464- added %%{?_dist_release}
465- BuildRequires: gamin-devel
466
467* Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
468- new upstream release
469
470* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
471- new upstream release
472
473* Wed Jan  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
474- new upstream release
475
476* Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
477- new upstream release
478
479* Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
480- new upstream release
481- removed BuildRequires: automake17
482
483* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
484- new upstream release
485
486* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
487- new upstream release
488
489* Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
490- new upstream release
491
492* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
493- rebuild with new environment
494
495* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
496- new upstream release
497
498* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
499- new upstream release
500
501* Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
502- new upstream release
503
504* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
505- new upstream release
506
507* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
508- new upstream release
509
510* Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
511- new upstream release
512
513* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
514- new upstream release
515
516* Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
517- rebuild
518
519* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
520- update glib2.{sh,csh}
521  - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
522
523* Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
524- new upstream release
525
526* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
527- new upstream release
528
529* Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
530- new upstream release
531
532* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
533- new upstream release
534
535* Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
536- added compat32-* packages for x86_64 architecture support
537- chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
538
539* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
540- new upstream release
541
542* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
543- new upstream release
544
545* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
546- new upstream release
547
548* Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
549- new upstream release
550
551* Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
552- fixed typo in glib2.csh
553
554* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
555- update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
556  G_BROKEN_FILENAMES.
557
558* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
559- new upstream release
560
561* Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
562- new upstream release
563
564* Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
565- new upstream release
566
567* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
568- new upstream release
569
570* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
571- new upstream release
572
573* Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
574- new upstream release
575- add *.la to build arts (should be fixed in arts?)
576
577* Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
578- new upstream release
579
580* Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
581- new upstream release
582
583* Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
584- new upstream release
585
586* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
587- new upstream release
588
589* Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
590- new upstream release
591
592* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
593- rebuilt
594
595* Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
596- new upstream release
597
598* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
599- new upstream release
600
601* Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
602- new upstream release
603
604* Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
605- new upstream release
606
607* Sat Jun  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
608- new upstream release
609
610* Sat May  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
611- new upstream release
612
613* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
614- new upstream release
615
616* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
617- rebuild with new toolchain
618
[7633]619* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
[521]620- new upstream release
621
622* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
623- new upstream release
624
625* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
626- new upstream release
627
628* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
629- new upstream release
630
631* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
632- new upstream release
633- build for Vine Linux
634
635* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
636- install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
637- blow away unpackaged files in install
638
639* Thu Aug  8 2002 Owen Taylor <otaylor@redhat.com>
640- Version 2.0.6
641- Remove fixed-ltmain.sh; shouldn't be needed any more.
642
643* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
644- automated rebuild
645
646* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
647- 2.0.4
648
649* Thu May 23 2002 Tim Powers <timp@redhat.com>
650- automated rebuild
651
652* Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
653 - rebuild in different environment
654
655* Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
656- Fix missing .po files (#63336)
657
658* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
659- Update to version 2.0.1
660
661* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
662- Version 2.0.0
663
664* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
665- Update to 1.3.15
666
667* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
668- Bump for rebuild
669
670* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
671- Update to 1.3.14
672
673* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
674- add horrible buildrequires hack
675
676* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
677- 1.3.13.91 cvs snap
678
679* Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
680- rebuild from CVS snapshot
681- use setup -q
682
683* Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
684- rebuild
685
686* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
687- 1.3.13
688
689* Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
690- attempting rebuild in rawhide
691
692* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
693- remove 64-bit patch now upstream, 1.3.12.90
694
695* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
696- add some missing files to file list, langify
697
698* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
699- add temporary patch to fix GTypeFundamentals on 64-bit
700
701* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
702- Version 1.3.11
703
704* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
705- Version 1.3.10
706
707* Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
708- Version 1.3.9
709
710* Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
711- Version 1.3.8
712
713* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
714- Make -devel package require main package (#45388)
715- Fix description and summary
716- Configure with --disable-gtk-doc
717
718* Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
719- add some portability fixes needed at least on s390
720- copy config.{guess,sub} instead of calling libtoolize
721
722* Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
723- try a new glib tarball with Makefile changes to work around
724  libtool linking to installed .la files
725- make -devel require pkgconfig
726
727* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
728- either libtool or the bad libtool hacks caused link
729  against glib-gobject 1.3.2, rebuild
730
731* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
732- 1.3.6
733- bad libtool workarounds
734
735* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
736- 1.3.5, rename to glib2
737
738* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
739- Final 1.3.2
740
741* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
742- Version 1.3.2pre1
743- Remove pkgconfig
744
745* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
746- Call 1.3.1b instead of snap... the snap* naming doesn't
747  order correctly.
748
749* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
750- new snapshot with fixed .pc files
751
752* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
753- include .pc files in file list
754
755* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
756- Include pkg-config
757- Upgrade to a glib CVS snapshot
758
759* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
760- rebuild to cope with glibc locale binary incompatibility
761
762* Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
763- Remove glib-config.1 manpage from build since
764  it conflicts with glib-devel. When we go to
765  glib glib1.2 setup, we should add it back
766
767* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
768- Version 1.3.1
769- Move back to standard %{prefix}
770
771* Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
772- Rebuild in /opt/gtk-beta
773
774* Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
775- New version (adds gobject)
776
[7633]777* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
[521]778- Don't blow away /etc/ld.so.conf (sorry!)
779
[7633]780* Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
[521]781- Snapshot RPM for Pango testing
782
783* Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
784- Added fixes from stable branch of CVS
785
786* Thu Oct 7  1999 Owen Taylor <otaylor@redhat.com>
787- version 1.2.6
788
789* Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
790- version 1.2.5
791
792* Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
793- version 1.2.4
794
795* Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
796- version 1.2.3
797
798* Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
799- version 1.2.1
800
801* Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
802- Version 1.2
803
804* Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
805- version 1.2.0pre1
806
807* Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
808- new description tags
809
810* Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
811- removed libtoolize from %build
812
813* Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
814- added libgthread to file list
815
816* Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
817- version 1.1.15
818
819* Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
820- version 1.1.14
821
822* Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
823- version 1.1.13
824
825* Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
826- version 1.1.12
827
828* Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
829- updated in preparation for the GNOME freeze
830
831* Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
832- Split out glib package
833
Note: See TracBrowser for help on using the repository browser.