source: projects/specs/trunk/g/gle/gle-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name    gle
2%define version 3.1.0
3%define release 2%{?_dist_release}
4Summary: The GLE Tubing and Extrusion Library
5Name: %{name}
6Version: %{version}
7Release: %{release}
8URL: http://www.linas.org/gle/
9Source: %{name}-%{version}.tar.gz
10License: distributable
11Group: System Environment/Libraries
12Buildroot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: mesa-libGLU-devel
14BuildRequires: mesa-libGL-devel
15BuildRequires: freeglut-devel
16BuildRequires: libXi-devel
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21GLE is a library package of C functions that draw extruded surfaces,
22including surfaces of revolution, sweeps, tubes, polycones,
23polycylinders and helicoids. Generically, the extruded surface is
24specified with a 2D polyline that is extruded along a 3D path.  A
25local coordinate system allows for additional flexibility in the
26primitives drawn.  Extrusions may be texture mapped in a variety of
27ways.  The GLE library generates 3D triangle coordinates, lighting
28normal vectors and texture coordinates as output. GLE uses the GL or
29OpenGL(R) API's to perform the actual rendering. The demos use GLUT
30and require GLUT to be installed.
31
32%package devel
33Summary: Static libraries and header files for gle
34Group: Development/Libraries
35Requires: gle
36
37%description devel
38gle-devel contains the static libraries and header files you'll
39need to develop gle applications. 
40
41%prep
42%setup -q
43
44%build
45%configure
46make
47
48%install
49rm -rf %{buildroot}
50%makeinstall
51## remove unuse files
52rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
53
54%clean
55rm -rf %{buildroot}
56
57%post -p /sbin/ldconfig
58
59%postun -p /sbin/ldconfig
60
61%files
62%defattr(-, root, root)
63%doc AUTHORS COPYING ChangeLog INSTALL README examples/
64%{_libdir}/libgle.so.*
65%{_mandir}/man3/*
66%{_datadir}/doc
67
68%files devel
69%defattr(-, root, root)
70%{_includedir}/GL/gle.h
71%{_libdir}/libgle.a
72#%{_libdir}/libgle.la
73%{_libdir}/libgle.so
74
75
76%changelog
77* Mon Sep 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.0-2vl5
78- added BuildRequires: mesa-libGL[U]-devel, freeglut-devel, libXi-devel
79
80* Thu Sep 25 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.0-1vl5
81- applied new versioning policy, spec in utf-8
82- removed *.la
83- modified paths about X11R6
84
85* Sun Dec 30 2007 Shu KONNO <owa@bg.wakwak.com> 3.1.0-0vl1
86- new upstream release
87- s/Copyright/License/
88- updated _libdir with /usr/X11R6/%%{_lib}
89
90* Fri Jun 15 2001 Jun Nishii <jun@vinelinux.org> 3.0.3-0vl1
91- ver.up
92
93
94* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 3.0.1-0vl1
95- first build
Note: See TracBrowser for help on using the repository browser.